Restore a needed patch that was lost during the last update.

Builds on solaris again.
This commit is contained in:
dmcmahill 2007-09-25 01:22:15 +00:00
parent 4eb30fb217
commit 16e8406b40
3 changed files with 97 additions and 1 deletions

View file

@ -1,9 +1,11 @@
$NetBSD: distinfo,v 1.21 2007/09/18 18:58:08 drochner Exp $
$NetBSD: distinfo,v 1.22 2007/09/25 01:22:15 dmcmahill Exp $
SHA1 (hdf5-1.6.6/hdf5-1.6.6.tar.gz) = c8a9ec598cf0debb694a1d7034fd85bbd67f173b
RMD160 (hdf5-1.6.6/hdf5-1.6.6.tar.gz) = e7cf3f8d6aa5f34ef10cabf650ed43d644e54f1b
Size (hdf5-1.6.6/hdf5-1.6.6.tar.gz) = 5299558 bytes
SHA1 (patch-aa) = 794ab1e1fbb41281c4b28a333f4bd91d37513084
SHA1 (patch-ab) = aa4911184b72d4818f6e65d3adf86110db9bd379
SHA1 (patch-ac) = 96c59a3694e0b80a2d321fed0af0b75d6b082462
SHA1 (patch-ad) = 4379aaf79ce58b12b69fad2419d44bee514c2a8c
SHA1 (patch-ba) = 1ba84ee22c3307100a2c8d3df4dfb2037be8e773
SHA1 (patch-bb) = bcfd87df515d64471f881d4d10c894d89a6bc56e

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ab,v 1.8 2007/09/25 01:22:15 dmcmahill Exp $
Adds missing -lsocket needed on solaris for socket(), bind(), and friends.
--- configure.in.orig 2007-08-16 12:13:34.000000000 -0400
+++ configure.in 2007-09-24 08:44:58.668063000 -0400
@@ -675,4 +675,5 @@
if test "`uname`" = "SunOS" -o "`uname -sr`" = "HP-UX B.11.00"; then
dnl ...for Solaris
+ AC_CHECK_LIB([socket], [socket])
AC_CHECK_LIB([nsl], [xdr_int])
fi

View file

@ -0,0 +1,82 @@
$NetBSD: patch-ac,v 1.9 2007/09/25 01:22:16 dmcmahill Exp $
regen from patched confgure.in
--- configure.orig 2007-08-16 12:16:59.000000000 -0400
+++ configure 2007-09-24 11:07:04.910306000 -0400
@@ -8820,4 +8820,75 @@
if test "`uname`" = "SunOS" -o "`uname -sr`" = "HP-UX B.11.00"; then
+{ echo "$as_me:$LINENO: checking for socket in -lsocket" >&5
+echo $ECHO_N "checking for socket in -lsocket... $ECHO_C" >&6; }
+if test "${ac_cv_lib_socket_socket+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+else
+ ac_check_lib_save_LIBS=$LIBS
+LIBS="-lsocket $LIBS"
+cat >conftest.$ac_ext <<_ACEOF
+/* confdefs.h. */
+_ACEOF
+cat confdefs.h >>conftest.$ac_ext
+cat >>conftest.$ac_ext <<_ACEOF
+/* end confdefs.h. */
+
+/* Override any GCC internal prototype to avoid an error.
+ Use char because int might match the return type of a GCC
+ builtin and then its argument prototype would still apply. */
+#ifdef __cplusplus
+extern "C"
+#endif
+char socket ();
+int
+main ()
+{
+return socket ();
+ ;
+ return 0;
+}
+_ACEOF
+rm -f conftest.$ac_objext conftest$ac_exeext
+if { (ac_try="$ac_link"
+case "(($ac_try" in
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+ *) ac_try_echo=$ac_try;;
+esac
+eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
+ (eval "$ac_link") 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } && {
+ test -z "$ac_c_werror_flag" ||
+ test ! -s conftest.err
+ } && test -s conftest$ac_exeext &&
+ $as_test_x conftest$ac_exeext; then
+ ac_cv_lib_socket_socket=yes
+else
+ echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
+ ac_cv_lib_socket_socket=no
+fi
+
+rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
+ conftest$ac_exeext conftest.$ac_ext
+LIBS=$ac_check_lib_save_LIBS
+fi
+{ echo "$as_me:$LINENO: result: $ac_cv_lib_socket_socket" >&5
+echo "${ECHO_T}$ac_cv_lib_socket_socket" >&6; }
+if test $ac_cv_lib_socket_socket = yes; then
+ cat >>confdefs.h <<_ACEOF
+#define HAVE_LIBSOCKET 1
+_ACEOF
+
+ LIBS="-lsocket $LIBS"
+
+fi
+
+
{ echo "$as_me:$LINENO: checking for xdr_int in -lnsl" >&5
echo $ECHO_N "checking for xdr_int in -lnsl... $ECHO_C" >&6; }