Initial import of p5-DBD-mysql based on msql-mysql-modules-1.2017.
This is the DBI backend for mysql databases.
This commit is contained in:
parent
a80c0473f0
commit
16f5429657
8 changed files with 77 additions and 0 deletions
29
databases/p5-DBD-mysql/Makefile
Normal file
29
databases/p5-DBD-mysql/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 1999/06/10 18:32:36 bad Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Msql-Mysql-modules-1.2017
|
||||
PKGNAME= p5-DBD-mysql-1.2017
|
||||
CATEGORIES= databases perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=DBD/}
|
||||
|
||||
MAINTAINER= bad@netbsd.org
|
||||
HOMEPAGE= http://www.mysql.com.org/
|
||||
|
||||
DEPENDS+= mysql-client-3.22.22:../../databases/mysql-client
|
||||
DEPENDS+= p5-DBI-1.08:../../databases/p5-DBI
|
||||
DEPENDS+= p5-Data-Dumper-2.10:../../devel/p5-Data-Dumper
|
||||
DEPENDS+= p5-Data-ShowTable-3.3:../../devel/p5-Data-ShowTable
|
||||
|
||||
USE_PERL5= YES
|
||||
|
||||
MYSQL_HEADERDIR= ${LOCALBASE}/include/mysql
|
||||
MYSQL_LIBDIR= ${LOCALBASE}/lib/mysql
|
||||
|
||||
CONFIGURE_ENV+= MYSQL_HEADERDIR="${MYSQL_HEADERDIR}"
|
||||
CONFIGURE_ENV+= MYSQL_LIBDIR="${MYSQL_LIBDIR}"
|
||||
CONFIGURE_ENV+= IN_MYSQL_DISTRIBUTION=1
|
||||
|
||||
do-configure:
|
||||
@cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${MAKE_ENV} ${LOCALBASE}/bin/perl Makefile.PL
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
databases/p5-DBD-mysql/files/md5
Normal file
3
databases/p5-DBD-mysql/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 1999/06/10 18:32:36 bad Exp $
|
||||
|
||||
MD5 (Msql-Mysql-modules-1.2017.tar.gz) = 8979a52abdc6642679a2f68e329dd9e8
|
13
databases/p5-DBD-mysql/patches/patch-aa
Normal file
13
databases/p5-DBD-mysql/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 1999/06/10 18:32:37 bad Exp $
|
||||
|
||||
--- Makefile.PL.orig Tue Jan 26 21:22:04 1999
|
||||
+++ Makefile.PL Thu Jun 10 19:04:20 1999
|
||||
@@ -417,7 +417,7 @@
|
||||
$cfg->{'Mysql'}->{'FINAL_LIBS'} = $final_libs;
|
||||
|
||||
my(@headerfiles) = ("$headerdir/mysql.h");
|
||||
- $X{dynamic_lib} = { OTHERLDFLAGS => "-L$libdir $linkwith" };
|
||||
+ $X{dynamic_lib} = { OTHERLDFLAGS => "-R$libdir -L$libdir $linkwith" };
|
||||
$X{DEFINE} = $defines;
|
||||
$X{LIBS} = $sysliblist;
|
||||
$X{INC} = "-I$headerdir -I../dbd -I\$(INSTALLSITEARCH)/auto/DBI"
|
1
databases/p5-DBD-mysql/pkg/COMMENT
Normal file
1
databases/p5-DBD-mysql/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
perl DBI/DBD driver for MySQL databases.
|
10
databases/p5-DBD-mysql/pkg/DESCR
Normal file
10
databases/p5-DBD-mysql/pkg/DESCR
Normal file
|
@ -0,0 +1,10 @@
|
|||
Mysql.pm and DBD::mysql implement two different approaches to
|
||||
communicate with an mysql server. DBD::mysql is built
|
||||
upon the DBI, the generic Perl Database Interface. It brings you an
|
||||
identical interface to a broad variety of databases and is in this
|
||||
regard comparable to ODBC. The advantage of the DBI approach is
|
||||
portability and interoperability. Mysql.pm is the elder species.
|
||||
It was written before DBI was available but inspired by an early
|
||||
draft of the DBI specification. As has been been circulating longer
|
||||
it are more mature and pretty stable. It is also more complete
|
||||
than DBD::mysql.
|
4
databases/p5-DBD-mysql/pkg/PLIST-md.shared
Normal file
4
databases/p5-DBD-mysql/pkg/PLIST-md.shared
Normal file
|
@ -0,0 +1,4 @@
|
|||
@comment $NetBSD: PLIST-md.shared,v 1.1.1.1 1999/06/10 18:32:37 bad Exp $
|
||||
lib/perl5/site_perl/${MACHINE_ARCH}-${LOWER_OPSYS}/auto/DBD/mysql/mysql.bs
|
||||
lib/perl5/site_perl/${MACHINE_ARCH}-${LOWER_OPSYS}/auto/DBD/mysql/mysql.so
|
||||
@dirrm lib/perl5/site_perl/${MACHINE_ARCH}-${LOWER_OPSYS}/auto/DBD/mysql
|
4
databases/p5-DBD-mysql/pkg/PLIST-md.static
Normal file
4
databases/p5-DBD-mysql/pkg/PLIST-md.static
Normal file
|
@ -0,0 +1,4 @@
|
|||
@comment $NetBSD: PLIST-md.static,v 1.1.1.1 1999/06/10 18:32:36 bad Exp $
|
||||
lib/perl5/site_perl/${MACHINE_ARCH}-${LOWER_OPSYS}/auto/DBD/mysql/mysql.a
|
||||
lib/perl5/site_perl/${MACHINE_ARCH}-${LOWER_OPSYS}/auto/DBD/mysql/extralibs.ld
|
||||
@dirrm lib/perl5/site_perl/${MACHINE_ARCH}-${LOWER_OPSYS}/auto/DBD/mysql
|
13
databases/p5-DBD-mysql/pkg/PLIST-mi
Normal file
13
databases/p5-DBD-mysql/pkg/PLIST-mi
Normal file
|
@ -0,0 +1,13 @@
|
|||
@comment $NetBSD: PLIST-mi,v 1.1.1.1 1999/06/10 18:32:36 bad Exp $
|
||||
bin/dbimon
|
||||
man/man1/dbimon.1
|
||||
lib/perl5/man/man3/Bundle::DBD::mysql.3
|
||||
lib/perl5/man/man3/DBD::mysql.3
|
||||
lib/perl5/man/man3/Mysql.3
|
||||
lib/perl5/site_perl/Bundle/DBD/mysql.pm
|
||||
lib/perl5/site_perl/DBD/mysql.pm
|
||||
lib/perl5/site_perl/Mysql.pm
|
||||
lib/perl5/site_perl/Mysql/Statement.pm
|
||||
@dirrm lib/perl5/site_perl/Mysql
|
||||
lib/perl5/site_perl/i386-netbsd/auto/Msql-Mysql-modules/.packlist
|
||||
@dirrm lib/perl5/site_perl/i386-netbsd/auto/Msql-Mysql-modules
|
Loading…
Reference in a new issue