Import the development version of emacs (23.0.94).

This package is based on emacs-current in pkgsrc-wip, which was
originally packaged by OBATA Akio.
This commit is contained in:
minskim 2009-06-05 02:57:53 +00:00
parent 079e2c5e96
commit 16fa31d2aa
9 changed files with 3583 additions and 0 deletions

View file

@ -0,0 +1,18 @@
GNU Emacs is an extensible, customizable editor textand more. At its
core is an interpreter for Emacs Lisp, a dialect of the Lisp
programming language with extensions to support text editing. The
features of GNU Emacs include:
- Content-sensitive editing modes, including syntax coloring, for a
wide variety of file types including plain text, source code, and
HTML.
- Complete built-in documentation, including a tutorial for new users.
- Support for many languages and their scripts, including all scripts,
Russian, Greek, Japanese, Chinese, Korean, Thai, Vietnamese, Lao,
Ethiopian, and some Indian scripts.
- Highly customizable, using Emacs Lisp code or a graphical
customization interface.
- A large number of extensions that add other functionality, including
a project planner, mail and news reader, debugger interface,
calendar, and more. Many of these extensions are distributed with
GNU Emacs; others are available separately.

View file

@ -0,0 +1,57 @@
# $NetBSD: Makefile,v 1.1.1.1 2009/06/05 02:57:53 minskim Exp $
DISTNAME= emacs-snapshot_20090604.orig
PKGNAME= ${DISTNAME:S/snapshot_/${EMACS_VERSION}./:S/.orig//}
CATEGORIES= editors
MASTER_SITES= http://emacs.orebokech.com/pool/main/e/emacs-snapshot/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.gnu.org/software/emacs/emacs.html
COMMENT= GNU editing macros (development version)
LICENSE= gnu-gpl-v3
PKG_DESTDIR_SUPPORT= user-destdir
CONFLICTS+= emacs-nox11-[0-9]*
FILESDIR= ${.CURDIR}/../../editors/emacs/files
GNU_CONFIGURE= yes
INFO_FILES= yes
USE_DIRS+= xdg-1.1
USE_TOOLS+= gmake makeinfo gzip
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV:C/\.[0-9]*$//}
CONFIGURE_ARGS+= --srcdir=${WRKSRC}
CONFIGURE_ARGS+= --localstatedir=${VARBASE}
CONFIGURE_ENV+= GAMEOWN=${GAMEOWN}
BUILD_DEFS+= VARBASE
BUILD_DEFS+= GAMEDATAMODE
PLIST_SRC+= PLIST
BUILD_TARGET= bootstrap
EMACS_VERSION= 23.0.94
PLIST_SUBST+= EMACS_VERSION=${EMACS_VERSION}
REPLACE_PERL= lib-src/grep-changelog
CHECK_INTERPRETER_SKIP= bin/grep-changelog
MAKE_DIRS_PERMS+= ${VARBASE}/games/emacs ${GAMEOWN} ${GAMEGRP} ${GAMEDIRMODE}
CONF_FILES_PERMS+= /dev/null ${VARBASE}/games/emacs/snake-scores \
${GAMEOWN} ${GAMEGRP} ${GAMEDATAMODE}
CONF_FILES_PERMS+= /dev/null ${VARBASE}/games/emacs/tetris-scores \
${GAMEOWN} ${GAMEGRP} ${GAMEDATAMODE}
# build PATH in the dumped emacs is not a problem
CHECK_WRKREF_SKIP+= bin/emacs
CHECK_WRKREF_SKIP+= bin/emacs-${EMACS_VERSION}
.include "options.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../mk/oss.buildlink3.mk"
post-extract:
cp ${FILESDIR}/site-init.el ${WRKSRC}/lisp
.include "../../mk/bsd.pkg.mk"

3301
editors/emacs-snapshot/PLIST Normal file

File diff suppressed because it is too large Load diff

View file

@ -0,0 +1,14 @@
@comment $NetBSD: PLIST.cocoa,v 1.1.1.1 2009/06/05 02:57:57 minskim Exp $
Applications/Emacs.app/Contents/Info.plist
Applications/Emacs.app/Contents/MacOS/Emacs
Applications/Emacs.app/Contents/PkgInfo
Applications/Emacs.app/Contents/Resources/Credits.html
Applications/Emacs.app/Contents/Resources/Emacs.icns
Applications/Emacs.app/Contents/Resources/English.lproj/InfoPlist.strings
Applications/Emacs.app/Contents/Resources/document.icns
bin/mac-fix-env
@dirrm Applications/Emacs.app/Contents/Resources/English.lproj
@dirrm Applications/Emacs.app/Contents/Resources
@dirrm Applications/Emacs.app/Contents/MacOS
@dirrm Applications/Emacs.app/Contents
@dirrm Applications/Emacs.app

View file

@ -0,0 +1,11 @@
@comment $NetBSD: PLIST.gnustep,v 1.1.1.1 2009/06/05 02:57:57 minskim Exp $
share/GNUstep/Local/Applications/Emacs.app/Emacs
share/GNUstep/Local/Applications/Emacs.app/Resources/Emacs.desktop
share/GNUstep/Local/Applications/Emacs.app/Resources/Info-gnustep.plist
share/GNUstep/Local/Applications/Emacs.app/Resources/emacstiff
share/GNUstep/Local/Applications/Emacs.app/library_paths.openapp
@dirrm share/GNUstep/Local/Applications/Emacs.app/Resources
@dirrm share/GNUstep/Local/Applications/Emacs.app
@comment in devel/gnustep-make: @dirrm share/GNUstep/Local/Applications
@comment in devel/gnustep-make: @dirrm share/GNUstep/Local
@comment in devel/gnustep-make: @dirrm share/GNUstep

View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2009/06/05 02:57:57 minskim Exp $
SHA1 (emacs-snapshot_20090604.orig.tar.gz) = 21ac8cfd45c791f507914b52b9605bc25b49035b
RMD160 (emacs-snapshot_20090604.orig.tar.gz) = d163cae20284a1c1df7628ce365430ea68797f92
Size (emacs-snapshot_20090604.orig.tar.gz) = 28804599 bytes
SHA1 (patch-ab) = f56a53c0e0ebf23505500b851a1766ea8b9c18f6
SHA1 (patch-ac) = 727439e174f1febd7fba2174a70a4e781414028d

View file

@ -0,0 +1,137 @@
# $NetBSD: options.mk,v 1.1.1.1 2009/06/05 02:57:57 minskim Exp $
#
PKG_OPTIONS_VAR= PKG_OPTIONS.emacs
PKG_SUPPORTED_OPTIONS= dbus xft2 svg
PKG_OPTIONS_OPTIONAL_GROUPS+= window-system
PKG_OPTIONS_GROUP.window-system= x11 nextstep
PKG_OPTIONS_OPTIONAL_GROUPS+= toolkit
PKG_OPTIONS_GROUP.toolkit= gtk motif xaw
PKG_SUGGESTED_OPTIONS= x11 xft2
.include "../../mk/bsd.options.mk"
###
### Support D-BUS
###
. if !empty(PKG_OPTIONS:Mdbus)
.include "../../sysutils/dbus/buildlink3.mk"
. else
CONFIGURE_ARGS+= --without-dbus
. endif
###
### Support SVG
###
. if !empty(PKG_OPTIONS:Msvg)
.include "../../graphics/librsvg/buildlink3.mk"
. else
CONFIGURE_ARGS+= --without-rsvg
. endif
###
### Any of the "toolkit" options with no window-system option implies "x11"
###
.if !empty(PKG_OPTIONS:Mgtk) || !empty(PKG_OPTIONS:Mmotif) || !empty(PKG_OPTIONS:Mxaw) || !empty(PKG_OPTIONS:Mxft2)
. if empty(PKG_OPTIONS:Mx11) && empty(PKG_OPTIONS:Mnextstep)
PKG_OPTIONS+= x11
. endif
.endif
###
### Default to using the Xaw X11 toolkit if none is specified.
###
.if !empty(PKG_OPTIONS:Mx11)
. if empty(PKG_OPTIONS:Mgtk) && empty(PKG_OPTIONS:Mmotif) && empty(PKG_OPTIONS:Mxaw)
PKG_OPTIONS+= xaw
. endif
.endif
###
### Support drawing pretty X11 widgets.
###
.if !empty(PKG_OPTIONS:Mx11)
CONFIGURE_ARGS+= --with-x
CONFIGURE_ARGS+= --with-xpm
CONFIGURE_ARGS+= --with-jpeg
CONFIGURE_ARGS+= --with-tiff
CONFIGURE_ARGS+= --with-gif
CONFIGURE_ARGS+= --with-png
.include "../../graphics/jpeg/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"
.include "../../graphics/libungif/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../x11/libSM/buildlink3.mk"
.include "../../x11/libXpm/buildlink3.mk"
###
### Enable font backend
###
. if !empty(PKG_OPTIONS:Mxft2)
.include "../../fonts/fontconfig/buildlink3.mk"
.include "../../graphics/libotf/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../x11/libXft/buildlink3.mk"
.include "../../devel/m17n-lib/buildlink3.mk"
. else
CONFIGURE_ARGS+= --without-xft --without-otf --without-m17n-flt
. endif
###
### Support using GTK X11 widgets.
###
. if !empty(PKG_OPTIONS:Mgtk)
USE_TOOLS+= pkg-config
.include "../../x11/gtk2/buildlink3.mk"
CONFIGURE_ARGS+= --with-x-toolkit=gtk
###
### Support using Motif X11 widgets.
###
. elif !empty(PKG_OPTIONS:Mmotif)
.include "../../mk/motif.buildlink3.mk"
CONFIGURE_ARGS+= --with-x-toolkit=motif
###
### Support using Xaw (Lucid) X11 widgets.
###
. elif !empty(PKG_OPTIONS:Mxaw)
.include "../../mk/xaw.buildlink3.mk"
CONFIGURE_ARGS+= --with-x-toolkit=athena
. endif
###
### Support using NextStep (Cocoa or GNUstep) windowing system
###
.elif !empty(PKG_OPTIONS:Mnextstep)
. if exists(/System/Library/Frameworks/Cocoa.framework)
APPLICATIONS_DIR= Applications
PLIST_SRC+= PLIST.cocoa
CHECK_WRKREF_SKIP+= Applications/Emacs.app/Contents/MacOS/Emacs
. else
.include "../../x11/gnustep-gui/buildlink3.mk"
MAKE_FILE= Makefile
APPLICATIONS_DIR= share/GNUstep/Local/Applications
PLIST_SRC+= PLIST.gnustep
. endif
CONFIGURE_ARGS+= --without-x
CONFIGURE_ARGS+= --with-ns
CONFIGURE_ARGS+= --disable-ns-self-contained
INSTALLATION_DIRS+= ${APPLICATIONS_DIR}
USE_TOOLS+= pax
post-install:
cd ${WRKSRC}/nextstep && \
pax -rw -pp -pm Emacs.app ${DESTDIR}${PREFIX}/${APPLICATIONS_DIR}
.else
CONFIGURE_ARGS+= --without-x
CONFIGURE_ARGS+= --without-xpm
CONFIGURE_ARGS+= --without-jpeg
CONFIGURE_ARGS+= --without-tiff
CONFIGURE_ARGS+= --without-gif
CONFIGURE_ARGS+= --without-png
.endif

View file

@ -0,0 +1,25 @@
$NetBSD: patch-ab,v 1.1.1.1 2009/06/05 02:57:57 minskim Exp $
--- configure.orig 2009-04-28 02:45:09.000000000 +0000
+++ configure
@@ -1856,7 +1856,7 @@ archlibdir='${libexecdir}/emacs/${versio
docdir='${datadir}/emacs/${version}/etc'
gamedir='${localstatedir}/games/emacs'
-gameuser=games
+gameuser=${GAMEOWN}
@@ -9405,9 +9405,9 @@ if test "${HAVE_NS}" = yes; then
window_system=nextstep
with_xft=no
# set up packaging dirs
- exec_prefix=${ns_appbindir}
- libexecdir=${ns_appbindir}/libexec
if test "${EN_NS_SELF_CONTAINED}" = yes; then
+ exec_prefix=${ns_appbindir}
+ libexecdir=${ns_appbindir}/libexec
prefix=${ns_appresdir}
fi
fi

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.1.1.1 2009/06/05 02:57:57 minskim Exp $
--- Makefile.in 2009-05-04 01:13:20.000000000 +0000
+++ Makefile.in
@@ -403,7 +403,7 @@ $(srcdir)/src/stamp-h.in: $(AUTOCONF_INP
install: all install-arch-indep install-arch-dep install-leim blessmail
@true
-MV_DIRS = for i in $$dir; do rm -fr `basename "$$i"` ; mv "$$i" . ; done
+MV_DIRS = for i in $$dir; do if test -e $$i ; then rm -fr `basename "$$i"` ; mv "$$i" . ; fi; done
### Install the executables that were compiled specifically for this machine.
### It would be nice to do something for a parallel make