Update to 1.8:
Changes in 1.8 final: Added support for OWNE ID3 frames. Changed key validation in the new PropertyMap API. ID3v1::Tag::setStringHandler will no londer delete the previous handler, the caller is responsible for this. File objects will also no longer delete the passed IOStream objects. It should be done in the caller code after the File object is no longer used. Added ID3v2::Tag::setLatin1StringHandler for custom handling of latin1-encoded text in ID3v2 frames. Fixed validation of ID3v2 frame IDs (IDs with Changes in 1.8 beta: New API for accessing tags by name. New abstract I/O stream layer to allow custom I/O handlers. Support for writing ID3v2.3 tags. Support for various module file formats (MOD, S3M, IT, XM). Support for MP4 and ASF is now enabled by default. Started using atomic int operations for reference counting. Added methods for checking if WMA and MP4 files are DRM-protected. Added taglib_free to the C bindings. New method to allow removing pictures from FLAC files. Support for reading audio properties from ALAC and Musepack SV8 files. Added replay-gain information to Musepack audio properties. Support for APEv2 binary tags. Many AudioProperties subclasses now provide information about the total number of samples. Various small bug fixes.
This commit is contained in:
parent
1fa3f66546
commit
171cfc4d47
4 changed files with 25 additions and 27 deletions
|
@ -1,12 +1,12 @@
|
|||
# $NetBSD: Makefile,v 1.27 2012/05/29 13:37:44 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.28 2012/10/02 17:24:48 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= taglib-1.7.2
|
||||
DISTNAME= taglib-1.8
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://developer.kde.org/~wheeler/files/src/
|
||||
MASTER_SITES= http://cloud.github.com/downloads/taglib/taglib/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://developer.kde.org/~wheeler/taglib.html
|
||||
HOMEPAGE= http://taglib.github.com/
|
||||
COMMENT= Library for accessing id tags in various media files
|
||||
LICENSE= gnu-lgpl-v2.1 OR mpl-1.1
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.14 2012/05/29 13:37:44 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.15 2012/10/02 17:24:48 wiz Exp $
|
||||
bin/taglib-config
|
||||
include/taglib/aifffile.h
|
||||
include/taglib/aiffproperties.h
|
||||
|
@ -30,6 +30,12 @@ include/taglib/id3v2framefactory.h
|
|||
include/taglib/id3v2header.h
|
||||
include/taglib/id3v2synchdata.h
|
||||
include/taglib/id3v2tag.h
|
||||
include/taglib/itfile.h
|
||||
include/taglib/itproperties.h
|
||||
include/taglib/modfile.h
|
||||
include/taglib/modfilebase.h
|
||||
include/taglib/modproperties.h
|
||||
include/taglib/modtag.h
|
||||
include/taglib/mp4atom.h
|
||||
include/taglib/mp4coverart.h
|
||||
include/taglib/mp4file.h
|
||||
|
@ -45,10 +51,13 @@ include/taglib/oggfile.h
|
|||
include/taglib/oggflacfile.h
|
||||
include/taglib/oggpage.h
|
||||
include/taglib/oggpageheader.h
|
||||
include/taglib/ownershipframe.h
|
||||
include/taglib/popularimeterframe.h
|
||||
include/taglib/privateframe.h
|
||||
include/taglib/relativevolumeframe.h
|
||||
include/taglib/rifffile.h
|
||||
include/taglib/s3mfile.h
|
||||
include/taglib/s3mproperties.h
|
||||
include/taglib/speexfile.h
|
||||
include/taglib/speexproperties.h
|
||||
include/taglib/tag.h
|
||||
|
@ -58,12 +67,16 @@ include/taglib/taglib_config.h
|
|||
include/taglib/taglib_export.h
|
||||
include/taglib/tbytevector.h
|
||||
include/taglib/tbytevectorlist.h
|
||||
include/taglib/tbytevectorstream.h
|
||||
include/taglib/textidentificationframe.h
|
||||
include/taglib/tfile.h
|
||||
include/taglib/tfilestream.h
|
||||
include/taglib/tiostream.h
|
||||
include/taglib/tlist.h
|
||||
include/taglib/tlist.tcc
|
||||
include/taglib/tmap.h
|
||||
include/taglib/tmap.tcc
|
||||
include/taglib/tpropertymap.h
|
||||
include/taglib/trueaudiofile.h
|
||||
include/taglib/trueaudioproperties.h
|
||||
include/taglib/tstring.h
|
||||
|
@ -80,9 +93,11 @@ include/taglib/wavpackproperties.h
|
|||
include/taglib/wavproperties.h
|
||||
include/taglib/xingheader.h
|
||||
include/taglib/xiphcomment.h
|
||||
include/taglib/xmfile.h
|
||||
include/taglib/xmproperties.h
|
||||
lib/libtag.so
|
||||
lib/libtag.so.1
|
||||
lib/libtag.so.1.10.2
|
||||
lib/libtag.so.1.12.0
|
||||
lib/libtag_c.so
|
||||
lib/libtag_c.so.0
|
||||
lib/libtag_c.so.0.0.0
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.15 2012/05/29 13:37:44 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.16 2012/10/02 17:24:48 wiz Exp $
|
||||
|
||||
SHA1 (taglib-1.7.2.tar.gz) = e657384ccf3284db2daba32dccece74534286012
|
||||
RMD160 (taglib-1.7.2.tar.gz) = 13ee35746d46ccc729e1822f9056343a8e5b05b4
|
||||
Size (taglib-1.7.2.tar.gz) = 535427 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = 5e18adbb0dcd64a265774c714b02be794cf9fb5b
|
||||
SHA1 (taglib-1.8.tar.gz) = bdbfd746fde42401d3a77cd930c7802d374a692d
|
||||
RMD160 (taglib-1.8.tar.gz) = 1009fe5b59043ff2096087ea167b358a175e5a92
|
||||
Size (taglib-1.8.tar.gz) = 595937 bytes
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-CMakeLists.txt,v 1.3 2012/05/29 13:37:45 wiz Exp $
|
||||
|
||||
Increase taglib minor version to be bigger than in the last automake
|
||||
release.
|
||||
|
||||
--- CMakeLists.txt.orig 2012-04-20 15:57:13.000000000 +0000
|
||||
+++ CMakeLists.txt
|
||||
@@ -39,7 +39,7 @@ if (WIN32)
|
||||
endif (WIN32)
|
||||
|
||||
SET(TAGLIB_LIB_MAJOR_VERSION "1")
|
||||
-SET(TAGLIB_LIB_MINOR_VERSION "7")
|
||||
+SET(TAGLIB_LIB_MINOR_VERSION "10")
|
||||
SET(TAGLIB_LIB_PATCH_VERSION "2")
|
||||
|
||||
SET(TAGLIB_LIB_VERSION_STRING "${TAGLIB_LIB_MAJOR_VERSION}.${TAGLIB_LIB_MINOR_VERSION}.${TAGLIB_LIB_PATCH_VERSION}")
|
Loading…
Reference in a new issue