Fix inline usage. Add missing return values.
This commit is contained in:
parent
a05d5829d5
commit
172039f8d5
3 changed files with 77 additions and 1 deletions
|
@ -1,6 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.4 2010/02/03 22:24:06 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.5 2012/11/01 19:50:59 joerg Exp $
|
||||
|
||||
SHA1 (qvplay-0.94.tar.gz) = ecc48babf604f802833de16eb404186820c93edc
|
||||
RMD160 (qvplay-0.94.tar.gz) = 2f84c15541913736ea53c089ae409c60c6dfdae2
|
||||
Size (qvplay-0.94.tar.gz) = 110612 bytes
|
||||
SHA1 (patch-aa) = 7e7c81c9253095b8b01fe0b083c4f0ae62c9da0e
|
||||
SHA1 (patch-command.c) = 33a957ed06c20d815ba34a1dc0b4469f0076ac45
|
||||
SHA1 (patch-qvrec.c) = 7afa5a31c1a9a107c205d7ea58fdcd8740f24478
|
||||
|
|
40
graphics/qvplay/patches/patch-command.c
Normal file
40
graphics/qvplay/patches/patch-command.c
Normal file
|
@ -0,0 +1,40 @@
|
|||
$NetBSD: patch-command.c,v 1.1 2012/11/01 19:50:59 joerg Exp $
|
||||
|
||||
--- command.c.orig 2012-10-30 22:18:05.000000000 +0000
|
||||
+++ command.c
|
||||
@@ -89,7 +89,7 @@ calcsum(p, len)
|
||||
return(sum);
|
||||
}
|
||||
|
||||
-inline void
|
||||
+void
|
||||
wbyte(c)
|
||||
u_char c;
|
||||
{
|
||||
@@ -104,7 +104,7 @@ wbyte(c)
|
||||
check_sum = check_sum + (int) c;
|
||||
}
|
||||
|
||||
-inline u_char
|
||||
+u_char
|
||||
rbyte()
|
||||
{
|
||||
u_char c;
|
||||
@@ -133,7 +133,7 @@ int checksum(u_char u)
|
||||
return(1);
|
||||
}
|
||||
|
||||
-inline void
|
||||
+void
|
||||
wstr(p, len)
|
||||
u_char *p;
|
||||
int len;
|
||||
@@ -149,7 +149,7 @@ wstr(p, len)
|
||||
check_sum = check_sum + calcsum(p, len);
|
||||
}
|
||||
|
||||
-inline void
|
||||
+void
|
||||
rstr(p, len)
|
||||
u_char *p;
|
||||
int len;
|
34
graphics/qvplay/patches/patch-qvrec.c
Normal file
34
graphics/qvplay/patches/patch-qvrec.c
Normal file
|
@ -0,0 +1,34 @@
|
|||
$NetBSD: patch-qvrec.c,v 1.1 2012/11/01 19:50:59 joerg Exp $
|
||||
|
||||
--- qvrec.c.orig 2012-10-30 22:18:26.000000000 +0000
|
||||
+++ qvrec.c
|
||||
@@ -617,12 +617,12 @@ main(argc, argv)
|
||||
if(QVremain(1) < 0){
|
||||
fprintf(stderr, "picture full.\n");
|
||||
errflg ++;
|
||||
- return;
|
||||
+ return 1;
|
||||
}
|
||||
if(QVremain(0) < 0){
|
||||
fprintf(stderr, "picture full.\n");
|
||||
errflg ++;
|
||||
- return;
|
||||
+ return 1;
|
||||
}
|
||||
} else {
|
||||
if(all_pic_num >= MAX_PICTURE_NUM_QV10) {
|
||||
@@ -659,12 +659,12 @@ main(argc, argv)
|
||||
if(QVremain(1) < 0){
|
||||
fprintf(stderr, "picture full.\n");
|
||||
errflg ++;
|
||||
- return;
|
||||
+ return 1;
|
||||
}
|
||||
if(QVremain(0) < 0){
|
||||
fprintf(stderr, "picture full.\n");
|
||||
errflg ++;
|
||||
- return;
|
||||
+ return 1;
|
||||
}
|
||||
} else {
|
||||
if(all_pic_num >= MAX_PICTURE_NUM_QV10) {
|
Loading…
Reference in a new issue