Update to 2.0.0:

Ported to gtk2.
This commit is contained in:
wiz 2004-09-25 23:03:13 +00:00
parent 4d6bde7e5c
commit 1726bb2a7d
5 changed files with 42 additions and 35 deletions

View file

@ -1,10 +1,10 @@
KanjiPad is a very simple program for handwriting recognition -
The user draws a character into the box, then requests translation.
The best candidates are displayed along the right hand side of
the window and can be selected for pasting into other programs.
The best candidates are displayed along the right hand side of the
window and can be selected for pasting into other programs.
It is meant primarily for dictionary purposes for learners of Japanese
- it does not support entering kana, so its usefulness as an input
method is limited. Furthermore, if you already know the reading of a
character, conventional pronunciation based methods of entering the
character are probably faster.
It is meant primarily for dictionary purposes for learners of
Japanese - it does not support entering kana, so it's usefulness
as an input method is limited. Furthermore, if you already know
the reading of a character, conventional pronunciation based methods
of entering the character are probably faster.

View file

@ -1,24 +1,21 @@
# $NetBSD: Makefile,v 1.7 2004/04/18 19:37:14 wiz Exp $
# $NetBSD: Makefile,v 1.8 2004/09/25 23:03:13 wiz Exp $
#
DISTNAME= kanjipad-1.2.1
PKGREVISION= 2
CATEGORIES= misc
MASTER_SITES= ftp://ftp.gtk.org/pub/users/otaylor/kanjipad/
DISTNAME= kanjipad-2.0.0
CATEGORIES= misc
MASTER_SITES= http://fishsoup.net/software/kanjipad/
MAINTAINER= wiz@NetBSD.org
HOMEPAGE= http://www.gtk.org/~otaylor/kanjipad/index.html
COMMENT= Japanese handwriting recognition with GTK interface
MAINTAINER= wiz@NetBSD.org
HOMEPAGE= http://fishsoup.net/software/kanjipad/
COMMENT= Japanese handwriting recognition
USE_PERL5= build
USE_BUILDLINK3= yes
USE_GNU_TOOLS+= make
USE_PERL5= build
USE_BUILDLINK3= YES
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/kanjipad
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/kanjipad
do-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/kanjipad
${INSTALL_PROGRAM} ${WRKSRC}/kanjipad ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/kpengine ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/jdata.dat ${PREFIX}/share/kanjipad
.include "../../x11/gtk/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,7 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2002/07/14 10:03:54 wiz Exp $
@comment $NetBSD: PLIST,v 1.2 2004/09/25 23:03:13 wiz Exp $
bin/kanjipad
bin/kpengine
share/kanjipad/jdata.dat
share/doc/kanjipad/README
@dirrm share/kanjipad
@dirrm share/doc/kanjipad

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.2 2002/10/13 11:38:17 wiz Exp $
$NetBSD: distinfo,v 1.3 2004/09/25 23:03:13 wiz Exp $
SHA1 (kanjipad-1.2.1.tar.gz) = 8ddc4222386feeb184dae4c57dc7ec3e922adfbc
Size (kanjipad-1.2.1.tar.gz) = 74287 bytes
SHA1 (patch-aa) = 74b3c48bef313b8befad1e2118e16d2d53645ffe
SHA1 (kanjipad-2.0.0.tar.gz) = 477daae975996ee105ca401fb8083b636fd6d25c
Size (kanjipad-2.0.0.tar.gz) = 75930 bytes
SHA1 (patch-aa) = 7064a80a06ea5e2129f609e73ad914941c245684

View file

@ -1,16 +1,24 @@
$NetBSD: patch-aa,v 1.2 2002/10/13 11:38:17 wiz Exp $
$NetBSD: patch-aa,v 1.3 2004/09/25 23:03:13 wiz Exp $
--- Makefile.orig Wed Mar 31 09:36:32 1999
--- Makefile.orig 2002-08-25 21:00:54.000000000 +0200
+++ Makefile
@@ -1,10 +1,10 @@
@@ -1,11 +1,10 @@
OPTIMIZE=-g -Wall
#OPTIMIZE=-O2
GTKLIBS=`gtk-config --libs`
GTKINC=`gtk-config --cflags`
-GTKINC=$(shell pkg-config --cflags gtk+-2.0) -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED
+GTKINC=$(shell pkg-config --cflags gtk+-2.0) -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED
GTKLIBS=$(shell pkg-config --libs gtk+-2.0)
GLIBLIBS=$(shell pkg-config --libs glib-2.0)
-PREFIX=/usr/local
+#PREFIX=/usr/local
DATADIR=$(PREFIX)/share
# location in which binaries are installed
@@ -75,4 +74,4 @@ distcheck: dist
cd .. && \
rm -rf $$distdir
-.PHONY: dist distcheck
\ No newline at end of file
+.PHONY: dist distcheck