Import ebview version 0.3.6.
Packaged by Yamashiro Jun and privided in PR 37452. EBView is a GTK+ based tool to access CD-ROM dictionaries of EPWING/EB/EBG/EBXA/EBXA-C formats.
This commit is contained in:
parent
98be5e390c
commit
17b2046355
6 changed files with 93 additions and 0 deletions
2
textproc/ebview/DESCR
Normal file
2
textproc/ebview/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
EBView is a GTK+ based tool to access CD-ROM dictionaries of
|
||||
EPWING/EB/EBG/EBXA/EBXA-C formats.
|
18
textproc/ebview/Makefile
Normal file
18
textproc/ebview/Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2007/12/12 08:34:16 obache Exp $
|
||||
|
||||
DISTNAME= ebview-0.3.6
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=ebview/}
|
||||
|
||||
MAINTAINER= yamajun@ofug.net
|
||||
HOMEPAGE= http://ebview.sourceforge.net/
|
||||
COMMENT= GTK2 based EPWING dictionary browser
|
||||
|
||||
USE_PKGLOCALEDIR= YES
|
||||
USE_TOOLS+= gmake
|
||||
GNU_CONFIGURE= YES
|
||||
|
||||
.include "../../converters/libiconv/buildlink3.mk"
|
||||
.include "../../textproc/eb/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
20
textproc/ebview/PLIST
Normal file
20
textproc/ebview/PLIST
Normal file
|
@ -0,0 +1,20 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2007/12/12 08:34:16 obache Exp $
|
||||
bin/ebview
|
||||
share/ebview/about.en
|
||||
share/ebview/about.jp
|
||||
share/ebview/endinglist-ja.xml
|
||||
share/ebview/endinglist.xml
|
||||
share/ebview/filter.xml
|
||||
share/ebview/help/en/body.html
|
||||
share/ebview/help/en/index.html
|
||||
share/ebview/help/en/menu.html
|
||||
share/ebview/help/ja/body.html
|
||||
share/ebview/help/ja/index.html
|
||||
share/ebview/help/ja/menu.html
|
||||
share/ebview/searchengines.xml
|
||||
share/ebview/shortcut.xml
|
||||
${PKGLOCALEDIR}/locale/ja/LC_MESSAGES/ebview.mo
|
||||
@dirrm share/ebview/help/ja
|
||||
@dirrm share/ebview/help/en
|
||||
@dirrm share/ebview/help
|
||||
@dirrm share/ebview
|
7
textproc/ebview/distinfo
Normal file
7
textproc/ebview/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2007/12/12 08:34:16 obache Exp $
|
||||
|
||||
SHA1 (ebview-0.3.6.tar.gz) = 47b63fb2f265c83cc5bf7aeb92f96d0e1cc7f9af
|
||||
RMD160 (ebview-0.3.6.tar.gz) = c32de00be68c13794f2c1d9c08edc34fc5dcb613
|
||||
Size (ebview-0.3.6.tar.gz) = 564915 bytes
|
||||
SHA1 (patch-aa) = 8ecee1eeb1fddb9f1378a3258c8b8ae9a91c1640
|
||||
SHA1 (patch-ab) = ffedc7cc8b931f63f5a661314ef3703f88498434
|
33
textproc/ebview/patches/patch-aa
Normal file
33
textproc/ebview/patches/patch-aa
Normal file
|
@ -0,0 +1,33 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2007/12/12 08:34:16 obache Exp $
|
||||
|
||||
--- src/preference.c.orig 2005-10-05 09:41:23.000000000 +0900
|
||||
+++ src/preference.c 2005-10-05 10:11:16.000000000 +0900
|
||||
@@ -400,7 +400,7 @@ void calculate_font_size(){
|
||||
PangoFontDescription* desc;
|
||||
PangoLanguage* lang;
|
||||
PangoFontMap* fontmap;
|
||||
-#ifndef __WIN32__
|
||||
+#if !GTK_CHECK_VERSION(2,8,0) && !defined(__WIN32__)
|
||||
Display *display;
|
||||
#endif
|
||||
PangoContext *context;
|
||||
@@ -420,6 +420,9 @@ void calculate_font_size(){
|
||||
desc = pango_font_description_from_string(fontset_normal);
|
||||
lang = pango_language_from_string("ja");
|
||||
|
||||
+#if GTK_CHECK_VERSION(2,8,0)
|
||||
+ fontmap = pango_cairo_font_map_get_default();
|
||||
+#else
|
||||
#ifdef __WIN32__
|
||||
fontmap = pango_win32_font_map_for_display();
|
||||
#else
|
||||
@@ -430,7 +433,8 @@ void calculate_font_size(){
|
||||
}
|
||||
|
||||
fontmap = pango_x_font_map_for_display(display);
|
||||
-#endif
|
||||
+#endif /* __WIN32__ */
|
||||
+#endif /* GTK_CHECK_VERSION(2,8,0) */
|
||||
|
||||
if(fontmap == NULL){
|
||||
LOG(LOG_INFO, "fontmap == NULL");
|
13
textproc/ebview/patches/patch-ab
Normal file
13
textproc/ebview/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2007/12/12 08:34:16 obache Exp $
|
||||
|
||||
--- src/ebview.c.orig 2007-11-10 20:57:09.000000000 +0900
|
||||
+++ src/ebview.c 2007-11-10 20:57:27.000000000 +0900
|
||||
@@ -15,8 +15,6 @@
|
||||
* Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
|
||||
-#define GTK_DISABLE_DEPRECATED 1
|
||||
-
|
||||
#define _GLOBAL
|
||||
#include <signal.h>
|
||||
#include <pthread.h>
|
Loading…
Reference in a new issue