Fixed file permissions of the installed files. 700 is not appropriate

for binaries.

Got rid of patch-aa for the Makefile.

PKGREVISION++
This commit is contained in:
rillig 2007-01-08 21:12:31 +00:00
parent f58ba92ec6
commit 180c4d9a5a
4 changed files with 14 additions and 26 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.11 2006/03/04 21:30:23 jlam Exp $
# $NetBSD: Makefile,v 1.12 2007/01/08 21:12:31 rillig Exp $
#
DISTNAME= rinetd
PKGNAME= ${DISTNAME}-0.62
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.boutell.com/rinetd/http/
@ -11,13 +11,15 @@ MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.boutell.com/rinetd/
COMMENT= Internet redirection server
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
NO_CONFIGURE= yes
BUILD_TARGET= rinetd
CPPFLAGS+= -DRINETD_CONF="\"${PKG_SYSCONFDIR}/rinetd.conf\""
INSTALLATION_DIRS= sbin ${PKGMANDIR}/man8
RCD_SCRIPTS= rinetd
RCD_SCRIPT_WRK.rinetd= ${WRKDIR}/rinetd.sh
SUBST_CLASSES+= paths
SUBST_FILES.paths= rinetd.8
@ -25,7 +27,11 @@ SUBST_SED.paths+= -e 's,@PREFIX@,${PREFIX},g'
SUBST_SED.paths+= -e 's,@PKG_SYSCONFDIR@,${PKG_SYSCONFDIR},g'
SUBST_STAGE.paths= post-patch
post-extract:
@cd ${WRKDIR} && ${MV} -f rinetd ${PKGNAME_NOREV}
do-build:
cd ${WRKSRC} && env ${MAKE_ENV} cc ${CPPFLAGS} ${CFLAGS} -o rinetd *.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rinetd ${PREFIX}/sbin/.
${INSTALL_MAN} ${WRKSRC}/rinetd.8 ${PREFIX}/${PKGMANDIR}/man8/.
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2005/05/02 20:34:03 reed Exp $
sbin/rinetd
@comment $NetBSD: PLIST,v 1.3 2007/01/08 21:12:31 rillig Exp $
man/man8/rinetd.8
sbin/rinetd
share/examples/rc.d/rinetd

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.2 2005/02/24 12:14:03 agc Exp $
$NetBSD: distinfo,v 1.3 2007/01/08 21:12:31 rillig Exp $
SHA1 (rinetd.tar.gz) = 2498fa03c2ef50bf924ffd0a034d5de5e3258f21
RMD160 (rinetd.tar.gz) = cccb194bae7bb2dde2eca45690a2618fbba10257
Size (rinetd.tar.gz) = 115541 bytes
SHA1 (patch-aa) = 885a732b1b3ea52dc0bbdad9b18ca0031fdcb889
SHA1 (patch-ab) = 9fa5cf00111a56051a40d73293ca071c125802a0
SHA1 (patch-ac) = 743b979bfc287bb0968e418a06cab8a8d2b6dc64

View file

@ -1,17 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/10/01 01:15:44 grant Exp $
--- Makefile.orig 1999-03-02 05:41:50.000000000 +1100
+++ Makefile
@@ -1,9 +1,7 @@
-CFLAGS=-DLINUX -g
-
rinetd: rinetd.o match.o
- gcc rinetd.o match.o -o rinetd
+ ${CC} rinetd.o match.o -o rinetd
install: rinetd
- install -m 700 rinetd /usr/sbin
- install -m 644 rinetd.8 /usr/man/man8
+ ${INSTALL} -m 700 rinetd ${PREFIX}/sbin
+ ${INSTALL} -m 644 rinetd.8 ${PREFIX}/man/man8