Changes 20050322:
- fixed the problem with Ticks getting incremented on every interrupt, not just 60Hz (e.g. moving the mouse made the caret blink faster) - Unix: integrated JIT compiler for Linux/x86 and FreeBSD/x86 - Unix: moved minimum autoconf support to 2.52+ - Unix: add large file support for 2+ GB hard disk images - Unix: cleaned up pthread attributes [Brian Johnson] - Unix: fixed floppy problems under Linux - Unix: implemented "ignoresegv" feature on Linux/x86, Linux/ppc, Darwin/ppc - Unix: serial port baud rates are now set correctly - Unix: it is now possible to make the serial drivers pipe their input/output to programs by using a '|' followed by a command line as the modem or printer port setting (instead of a device name like '/dev/ttyS0') - Unix: the option "--config FILE" tells B2 to use a different config file - Unix: new prefs options "dsp" and "mixer" to set the OSS device names instead of the hardcoded '/dev/dsp' and '/dev/mixer' - Unix: new ether prefs option 'tun' to use a TUN/TAP interface. The configure script used can be overriden with "etherconfig" - Unix: SDL audio and video output are now available in option - Unix: port JIT compiler to Linux/x86_64 (AMD64 and EM64T platforms) - Unix: sheep_net driver ported to kernel 2.6 (patches from Mac-On-Linux) - Unix: fix network code to work correctly on 64-bit platforms - Unix: implement X11 to MacOS exchange of text through the clipboard - Windows: a new port derived from Lauri's work is now available
This commit is contained in:
parent
ee0cbb624f
commit
181bc687b6
8 changed files with 77 additions and 52 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.21 2005/06/01 18:02:46 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.22 2005/07/01 12:34:32 adam Exp $
|
||||
|
||||
DISTNAME= BasiliskII_src_14032003
|
||||
PKGNAME= BasiliskII-1.0.20030314
|
||||
DISTNAME= BasiliskII_src_22032005
|
||||
PKGNAME= BasiliskII-1.0.20050322
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= http://gwenole.beauchesne.online.fr/basilisk2/files/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -10,19 +10,15 @@ MAINTAINER= tech-pkg@NetBSD.org
|
|||
HOMEPAGE= http://gwenole.beauchesne.online.fr/basilisk2/
|
||||
COMMENT= Open Source 68k Macintosh emulator
|
||||
|
||||
NOT_FOR_PLATFORM+= Darwin-*-*
|
||||
|
||||
WRKSRC= ${WRKDIR}/BasiliskII-1.0/src/Unix
|
||||
GNU_CONFIGURE= yes
|
||||
USE_TOOLS+= gmake
|
||||
USE_LANGUAGES= c c++
|
||||
USE_LANGUAGES= c c++
|
||||
USE_TOOLS+= gmake
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --disable-fbdev-dga
|
||||
CONFIGURE_ARGS+= --enable-addressing=banks
|
||||
CONFIGURE_ARGS+= --without-mon
|
||||
|
||||
CONFIGURE_ARGS+= --without-gtk \
|
||||
--without-esd \
|
||||
--disable-fbdev-dga \
|
||||
--without-mon
|
||||
|
||||
.include "../../mk/x11.buildlink3.mk"
|
||||
.include "options.mk"
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/BasiliskII
|
||||
|
@ -30,4 +26,5 @@ post-install:
|
|||
${INSTALL_DATA} ${WRKSRC}/../../TECH ${PREFIX}/share/doc/BasiliskII/
|
||||
${INSTALL_DATA} ${WRKSRC}/../../TODO ${PREFIX}/share/doc/BasiliskII/
|
||||
|
||||
.include "../../converters/libiconv/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2002/11/09 14:12:26 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2005/07/01 12:34:32 adam Exp $
|
||||
bin/BasiliskII
|
||||
man/man1/BasiliskII.1
|
||||
share/BasiliskII/keycodes
|
||||
share/BasiliskII/fbdevices
|
||||
share/BasiliskII/keycodes
|
||||
share/BasiliskII/tunconfig
|
||||
share/doc/BasiliskII/README
|
||||
share/doc/BasiliskII/TECH
|
||||
share/doc/BasiliskII/TODO
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.8 2005/02/23 18:49:17 agc Exp $
|
||||
$NetBSD: distinfo,v 1.9 2005/07/01 12:34:32 adam Exp $
|
||||
|
||||
SHA1 (BasiliskII_src_14032003.tar.bz2) = 935e00e1401fc5dfaad7ac7d54184265bab0aeb8
|
||||
RMD160 (BasiliskII_src_14032003.tar.bz2) = fa9718bdb4dcdd18ac3d9b87cdfb8c588a668124
|
||||
Size (BasiliskII_src_14032003.tar.bz2) = 649594 bytes
|
||||
SHA1 (patch-aa) = e41d9a3a932bb312e2ea35372c4e46a45f0fcae9
|
||||
SHA1 (patch-ab) = 17c94164ece847bd5695e8fb79ff5132c3c53859
|
||||
SHA1 (patch-ac) = c74b28008032f8f31cbee1085d4873c36c7e71a5
|
||||
SHA1 (patch-ad) = c3bc05f1387c07bc0b4fc60e54a6c5f935a80785
|
||||
SHA1 (BasiliskII_src_22032005.tar.bz2) = e6c6efe9dded3e50b204fc641f42d15447819109
|
||||
RMD160 (BasiliskII_src_22032005.tar.bz2) = 6fac78005ed8a8794c192a07d36285a68ad1ccfa
|
||||
Size (BasiliskII_src_22032005.tar.bz2) = 914468 bytes
|
||||
SHA1 (patch-aa) = f1ddf3941a45e09dc2ec75a24939261387e35142
|
||||
SHA1 (patch-ab) = 3bbc87e42cdae430097483401a0d3b032a746185
|
||||
SHA1 (patch-ac) = 61804c0ff4778964241a5ae4d73ea1d4f09e13e2
|
||||
SHA1 (patch-ad) = 374d361b8aadcb31aa85e673b1b9ff0947f491dd
|
||||
|
|
28
emulators/BasiliskII/options.mk
Normal file
28
emulators/BasiliskII/options.mk
Normal file
|
@ -0,0 +1,28 @@
|
|||
# $NetBSD: options.mk,v 1.1 2005/07/01 12:34:32 adam Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.BasiliskII
|
||||
PKG_SUPPORTED_OPTIONS= esd gtk sdl
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mesd)
|
||||
CONFIGURE_ARGS+= --with-esd
|
||||
.include "../../audio/esound/buildlink3.mk"
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-esd
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mgtk)
|
||||
CONFIGURE_ARGS+= --with-gtk
|
||||
.include "../../x11/gtk/buildlink3.mk"
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-gtk
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Msdl)
|
||||
CONFIGURE_ARGS+= --enable-sdl-audio
|
||||
CONFIGURE_ARGS+= --enable-sdl-video
|
||||
.include "../../devel/SDL/buildlink3.mk"
|
||||
.else
|
||||
.include "../../mk/x11.buildlink3.mk"
|
||||
.endif
|
|
@ -1,14 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1 2003/06/14 06:49:05 tron Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2005/07/01 12:34:33 adam Exp $
|
||||
|
||||
--- main_unix.cpp.orig Thu Jun 12 22:53:57 2003
|
||||
+++ main_unix.cpp
|
||||
@@ -615,7 +615,9 @@ int main(int argc, char **argv)
|
||||
|
||||
// Start 60Hz timer
|
||||
sigemptyset(&timer_sa.sa_mask); // Block virtual 68k interrupts during SIGARLM handling
|
||||
+#if !EMULATED_68K
|
||||
sigaddset(&timer_sa.sa_mask, SIG_IRQ);
|
||||
+#endif
|
||||
timer_sa.sa_handler = one_tick;
|
||||
timer_sa.sa_flags = SA_ONSTACK | SA_RESTART;
|
||||
if (sigaction(SIGALRM, &timer_sa, NULL) < 0) {
|
||||
--- ../dummy/ether_dummy.cpp.orig 2005-07-01 12:04:04.000000000 +0000
|
||||
+++ ../dummy/ether_dummy.cpp
|
||||
@@ -173,7 +173,7 @@ void EtherInterrupt(void)
|
||||
length = recvfrom(fd, packet, 1514, 0, (struct sockaddr *)&from, &from_len);
|
||||
if (length < 14)
|
||||
break;
|
||||
- ether_udp_read(packet, length, &from);
|
||||
+ ether_udp_read((uint32)packet, length, &from);
|
||||
}
|
||||
}
|
||||
#endif
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.1 2003/06/14 06:49:05 tron Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2005/07/01 12:34:33 adam Exp $
|
||||
|
||||
--- video_x.cpp.orig Thu Jun 12 23:38:31 2003
|
||||
--- video_x.cpp.orig 2005-03-21 23:57:34.000000000 +0000
|
||||
+++ video_x.cpp
|
||||
@@ -2226,7 +2226,7 @@ static void update_display_dynamic(int t
|
||||
@@ -2288,7 +2288,7 @@ static void update_display_dynamic(int t
|
||||
static void update_display_static(driver_window *drv)
|
||||
{
|
||||
// Incremental update code
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ac,v 1.2 2003/10/12 21:11:52 wiz Exp $
|
||||
$NetBSD: patch-ac,v 1.3 2005/07/01 12:34:33 adam Exp $
|
||||
|
||||
--- vm_alloc.cpp.orig Fri Mar 14 20:17:27 2003
|
||||
--- vm_alloc.cpp.orig 2005-01-30 21:42:14.000000000 +0000
|
||||
+++ vm_alloc.cpp
|
||||
@@ -29,6 +29,7 @@
|
||||
@@ -39,6 +39,7 @@
|
||||
#include "vm_alloc.h"
|
||||
|
||||
#ifdef HAVE_MACH_VM
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ad,v 1.2 2004/07/17 01:56:38 xtraeme Exp $
|
||||
$NetBSD: patch-ad,v 1.3 2005/07/01 12:34:33 adam Exp $
|
||||
|
||||
--- sshpty.c.orig 2003-03-14 20:17:27.000000000 +0100
|
||||
+++ sshpty.c 2004-07-17 03:54:38.000000000 +0200
|
||||
@@ -18,6 +18,7 @@
|
||||
--- sshpty.c.orig 2003-08-17 10:20:22.000000000 +0000
|
||||
+++ sshpty.c
|
||||
@@ -18,6 +18,7 @@ RCSID("$OpenBSD: sshpty.c,v 1.4 2001/12/
|
||||
/* Selections from openssh's "includes.h" */
|
||||
#include "config.h"
|
||||
|
||||
|
@ -10,7 +10,7 @@ $NetBSD: patch-ad,v 1.2 2004/07/17 01:56:38 xtraeme Exp $
|
|||
#include <stdio.h>
|
||||
#include <ctype.h>
|
||||
#include <errno.h>
|
||||
@@ -144,19 +145,30 @@
|
||||
@@ -145,19 +146,30 @@ pty_allocate(int *ptyfd, int *ttyfd, cha
|
||||
*/
|
||||
int ptm;
|
||||
char *pts;
|
||||
|
@ -42,7 +42,7 @@ $NetBSD: patch-ad,v 1.2 2004/07/17 01:56:38 xtraeme Exp $
|
|||
if (unlockpt(ptm) < 0) {
|
||||
error("unlockpt: %.100s", strerror(errno));
|
||||
return 0;
|
||||
@@ -174,7 +186,7 @@
|
||||
@@ -175,7 +187,7 @@ pty_allocate(int *ptyfd, int *ttyfd, cha
|
||||
close(*ptyfd);
|
||||
return 0;
|
||||
}
|
||||
|
@ -51,7 +51,7 @@ $NetBSD: patch-ad,v 1.2 2004/07/17 01:56:38 xtraeme Exp $
|
|||
/*
|
||||
* Push the appropriate streams modules, as described in Solaris pts(7).
|
||||
* HP-UX pts(7) doesn't have ttcompat module.
|
||||
@@ -183,7 +195,7 @@
|
||||
@@ -184,7 +196,7 @@ pty_allocate(int *ptyfd, int *ttyfd, cha
|
||||
error("ioctl I_PUSH ptem: %.100s", strerror(errno));
|
||||
if (ioctl(*ttyfd, I_PUSH, "ldterm") < 0)
|
||||
error("ioctl I_PUSH ldterm: %.100s", strerror(errno));
|
||||
|
@ -60,7 +60,7 @@ $NetBSD: patch-ad,v 1.2 2004/07/17 01:56:38 xtraeme Exp $
|
|||
if (ioctl(*ttyfd, I_PUSH, "ttcompat") < 0)
|
||||
error("ioctl I_PUSH ttcompat: %.100s", strerror(errno));
|
||||
#endif
|
||||
@@ -276,7 +288,7 @@
|
||||
@@ -277,7 +289,7 @@ pty_allocate(int *ptyfd, int *ttyfd, cha
|
||||
}
|
||||
/* set tty modes to a sane state for broken clients */
|
||||
if (tcgetattr(*ptyfd, &tio) < 0)
|
||||
|
@ -69,7 +69,7 @@ $NetBSD: patch-ad,v 1.2 2004/07/17 01:56:38 xtraeme Exp $
|
|||
else {
|
||||
tio.c_lflag |= (ECHO | ISIG | ICANON);
|
||||
tio.c_oflag |= (OPOST | ONLCR);
|
||||
@@ -284,7 +296,7 @@
|
||||
@@ -285,7 +297,7 @@ pty_allocate(int *ptyfd, int *ttyfd, cha
|
||||
|
||||
/* Set the new modes for the terminal. */
|
||||
if (tcsetattr(*ptyfd, TCSANOW, &tio) < 0)
|
||||
|
|
Loading…
Reference in a new issue