Readd the various pieces for DragonFly. Explicitly disable mmap,
it currently doesn't work.
This commit is contained in:
parent
5afe8069a2
commit
183c3a1721
9 changed files with 107 additions and 5 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.53 2006/04/06 06:22:10 reed Exp $
|
||||
# $NetBSD: Makefile,v 1.54 2006/05/10 18:26:34 joerg Exp $
|
||||
|
||||
DISTNAME= clisp-2.38
|
||||
CATEGORIES= lang
|
||||
|
@ -17,7 +17,7 @@ PKG_INSTALLATION_TYPES= overwrite pkgviews
|
|||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${MACHINE_ARCH:Malpha} || ${MACHINE_ARCH:Mamd64} || ${MACHINE_ARCH:Mx86_64}
|
||||
.if ${MACHINE_ARCH:Malpha} || ${MACHINE_ARCH:Mamd64} || ${MACHINE_ARCH:Mx86_64} || ${OPSYS} == "DragonFly"
|
||||
MODULES+= --disable-mmap
|
||||
.endif
|
||||
|
||||
|
|
|
@ -1,6 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.11 2006/03/11 23:32:44 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.12 2006/05/10 18:26:34 joerg Exp $
|
||||
|
||||
SHA1 (clisp-2.38.tar.bz2) = d9586c04ed4778b5c603b3b1df73e8c76220df59
|
||||
RMD160 (clisp-2.38.tar.bz2) = 9070e1d7cd4db66de62f077b68a7fef7413da622
|
||||
Size (clisp-2.38.tar.bz2) = 8078151 bytes
|
||||
SHA1 (patch-aa) = b22797602a3cbd43fb56ad4a2a54f69d67979929
|
||||
SHA1 (patch-aa) = b5152788246655bcf0f527996a3278812e946a7a
|
||||
SHA1 (patch-ab) = b28180bff26e121bab0c53a07f2aafe5ff31e302
|
||||
SHA1 (patch-ac) = d0fcae585caf2559776c969db9699ccaf63005bc
|
||||
SHA1 (patch-ad) = c1f789f09e067a620ff74ac8677688ae9c6269bd
|
||||
SHA1 (patch-ae) = 7ba7ad6c6d399e00964df9c6cf7ff0a26c9dc814
|
||||
SHA1 (patch-af) = 5d26951e3712eabfac0888760224378ca19fe6fb
|
||||
SHA1 (patch-ag) = 3390c5bf98911bf6447e29af9688ec0b5e169bac
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-aa,v 1.12 2006/03/11 23:32:44 wiz Exp $
|
||||
$NetBSD: patch-aa,v 1.13 2006/05/10 18:26:34 joerg Exp $
|
||||
|
||||
--- src/makemake.in.orig 2006-01-23 21:07:27.000000000 +0000
|
||||
+++ src/makemake.in
|
||||
|
@ -15,3 +15,12 @@ $NetBSD: patch-aa,v 1.12 2006/03/11 23:32:44 wiz Exp $
|
|||
MANDIR="$mandir"
|
||||
fi
|
||||
if [ $HOS = unix ] ; then
|
||||
@@ -1334,7 +1334,7 @@ if [ "${with_dynamic_modules}" != no ];
|
||||
freebsd2* | netbsd* | openbsd*)
|
||||
XCC_CREATESHARED='ld -Bshareable -o $lib $libs'
|
||||
;;
|
||||
- freebsd3* | gnu* | linux* | cygwin* )
|
||||
+ freebsd3* | gnu* | linux* | cygwin* | dragonfly*)
|
||||
XCC_CREATESHARED='$CC $CFLAGS $CLFLAGS -shared -o $lib $libs'
|
||||
;;
|
||||
hpux9* | hpux10*)
|
||||
|
|
22
lang/clisp/patches/patch-ab
Normal file
22
lang/clisp/patches/patch-ab
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ab,v 1.9 2006/05/10 18:26:34 joerg Exp $
|
||||
|
||||
--- src/lispbibl.d.orig 2006-03-24 07:34:12.000000000 +0000
|
||||
+++ src/lispbibl.d
|
||||
@@ -122,7 +122,7 @@
|
||||
#if (defined(sun) && defined(unix) && defined(sun386))
|
||||
#define SUN386
|
||||
#endif
|
||||
- #if (defined(unix) && (defined(linux) || defined(__CYGWIN32__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)) && (defined(i386) || defined(__i386__) || defined(__x86_64__) || defined(__amd64__)))
|
||||
+ #if (defined(unix) && (defined(linux) || defined(__CYGWIN32__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__DragonFly__)) && (defined(i386) || defined(__i386__) || defined(__x86_64__) || defined(__amd64__)))
|
||||
#define PC386
|
||||
#endif
|
||||
#if (defined(sun) && defined(unix) && defined(mc68020))
|
||||
@@ -232,7 +232,7 @@
|
||||
#ifdef __NetBSD__
|
||||
#define UNIX_NETBSD
|
||||
#endif
|
||||
- #ifdef __FreeBSD__
|
||||
+ #if defined(__FreeBSD__) || defined(__DragonFly__)
|
||||
#define UNIX_FREEBSD
|
||||
#endif
|
||||
#ifdef __OpenBSD__
|
13
lang/clisp/patches/patch-ac
Normal file
13
lang/clisp/patches/patch-ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.7 2006/05/10 18:26:34 joerg Exp $
|
||||
|
||||
--- src/asmi386.h.orig 2006-03-24 07:35:25.000000000 +0000
|
||||
+++ src/asmi386.h
|
||||
@@ -231,7 +231,7 @@
|
||||
|
||||
#ifdef _MSC_VER
|
||||
#define DECLARE_FUNCTION(name)
|
||||
-#elif defined(__svr4__) || defined(__ELF__) || defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__ROSE__) || defined(_SEQUENT_) || defined(DGUX) || defined(_SCO_COFF) || defined(_SCO_ELF)
|
||||
+#elif defined(__svr4__) || defined(__ELF__) || defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__DragonFly__) || defined(__ROSE__) || defined(_SEQUENT_) || defined(DGUX) || defined(_SCO_COFF) || defined(_SCO_ELF)
|
||||
#define DECLARE_FUNCTION(name) .type C(name),@function
|
||||
#else
|
||||
#define DECLARE_FUNCTION(name)
|
13
lang/clisp/patches/patch-ad
Normal file
13
lang/clisp/patches/patch-ad
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ad,v 1.7 2006/05/10 18:26:34 joerg Exp $
|
||||
|
||||
--- src/asmi386.hh.orig 2006-03-24 07:35:56.000000000 +0000
|
||||
+++ src/asmi386.hh
|
||||
@@ -231,7 +231,7 @@
|
||||
// Define the DECLARE_FUNCTION(name) macro.
|
||||
#ifdef _MSC_VER
|
||||
#define DECLARE_FUNCTION(name)
|
||||
-#elif defined(__svr4__) || defined(__ELF__) || defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__ROSE__) || defined(_SEQUENT_) || defined(DGUX) || defined(_SCO_COFF) || defined(_SCO_ELF)
|
||||
+#elif defined(__svr4__) || defined(__ELF__) || defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__DragonFly__) || defined(__ROSE__) || defined(_SEQUENT_) || defined(DGUX) || defined(_SCO_COFF) || defined(_SCO_ELF)
|
||||
#define DECLARE_FUNCTION(name) .type C(name),@function
|
||||
#else
|
||||
#define DECLARE_FUNCTION(name)
|
13
lang/clisp/patches/patch-ae
Normal file
13
lang/clisp/patches/patch-ae
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.7 2006/05/10 18:26:34 joerg Exp $
|
||||
|
||||
--- ffcall/avcall/asmi386.h.orig 2006-03-24 07:37:13.000000000 +0000
|
||||
+++ ffcall/avcall/asmi386.h
|
||||
@@ -231,7 +231,7 @@
|
||||
|
||||
#ifdef _MSC_VER
|
||||
#define DECLARE_FUNCTION(name)
|
||||
-#elif defined(__svr4__) || defined(__ELF__) || defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__ROSE__) || defined(_SEQUENT_) || defined(DGUX) || defined(_SCO_COFF) || defined(_SCO_ELF)
|
||||
+#elif defined(__svr4__) || defined(__ELF__) || defined(__NetBSD__) || defined(__FreeBSD__) || defined(__DragonFly__) || defined(__OpenBSD__) || defined(__ROSE__) || defined(_SEQUENT_) || defined(DGUX) || defined(_SCO_COFF) || defined(_SCO_ELF)
|
||||
#define DECLARE_FUNCTION(name) .type C(name),@function
|
||||
#else
|
||||
#define DECLARE_FUNCTION(name)
|
13
lang/clisp/patches/patch-af
Normal file
13
lang/clisp/patches/patch-af
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-af,v 1.6 2006/05/10 18:26:34 joerg Exp $
|
||||
|
||||
--- ffcall/callback/vacall_r/asmi386.h.orig 2006-03-24 07:49:53.000000000 +0000
|
||||
+++ ffcall/callback/vacall_r/asmi386.h
|
||||
@@ -231,7 +231,7 @@
|
||||
|
||||
#ifdef _MSC_VER
|
||||
#define DECLARE_FUNCTION(name)
|
||||
-#elif defined(__svr4__) || defined(__ELF__) || defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__ROSE__) || defined(_SEQUENT_) || defined(DGUX) || defined(_SCO_COFF) || defined(_SCO_ELF)
|
||||
+#elif defined(__svr4__) || defined(__ELF__) || defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__DragonFly__) || defined(__ROSE__) || defined(_SEQUENT_) || defined(DGUX) || defined(_SCO_COFF) || defined(_SCO_ELF)
|
||||
#define DECLARE_FUNCTION(name) .type C(name),@function
|
||||
#else
|
||||
#define DECLARE_FUNCTION(name)
|
13
lang/clisp/patches/patch-ag
Normal file
13
lang/clisp/patches/patch-ag
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ag,v 1.4 2006/05/10 18:26:34 joerg Exp $
|
||||
|
||||
--- ffcall/vacall/asmi386.h.orig 2006-03-24 07:50:16.000000000 +0000
|
||||
+++ ffcall/vacall/asmi386.h
|
||||
@@ -231,7 +231,7 @@
|
||||
|
||||
#ifdef _MSC_VER
|
||||
#define DECLARE_FUNCTION(name)
|
||||
-#elif defined(__svr4__) || defined(__ELF__) || defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__ROSE__) || defined(_SEQUENT_) || defined(DGUX) || defined(_SCO_COFF) || defined(_SCO_ELF)
|
||||
+#elif defined(__svr4__) || defined(__ELF__) || defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__DragonFly__) || defined(__ROSE__) || defined(_SEQUENT_) || defined(DGUX) || defined(_SCO_COFF) || defined(_SCO_ELF)
|
||||
#define DECLARE_FUNCTION(name) .type C(name),@function
|
||||
#else
|
||||
#define DECLARE_FUNCTION(name)
|
Loading…
Reference in a new issue