Update to 0.3.0. Set LICENSE. Since python .py file is not installed
even when python is enabled, comment out python dependency. New in version 0.3.0 ==================== * WARNING!!! Slight API change!!! see docs for px_proxy_factory_get_proxies() * Credentials support (see API change above) * A complete rewrite of the module manager * file:// as valid PAC URLs * Sample Mono application * Automake 1.11 shaved output * gnome backend rewrite (now w/o thread issues) * Test suite base functionality exists * Many solaris build fixes * Seamonkey support as JS pacrunner * Bugfixes * Compiles for MS Windows using Mingw
This commit is contained in:
parent
60df5dca0d
commit
185f8a89c3
7 changed files with 23 additions and 153 deletions
|
@ -1,31 +1,30 @@
|
|||
# $NetBSD: Makefile,v 1.5 2009/09/09 15:11:31 drochner Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2009/12/15 11:00:11 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libproxy-0.2.3
|
||||
PKGREVISION= 1
|
||||
DISTNAME= libproxy-0.3.0
|
||||
CATEGORIES= www gnome
|
||||
MASTER_SITES= http://libproxy.googlecode.com/files/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://code.google.com/p/libproxy/
|
||||
COMMENT= Library that provides automatic proxy configuration management
|
||||
LICENSE= gnu-lgpl-v2.1
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= pkg-config gmake autoreconf autoconf automake
|
||||
USE_TOOLS+= pkg-config gmake
|
||||
PY_PATCHPLIST= yes
|
||||
|
||||
PKGCONFIG_OVERRIDE+= libproxy-1.0.pc.in
|
||||
|
||||
pre-configure:
|
||||
cd ${WRKSRC} && autoreconf --force
|
||||
# 0.3.0 doesn't install the python bindings even when they
|
||||
# are enabled, so comment out dependencies.
|
||||
#PYTHON_VERSIONS_ACCEPTED= 25 26
|
||||
#BUILDLINK_API_DEPENDS.python26+= python26>=2.6.2nb4
|
||||
#BUILDLINK_API_DEPENDS.python25+= python25>=2.5.4nb2
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 25 26
|
||||
BUILDLINK_API_DEPENDS.python26+= python26>=2.6.2nb4
|
||||
BUILDLINK_API_DEPENDS.python25+= python25>=2.5.4nb2
|
||||
|
||||
.include "../../lang/python/extension.mk"
|
||||
#.include "../../lang/python/extension.mk"
|
||||
.include "../../mk/dlopen.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,13 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2009/06/14 22:00:25 joerg Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2009/12/15 11:00:11 wiz Exp $
|
||||
bin/proxy
|
||||
include/proxy.h
|
||||
lib/libproxy.la
|
||||
lib/libproxy/${PKGVERSION}/plugins/envvar.so
|
||||
lib/libproxy/${PKGVERSION}/plugins/file.so
|
||||
lib/libproxy/${PKGVERSION}/modules/config_direct.so
|
||||
lib/libproxy/${PKGVERSION}/modules/config_envvar.so
|
||||
lib/libproxy/${PKGVERSION}/modules/config_file.so
|
||||
lib/libproxy/${PKGVERSION}/modules/config_wpad.so
|
||||
lib/libproxy/${PKGVERSION}/modules/ignore_domain.so
|
||||
lib/libproxy/${PKGVERSION}/modules/ignore_ip.so
|
||||
lib/libproxy/${PKGVERSION}/modules/wpad_dns.so
|
||||
lib/libproxy/${PKGVERSION}/modules/wpad_dnsdevolution.so
|
||||
lib/pkgconfig/libproxy-1.0.pc
|
||||
${PYSITELIB}/libproxy.py
|
||||
|
|
|
@ -1,9 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.4 2009/03/18 12:40:52 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.5 2009/12/15 11:00:11 wiz Exp $
|
||||
|
||||
SHA1 (libproxy-0.2.3.tar.gz) = 2b2b00a179740548035a1145bbae600db9b0a2ce
|
||||
RMD160 (libproxy-0.2.3.tar.gz) = c86c4f8403cb879380e101d074af469c960b5c1c
|
||||
Size (libproxy-0.2.3.tar.gz) = 378773 bytes
|
||||
SHA1 (patch-aa) = 6e6c7b1e0e396bed522480ca6fb347c5787a1359
|
||||
SHA1 (patch-ab) = 092f99af979d3a456e188386a3e62da1ac6e843d
|
||||
SHA1 (patch-ac) = 891e6217c1d7cd78a5f57afb8b1267aed8c1de75
|
||||
SHA1 (patch-ad) = f88c2818f861533a504119333e5aff44bb12ce0f
|
||||
SHA1 (libproxy-0.3.0.tar.gz) = 9d0d29b352a2cc4d9511d362bc02162eca91df59
|
||||
RMD160 (libproxy-0.3.0.tar.gz) = 270d216a1e9c1d174ffc1572d2bdaa30bb51d034
|
||||
Size (libproxy-0.3.0.tar.gz) = 367083 bytes
|
||||
|
|
|
@ -1,95 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.4 2009/03/18 12:40:52 drochner Exp $
|
||||
|
||||
--- configure.ac.orig 2008-06-05 23:56:16 +0300
|
||||
+++ configure.ac 2009-03-18 05:25:38 +0200
|
||||
@@ -41,14 +41,14 @@ AC_ARG_WITH([gnome],
|
||||
[AS_HELP_STRING([--with-gnome],
|
||||
[build GNOME configuration plugin @<:@automatic@:>@])],
|
||||
[],
|
||||
- [test x$have_gconf == xyes &&
|
||||
- test x$have_x11 == xyes &&
|
||||
- test x$have_xmu == xyes &&
|
||||
+ [test x$have_gconf = xyes &&
|
||||
+ test x$have_x11 = xyes &&
|
||||
+ test x$have_xmu = xyes &&
|
||||
with_gnome=yes])
|
||||
if test x$with_gnome = xyes; then
|
||||
- if test x$have_gconf == xyes && \
|
||||
- test x$have_x11 == xyes && \
|
||||
- test x$have_xmu == xyes; then
|
||||
+ if test x$have_gconf = xyes && \
|
||||
+ test x$have_x11 = xyes && \
|
||||
+ test x$have_xmu = xyes; then
|
||||
GNOME_CFLAGS="$x11_CFLAGS $xmu_CFLAGS $gconf_CFLAGS"
|
||||
GNOME_LIBS="$x11_LIBS $xmu_LIBS $gconf_LIBS"
|
||||
AC_SUBST(GNOME_CFLAGS)
|
||||
@@ -67,12 +67,12 @@ AC_ARG_WITH([kde],
|
||||
[AS_HELP_STRING([--with-kde],
|
||||
[build KDE configuration plugin @<:@automatic@:>@])],
|
||||
[],
|
||||
- [test x$have_x11 == xyes &&
|
||||
- test x$have_xmu == xyes &&
|
||||
+ [test x$have_x11 = xyes &&
|
||||
+ test x$have_xmu = xyes &&
|
||||
with_kde=yes])
|
||||
if test x$with_kde = xyes; then
|
||||
- if test x$have_x11 == xyes && \
|
||||
- test x$have_xmu == xyes; then
|
||||
+ if test x$have_x11 = xyes && \
|
||||
+ test x$have_xmu = xyes; then
|
||||
KDE_CFLAGS="$x11_CFLAGS $xmu_CFLAGS"
|
||||
KDE_LIBS="$x11_LIBS $xmu_LIBS"
|
||||
AC_SUBST(KDE_CFLAGS)
|
||||
@@ -91,9 +91,9 @@ AC_ARG_WITH([webkit],
|
||||
[AS_HELP_STRING([--with-webkit],
|
||||
[build WebKit JavaScriptCore PAC runner plugin @<:@automatic@:>@])],
|
||||
[],
|
||||
- [test x$have_webkit == xyes && with_webkit=yes])
|
||||
+ [test x$have_webkit = xyes && with_webkit=yes])
|
||||
if test x$with_webkit = xyes; then
|
||||
- if test x$have_webkit == xyes; then
|
||||
+ if test x$have_webkit = xyes; then
|
||||
WEBKIT_CFLAGS="$webkit_CFLAGS"
|
||||
WEBKIT_LIBS="$webkit_LIBS"
|
||||
AC_SUBST(WEBKIT_CFLAGS)
|
||||
@@ -112,9 +112,9 @@ AC_ARG_WITH([mozjs],
|
||||
[AS_HELP_STRING([--with-mozjs],
|
||||
[build Mozilla JavaScript PAC runner plugin @<:@automatic@:>@])],
|
||||
[],
|
||||
- [test x$have_mozjs == xyes && with_mozjs=yes])
|
||||
+ [test x$have_mozjs = xyes && with_mozjs=yes])
|
||||
if test x$with_mozjs = xyes; then
|
||||
- if test x$have_mozjs == xyes; then
|
||||
+ if test x$have_mozjs = xyes; then
|
||||
MOZJS_CFLAGS="$mozjs_CFLAGS"
|
||||
MOZJS_LIBS="$mozjs_LIBS"
|
||||
AC_SUBST(MOZJS_CFLAGS)
|
||||
@@ -133,9 +133,9 @@ AC_ARG_WITH([networkmanager],
|
||||
[AS_HELP_STRING([--with-networkmanager],
|
||||
[build NetworkManager plugin @<:@automatic@:>@])],
|
||||
[],
|
||||
- [test x$have_networkmanager == xyes && with_networkmanager=yes])
|
||||
+ [test x$have_networkmanager = xyes && with_networkmanager=yes])
|
||||
if test x$with_networkmanager = xyes; then
|
||||
- if test x$have_networkmanager == xyes; then
|
||||
+ if test x$have_networkmanager = xyes; then
|
||||
NETWORKMANAGER_CFLAGS="$NetworkManager_CFLAGS"
|
||||
NETWORKMANAGER_LIBS="$NetworkManager_LIBS"
|
||||
AC_SUBST(NETWORKMANAGER_CFLAGS)
|
||||
@@ -176,12 +176,15 @@ AC_C_CONST
|
||||
AC_TYPE_SIZE_T
|
||||
PLUGINDIR=$libdir/$PACKAGE_NAME/$PACKAGE_VERSION/plugins
|
||||
AC_SUBST(PLUGINDIR)
|
||||
-CFLAGS="-g -std=c99 $CFLAGS -DPLUGINDIR=\\\"$PLUGINDIR\\\" -DSYSCONFDIR=\\\"$sysconfdir\\\" -D_POSIX_C_SOURCE=1"
|
||||
+CFLAGS="-g -std=c99 $CFLAGS -DPLUGINDIR=\\\"$PLUGINDIR\\\" -DSYSCONFDIR=\\\"$sysconfdir\\\" -D_POSIX_C_SOURCE=200112"
|
||||
|
||||
### Checks for library functions.
|
||||
AC_FUNC_MALLOC
|
||||
#AC_CHECK_FUNCS([gethostbyname gethostname memset socket strdup strstr])
|
||||
|
||||
+AC_CHECK_LIB(dl, dlopen, DL_LIBS="-ldl")
|
||||
+AC_SUBST(DL_LIBS)
|
||||
+
|
||||
AC_CONFIG_FILES([libproxy-1.0.pc Makefile src/Makefile src/lib/Makefile
|
||||
src/plugins/Makefile src/bin/Makefile src/bindings/Makefile
|
||||
src/bindings/python/Makefile src/bindings/java/Makefile
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1 2009/03/12 13:31:48 hasso Exp $
|
||||
|
||||
--- ./src/lib/url.c.orig 2009-03-12 11:23:52 +0200
|
||||
+++ ./src/lib/url.c 2009-03-12 11:24:58 +0200
|
||||
@@ -26,6 +26,7 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <arpa/inet.h>
|
||||
+#include <netinet/in.h>
|
||||
|
||||
#include "misc.h"
|
||||
#include "url.h"
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1 2009/03/12 13:31:48 hasso Exp $
|
||||
|
||||
--- ./src/lib/proxy_factory.c.orig 2009-03-12 11:25:26 +0200
|
||||
+++ ./src/lib/proxy_factory.c 2009-03-12 11:25:47 +0200
|
||||
@@ -27,6 +27,7 @@
|
||||
#include <math.h>
|
||||
#include <sys/socket.h>
|
||||
#include <arpa/inet.h>
|
||||
+#include <netinet/in.h>
|
||||
#include <pthread.h>
|
||||
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1 2009/03/12 13:31:48 hasso Exp $
|
||||
|
||||
--- src/bin/Makefile.am.orig 2009-03-12 12:18:18 +0200
|
||||
+++ src/bin/Makefile.am 2009-03-12 12:18:33 +0200
|
||||
@@ -3,5 +3,5 @@ bin_PROGRAMS = proxy
|
||||
# Command line interface to libproxy
|
||||
proxy_SOURCES = proxy.c
|
||||
proxy_CFLAGS = -I$(top_srcdir)/src/lib
|
||||
-proxy_LDFLAGS = -ldl
|
||||
+proxy_LDFLAGS = $(DL_LIBS)
|
||||
proxy_LDADD = ../lib/libproxy.la
|
Loading…
Reference in a new issue