Version 4.1.3 - 2011-01-17
fixed a coredump in torrent (introduced in 4.1.2). Version 4.1.2 - 2010-12-31 new command ln [-s], supported by FTP (SITE [SYM]LINK), FISH, SFTP, and locally via file: schema. create remote symlinks in mirror -R if supported by server. detect and remove duplicate peers in torrent. Version 4.1.0 - 2010-11-22 send path components to ftp server separately, unless TVFS is in FEAT reply. save pget status at the very beginning of pget execution. allow mirror pget continuation (mirror -c --use-pget). allow multiple torrent startup at once (e.g. torrent *.torrent). pre-allocate disk space in torrent, if posix_fallocate(3) is supported. new command prefix `local'. It makes the following command use local session instead of remote. added torrent multi-tracker support. fixed convert-mozilla-cookies cookie duplication. Version 4.0.10 - 2010-09-01 use cached file set, don't parse file listing again. updated convert-netscape-cookies. fixed a problem with zeroed errno in http. fixed coredump on mirror --log=file when the file cannot be opened. translations updated (de, ru).
This commit is contained in:
parent
eaed984cec
commit
189bc78bde
5 changed files with 29 additions and 19 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.93 2010/07/25 21:38:34 pettai Exp $
|
||||
# $NetBSD: Makefile,v 1.94 2011/03/10 23:38:42 pettai Exp $
|
||||
|
||||
DISTNAME= lftp-4.0.9
|
||||
DISTNAME= lftp-4.1.3
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://ftp.yars.free.net/pub/source/lftp/ \
|
||||
ftp://ftp.st.ryukoku.ac.jp/pub/network/ftp/lftp/ \
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
@comment $NetBSD: PLIST.perl,v 1.1 2005/12/04 22:12:07 salo Exp $
|
||||
share/lftp/convert-netscape-cookies
|
||||
@comment $NetBSD: PLIST.perl,v 1.2 2011/03/10 23:38:42 pettai Exp $
|
||||
share/lftp/convert-mozilla-cookies
|
||||
share/lftp/verify-file
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.54 2010/07/25 21:38:34 pettai Exp $
|
||||
$NetBSD: distinfo,v 1.55 2011/03/10 23:38:42 pettai Exp $
|
||||
|
||||
SHA1 (lftp-4.0.9.tar.bz2) = 86aba6fea67b4811cd5484e6816d2fd01068ef1f
|
||||
RMD160 (lftp-4.0.9.tar.bz2) = a5d08e0c00046ff2c2efd136378fee51a54566b9
|
||||
Size (lftp-4.0.9.tar.bz2) = 1616263 bytes
|
||||
SHA1 (patch-aa) = e127aadcaf3c313584747091efb89a3f765a9d7f
|
||||
SHA1 (lftp-4.1.3.tar.bz2) = 1841d19e4baf247d12e800735d18b73c133ba266
|
||||
RMD160 (lftp-4.1.3.tar.bz2) = ed7af905b4d00cd9de9381d2bd3a4aade2f0de84
|
||||
Size (lftp-4.1.3.tar.bz2) = 1664573 bytes
|
||||
SHA1 (patch-aa) = d63ec027e99130fa24621906194e43caabd086bd
|
||||
SHA1 (patch-ab) = cbf428fb51c64431eb32d25160303333ce695b5a
|
||||
SHA1 (patch-ac) = 32e1fba23d4d6bd0b06bacbe503cb9b39d2bf825
|
||||
SHA1 (patch-ad) = 365c205cf83f65b7253b71e67e530ac2fcf58154
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: options.mk,v 1.10 2009/07/02 18:54:18 tnn Exp $
|
||||
# $NetBSD: options.mk,v 1.11 2011/03/10 23:38:42 pettai Exp $
|
||||
#
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.lftp
|
||||
|
@ -6,7 +6,7 @@ PKG_OPTIONS_VAR= PKG_OPTIONS.lftp
|
|||
PKG_OPTIONS_OPTIONAL_GROUPS= ssl
|
||||
PKG_OPTIONS_GROUP.ssl= gnutls ssl
|
||||
|
||||
PKG_SUPPORTED_OPTIONS= perl
|
||||
PKG_SUPPORTED_OPTIONS= perl dnssec
|
||||
PKG_SUGGESTED_OPTIONS= ssl
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
@ -33,12 +33,20 @@ CONFIGURE_ARGS+= --without-openssl
|
|||
USE_TOOLS+= perl:run
|
||||
DEPENDS+= p5-Digest-MD5-[0-9]*:../../security/p5-Digest-MD5
|
||||
DEPENDS+= p5-String-CRC32-[0-9]*:../../textproc/p5-String-CRC32
|
||||
REPLACE_PERL+= src/convert-netscape-cookies src/verify-file
|
||||
REPLACE_PERL+= src/convert-mozilla-cookies src/verify-file
|
||||
PLIST_SRC+= ${PKGDIR}/PLIST.perl
|
||||
|
||||
post-install-perl:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/src/convert-netscape-cookies \
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/src/convert-mozilla-cookies \
|
||||
${WRKSRC}/src/verify-file ${DESTDIR}${PREFIX}/share/lftp
|
||||
.else
|
||||
post-install-perl:
|
||||
.endif
|
||||
|
||||
###
|
||||
### DNSSEC support
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mdnssec)
|
||||
. include "../../security/dnssec-tools/buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --with-dnssec-local-validation
|
||||
.endif
|
||||
|
|
|
@ -1,22 +1,24 @@
|
|||
$NetBSD: patch-aa,v 1.15 2009/12/05 16:25:01 tnn Exp $
|
||||
$NetBSD: patch-aa,v 1.16 2011/03/10 23:38:42 pettai Exp $
|
||||
|
||||
Do not install by default Perl scripts; they are installed via
|
||||
${INSTALL_SCRIPT} if the user set the "perl" option.
|
||||
|
||||
Do not remove the *.la files.
|
||||
|
||||
--- src/Makefile.in.orig 2009-09-16 11:31:08.000000000 +0200
|
||||
$NetBSD: patch-aa,v 1.16 2011/03/10 23:38:42 pettai Exp $
|
||||
|
||||
--- src/Makefile.in.orig 2011-01-17 08:29:59.000000000 +0000
|
||||
+++ src/Makefile.in
|
||||
@@ -980,7 +980,7 @@ top_builddir = @top_builddir@
|
||||
@@ -1178,7 +1178,7 @@ top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
pkgverlibdir = $(pkglibdir)/$(VERSION)
|
||||
bin_SCRIPTS = lftpget
|
||||
-pkgdata_SCRIPTS = import-ncftp import-netscape verify-file convert-netscape-cookies
|
||||
-pkgdata_SCRIPTS = import-ncftp import-netscape verify-file convert-mozilla-cookies
|
||||
+pkgdata_SCRIPTS = import-ncftp import-netscape
|
||||
noinst_SCRIPTS = ftpget
|
||||
EXTRA_DIST = $(pkgdata_SCRIPTS) $(bin_SCRIPTS) $(noinst_SCRIPTS)
|
||||
lftp_SOURCES = lftp.cc complete.h complete.cc lftp_rl.c lftp_rl.h
|
||||
@@ -1513,7 +1513,7 @@ all-am: Makefile $(LTLIBRARIES) $(PROGRA
|
||||
@@ -1776,7 +1776,7 @@ all-am: Makefile $(LTLIBRARIES) $(PROGRA
|
||||
install-binPROGRAMS: install-libLTLIBRARIES
|
||||
|
||||
installdirs:
|
||||
|
@ -25,7 +27,7 @@ Do not remove the *.la files.
|
|||
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
|
||||
done
|
||||
install: install-am
|
||||
@@ -1631,6 +1631,9 @@ uninstall-am: uninstall-binPROGRAMS unin
|
||||
@@ -1906,6 +1906,9 @@ uninstall-am: uninstall-binPROGRAMS unin
|
||||
|
||||
# libtool does not strip modules, do it here.
|
||||
install-data-hook:
|
||||
|
|
Loading…
Reference in a new issue