Update chat/weechat to 0.3.1.1

Version 0.3.1.1:
This version fixes crashes with SSL connection to IRC server and purge of old
DCC chats. It is recommended to upgrade from 0.3.1 to 0.3.1.1 for all users.

Version 0.3.1:
- new IRC commands: allserv, allchan, sajoin, samode, sanick, sapart, saquit,
- check of SSL certificates and use of CertFP for IRC servers,
- options to customize IRC CTCP replies,
- options to choose target buffer for IRC messages,
- anti-flood improved for IRC servers,
- new expansions for alias arguments,
- new color darkgray, bright colors supported for backgrounds,
- many bugs fixed.
This commit is contained in:
tonio 2010-03-12 14:36:57 +00:00
parent 89e3f4f89a
commit 18b2ddd197
4 changed files with 25 additions and 7 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.25 2009/11/03 22:22:31 tonio Exp $
# $NetBSD: Makefile,v 1.26 2010/03/12 14:36:57 tonio Exp $
#
DISTNAME= weechat-0.3.0
DISTNAME= weechat-0.3.1.1
CATEGORIES= chat
MASTER_SITES= http://www.weechat.org/files/src/
@ -20,6 +20,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-ruby --disable-aspell
MAKE_ENV+= INSTALL_DATA_DIR=${INSTALL_DATA_DIR:Q}
MAKE_ENV+= PREFIX=${DESTDIR:Q}${PREFIX:Q}
LIBS.SunOS+= -lnsl
.include "options.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.12 2009/11/03 22:22:31 tonio Exp $
@comment $NetBSD: PLIST,v 1.13 2010/03/12 14:36:57 tonio Exp $
bin/weechat-curses
include/weechat/weechat-plugin.h
lib/pkgconfig/weechat.pc
@ -17,5 +17,6 @@ share/locale/de/LC_MESSAGES/weechat.mo
share/locale/es/LC_MESSAGES/weechat.mo
share/locale/fr/LC_MESSAGES/weechat.mo
share/locale/hu/LC_MESSAGES/weechat.mo
share/locale/it/LC_MESSAGES/weechat.mo
share/locale/pl/LC_MESSAGES/weechat.mo
share/locale/ru/LC_MESSAGES/weechat.mo

View file

@ -1,8 +1,9 @@
$NetBSD: distinfo,v 1.16 2009/11/03 22:22:31 tonio Exp $
$NetBSD: distinfo,v 1.17 2010/03/12 14:36:57 tonio Exp $
SHA1 (weechat-0.3.0.tar.gz) = d7d0ae999fb8aba65afca4bcf3a557fd318f59ef
RMD160 (weechat-0.3.0.tar.gz) = 3cbdc99b36b64761b77d2f2d4e6cc4a2e62d1764
Size (weechat-0.3.0.tar.gz) = 1933034 bytes
SHA1 (weechat-0.3.1.1.tar.gz) = bc4f5dffeff91feb430aec5ee25e308796b68936
RMD160 (weechat-0.3.1.1.tar.gz) = d9a183ccbb76d9b98ca1435f59f936a8de0e2591
Size (weechat-0.3.1.1.tar.gz) = 2263262 bytes
SHA1 (patch-aa) = 5bfba8832834898030fb1612adee83c8a7d1e708
SHA1 (patch-ab) = 14264c459810e7300b5adedd0ff98e749dad3f2d
SHA1 (patch-ac) = 1f713c92e58898fd0ef3169fe9f815265cfea2e9
SHA1 (patch-ad) = 5b9dcc4605660f2f6da9c0e3bc9e6e1b9a26bb24

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ad,v 1.3 2010/03/12 14:36:57 tonio Exp $
Solaris build
--- src/gui/curses/gui-curses-window.c.orig 2010-01-27 09:59:01.000000000 +0000
+++ src/gui/curses/gui-curses-window.c
@@ -27,6 +27,8 @@
#include <string.h>
#include <stdarg.h>
#include <libgen.h>
+#include <unistd.h>
+#include <termios.h>
#include <sys/ioctl.h>
#include "../../core/weechat.h"