Updated to latest release, 2.4.13, as requested by doc/TODO. Removed
patches which were applied upstream or deprecated. USE_TOOLS+=groff to fix generation of a few .html files on OpenBSD. Depends on libgcrypt instead of openssl now. From ChangeLog: from 2.4.12 to 2.4.13 - adding initialization value for two variables to avoid inappropriate warning when compiling with -Wall option - reducing UNIX_PATH_MAX by the system when not defined from 108 to 104 bytes to accommodate BSD systems - fixing assignment operator of class criterium that was not returning any value as it should - removing useless boolean expression that always succeeds in logical AND expression - adding support for back-slash of quoting characters in DCF files - fixed compilation issues with clang / FreeBSD, Thanks to Neil Darlow's server ;-) - fixed compilation warning due to deprecated symbols in libgcrypt header files - replaced gnu make specific rules by legacy ones to avoid automake warning about them - removed old unused stuff from misc sub-directory - adding warning at compilation time if libgcrypt used is older than 1.6.0 - adding warning at execution time if hash computation is requested with slices greater than 256 Gio and ligbcrypt dynamically or statically linked is older than 1.6.0 - adding alternative methods in list_entry API class to return dates as number of seconds - fixed bug in hour-shift (-H option) when comparing dates from an old extracted catalogue (archive format 7 or older). - fixed documentation bug about the meaning of the compression ratio - fixed a display bug about the "compression flag" wrongly displayed for uncompressed files - fixed unhandled exception when giving non number argument to -1 option from 2.4.11 to 2.4.12 - for correctness fixed delete vs delete[] on vector of char (not incidence reported) - fixed out of range access in routine used to read very old archive format - fixed error in logical expression leading a sanity test to be useless - removed duplicated variable assignment - updated FAQ - fixed typo and spelling errors - fixed bug (reported by Torsten Bronger) in the escape layer leading libdar to wrongly reporting a file as corrupted at reading time - fixed bug in the sparse file detection mechanism that lead the minimum size hole detection to become a multiple of the default value or specified one. This implied a less efficient reduction of sparse files because smaller holes in files were ignored - fixed and updated man page about --go-into option - updated full-from-diff target in /etc/darrc default file - added a debug option in hash_file class (option only used from testing tools) to troubleshoot sha1/md5 hash problem on slices larger than (2**38)+63 bytes, bug reported by Mike Lenzen and understood by Yuriy Kaminskiy at libgcrypt. Note: This bug is still open due to an integer overflow in libgcrypt. - backported from current development code an additional and more simple way to read an archive using the libdar API. This API extension is not used by dar command-line tools for now. - Fixing installation of libdar header files on Darwin, where "DARwin" macros were not filtered out from the generated libdar header files. - Fixing self reported bug 'generic_file.cpp line 309' met while comparing an archive with a filesystem - Update code in order to compile with gcc-4.8.2 in g++11 mode (partial implementation and adaptation of Fabian Stanke's patch) - Fixing bug met while performing a verbose archive listing in sequential read mode - Added Ryan Schmidt's Patch to properly display status at end of ./configure script under BSD systems (in particular Mac OS X) - Updating configure.ac script to fix warning reported by autoconf when generating the ./configure script - Addressed portability problem with BSD systems that do not provide a -d option to the 'cp' command, preventing proper installation of the Doxygen documentation. Fix based on patch provided by Jan Gosmann. from 2.4.10 to 2.4.11 - Modified behavior of 'dar -h' and 'dar -V', both now return 0 as exist status instead of 1 (which means syntax error). - Fixed bug: -Q is now available with -V under the collapsed form -QV or -VQ - fixed typo in documentation - fixed memory leakage met when dar fails a merging operation because the resulting archive is specified in an directory that does not exist. - fixed bug met when isolating a differential backup in sequential read mode - fixed bug about slice file permission not taking care about umask variable when the --hash feature is used. - fixed performance issue when reading an archive over a pair of piles using dar_slave (possibly over ssh) when the archive makes use of escape marks and when no encryption is used - added target "full-from-diff" in /etc/darrc default file - fixed bug avoiding reading an truncated archive in direct access mode with the help of an external catalogue. - new and better implementation of archive extraction in sequential read mode - fixing bug (segfault) met when hitting CTRL-C while reading an archive in sequential mode - fixing libdar.pc for pkg-config for the cflags given to external applications - fixed memory allocation/desallocation mismatches (delete vs delete [] ) concerning four vector of chars. - fixed error in logical expression leading a sanity test to be useless
This commit is contained in:
parent
a4ddc061c4
commit
19b8053d03
25 changed files with 58 additions and 509 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.46 2014/04/15 20:36:06 asau Exp $
|
||||
# $NetBSD: Makefile,v 1.47 2014/05/14 04:35:20 rodent Exp $
|
||||
|
||||
DISTNAME= dar-2.4.10
|
||||
PKGREVISION= 3
|
||||
DISTNAME= dar-2.4.13
|
||||
CATEGORIES= archivers sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=dar/}
|
||||
|
||||
|
@ -113,6 +112,6 @@ BUILDLINK_TRANSFORM= l:execinfo:execinfo:elf
|
|||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../security/libgcrypt/buildlink3.mk"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.12 2013/06/28 15:03:55 ryoon Exp $
|
||||
@comment $NetBSD: PLIST,v 1.13 2014/05/14 04:35:20 rodent Exp $
|
||||
bin/dar
|
||||
bin/dar_cp
|
||||
bin/dar_manager
|
||||
|
@ -36,6 +36,7 @@ include/dar/libdar_4_4.hpp
|
|||
include/dar/libdar_config.h
|
||||
include/dar/libdar_my_config.h
|
||||
include/dar/limitint.hpp
|
||||
include/dar/list_entry.hpp
|
||||
include/dar/mask.hpp
|
||||
include/dar/mask_list.hpp
|
||||
include/dar/mem_ui.hpp
|
||||
|
@ -126,6 +127,7 @@ share/doc/dar/mini-howto/dar-differential-backup-mini-howto.en.html
|
|||
share/doc/dar/mini-howto/dar-differential-backup-mini-howto.es.html
|
||||
share/doc/dar/mini-howto/dar-differential-backup-mini-howto.it.html
|
||||
share/doc/dar/mini-howto/index.html
|
||||
share/doc/dar/old_dar_key.txt
|
||||
share/doc/dar/presentation.html
|
||||
share/doc/dar/usage_notes.html
|
||||
share/examples/dar/darrc
|
||||
|
|
|
@ -1,28 +1,13 @@
|
|||
$NetBSD: distinfo,v 1.29 2014/01/20 19:29:34 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.30 2014/05/14 04:35:20 rodent Exp $
|
||||
|
||||
SHA1 (dar-2.4.10.tar.gz) = bf02ba10bfcd2ad959017706f167fc390aafe932
|
||||
RMD160 (dar-2.4.10.tar.gz) = 26161a09a60e36a3094f94d8831a157b7c3e4d0a
|
||||
Size (dar-2.4.10.tar.gz) = 1760827 bytes
|
||||
SHA1 (patch-aa) = 734ec162dbc339b2015a169bb9fe723e45d0a29b
|
||||
SHA1 (patch-ab) = f07d55861f21545b0ae8ac6b187a94526e44e345
|
||||
SHA1 (patch-ac) = dcbf4e31071c83a167a60a20e4980b35f055a46e
|
||||
SHA1 (patch-ad) = e32c33d5670f39a04f8ceef94d6e9d5a6b524016
|
||||
SHA1 (patch-ae) = 54220384bf2031df64c38f5abea038382ca37e8e
|
||||
SHA1 (patch-af) = 414e58277c946b59f57352e260ac5d49673ef008
|
||||
SHA1 (patch-src_dar__suite_command__line.cpp) = 63d3004bf7d49277c1508fe5d9ac52ec0d5bf11f
|
||||
SHA1 (patch-src_dar__suite_crit__action__cmd__line.cpp) = bc9484e836fbde98f682f6031aaadd99cc8eb479
|
||||
SHA1 (patch-src_dar__suite_dar__manager.cpp) = 2ed9008b5e7629ef8e279b7d1218a4fae5101df1
|
||||
SHA1 (patch-src_dar__suite_dar__xform.cpp) = 929e7cbb933a8d58bd1b79ecb50404f5dbbfddfe
|
||||
SHA1 (patch-src_dar__suite_line__tools.cpp) = 076c5213aaa3e6dfa471322b6597c0ce8ccfd2a8
|
||||
SHA1 (patch-src_examples_factoriel.cpp) = 6c9e038b7a3bbfdc96dbbdf1b7e100c159353f87
|
||||
SHA1 (patch-src_examples_formula.cpp) = 583ceeba0a232e657ab0696711f630476ec2e495
|
||||
SHA1 (patch-src_examples_prime.cpp) = 09fc3b96642945042a2d13bb4c1995546cdb7607
|
||||
SHA1 (patch-src_libdar_mask__list.hpp) = b3b6eaa36875784432e53d5dfbfb33d7623054a3
|
||||
SHA1 (patch-src_libdar_secu__string.hpp) = 6793cb79bf5f8c4d3ac83ba4f2cd2fd9f452afb1
|
||||
SHA1 (patch-src_testing_Makefile.in) = e8d48b5fa9fcdd2f5bef3fca240850c0787f6647
|
||||
SHA1 (patch-src_testing_test__catalogue.cpp) = 2d1a8299f01776e3fa9996819aa8be523b73b4cc
|
||||
SHA1 (patch-src_testing_test__deci.cpp) = 053e2123a5219dc0cb827743e348f9463ce84615
|
||||
SHA1 (patch-src_testing_test__escape.cpp) = b7959b2e5e3675d2e64f232face3b18384f8e3da
|
||||
SHA1 (patch-src_testing_test__infinint.cpp) = 5ee29a1881b05881bb334f1cd7bfd30ea21baf7f
|
||||
SHA1 (patch-src_testing_test__terminateur.cpp) = 79d4efadfc4528d6def28985228a0d25d1fc6e78
|
||||
SHA1 (patch-src_testing_testtools.cpp) = 4cdd4a6fde69f40463464f6ead1d208a685a516b
|
||||
SHA1 (dar-2.4.13.tar.gz) = b20471ada21cd0cbe4687e7bdd3c2e6f70f5c0d1
|
||||
RMD160 (dar-2.4.13.tar.gz) = 20cf6492aedd82b3bc227603588c8e6f44560dde
|
||||
Size (dar-2.4.13.tar.gz) = 1799774 bytes
|
||||
SHA1 (patch-aa) = 86370bb2515795b2c5645beaafeb8af08d9f209b
|
||||
SHA1 (patch-ab) = 9b8fd96e3944aedeaa4f2df0d5bfe17a73d3f7eb
|
||||
SHA1 (patch-ac) = 0581af6c9229d614fcaa6df9d1e52ef773af9ea6
|
||||
SHA1 (patch-ad) = d3b7c3564462bc25e447d87af4ea005c88540ead
|
||||
SHA1 (patch-ae) = 95a00fb53851068e6e02bfe013b39970bc12230e
|
||||
SHA1 (patch-af) = 1ece254cecbec601da9a57c32f515f1008f87859
|
||||
SHA1 (patch-src_libdar_mask__list.hpp) = 33612489e2b2e14fc9e6606aac0c4988988d89e4
|
||||
SHA1 (patch-src_libdar_secu__string.hpp) = 073db488ceed38d9dc1999786ac666a9179c520e
|
||||
|
|
|
@ -1,11 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.5 2013/06/28 15:03:55 ryoon Exp $
|
||||
$NetBSD: patch-aa,v 1.6 2014/05/14 04:35:20 rodent Exp $
|
||||
|
||||
--- doc/Makefile.in.orig 2013-03-09 12:40:15.000000000 +0000
|
||||
Fix DOCDIR path.
|
||||
|
||||
--- doc/Makefile.in.orig 2014-04-21 11:24:24.000000000 +0000
|
||||
+++ doc/Makefile.in
|
||||
@@ -16,7 +16,7 @@
|
||||
@SET_MAKE@
|
||||
|
||||
VPATH = @srcdir@
|
||||
@@ -33,7 +33,7 @@ am__make_dryrun = \
|
||||
esac; \
|
||||
test $$am__dry = yes; \
|
||||
}
|
||||
-pkgdatadir = $(datadir)/@PACKAGE@
|
||||
+pkgdatadir = $(datadir)/doc/@PACKAGE@
|
||||
pkgincludedir = $(includedir)/@PACKAGE@
|
||||
|
|
|
@ -1,11 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.5 2013/06/28 15:03:55 ryoon Exp $
|
||||
$NetBSD: patch-ab,v 1.6 2014/05/14 04:35:20 rodent Exp $
|
||||
|
||||
--- doc/mini-howto/Makefile.in.orig 2013-03-09 12:40:15.000000000 +0000
|
||||
Fix DOCDIR path.
|
||||
|
||||
--- doc/mini-howto/Makefile.in.orig 2014-04-21 11:24:24.000000000 +0000
|
||||
+++ doc/mini-howto/Makefile.in
|
||||
@@ -16,7 +16,7 @@
|
||||
@SET_MAKE@
|
||||
|
||||
VPATH = @srcdir@
|
||||
@@ -33,7 +33,7 @@ am__make_dryrun = \
|
||||
esac; \
|
||||
test $$am__dry = yes; \
|
||||
}
|
||||
-pkgdatadir = $(datadir)/@PACKAGE@
|
||||
+pkgdatadir = $(datadir)/doc/@PACKAGE@
|
||||
pkgincludedir = $(includedir)/@PACKAGE@
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
$NetBSD: patch-ac,v 1.8 2011/08/20 16:02:23 cheusov Exp $
|
||||
$NetBSD: patch-ac,v 1.9 2014/05/14 04:35:20 rodent Exp $
|
||||
|
||||
Solaris has <getopt.h>, but the plain getopt() function is defined in
|
||||
<unistd.h>, so it needs both headers.
|
||||
|
||||
--- configure.orig 2011-07-21 14:52:29.000000000 +0000
|
||||
--- configure.orig 2014-04-21 11:24:23.000000000 +0000
|
||||
+++ configure
|
||||
@@ -28383,11 +28383,10 @@ extern "C" {
|
||||
@@ -21763,11 +21763,10 @@ extern "C" {
|
||||
#endif
|
||||
#if HAVE_GETOPT_H
|
||||
#include <getopt.h>
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ad,v 1.7 2014/01/20 19:29:34 joerg Exp $
|
||||
$NetBSD: patch-ad,v 1.8 2014/05/14 04:35:20 rodent Exp $
|
||||
|
||||
On Solaris 10 with SunPro, vector<> does not have a method assign().
|
||||
|
||||
--- src/libdar/mask_list.cpp.orig 2011-02-11 20:23:42.000000000 +0000
|
||||
--- src/libdar/mask_list.cpp.orig 2014-04-21 10:02:16.000000000 +0000
|
||||
+++ src/libdar/mask_list.cpp
|
||||
@@ -55,6 +55,21 @@ using namespace std;
|
||||
namespace libdar
|
||||
|
@ -73,7 +73,7 @@ On Solaris 10 with SunPro, vector<> does not have a method assign().
|
|||
min = tmp;
|
||||
else
|
||||
if(contenu[tmp] == target)
|
||||
@@ -246,57 +263,11 @@ namespace libdar
|
||||
@@ -246,59 +263,11 @@ namespace libdar
|
||||
ret = contenu[max] == target || contenu[min] == target;
|
||||
if(including && !ret) // if including files, we must also include directories leading to a listed file
|
||||
{
|
||||
|
@ -105,11 +105,13 @@ On Solaris 10 with SunPro, vector<> does not have a method assign().
|
|||
- basic_string<mask_list::my_char> mask_list::convert_string_char(const string & src)
|
||||
- {
|
||||
- basic_string<my_char> ret;
|
||||
- my_char tmp;
|
||||
-
|
||||
- string::const_iterator ut = src.begin();
|
||||
- while(ut != src.end())
|
||||
- {
|
||||
- ret += my_char(*ut);
|
||||
- tmp = *ut;
|
||||
- ret += tmp;
|
||||
- ++ut;
|
||||
- }
|
||||
-
|
||||
|
|
|
@ -1,7 +1,9 @@
|
|||
$NetBSD: patch-ae,v 1.3 2006/10/08 22:14:54 rillig Exp $
|
||||
$NetBSD: patch-ae,v 1.4 2014/05/14 04:35:20 rodent Exp $
|
||||
|
||||
--- doc/samples/cdbackup.sh.orig 2003-07-22 23:01:34.000000000 +0200
|
||||
+++ doc/samples/cdbackup.sh 2006-10-08 23:37:24.000000000 +0200
|
||||
Fix portability failure.
|
||||
|
||||
--- doc/samples/cdbackup.sh.orig 2013-08-25 17:09:49.000000000 +0000
|
||||
+++ doc/samples/cdbackup.sh
|
||||
@@ -72,8 +72,8 @@ RM="/bin/rm"
|
||||
#initial call of this script (just executes dar with the proper parameters):
|
||||
DATE=`$DATECMD -I`
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
$NetBSD: patch-af,v 1.5 2013/06/28 15:03:55 ryoon Exp $
|
||||
$NetBSD: patch-af,v 1.6 2014/05/14 04:35:20 rodent Exp $
|
||||
|
||||
Make sure we link with AM_LDFLAGS, which arranges the link and rpath for
|
||||
libintl.so.
|
||||
|
||||
--- src/libdar/Makefile.in.orig 2013-03-09 12:40:16.000000000 +0000
|
||||
--- src/libdar/Makefile.in.orig 2014-04-21 11:24:25.000000000 +0000
|
||||
+++ src/libdar/Makefile.in
|
||||
@@ -98,7 +98,7 @@ am_libdar_la_OBJECTS = $(am__objects_1)
|
||||
@@ -118,7 +118,7 @@ am_libdar_la_OBJECTS = $(am__objects_1)
|
||||
libdar_la_OBJECTS = $(am_libdar_la_OBJECTS)
|
||||
libdar_la_LINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) \
|
||||
$(LIBTOOLFLAGS) --mode=link $(CXXLD) $(AM_CXXFLAGS) \
|
||||
|
@ -14,7 +14,7 @@ libintl.so.
|
|||
@BUILD_MODE32_FALSE@@BUILD_MODE64_FALSE@am_libdar_la_rpath = -rpath \
|
||||
@BUILD_MODE32_FALSE@@BUILD_MODE64_FALSE@ $(libdir)
|
||||
libdar32_la_LIBADD =
|
||||
@@ -106,14 +106,14 @@ am_libdar32_la_OBJECTS = $(am__objects_1
|
||||
@@ -126,14 +126,14 @@ am_libdar32_la_OBJECTS = $(am__objects_1
|
||||
libdar32_la_OBJECTS = $(am_libdar32_la_OBJECTS)
|
||||
libdar32_la_LINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) \
|
||||
$(LIBTOOLFLAGS) --mode=link $(CXXLD) $(AM_CXXFLAGS) \
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
$NetBSD: patch-src_dar__suite_command__line.cpp,v 1.1 2013/06/26 15:49:31 joerg Exp $
|
||||
|
||||
--- src/dar_suite/command_line.cpp.orig 2013-06-20 19:13:40.000000000 +0000
|
||||
+++ src/dar_suite/command_line.cpp
|
||||
@@ -758,7 +758,7 @@ static bool get_args_recursive(recursive
|
||||
try
|
||||
{
|
||||
// trying to read a simple integer
|
||||
- deci tmp = string(optarg);
|
||||
+ libdar::deci tmp = string(optarg);
|
||||
p.fixed_date = tmp.computer();
|
||||
}
|
||||
catch(Edeci & e)
|
||||
@@ -845,7 +845,7 @@ static bool get_args_recursive(recursive
|
||||
case 'p':
|
||||
if(optarg != NULL)
|
||||
{
|
||||
- deci conv = string(optarg);
|
||||
+ libdar::deci conv = string(optarg);
|
||||
p.pause = conv.computer();
|
||||
}
|
||||
else
|
||||
@@ -1222,7 +1222,7 @@ static bool get_args_recursive(recursive
|
||||
{
|
||||
try
|
||||
{
|
||||
- p.hourshift = deci(string(optarg)).computer();
|
||||
+ p.hourshift = libdar::deci(string(optarg)).computer();
|
||||
}
|
||||
catch(Edeci & e)
|
||||
{
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-src_dar__suite_crit__action__cmd__line.cpp,v 1.1 2013/06/26 15:49:31 joerg Exp $
|
||||
|
||||
--- src/dar_suite/crit_action_cmd_line.cpp.orig 2013-06-20 19:17:02.000000000 +0000
|
||||
+++ src/dar_suite/crit_action_cmd_line.cpp
|
||||
@@ -413,7 +413,7 @@ static const criterium * criterium_creat
|
||||
case 'r':
|
||||
try
|
||||
{
|
||||
- deci tmp = sub_arg;
|
||||
+ libdar::deci tmp = sub_arg;
|
||||
date = tmp.computer();
|
||||
}
|
||||
catch(Edeci & e)
|
|
@ -1,76 +0,0 @@
|
|||
$NetBSD: patch-src_dar__suite_dar__manager.cpp,v 1.1 2013/06/26 15:49:31 joerg Exp $
|
||||
|
||||
--- src/dar_suite/dar_manager.cpp.orig 2013-06-20 19:21:17.000000000 +0000
|
||||
+++ src/dar_suite/dar_manager.cpp
|
||||
@@ -78,7 +78,7 @@ using namespace libdar;
|
||||
#define MISSING_ARG "Missing argument to -%c"
|
||||
#define INVALID_ARG "Invalid argument given to -%c (requires integer)"
|
||||
|
||||
-enum operation { none_op, create, add, listing, del, chbase, where, options, dar, restore, used, files, stats, move, interactive, check, batch };
|
||||
+enum operation { none_op, create, add, listing, del, chbase, where, options, dar, restore, used, files, stats, my_move, interactive, check, batch };
|
||||
|
||||
static S_I little_main(user_interaction & dialog, S_I argc, char *const argv[], const char **env);
|
||||
static bool command_line(user_interaction & dialog,
|
||||
@@ -183,7 +183,7 @@ S_I little_main(user_interaction & dialo
|
||||
case used:
|
||||
case files:
|
||||
case stats:
|
||||
- case move:
|
||||
+ case my_move:
|
||||
case interactive:
|
||||
case check:
|
||||
case batch:
|
||||
@@ -386,7 +386,7 @@ static bool command_line(user_interactio
|
||||
case 'm':
|
||||
if(op != none_op)
|
||||
throw Erange("command_line", tools_printf(gettext(ONLY_ONCE), char(lu)));
|
||||
- op = move;
|
||||
+ op = my_move;
|
||||
if(optarg == NULL)
|
||||
throw Erange("command_line", tools_printf(gettext(MISSING_ARG), char(lu)));
|
||||
num = tools_str2int(optarg);
|
||||
@@ -448,7 +448,7 @@ static bool command_line(user_interactio
|
||||
{
|
||||
try
|
||||
{
|
||||
- deci tmp = string(optarg);
|
||||
+ libdar::deci tmp = string(optarg);
|
||||
date = tmp.computer();
|
||||
}
|
||||
catch(Edeci & e)
|
||||
@@ -529,7 +529,7 @@ static bool command_line(user_interactio
|
||||
break;
|
||||
case options:
|
||||
break;
|
||||
- case move:
|
||||
+ case my_move:
|
||||
if(rest.size() != 1)
|
||||
{
|
||||
dialog.warning(gettext("Missing argument to command line, aborting"));
|
||||
@@ -1068,7 +1068,7 @@ static void op_interactive(user_interact
|
||||
saved = false;
|
||||
break;
|
||||
case 'm':
|
||||
- input = dialog.get_string(gettext("Archive number to move: "), true);
|
||||
+ input = dialog.get_string(gettext("Archive number to my_move: "), true);
|
||||
num = tools_str2int(input);
|
||||
input = dialog.get_string(gettext("In which position to insert this archive: "), true);
|
||||
num2 = tools_str2int(input);
|
||||
@@ -1298,7 +1298,7 @@ static void finalize(user_interaction &
|
||||
case where:
|
||||
case options:
|
||||
case dar:
|
||||
- case move:
|
||||
+ case my_move:
|
||||
case batch:
|
||||
if(info_details)
|
||||
dialog.warning(gettext("Compressing and writing back database to file..."));
|
||||
@@ -1362,7 +1362,7 @@ static void action(user_interaction & di
|
||||
case stats:
|
||||
op_stats(dialog, dat, info_details);
|
||||
break;
|
||||
- case move:
|
||||
+ case my_move:
|
||||
op_move(dialog, dat, num, num2, info_details);
|
||||
break;
|
||||
case interactive:
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-src_dar__suite_dar__xform.cpp,v 1.1 2013/06/26 15:49:31 joerg Exp $
|
||||
|
||||
--- src/dar_suite/dar_xform.cpp.orig 2013-06-20 19:18:01.000000000 +0000
|
||||
+++ src/dar_suite/dar_xform.cpp
|
||||
@@ -314,7 +314,7 @@ static bool command_line(user_interactio
|
||||
case 'p':
|
||||
if(optarg != NULL)
|
||||
{
|
||||
- deci conv = string(optarg);
|
||||
+ libdar::deci conv = string(optarg);
|
||||
pause = conv.computer();
|
||||
}
|
||||
else
|
|
@ -1,56 +0,0 @@
|
|||
$NetBSD: patch-src_dar__suite_line__tools.cpp,v 1.1 2013/06/26 15:49:31 joerg Exp $
|
||||
|
||||
--- src/dar_suite/line_tools.cpp.orig 2013-06-20 19:14:58.000000000 +0000
|
||||
+++ src/dar_suite/line_tools.cpp
|
||||
@@ -215,8 +215,8 @@ void line_tools_repeat_param(const strin
|
||||
|
||||
try
|
||||
{
|
||||
- deci x1 = tmp1;
|
||||
- deci x2 = tmp2;
|
||||
+ libdar::deci x1 = tmp1;
|
||||
+ libdar::deci x2 = tmp2;
|
||||
|
||||
repeat_count = x1.computer();
|
||||
repeat_byte = x2.computer();
|
||||
@@ -514,14 +514,14 @@ void line_tools_get_min_digits(string th
|
||||
it1 = tools_find_first_char_of(the_arg, ',');
|
||||
if(it1 == the_arg.end()) // a single number is provided
|
||||
{
|
||||
- deci tmp = the_arg;
|
||||
+ libdar::deci tmp = the_arg;
|
||||
num = tmp.computer();
|
||||
}
|
||||
else // at least two numbers are provided
|
||||
{
|
||||
if(the_arg.begin() != it1)
|
||||
{
|
||||
- deci convert = string(the_arg.begin(), it1);
|
||||
+ libdar::deci convert = string(the_arg.begin(), it1);
|
||||
num = convert.computer();
|
||||
}
|
||||
// else we ignore the leading ','
|
||||
@@ -533,20 +533,20 @@ void line_tools_get_min_digits(string th
|
||||
it2 = tools_find_first_char_of(tmp2, ',');
|
||||
if(it2 == tmp2.end()) // just two number have been provided
|
||||
{
|
||||
- deci convert = tmp2;
|
||||
+ libdar::deci convert = tmp2;
|
||||
ref_num = convert.computer();
|
||||
}
|
||||
else
|
||||
{
|
||||
if(tmp2.begin() != it2)
|
||||
{
|
||||
- deci convert = string(tmp2.begin(), it2);
|
||||
+ libdar::deci convert = string(tmp2.begin(), it2);
|
||||
ref_num = convert.computer();
|
||||
}
|
||||
++it2;
|
||||
if(it2 != tmp2.end())
|
||||
{
|
||||
- deci convert = string(it2, tmp2.end());
|
||||
+ libdar::deci convert = string(it2, tmp2.end());
|
||||
aux_num = convert.computer();
|
||||
}
|
||||
}
|
|
@ -1,31 +0,0 @@
|
|||
$NetBSD: patch-src_examples_factoriel.cpp,v 1.1 2013/06/26 15:49:31 joerg Exp $
|
||||
|
||||
--- src/examples/factoriel.cpp.orig 2013-06-20 19:26:28.000000000 +0000
|
||||
+++ src/examples/factoriel.cpp
|
||||
@@ -85,7 +85,7 @@ static int little_main(user_interaction
|
||||
exit(1);
|
||||
|
||||
string s = argv[1];
|
||||
- deci f = s;
|
||||
+ libdar::deci f = s;
|
||||
infinint max = f.computer();
|
||||
infinint i = 2;
|
||||
infinint p = 1;
|
||||
@@ -97,7 +97,7 @@ static int little_main(user_interaction
|
||||
}
|
||||
|
||||
ui.warning("calcul finished, now computing the decimal representation ... ");
|
||||
- f = deci(p);
|
||||
+ f = libdar::deci(p);
|
||||
ui.warning(f.human());
|
||||
if(argc == 3)
|
||||
{
|
||||
@@ -112,7 +112,7 @@ static int little_main(user_interaction
|
||||
p.dump(fic);
|
||||
fic.skip(0);
|
||||
cp = infinint(fic);
|
||||
- ui.warning(string("read from file: ") + deci(cp).human());
|
||||
+ ui.warning(string("read from file: ") + libdar::deci(cp).human());
|
||||
}
|
||||
}
|
||||
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-src_examples_formula.cpp,v 1.1 2013/06/26 15:49:31 joerg Exp $
|
||||
|
||||
--- src/examples/formula.cpp.orig 2013-06-20 19:27:22.000000000 +0000
|
||||
+++ src/examples/formula.cpp
|
||||
@@ -60,7 +60,7 @@ int little_main(user_interaction & ui, S
|
||||
else
|
||||
{
|
||||
string formula = crit_action_canonize_string(argv[1]);
|
||||
- deci tmp = calculus(formula);
|
||||
+ libdar::deci tmp = calculus(formula);
|
||||
|
||||
cout << tmp.human() << endl;
|
||||
|
||||
@@ -113,7 +113,7 @@ static infinint calculus(const string &
|
||||
return calculus(string(formula.begin() + 1, formula.end() - 1));
|
||||
else // assuming an integer
|
||||
{
|
||||
- deci tmp = formula;
|
||||
+ libdar::deci tmp = formula;
|
||||
return tmp.computer();
|
||||
}
|
||||
}
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-src_examples_prime.cpp,v 1.1 2013/06/26 15:49:31 joerg Exp $
|
||||
|
||||
--- src/examples/prime.cpp.orig 2013-06-20 19:27:04.000000000 +0000
|
||||
+++ src/examples/prime.cpp
|
||||
@@ -58,7 +58,7 @@ int little_main(user_interaction & ui, S
|
||||
exit(1);
|
||||
}
|
||||
|
||||
- deci x = string(argv[1]);
|
||||
+ libdar::deci x = string(argv[1]);
|
||||
cout << "converting string to infinint... " << endl;
|
||||
infinint num = x.computer();
|
||||
cout << "checking whether the number is a prime factor... " << endl;
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-src_libdar_mask__list.hpp,v 1.2 2014/01/20 19:29:34 joerg Exp $
|
||||
$NetBSD: patch-src_libdar_mask__list.hpp,v 1.3 2014/05/14 04:35:20 rodent Exp $
|
||||
|
||||
--- src/libdar/mask_list.hpp.orig 2012-11-30 20:51:11.000000000 +0000
|
||||
--- src/libdar/mask_list.hpp.orig 2014-04-21 10:02:16.000000000 +0000
|
||||
+++ src/libdar/mask_list.hpp
|
||||
@@ -70,46 +70,10 @@ namespace libdar
|
||||
|
||||
|
@ -13,8 +13,8 @@ $NetBSD: patch-src_libdar_mask__list.hpp,v 1.2 2014/01/20 19:29:34 joerg Exp $
|
|||
- class my_char
|
||||
- {
|
||||
- public:
|
||||
- my_char() { val = 0; };
|
||||
- my_char(const char x) : val(x) {};
|
||||
- const my_char & operator = (const char x) { val = x; return *this; };
|
||||
-
|
||||
- bool operator < (const my_char & x) const
|
||||
- {
|
||||
- if(val == '/')
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-src_libdar_secu__string.hpp,v 1.2 2013/06/28 15:03:55 ryoon Exp $
|
||||
$NetBSD: patch-src_libdar_secu__string.hpp,v 1.3 2014/05/14 04:35:20 rodent Exp $
|
||||
|
||||
--- src/libdar/secu_string.hpp.orig 2012-11-30 20:51:11.000000000 +0000
|
||||
--- src/libdar/secu_string.hpp.orig 2014-04-21 10:02:16.000000000 +0000
|
||||
+++ src/libdar/secu_string.hpp
|
||||
@@ -35,6 +35,7 @@
|
||||
#include "../my_config.h"
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-src_testing_test__catalogue.cpp,v 1.1 2013/06/26 15:49:31 joerg Exp $
|
||||
|
||||
--- src/testing/test_catalogue.cpp.orig 2013-06-20 19:28:21.000000000 +0000
|
||||
+++ src/testing/test_catalogue.cpp
|
||||
@@ -258,7 +258,7 @@ void f2()
|
||||
if(i->is_more_recent_than(*w, 0))
|
||||
{
|
||||
cout << "plus recent" << endl;
|
||||
- cout << "new is " << deci(w->get_last_modif()).human() << " ref " << deci(i->get_last_modif()).human() << endl;
|
||||
+ cout << "new is " << libdar::deci(w->get_last_modif()).human() << " ref " << libdar::deci(i->get_last_modif()).human() << endl;
|
||||
}
|
||||
else
|
||||
cout << "pas plus recent" << endl;
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-src_testing_test__deci.cpp,v 1.1 2013/06/26 15:49:31 joerg Exp $
|
||||
|
||||
--- src/testing/test_deci.cpp.orig 2013-06-20 19:29:44.000000000 +0000
|
||||
+++ src/testing/test_deci.cpp
|
||||
@@ -39,10 +39,10 @@ int main()
|
||||
|
||||
static void f1()
|
||||
{
|
||||
- deci d1 = string("00001");
|
||||
+ libdar::deci d1 = string("00001");
|
||||
infinint t = 3;
|
||||
- deci d2 = t;
|
||||
- deci d3 = infinint(125);
|
||||
+ libdar::deci d2 = t;
|
||||
+ libdar::deci d3 = infinint(125);
|
||||
U_I c;
|
||||
|
||||
cout << d1.human() << endl;
|
|
@ -1,11 +0,0 @@
|
|||
$NetBSD: patch-src_testing_test__escape.cpp,v 1.1 2013/06/26 15:49:31 joerg Exp $
|
||||
|
||||
--- src/testing/test_escape.cpp.orig 2013-06-20 19:30:16.000000000 +0000
|
||||
+++ src/testing/test_escape.cpp
|
||||
@@ -121,5 +121,5 @@ void f2()
|
||||
cout << "OK" << endl;
|
||||
else
|
||||
cout << "NOK" << endl;
|
||||
- cout << deci(tested.get_position()).human() << endl;
|
||||
+ cout << libdar::deci(tested.get_position()).human() << endl;
|
||||
}
|
|
@ -1,122 +0,0 @@
|
|||
$NetBSD: patch-src_testing_test__infinint.cpp,v 1.1 2013/06/26 15:49:31 joerg Exp $
|
||||
|
||||
--- src/testing/test_infinint.cpp.orig 2013-06-20 19:28:49.000000000 +0000
|
||||
+++ src/testing/test_infinint.cpp
|
||||
@@ -83,9 +83,9 @@ static void routine1()
|
||||
infinint f2 = f1;
|
||||
infinint f3 = 0;
|
||||
|
||||
- deci d1 = f1;
|
||||
- deci d2 = f2;
|
||||
- deci d3 = f3;
|
||||
+ libdar::deci d1 = f1;
|
||||
+ libdar::deci d2 = f2;
|
||||
+ libdar::deci d3 = f3;
|
||||
|
||||
ui->warning(d1.human() + " " + d2.human() + " " + d3.human());
|
||||
|
||||
@@ -98,7 +98,7 @@ static void routine1()
|
||||
if(fd >= 0)
|
||||
{
|
||||
f3 = infinint(*ui, fd);
|
||||
- d3 = deci(f3);
|
||||
+ d3 = libdar::deci(f3);
|
||||
ui->warning(d3.human());
|
||||
}
|
||||
close(fd);
|
||||
@@ -106,33 +106,33 @@ static void routine1()
|
||||
}
|
||||
|
||||
f1 += 3;
|
||||
- d1 = deci(f1);
|
||||
+ d1 = libdar::deci(f1);
|
||||
ui->warning(d1.human());
|
||||
|
||||
f1 -= 2;
|
||||
- d1 = deci(f1);
|
||||
+ d1 = libdar::deci(f1);
|
||||
ui->warning(d1.human());
|
||||
|
||||
f1 *= 10;
|
||||
- d1 = deci(f1);
|
||||
+ d1 = libdar::deci(f1);
|
||||
ui->warning(d1.human());
|
||||
|
||||
f2 = f1;
|
||||
f1 /= 3;
|
||||
- d1 = deci(f1);
|
||||
+ d1 = libdar::deci(f1);
|
||||
ui->warning(d1.human());
|
||||
|
||||
f2 %= 3;
|
||||
- d2 = deci(f2);
|
||||
+ d2 = libdar::deci(f2);
|
||||
ui->warning(d2.human());
|
||||
|
||||
f2 >>= 12;
|
||||
- d2 = deci(f2);
|
||||
+ d2 = libdar::deci(f2);
|
||||
ui->warning(d2.human());
|
||||
|
||||
f1 = 4;
|
||||
f2 >>= f1;
|
||||
- d2 = deci(f2);
|
||||
+ d2 = libdar::deci(f2);
|
||||
ui->warning(d2.human());
|
||||
|
||||
f1 = 4+12;
|
||||
@@ -143,9 +143,9 @@ static void routine1()
|
||||
cout << f3 << endl;
|
||||
cout << (123 << 16) << endl;
|
||||
f2 <<= 4+12;
|
||||
- d2 = deci(f2);
|
||||
+ d2 = libdar::deci(f2);
|
||||
ui->warning(d2.human());
|
||||
- d3 = deci(f3);
|
||||
+ d3 = libdar::deci(f3);
|
||||
ui->warning(d3.human());
|
||||
|
||||
try
|
||||
@@ -184,12 +184,12 @@ static void routine1()
|
||||
{
|
||||
for(f3 = 2; f3 <= f1; f3++)
|
||||
{
|
||||
- d1 = deci(f1);
|
||||
- d2 = deci(f2);
|
||||
- d3 = deci(f3);
|
||||
+ d1 = libdar::deci(f1);
|
||||
+ d2 = libdar::deci(f2);
|
||||
+ d3 = libdar::deci(f3);
|
||||
ui->warning(d1.human() + " " + d2.human() + " " + d3.human());
|
||||
f2 *= f3;
|
||||
- d2 = deci(f2);
|
||||
+ d2 = libdar::deci(f2);
|
||||
ui->warning(d2.human());
|
||||
}
|
||||
}
|
||||
@@ -197,17 +197,17 @@ static void routine1()
|
||||
{
|
||||
ui->warning(e.get_message());
|
||||
}
|
||||
- d2 = deci(f2);
|
||||
- d1 = deci(f1);
|
||||
+ d2 = libdar::deci(f2);
|
||||
+ d1 = libdar::deci(f1);
|
||||
ui->warning(string("factoriel(") + d1.human() + ") = " + d2.human());
|
||||
}
|
||||
|
||||
static void routine2()
|
||||
{
|
||||
- ui->warning(deci(infinint(2).power((U_I)0)).human());
|
||||
- ui->warning(deci(infinint(2).power(infinint(0))).human());
|
||||
- ui->warning(deci(infinint(2).power((U_I)1)).human());
|
||||
- ui->warning(deci(infinint(2).power(infinint(1))).human());
|
||||
- ui->warning(deci(infinint(2).power((U_I)2)).human());
|
||||
- ui->warning(deci(infinint(2).power(infinint(2))).human());
|
||||
+ ui->warning(libdar::deci(infinint(2).power((U_I)0)).human());
|
||||
+ ui->warning(libdar::deci(infinint(2).power(infinint(0))).human());
|
||||
+ ui->warning(libdar::deci(infinint(2).power((U_I)1)).human());
|
||||
+ ui->warning(libdar::deci(infinint(2).power(infinint(1))).human());
|
||||
+ ui->warning(libdar::deci(infinint(2).power((U_I)2)).human());
|
||||
+ ui->warning(libdar::deci(infinint(2).power(infinint(2))).human());
|
||||
}
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-src_testing_test__terminateur.cpp,v 1.1 2013/06/26 15:49:31 joerg Exp $
|
||||
|
||||
--- src/testing/test_terminateur.cpp.orig 2013-06-20 19:28:01.000000000 +0000
|
||||
+++ src/testing/test_terminateur.cpp
|
||||
@@ -83,7 +83,7 @@ static void f1()
|
||||
for(S_I i=2;i<30;i++)
|
||||
grand *= i;
|
||||
|
||||
- deci conv = grand;
|
||||
+ libdar::deci conv = grand;
|
||||
cout << conv.human() << endl;
|
||||
term.set_catalogue_start(grand);
|
||||
term.dump(toto);
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-src_testing_testtools.cpp,v 1.1 2013/06/26 15:49:31 joerg Exp $
|
||||
|
||||
--- src/testing/testtools.cpp.orig 2013-06-20 19:29:24.000000000 +0000
|
||||
+++ src/testing/testtools.cpp
|
||||
@@ -35,7 +35,7 @@ using namespace std;
|
||||
|
||||
void display(const infinint & x)
|
||||
{
|
||||
- deci vu = x;
|
||||
+ libdar::deci vu = x;
|
||||
cout << vu.human() << endl;
|
||||
}
|
||||
|
Loading…
Reference in a new issue