Update to verion 9.19.

Changes:

- work around perl 5.18.0 breakage in tabbed extension
  (reported by Karol Blazewicz) and in pod (Dominic Hargreaves).
- fix regression that caused the double-click word selection to
  erroneously include a tab on the left of the selected word.
- implement FOCUS variable and focus_fade function in background
  expression, to allow focus-sensitive background images.
- add support for the set cursor style (DECSCUSR) control
  function.
- honour cursorColor also when the cursor style is underline.
- export some Color_xxx constants to Perl.

pkgsrc changes:
- remove patches/patch-src_perl_tabbed, it is upstream now
This commit is contained in:
morr 2013-11-30 23:24:10 +00:00
parent 9957602706
commit 1a119e4c37
3 changed files with 6 additions and 29 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.48 2013/07/22 17:55:21 morr Exp $
# $NetBSD: Makefile,v 1.49 2013/11/30 23:24:10 morr Exp $
DISTNAME= rxvt-unicode-9.18
DISTNAME= rxvt-unicode-9.19
CATEGORIES= x11
MASTER_SITES= http://dist.schmorp.de/rxvt-unicode/ \
http://dist.schmorp.de/rxvt-unicode/Attic/
@ -22,9 +22,6 @@ CONFIGURE_ARGS+= --enable-256-color
INSTALLATION_DIRS+= share/doc/rxvt-unicode share/examples/rxvt-unicode
post-patch:
${RM} ${WRKSRC}/src/perl/tabbed.orig
post-install:
${INSTALL_DATA} ${WRKSRC}/README.FAQ \
${DESTDIR}${PREFIX}/share/doc/rxvt-unicode

View file

@ -1,10 +1,8 @@
$NetBSD: distinfo,v 1.22 2013/11/10 20:29:24 joerg Exp $
$NetBSD: distinfo,v 1.23 2013/11/30 23:24:10 morr Exp $
SHA1 (rxvt-unicode-9.18.tar.bz2) = 5d12639c4b17019357ee62c08916b826e5d03259
RMD160 (rxvt-unicode-9.18.tar.bz2) = 0429b78d85bdedbfa7a33dd749fb5e72582bb75f
Size (rxvt-unicode-9.18.tar.bz2) = 897170 bytes
SHA1 (rxvt-unicode-9.19.tar.bz2) = 979f990b73cf057d81f25884668f362b5a748154
RMD160 (rxvt-unicode-9.19.tar.bz2) = 676ade0999389ee918c3c264b2a100308a8dd41f
Size (rxvt-unicode-9.19.tar.bz2) = 914096 bytes
SHA1 (patch-Makefile.in) = 1c2890e2057d062f823f944fc2ecd2258f14b61e
SHA1 (patch-configure) = bd8a6fb21a02f7df6c29a932de10fdc2213ae8b0
SHA1 (patch-doc_Makefile.in) = 8465193e21878a18ae467dc50a336a65f1bd4de7
SHA1 (patch-src_perl_tabbed) = 7af00b0d704ca4801c86dedf80aadbbd1b87ad33
SHA1 (patch-src_rxvtutil.h) = be8c1b26b24c3c36f8e0b24cf7fae51709cbaf34

View file

@ -1,18 +0,0 @@
$NetBSD: patch-src_perl_tabbed,v 1.1 2013/07/22 17:55:21 morr Exp $
Fix to make it compatibible with perl 5.18
(https://metacpan.org/module/RJBS/perl-5.18.0/pod/perldelta.pod#qw-...-can-no-longer-be-used-as-parentheses)
Patch taken from http://lists.schmorp.de/pipermail/rxvt-unicode/2013q2/001793.html
--- src/perl/tabbed.orig 2013-02-17 00:41:38.000000000 +0000
+++ src/perl/tabbed
@@ -402,7 +402,7 @@ package urxvt::ext::tabbed::tab;
# simply proxies all interesting calls back to the tabbed class.
{
- for my $hook qw(start destroy key_press property_notify) {
+ for my $hook (qw(start destroy key_press property_notify)) {
eval qq{
sub on_$hook {
my \$parent = \$_[0]{term}{parent}