+ Don't allow the configure script to find libintl.so or else the resulting
libXpm will be linked against it, which is not necessary. Instead, just pass down INTLLIBS in the build environment for use by the [cs]xpm Makefiles, which are the only programs that use gettext(). Bump the PKGREVISION to 1.
This commit is contained in:
parent
b54f44788b
commit
1a14b4895b
5 changed files with 55 additions and 3 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.6 2008/02/06 14:03:41 rillig Exp $
|
||||
# $NetBSD: Makefile,v 1.7 2008/02/24 02:26:33 jlam Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libXpm-3.5.7
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= graphics x11
|
||||
MASTER_SITES= http://xorg.freedesktop.org/releases/individual/lib/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -16,11 +17,18 @@ PKG_DESTDIR_SUPPORT= user-destdir
|
|||
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= pkg-config xgettext
|
||||
BROKEN_GETTEXT_DETECTION=yes
|
||||
PKGCONFIG_OVERRIDE+= xpm.pc.in
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV+= APP_MAN_SUFFIX=1
|
||||
|
||||
# Don't allow the configure script to find libintl.so or else the resulting
|
||||
# libXpm will be linked against it, which is not necessary. Instead, just
|
||||
# pass down INTLLIBS in the build environment for use by the [cs]xpm
|
||||
# Makefiles.
|
||||
#
|
||||
CONFIGURE_ENV+= ac_cv_search_gettext=no
|
||||
MAKE_ENV+= INTLLIBS=${BUILDLINK_LDADD.gettext:Q}
|
||||
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../x11/libX11/buildlink3.mk"
|
||||
.include "../../x11/libXext/buildlink3.mk"
|
||||
|
|
|
@ -1,5 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.2 2008/01/15 23:22:36 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.3 2008/02/24 02:26:33 jlam Exp $
|
||||
|
||||
SHA1 (libXpm-3.5.7.tar.bz2) = 215208091051530867efae0a4c1cedb7385d5f0e
|
||||
RMD160 (libXpm-3.5.7.tar.bz2) = 6bd355cb5f011b271b177d86db7f9a4e9d885ed3
|
||||
Size (libXpm-3.5.7.tar.bz2) = 358241 bytes
|
||||
SHA1 (patch-aa) = a291094517f967b61d19a217b1f3e5b2452210f8
|
||||
SHA1 (patch-ab) = 93505bd7e3591bd4c94ed835d7c8c91b5d246f6b
|
||||
SHA1 (patch-ac) = 43cc51e6214e233b02d81c2dd3cfef23a3a9e30e
|
||||
|
|
15
x11/libXpm/patches/patch-aa
Normal file
15
x11/libXpm/patches/patch-aa
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-aa,v 1.1 2008/02/24 02:26:33 jlam Exp $
|
||||
|
||||
--- configure.orig 2007-08-22 16:23:54.000000000 -0400
|
||||
+++ configure
|
||||
@@ -20621,6 +20621,10 @@ else
|
||||
echo "${ECHO_T}$LOCALEDIR" >&6; }
|
||||
fi
|
||||
|
||||
+# For pkgsrc, always set USE_GETTEXT=yes because it is used by [cs]xpm.
|
||||
+# We will pass INTLLIBS down to [cs]xpm as part of the build environment.
|
||||
+#
|
||||
+USE_GETTEXT=yes
|
||||
if test "x$USE_GETTEXT" = "xyes" ; then
|
||||
|
||||
cat >>confdefs.h <<\_ACEOF
|
13
x11/libXpm/patches/patch-ab
Normal file
13
x11/libXpm/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1 2008/02/24 02:26:33 jlam Exp $
|
||||
|
||||
--- cxpm/Makefile.in.orig 2007-08-22 16:23:56.000000000 -0400
|
||||
+++ cxpm/Makefile.in
|
||||
@@ -119,7 +119,7 @@ INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
LIBOBJS = @LIBOBJS@
|
||||
-LIBS = @LIBS@
|
||||
+LIBS = @LIBS@ $(INTLLIBS)
|
||||
LIBTOOL = @LIBTOOL@
|
||||
LIB_MAN_DIR = @LIB_MAN_DIR@
|
||||
LIB_MAN_SUFFIX = @LIB_MAN_SUFFIX@
|
13
x11/libXpm/patches/patch-ac
Normal file
13
x11/libXpm/patches/patch-ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.1 2008/02/24 02:26:33 jlam Exp $
|
||||
|
||||
--- sxpm/Makefile.in.orig 2007-08-22 16:23:56.000000000 -0400
|
||||
+++ sxpm/Makefile.in
|
||||
@@ -123,7 +123,7 @@ INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
LIBOBJS = @LIBOBJS@
|
||||
-LIBS = @LIBS@
|
||||
+LIBS = @LIBS@ $(INTLLIBS)
|
||||
LIBTOOL = @LIBTOOL@
|
||||
LIB_MAN_DIR = @LIB_MAN_DIR@
|
||||
LIB_MAN_SUFFIX = @LIB_MAN_SUFFIX@
|
Loading…
Reference in a new issue