Update to version 0.91.2 of this package, a bug fix release - the old
version of the distfile was no longer around on the MASTER_SITE. Removed old patches ac and ad, and added a new one to include CPPFLAGS in CFLAGS, passed from the package Makefile through the environment. Fixed the manual page handling on NetBSD.
This commit is contained in:
parent
1fbdc75b18
commit
1a239ab1ac
5 changed files with 20 additions and 46 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.9 1999/10/21 16:54:00 agc Exp $
|
||||
# $NetBSD: Makefile,v 1.10 1999/10/25 23:14:58 agc Exp $
|
||||
#
|
||||
|
||||
DISTNAME= catdoc-0.91.1
|
||||
DISTNAME= catdoc-0.91.2
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://www.go.dlr.de/fresh/unix/src/contrib/
|
||||
|
||||
|
@ -13,17 +13,7 @@ WRKSRC= ${WRKDIR}/catdoc
|
|||
|
||||
USE_X11= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CFLAGS+= -Dunix
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${OPSYS} == "NetBSD"
|
||||
MANCOMPRESSED_IF_MANZ= yes
|
||||
PLIST_SRC= ${WRKDIR}/PLIST-src
|
||||
|
||||
post-install:
|
||||
${CP} ${FILESDIR}/PLIST ${PLIST_SRC}
|
||||
${ECHO} "man/cat1/catdoc.0" >> ${PLIST_SRC}
|
||||
.endif
|
||||
CPPFLAGS+= -Dunix -D__unix
|
||||
MAKE_ENV+= CPPFLAGS="${CPPFLAGS}"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.3 1999/10/21 16:54:01 agc Exp $
|
||||
$NetBSD: md5,v 1.4 1999/10/25 23:14:58 agc Exp $
|
||||
|
||||
MD5 (catdoc-0.91.1.tar.gz) = 6d44fb20f2fb2365fbc26e5753b4a8bf
|
||||
MD5 (catdoc-0.91.2.tar.gz) = edfaedb7b60ff6336b03f67c16dd4c60
|
||||
|
|
|
@ -1,4 +1,5 @@
|
|||
$NetBSD: patch-sum,v 1.2 1999/10/21 16:54:01 agc Exp $
|
||||
$NetBSD: patch-sum,v 1.3 1999/10/25 23:14:58 agc Exp $
|
||||
|
||||
MD5 (patch-aa) = c9fb166485a2d62e8ea6822e2b2daf95
|
||||
MD5 (patch-ab) = 01f9213ed1c552754471283f7265f64b
|
||||
MD5 (patch-ac) = 91c69775ad97747df382aabbfa51dff8
|
||||
|
|
|
@ -1,13 +1,15 @@
|
|||
$NetBSD: patch-ac,v 1.2 1998/08/07 11:14:11 agc Exp $
|
||||
$NetBSD: patch-ac,v 1.3 1999/10/25 23:14:58 agc Exp $
|
||||
|
||||
--- catdoc.c.orig Fri Jun 5 12:43:35 1998
|
||||
+++ catdoc.c Sat Jun 20 01:03:13 1998
|
||||
@@ -46,7 +46,7 @@
|
||||
#define BUFFER_SIZE 16384
|
||||
#endif
|
||||
/* enable this define, if you don't want cyrillic code page translations */
|
||||
-/* #define LATIN1*/
|
||||
+#define LATIN1
|
||||
Add CPPFLAGS to CFLAGS, passed down through the environment.
|
||||
|
||||
--- src/Makefile.in 1999/10/25 23:01:49 1.1
|
||||
+++ src/Makefile.in 1999/10/25 23:02:01
|
||||
@@ -61,7 +61,7 @@
|
||||
-DREPL_EXT=\"$(REPL_EXT)\" -DUNKNOWN_CHAR=\'$(UNKNOWN_CHAR)\'\
|
||||
-DSOURCE_CHARSET=\"$(SOURCE_CHARSET)\" -DTARGET_CHARSET=\"$(TARGET_CHARSET)\"
|
||||
|
||||
-CFLAGS=$(FLAGS) $(DEFINES)
|
||||
+CFLAGS=$(FLAGS) $(DEFINES) ${CPPFLAGS}
|
||||
OBJ=catdoc.o charsets.o substmap.o reader.o writer.o fileutil.o\
|
||||
confutil.o analyze.o rtfreader.o
|
||||
|
||||
/* ......................................................... charsets ... */
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.2 1998/08/07 11:14:12 agc Exp $
|
||||
|
||||
--- wordview.orig Tue Nov 11 15:04:07 1997
|
||||
+++ wordview Sat Jun 20 01:20:09 1998
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/wish4.2
|
||||
+#!@PREFIX@/bin/wish8.0
|
||||
|
||||
set font 8x13
|
||||
|
||||
@@ -72,7 +72,7 @@
|
||||
if ![file readable $name] {
|
||||
return -code error "Cannot open file $name"
|
||||
}
|
||||
-set f [open "|[file dirname [info script]]/catdoc -w $name" r]
|
||||
+set f [open "|@PREFIX@/bin/catdoc -w $name" r]
|
||||
.text configure -state normal
|
||||
.text delete 0.0 end
|
||||
.text insert 0.0 [read $f] doc
|
Loading…
Reference in a new issue