lynis: update to 2.6.0

Changes:
--------
* Binary paths are now sorted
* Greek language added
* systemd detection improved
* VirtualBox detection extended
* Several code enhancements

Tests:
------
* [PHP-2379] - Small enhancement to resolve error on screen in some cases
* [MALW-3280] - Improved detection for BitDefender tooling
This commit is contained in:
sborrill 2018-01-18 16:42:40 +00:00
parent d0ee27ce4d
commit 1a63599d49
4 changed files with 11 additions and 28 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.2 2018/01/18 16:26:05 sborrill Exp $
# $NetBSD: Makefile,v 1.3 2018/01/18 16:42:40 sborrill Exp $
#
DISTNAME= lynis-2.5.9
DISTNAME= lynis-2.6.0
CATEGORIES= security
MASTER_SITES= https://cisofy.com/files/

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2018/01/15 12:38:37 sborrill Exp $
@comment $NetBSD: PLIST,v 1.2 2018/01/18 16:42:40 sborrill Exp $
bin/lynis
lib/lynis/db/fileperms.db
lib/lynis/db/hints.db
@ -12,6 +12,7 @@ lib/lynis/db/languages/en-US
lib/lynis/db/languages/es
lib/lynis/db/languages/fi
lib/lynis/db/languages/fr
lib/lynis/db/languages/gr
lib/lynis/db/languages/he
lib/lynis/db/languages/hu
lib/lynis/db/languages/it

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.2 2018/01/18 13:22:18 sborrill Exp $
$NetBSD: distinfo,v 1.3 2018/01/18 16:42:40 sborrill Exp $
SHA1 (lynis-2.5.9.tar.gz) = 71733fa3de9894ca140333070de2843018b02d80
RMD160 (lynis-2.5.9.tar.gz) = 1915a0f6cd7ad598c73d575259f801845dff3a1c
SHA512 (lynis-2.5.9.tar.gz) = 655942b6546183396a416df6b7a365918aab1a19b55e2b1d34da4a5fe7fe865aee59aae6de2467b8e5393cae9bb80f97c48a85f1e3606951d88ea21cb624c45a
Size (lynis-2.5.9.tar.gz) = 269067 bytes
SHA1 (patch-include_functions) = ceea3edbbf47bc8d41cffebaaefd9152592f66d7
SHA1 (lynis-2.6.0.tar.gz) = 73099471eee2742477ca27ea7e9664da74a56ae2
RMD160 (lynis-2.6.0.tar.gz) = 2049214b21b045275c5384f64b4f4bb23e6d87a7
SHA512 (lynis-2.6.0.tar.gz) = eb0aa18b0b8b453ee61b0f5ff82f0f0bbffd9fe1b38232d04b2384dbbced4cdb2ea00e3b089d9c3765e1ea405c6fe5f03332bc7b4ea0189639226907e37f1b25
Size (lynis-2.6.0.tar.gz) = 268446 bytes
SHA1 (patch-include_functions) = 157c720799d27adc8e90266f78de8da2db4b58cb
SHA1 (patch-lynis) = f35b682d9c30afdd6bc4e35ca684a4bd7209f63d

View file

@ -1,7 +1,6 @@
$NetBSD: patch-include_functions,v 1.2 2018/01/18 13:22:19 sborrill Exp $
$NetBSD: patch-include_functions,v 1.3 2018/01/18 16:42:40 sborrill Exp $
Set location of default profiles.
Remove bash comparisons.
--- include/functions.orig 2018-01-12 00:00:00.000000000 +0000
+++ include/functions 2018-01-15 11:38:48.000000000 +0000
@ -14,20 +13,3 @@ Remove bash comparisons.
for PNAME in ${tPROFILE_NAMES}; do
for PLOC in ${tPROFILE_TARGETS}; do
# Only use one default.prf
@@ -3010,14 +3010,14 @@
LogText "${FUNCNAME}: check if ${1} is equal to ${2}"
- if [ "$1" == "$2" ]; then
+ if [ "$1" = "$2" ]; then
LogText "${FUNCNAME}: ${1} is equal to ${2}"
RETVAL=0
fi
if ! [ -z ${3+x} ]; then
LogText "${FUNCNAME}: ${1} is equal to ${3}"
- if [ "$2" == "$3" ]; then
+ if [ "$2" = "$3" ]; then
LogText "${FUNCNAME}: ${OPTION} is equal to ${3}"
RETVAL=1
fi