py-poetry: added version 1.1.12
Poetry helps you declare, manage and install dependencies of Python projects, ensuring you have the right stack everywhere.
This commit is contained in:
parent
3422ee2536
commit
1a6cbcf5a1
7 changed files with 496 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.3547 2022/01/11 19:03:59 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.3548 2022/01/11 19:21:49 adam Exp $
|
||||
#
|
||||
|
||||
COMMENT= Development utilities
|
||||
|
@ -2470,6 +2470,8 @@ SUBDIR+= py-pkginfo
|
|||
SUBDIR+= py-pluggy
|
||||
SUBDIR+= py-plumbum
|
||||
SUBDIR+= py-ply
|
||||
SUBDIR+= py-poetry
|
||||
SUBDIR+= py-poetry-core
|
||||
SUBDIR+= py-polib
|
||||
SUBDIR+= py-pqueue
|
||||
SUBDIR+= py-prefixspan
|
||||
|
|
1
devel/py-poetry/ALTERNATIVES
Normal file
1
devel/py-poetry/ALTERNATIVES
Normal file
|
@ -0,0 +1 @@
|
|||
bin/poetry @PREFIX@/bin/poetry-@PYVERSSUFFIX@
|
2
devel/py-poetry/DESCR
Normal file
2
devel/py-poetry/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
Poetry helps you declare, manage and install dependencies of Python projects,
|
||||
ensuring you have the right stack everywhere.
|
49
devel/py-poetry/Makefile
Normal file
49
devel/py-poetry/Makefile
Normal file
|
@ -0,0 +1,49 @@
|
|||
# $NetBSD: Makefile,v 1.1 2022/01/11 19:21:49 adam Exp $
|
||||
|
||||
DISTNAME= poetry-1.1.12
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= ${MASTER_SITE_PYPI:=p/poetry/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://python-poetry.org/
|
||||
COMMENT= Python dependency management and packaging made easy
|
||||
LICENSE= mit
|
||||
|
||||
BUILD_DEPENDS+= ${PYPKGPREFIX}-setuptools_scm-[0-9]*:../../devel/py-setuptools_scm
|
||||
DEPENDS+= ${PYPKGPREFIX}-cachecontrol>=0.12.9:../../devel/py-cachecontrol
|
||||
DEPENDS+= ${PYPKGPREFIX}-cachy>=0.3.0:../../devel/py-cachy
|
||||
DEPENDS+= ${PYPKGPREFIX}-clikit>=0.6.2:../../comms/py-clikit
|
||||
DEPENDS+= ${PYPKGPREFIX}-cleo>=0.8.1:../../comms/py-cleo
|
||||
DEPENDS+= ${PYPKGPREFIX}-crashtest>=0.3.0:../../misc/py-crashtest
|
||||
DEPENDS+= ${PYPKGPREFIX}-html5lib>=1.0:../../textproc/py-html5lib
|
||||
DEPENDS+= ${PYPKGPREFIX}-keyring>=21.2.0:../../security/py-keyring
|
||||
DEPENDS+= ${PYPKGPREFIX}-packaging>=20.4:../../devel/py-packaging
|
||||
DEPENDS+= ${PYPKGPREFIX}-pexpect>=4.7.0:../../devel/py-pexpect
|
||||
DEPENDS+= ${PYPKGPREFIX}-pkginfo>=1.4:../../devel/py-pkginfo
|
||||
DEPENDS+= ${PYPKGPREFIX}-poetry-core>=1.0.7:../../devel/py-poetry-core
|
||||
DEPENDS+= ${PYPKGPREFIX}-requests-toolbelt>=0.9.1:../../devel/py-requests-toolbelt
|
||||
DEPENDS+= ${PYPKGPREFIX}-requests>=2.18:../../devel/py-requests
|
||||
DEPENDS+= ${PYPKGPREFIX}-shellingham>=1.1:../../misc/py-shellingham
|
||||
DEPENDS+= ${PYPKGPREFIX}-tomlkit>=0.7.0:../../textproc/py-tomlkit
|
||||
DEPENDS+= ${PYPKGPREFIX}-virtualenv>=20.0.26:../../devel/py-virtualenv
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test>=6.0:../../devel/py-test
|
||||
|
||||
PYTHON_VERSIONS_INCOMPATIBLE= 27
|
||||
|
||||
.include "../../lang/python/pyversion.mk"
|
||||
.if ${_PYTHON_VERSION} < 38
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-mock-[0-9]*:../../devel/py-mock
|
||||
.endif
|
||||
|
||||
USE_LANGUAGES= # none
|
||||
|
||||
post-install:
|
||||
# conflicts with py-poetry-core
|
||||
${RM} -f ${DESTDIR}${PREFIX}/${PYSITELIB}/poetry/__init__.py
|
||||
${RM} -f ${DESTDIR}${PREFIX}/${PYSITELIB}/poetry/__pycache__/__init__.*
|
||||
cd ${DESTDIR}${PREFIX}/bin && \
|
||||
${MV} poetry poetry-${PYVERSSUFFIX} || ${TRUE}
|
||||
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
420
devel/py-poetry/PLIST
Normal file
420
devel/py-poetry/PLIST
Normal file
|
@ -0,0 +1,420 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2022/01/11 19:21:49 adam Exp $
|
||||
bin/poetry-${PYVERSSUFFIX}
|
||||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/entry_points.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/requires.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
|
||||
${PYSITELIB}/poetry/__main__.py
|
||||
${PYSITELIB}/poetry/__main__.pyc
|
||||
${PYSITELIB}/poetry/__main__.pyo
|
||||
${PYSITELIB}/poetry/__version__.py
|
||||
${PYSITELIB}/poetry/__version__.pyc
|
||||
${PYSITELIB}/poetry/__version__.pyo
|
||||
${PYSITELIB}/poetry/config/__init__.py
|
||||
${PYSITELIB}/poetry/config/__init__.pyc
|
||||
${PYSITELIB}/poetry/config/__init__.pyo
|
||||
${PYSITELIB}/poetry/config/config.py
|
||||
${PYSITELIB}/poetry/config/config.pyc
|
||||
${PYSITELIB}/poetry/config/config.pyo
|
||||
${PYSITELIB}/poetry/config/config_source.py
|
||||
${PYSITELIB}/poetry/config/config_source.pyc
|
||||
${PYSITELIB}/poetry/config/config_source.pyo
|
||||
${PYSITELIB}/poetry/config/dict_config_source.py
|
||||
${PYSITELIB}/poetry/config/dict_config_source.pyc
|
||||
${PYSITELIB}/poetry/config/dict_config_source.pyo
|
||||
${PYSITELIB}/poetry/config/file_config_source.py
|
||||
${PYSITELIB}/poetry/config/file_config_source.pyc
|
||||
${PYSITELIB}/poetry/config/file_config_source.pyo
|
||||
${PYSITELIB}/poetry/console/__init__.py
|
||||
${PYSITELIB}/poetry/console/__init__.pyc
|
||||
${PYSITELIB}/poetry/console/__init__.pyo
|
||||
${PYSITELIB}/poetry/console/application.py
|
||||
${PYSITELIB}/poetry/console/application.pyc
|
||||
${PYSITELIB}/poetry/console/application.pyo
|
||||
${PYSITELIB}/poetry/console/args/__init__.py
|
||||
${PYSITELIB}/poetry/console/args/__init__.pyc
|
||||
${PYSITELIB}/poetry/console/args/__init__.pyo
|
||||
${PYSITELIB}/poetry/console/args/run_args_parser.py
|
||||
${PYSITELIB}/poetry/console/args/run_args_parser.pyc
|
||||
${PYSITELIB}/poetry/console/args/run_args_parser.pyo
|
||||
${PYSITELIB}/poetry/console/commands/__init__.py
|
||||
${PYSITELIB}/poetry/console/commands/__init__.pyc
|
||||
${PYSITELIB}/poetry/console/commands/__init__.pyo
|
||||
${PYSITELIB}/poetry/console/commands/about.py
|
||||
${PYSITELIB}/poetry/console/commands/about.pyc
|
||||
${PYSITELIB}/poetry/console/commands/about.pyo
|
||||
${PYSITELIB}/poetry/console/commands/add.py
|
||||
${PYSITELIB}/poetry/console/commands/add.pyc
|
||||
${PYSITELIB}/poetry/console/commands/add.pyo
|
||||
${PYSITELIB}/poetry/console/commands/build.py
|
||||
${PYSITELIB}/poetry/console/commands/build.pyc
|
||||
${PYSITELIB}/poetry/console/commands/build.pyo
|
||||
${PYSITELIB}/poetry/console/commands/cache/__init__.py
|
||||
${PYSITELIB}/poetry/console/commands/cache/__init__.pyc
|
||||
${PYSITELIB}/poetry/console/commands/cache/__init__.pyo
|
||||
${PYSITELIB}/poetry/console/commands/cache/cache.py
|
||||
${PYSITELIB}/poetry/console/commands/cache/cache.pyc
|
||||
${PYSITELIB}/poetry/console/commands/cache/cache.pyo
|
||||
${PYSITELIB}/poetry/console/commands/cache/clear.py
|
||||
${PYSITELIB}/poetry/console/commands/cache/clear.pyc
|
||||
${PYSITELIB}/poetry/console/commands/cache/clear.pyo
|
||||
${PYSITELIB}/poetry/console/commands/cache/list.py
|
||||
${PYSITELIB}/poetry/console/commands/cache/list.pyc
|
||||
${PYSITELIB}/poetry/console/commands/cache/list.pyo
|
||||
${PYSITELIB}/poetry/console/commands/check.py
|
||||
${PYSITELIB}/poetry/console/commands/check.pyc
|
||||
${PYSITELIB}/poetry/console/commands/check.pyo
|
||||
${PYSITELIB}/poetry/console/commands/command.py
|
||||
${PYSITELIB}/poetry/console/commands/command.pyc
|
||||
${PYSITELIB}/poetry/console/commands/command.pyo
|
||||
${PYSITELIB}/poetry/console/commands/config.py
|
||||
${PYSITELIB}/poetry/console/commands/config.pyc
|
||||
${PYSITELIB}/poetry/console/commands/config.pyo
|
||||
${PYSITELIB}/poetry/console/commands/debug/__init__.py
|
||||
${PYSITELIB}/poetry/console/commands/debug/__init__.pyc
|
||||
${PYSITELIB}/poetry/console/commands/debug/__init__.pyo
|
||||
${PYSITELIB}/poetry/console/commands/debug/debug.py
|
||||
${PYSITELIB}/poetry/console/commands/debug/debug.pyc
|
||||
${PYSITELIB}/poetry/console/commands/debug/debug.pyo
|
||||
${PYSITELIB}/poetry/console/commands/debug/info.py
|
||||
${PYSITELIB}/poetry/console/commands/debug/info.pyc
|
||||
${PYSITELIB}/poetry/console/commands/debug/info.pyo
|
||||
${PYSITELIB}/poetry/console/commands/debug/resolve.py
|
||||
${PYSITELIB}/poetry/console/commands/debug/resolve.pyc
|
||||
${PYSITELIB}/poetry/console/commands/debug/resolve.pyo
|
||||
${PYSITELIB}/poetry/console/commands/env/__init__.py
|
||||
${PYSITELIB}/poetry/console/commands/env/__init__.pyc
|
||||
${PYSITELIB}/poetry/console/commands/env/__init__.pyo
|
||||
${PYSITELIB}/poetry/console/commands/env/env.py
|
||||
${PYSITELIB}/poetry/console/commands/env/env.pyc
|
||||
${PYSITELIB}/poetry/console/commands/env/env.pyo
|
||||
${PYSITELIB}/poetry/console/commands/env/info.py
|
||||
${PYSITELIB}/poetry/console/commands/env/info.pyc
|
||||
${PYSITELIB}/poetry/console/commands/env/info.pyo
|
||||
${PYSITELIB}/poetry/console/commands/env/list.py
|
||||
${PYSITELIB}/poetry/console/commands/env/list.pyc
|
||||
${PYSITELIB}/poetry/console/commands/env/list.pyo
|
||||
${PYSITELIB}/poetry/console/commands/env/remove.py
|
||||
${PYSITELIB}/poetry/console/commands/env/remove.pyc
|
||||
${PYSITELIB}/poetry/console/commands/env/remove.pyo
|
||||
${PYSITELIB}/poetry/console/commands/env/use.py
|
||||
${PYSITELIB}/poetry/console/commands/env/use.pyc
|
||||
${PYSITELIB}/poetry/console/commands/env/use.pyo
|
||||
${PYSITELIB}/poetry/console/commands/env_command.py
|
||||
${PYSITELIB}/poetry/console/commands/env_command.pyc
|
||||
${PYSITELIB}/poetry/console/commands/env_command.pyo
|
||||
${PYSITELIB}/poetry/console/commands/export.py
|
||||
${PYSITELIB}/poetry/console/commands/export.pyc
|
||||
${PYSITELIB}/poetry/console/commands/export.pyo
|
||||
${PYSITELIB}/poetry/console/commands/init.py
|
||||
${PYSITELIB}/poetry/console/commands/init.pyc
|
||||
${PYSITELIB}/poetry/console/commands/init.pyo
|
||||
${PYSITELIB}/poetry/console/commands/install.py
|
||||
${PYSITELIB}/poetry/console/commands/install.pyc
|
||||
${PYSITELIB}/poetry/console/commands/install.pyo
|
||||
${PYSITELIB}/poetry/console/commands/installer_command.py
|
||||
${PYSITELIB}/poetry/console/commands/installer_command.pyc
|
||||
${PYSITELIB}/poetry/console/commands/installer_command.pyo
|
||||
${PYSITELIB}/poetry/console/commands/lock.py
|
||||
${PYSITELIB}/poetry/console/commands/lock.pyc
|
||||
${PYSITELIB}/poetry/console/commands/lock.pyo
|
||||
${PYSITELIB}/poetry/console/commands/new.py
|
||||
${PYSITELIB}/poetry/console/commands/new.pyc
|
||||
${PYSITELIB}/poetry/console/commands/new.pyo
|
||||
${PYSITELIB}/poetry/console/commands/publish.py
|
||||
${PYSITELIB}/poetry/console/commands/publish.pyc
|
||||
${PYSITELIB}/poetry/console/commands/publish.pyo
|
||||
${PYSITELIB}/poetry/console/commands/remove.py
|
||||
${PYSITELIB}/poetry/console/commands/remove.pyc
|
||||
${PYSITELIB}/poetry/console/commands/remove.pyo
|
||||
${PYSITELIB}/poetry/console/commands/run.py
|
||||
${PYSITELIB}/poetry/console/commands/run.pyc
|
||||
${PYSITELIB}/poetry/console/commands/run.pyo
|
||||
${PYSITELIB}/poetry/console/commands/search.py
|
||||
${PYSITELIB}/poetry/console/commands/search.pyc
|
||||
${PYSITELIB}/poetry/console/commands/search.pyo
|
||||
${PYSITELIB}/poetry/console/commands/self/__init__.py
|
||||
${PYSITELIB}/poetry/console/commands/self/__init__.pyc
|
||||
${PYSITELIB}/poetry/console/commands/self/__init__.pyo
|
||||
${PYSITELIB}/poetry/console/commands/self/self.py
|
||||
${PYSITELIB}/poetry/console/commands/self/self.pyc
|
||||
${PYSITELIB}/poetry/console/commands/self/self.pyo
|
||||
${PYSITELIB}/poetry/console/commands/self/update.py
|
||||
${PYSITELIB}/poetry/console/commands/self/update.pyc
|
||||
${PYSITELIB}/poetry/console/commands/self/update.pyo
|
||||
${PYSITELIB}/poetry/console/commands/shell.py
|
||||
${PYSITELIB}/poetry/console/commands/shell.pyc
|
||||
${PYSITELIB}/poetry/console/commands/shell.pyo
|
||||
${PYSITELIB}/poetry/console/commands/show.py
|
||||
${PYSITELIB}/poetry/console/commands/show.pyc
|
||||
${PYSITELIB}/poetry/console/commands/show.pyo
|
||||
${PYSITELIB}/poetry/console/commands/update.py
|
||||
${PYSITELIB}/poetry/console/commands/update.pyc
|
||||
${PYSITELIB}/poetry/console/commands/update.pyo
|
||||
${PYSITELIB}/poetry/console/commands/version.py
|
||||
${PYSITELIB}/poetry/console/commands/version.pyc
|
||||
${PYSITELIB}/poetry/console/commands/version.pyo
|
||||
${PYSITELIB}/poetry/console/config/__init__.py
|
||||
${PYSITELIB}/poetry/console/config/__init__.pyc
|
||||
${PYSITELIB}/poetry/console/config/__init__.pyo
|
||||
${PYSITELIB}/poetry/console/config/application_config.py
|
||||
${PYSITELIB}/poetry/console/config/application_config.pyc
|
||||
${PYSITELIB}/poetry/console/config/application_config.pyo
|
||||
${PYSITELIB}/poetry/console/logging/__init__.py
|
||||
${PYSITELIB}/poetry/console/logging/__init__.pyc
|
||||
${PYSITELIB}/poetry/console/logging/__init__.pyo
|
||||
${PYSITELIB}/poetry/console/logging/formatters/__init__.py
|
||||
${PYSITELIB}/poetry/console/logging/formatters/__init__.pyc
|
||||
${PYSITELIB}/poetry/console/logging/formatters/__init__.pyo
|
||||
${PYSITELIB}/poetry/console/logging/formatters/builder_formatter.py
|
||||
${PYSITELIB}/poetry/console/logging/formatters/builder_formatter.pyc
|
||||
${PYSITELIB}/poetry/console/logging/formatters/builder_formatter.pyo
|
||||
${PYSITELIB}/poetry/console/logging/formatters/formatter.py
|
||||
${PYSITELIB}/poetry/console/logging/formatters/formatter.pyc
|
||||
${PYSITELIB}/poetry/console/logging/formatters/formatter.pyo
|
||||
${PYSITELIB}/poetry/console/logging/io_formatter.py
|
||||
${PYSITELIB}/poetry/console/logging/io_formatter.pyc
|
||||
${PYSITELIB}/poetry/console/logging/io_formatter.pyo
|
||||
${PYSITELIB}/poetry/console/logging/io_handler.py
|
||||
${PYSITELIB}/poetry/console/logging/io_handler.pyc
|
||||
${PYSITELIB}/poetry/console/logging/io_handler.pyo
|
||||
${PYSITELIB}/poetry/exceptions.py
|
||||
${PYSITELIB}/poetry/exceptions.pyc
|
||||
${PYSITELIB}/poetry/exceptions.pyo
|
||||
${PYSITELIB}/poetry/factory.py
|
||||
${PYSITELIB}/poetry/factory.pyc
|
||||
${PYSITELIB}/poetry/factory.pyo
|
||||
${PYSITELIB}/poetry/inspection/__init__.py
|
||||
${PYSITELIB}/poetry/inspection/__init__.pyc
|
||||
${PYSITELIB}/poetry/inspection/__init__.pyo
|
||||
${PYSITELIB}/poetry/inspection/info.py
|
||||
${PYSITELIB}/poetry/inspection/info.pyc
|
||||
${PYSITELIB}/poetry/inspection/info.pyo
|
||||
${PYSITELIB}/poetry/installation/__init__.py
|
||||
${PYSITELIB}/poetry/installation/__init__.pyc
|
||||
${PYSITELIB}/poetry/installation/__init__.pyo
|
||||
${PYSITELIB}/poetry/installation/authenticator.py
|
||||
${PYSITELIB}/poetry/installation/authenticator.pyc
|
||||
${PYSITELIB}/poetry/installation/authenticator.pyo
|
||||
${PYSITELIB}/poetry/installation/base_installer.py
|
||||
${PYSITELIB}/poetry/installation/base_installer.pyc
|
||||
${PYSITELIB}/poetry/installation/base_installer.pyo
|
||||
${PYSITELIB}/poetry/installation/chef.py
|
||||
${PYSITELIB}/poetry/installation/chef.pyc
|
||||
${PYSITELIB}/poetry/installation/chef.pyo
|
||||
${PYSITELIB}/poetry/installation/chooser.py
|
||||
${PYSITELIB}/poetry/installation/chooser.pyc
|
||||
${PYSITELIB}/poetry/installation/chooser.pyo
|
||||
${PYSITELIB}/poetry/installation/executor.py
|
||||
${PYSITELIB}/poetry/installation/executor.pyc
|
||||
${PYSITELIB}/poetry/installation/executor.pyo
|
||||
${PYSITELIB}/poetry/installation/installer.py
|
||||
${PYSITELIB}/poetry/installation/installer.pyc
|
||||
${PYSITELIB}/poetry/installation/installer.pyo
|
||||
${PYSITELIB}/poetry/installation/noop_installer.py
|
||||
${PYSITELIB}/poetry/installation/noop_installer.pyc
|
||||
${PYSITELIB}/poetry/installation/noop_installer.pyo
|
||||
${PYSITELIB}/poetry/installation/operations/__init__.py
|
||||
${PYSITELIB}/poetry/installation/operations/__init__.pyc
|
||||
${PYSITELIB}/poetry/installation/operations/__init__.pyo
|
||||
${PYSITELIB}/poetry/installation/operations/install.py
|
||||
${PYSITELIB}/poetry/installation/operations/install.pyc
|
||||
${PYSITELIB}/poetry/installation/operations/install.pyo
|
||||
${PYSITELIB}/poetry/installation/operations/operation.py
|
||||
${PYSITELIB}/poetry/installation/operations/operation.pyc
|
||||
${PYSITELIB}/poetry/installation/operations/operation.pyo
|
||||
${PYSITELIB}/poetry/installation/operations/uninstall.py
|
||||
${PYSITELIB}/poetry/installation/operations/uninstall.pyc
|
||||
${PYSITELIB}/poetry/installation/operations/uninstall.pyo
|
||||
${PYSITELIB}/poetry/installation/operations/update.py
|
||||
${PYSITELIB}/poetry/installation/operations/update.pyc
|
||||
${PYSITELIB}/poetry/installation/operations/update.pyo
|
||||
${PYSITELIB}/poetry/installation/pip_installer.py
|
||||
${PYSITELIB}/poetry/installation/pip_installer.pyc
|
||||
${PYSITELIB}/poetry/installation/pip_installer.pyo
|
||||
${PYSITELIB}/poetry/io/__init__.py
|
||||
${PYSITELIB}/poetry/io/__init__.pyc
|
||||
${PYSITELIB}/poetry/io/__init__.pyo
|
||||
${PYSITELIB}/poetry/io/null_io.py
|
||||
${PYSITELIB}/poetry/io/null_io.pyc
|
||||
${PYSITELIB}/poetry/io/null_io.pyo
|
||||
${PYSITELIB}/poetry/json/__init__.py
|
||||
${PYSITELIB}/poetry/json/__init__.pyc
|
||||
${PYSITELIB}/poetry/json/__init__.pyo
|
||||
${PYSITELIB}/poetry/json/schemas/poetry-schema.json
|
||||
${PYSITELIB}/poetry/layouts/__init__.py
|
||||
${PYSITELIB}/poetry/layouts/__init__.pyc
|
||||
${PYSITELIB}/poetry/layouts/__init__.pyo
|
||||
${PYSITELIB}/poetry/layouts/layout.py
|
||||
${PYSITELIB}/poetry/layouts/layout.pyc
|
||||
${PYSITELIB}/poetry/layouts/layout.pyo
|
||||
${PYSITELIB}/poetry/layouts/src.py
|
||||
${PYSITELIB}/poetry/layouts/src.pyc
|
||||
${PYSITELIB}/poetry/layouts/src.pyo
|
||||
${PYSITELIB}/poetry/layouts/standard.py
|
||||
${PYSITELIB}/poetry/layouts/standard.pyc
|
||||
${PYSITELIB}/poetry/layouts/standard.pyo
|
||||
${PYSITELIB}/poetry/locations.py
|
||||
${PYSITELIB}/poetry/locations.pyc
|
||||
${PYSITELIB}/poetry/locations.pyo
|
||||
${PYSITELIB}/poetry/masonry/__init__.py
|
||||
${PYSITELIB}/poetry/masonry/__init__.pyc
|
||||
${PYSITELIB}/poetry/masonry/__init__.pyo
|
||||
${PYSITELIB}/poetry/masonry/api.py
|
||||
${PYSITELIB}/poetry/masonry/api.pyc
|
||||
${PYSITELIB}/poetry/masonry/api.pyo
|
||||
${PYSITELIB}/poetry/masonry/builders/__init__.py
|
||||
${PYSITELIB}/poetry/masonry/builders/__init__.pyc
|
||||
${PYSITELIB}/poetry/masonry/builders/__init__.pyo
|
||||
${PYSITELIB}/poetry/masonry/builders/editable.py
|
||||
${PYSITELIB}/poetry/masonry/builders/editable.pyc
|
||||
${PYSITELIB}/poetry/masonry/builders/editable.pyo
|
||||
${PYSITELIB}/poetry/mixology/__init__.py
|
||||
${PYSITELIB}/poetry/mixology/__init__.pyc
|
||||
${PYSITELIB}/poetry/mixology/__init__.pyo
|
||||
${PYSITELIB}/poetry/mixology/assignment.py
|
||||
${PYSITELIB}/poetry/mixology/assignment.pyc
|
||||
${PYSITELIB}/poetry/mixology/assignment.pyo
|
||||
${PYSITELIB}/poetry/mixology/failure.py
|
||||
${PYSITELIB}/poetry/mixology/failure.pyc
|
||||
${PYSITELIB}/poetry/mixology/failure.pyo
|
||||
${PYSITELIB}/poetry/mixology/incompatibility.py
|
||||
${PYSITELIB}/poetry/mixology/incompatibility.pyc
|
||||
${PYSITELIB}/poetry/mixology/incompatibility.pyo
|
||||
${PYSITELIB}/poetry/mixology/incompatibility_cause.py
|
||||
${PYSITELIB}/poetry/mixology/incompatibility_cause.pyc
|
||||
${PYSITELIB}/poetry/mixology/incompatibility_cause.pyo
|
||||
${PYSITELIB}/poetry/mixology/partial_solution.py
|
||||
${PYSITELIB}/poetry/mixology/partial_solution.pyc
|
||||
${PYSITELIB}/poetry/mixology/partial_solution.pyo
|
||||
${PYSITELIB}/poetry/mixology/result.py
|
||||
${PYSITELIB}/poetry/mixology/result.pyc
|
||||
${PYSITELIB}/poetry/mixology/result.pyo
|
||||
${PYSITELIB}/poetry/mixology/set_relation.py
|
||||
${PYSITELIB}/poetry/mixology/set_relation.pyc
|
||||
${PYSITELIB}/poetry/mixology/set_relation.pyo
|
||||
${PYSITELIB}/poetry/mixology/solutions/__init__.py
|
||||
${PYSITELIB}/poetry/mixology/solutions/__init__.pyc
|
||||
${PYSITELIB}/poetry/mixology/solutions/__init__.pyo
|
||||
${PYSITELIB}/poetry/mixology/solutions/providers/__init__.py
|
||||
${PYSITELIB}/poetry/mixology/solutions/providers/__init__.pyc
|
||||
${PYSITELIB}/poetry/mixology/solutions/providers/__init__.pyo
|
||||
${PYSITELIB}/poetry/mixology/solutions/providers/python_requirement_solution_provider.py
|
||||
${PYSITELIB}/poetry/mixology/solutions/providers/python_requirement_solution_provider.pyc
|
||||
${PYSITELIB}/poetry/mixology/solutions/providers/python_requirement_solution_provider.pyo
|
||||
${PYSITELIB}/poetry/mixology/solutions/solutions/__init__.py
|
||||
${PYSITELIB}/poetry/mixology/solutions/solutions/__init__.pyc
|
||||
${PYSITELIB}/poetry/mixology/solutions/solutions/__init__.pyo
|
||||
${PYSITELIB}/poetry/mixology/solutions/solutions/python_requirement_solution.py
|
||||
${PYSITELIB}/poetry/mixology/solutions/solutions/python_requirement_solution.pyc
|
||||
${PYSITELIB}/poetry/mixology/solutions/solutions/python_requirement_solution.pyo
|
||||
${PYSITELIB}/poetry/mixology/term.py
|
||||
${PYSITELIB}/poetry/mixology/term.pyc
|
||||
${PYSITELIB}/poetry/mixology/term.pyo
|
||||
${PYSITELIB}/poetry/mixology/version_solver.py
|
||||
${PYSITELIB}/poetry/mixology/version_solver.pyc
|
||||
${PYSITELIB}/poetry/mixology/version_solver.pyo
|
||||
${PYSITELIB}/poetry/packages/__init__.py
|
||||
${PYSITELIB}/poetry/packages/__init__.pyc
|
||||
${PYSITELIB}/poetry/packages/__init__.pyo
|
||||
${PYSITELIB}/poetry/packages/dependency_package.py
|
||||
${PYSITELIB}/poetry/packages/dependency_package.pyc
|
||||
${PYSITELIB}/poetry/packages/dependency_package.pyo
|
||||
${PYSITELIB}/poetry/packages/locker.py
|
||||
${PYSITELIB}/poetry/packages/locker.pyc
|
||||
${PYSITELIB}/poetry/packages/locker.pyo
|
||||
${PYSITELIB}/poetry/packages/package_collection.py
|
||||
${PYSITELIB}/poetry/packages/package_collection.pyc
|
||||
${PYSITELIB}/poetry/packages/package_collection.pyo
|
||||
${PYSITELIB}/poetry/poetry.py
|
||||
${PYSITELIB}/poetry/poetry.pyc
|
||||
${PYSITELIB}/poetry/poetry.pyo
|
||||
${PYSITELIB}/poetry/publishing/__init__.py
|
||||
${PYSITELIB}/poetry/publishing/__init__.pyc
|
||||
${PYSITELIB}/poetry/publishing/__init__.pyo
|
||||
${PYSITELIB}/poetry/publishing/publisher.py
|
||||
${PYSITELIB}/poetry/publishing/publisher.pyc
|
||||
${PYSITELIB}/poetry/publishing/publisher.pyo
|
||||
${PYSITELIB}/poetry/publishing/uploader.py
|
||||
${PYSITELIB}/poetry/publishing/uploader.pyc
|
||||
${PYSITELIB}/poetry/publishing/uploader.pyo
|
||||
${PYSITELIB}/poetry/puzzle/__init__.py
|
||||
${PYSITELIB}/poetry/puzzle/__init__.pyc
|
||||
${PYSITELIB}/poetry/puzzle/__init__.pyo
|
||||
${PYSITELIB}/poetry/puzzle/exceptions.py
|
||||
${PYSITELIB}/poetry/puzzle/exceptions.pyc
|
||||
${PYSITELIB}/poetry/puzzle/exceptions.pyo
|
||||
${PYSITELIB}/poetry/puzzle/provider.py
|
||||
${PYSITELIB}/poetry/puzzle/provider.pyc
|
||||
${PYSITELIB}/poetry/puzzle/provider.pyo
|
||||
${PYSITELIB}/poetry/puzzle/solver.py
|
||||
${PYSITELIB}/poetry/puzzle/solver.pyc
|
||||
${PYSITELIB}/poetry/puzzle/solver.pyo
|
||||
${PYSITELIB}/poetry/repositories/__init__.py
|
||||
${PYSITELIB}/poetry/repositories/__init__.pyc
|
||||
${PYSITELIB}/poetry/repositories/__init__.pyo
|
||||
${PYSITELIB}/poetry/repositories/base_repository.py
|
||||
${PYSITELIB}/poetry/repositories/base_repository.pyc
|
||||
${PYSITELIB}/poetry/repositories/base_repository.pyo
|
||||
${PYSITELIB}/poetry/repositories/exceptions.py
|
||||
${PYSITELIB}/poetry/repositories/exceptions.pyc
|
||||
${PYSITELIB}/poetry/repositories/exceptions.pyo
|
||||
${PYSITELIB}/poetry/repositories/installed_repository.py
|
||||
${PYSITELIB}/poetry/repositories/installed_repository.pyc
|
||||
${PYSITELIB}/poetry/repositories/installed_repository.pyo
|
||||
${PYSITELIB}/poetry/repositories/legacy_repository.py
|
||||
${PYSITELIB}/poetry/repositories/legacy_repository.pyc
|
||||
${PYSITELIB}/poetry/repositories/legacy_repository.pyo
|
||||
${PYSITELIB}/poetry/repositories/pool.py
|
||||
${PYSITELIB}/poetry/repositories/pool.pyc
|
||||
${PYSITELIB}/poetry/repositories/pool.pyo
|
||||
${PYSITELIB}/poetry/repositories/pypi_repository.py
|
||||
${PYSITELIB}/poetry/repositories/pypi_repository.pyc
|
||||
${PYSITELIB}/poetry/repositories/pypi_repository.pyo
|
||||
${PYSITELIB}/poetry/repositories/remote_repository.py
|
||||
${PYSITELIB}/poetry/repositories/remote_repository.pyc
|
||||
${PYSITELIB}/poetry/repositories/remote_repository.pyo
|
||||
${PYSITELIB}/poetry/repositories/repository.py
|
||||
${PYSITELIB}/poetry/repositories/repository.pyc
|
||||
${PYSITELIB}/poetry/repositories/repository.pyo
|
||||
${PYSITELIB}/poetry/utils/__init__.py
|
||||
${PYSITELIB}/poetry/utils/__init__.pyc
|
||||
${PYSITELIB}/poetry/utils/__init__.pyo
|
||||
${PYSITELIB}/poetry/utils/_compat.py
|
||||
${PYSITELIB}/poetry/utils/_compat.pyc
|
||||
${PYSITELIB}/poetry/utils/_compat.pyo
|
||||
${PYSITELIB}/poetry/utils/appdirs.py
|
||||
${PYSITELIB}/poetry/utils/appdirs.pyc
|
||||
${PYSITELIB}/poetry/utils/appdirs.pyo
|
||||
${PYSITELIB}/poetry/utils/env.py
|
||||
${PYSITELIB}/poetry/utils/env.pyc
|
||||
${PYSITELIB}/poetry/utils/env.pyo
|
||||
${PYSITELIB}/poetry/utils/exporter.py
|
||||
${PYSITELIB}/poetry/utils/exporter.pyc
|
||||
${PYSITELIB}/poetry/utils/exporter.pyo
|
||||
${PYSITELIB}/poetry/utils/extras.py
|
||||
${PYSITELIB}/poetry/utils/extras.pyc
|
||||
${PYSITELIB}/poetry/utils/extras.pyo
|
||||
${PYSITELIB}/poetry/utils/helpers.py
|
||||
${PYSITELIB}/poetry/utils/helpers.pyc
|
||||
${PYSITELIB}/poetry/utils/helpers.pyo
|
||||
${PYSITELIB}/poetry/utils/password_manager.py
|
||||
${PYSITELIB}/poetry/utils/password_manager.pyc
|
||||
${PYSITELIB}/poetry/utils/password_manager.pyo
|
||||
${PYSITELIB}/poetry/utils/patterns.py
|
||||
${PYSITELIB}/poetry/utils/patterns.pyc
|
||||
${PYSITELIB}/poetry/utils/patterns.pyo
|
||||
${PYSITELIB}/poetry/utils/setup_reader.py
|
||||
${PYSITELIB}/poetry/utils/setup_reader.pyc
|
||||
${PYSITELIB}/poetry/utils/setup_reader.pyo
|
||||
${PYSITELIB}/poetry/utils/shell.py
|
||||
${PYSITELIB}/poetry/utils/shell.pyc
|
||||
${PYSITELIB}/poetry/utils/shell.pyo
|
||||
${PYSITELIB}/poetry/version/__init__.py
|
||||
${PYSITELIB}/poetry/version/__init__.pyc
|
||||
${PYSITELIB}/poetry/version/__init__.pyo
|
||||
${PYSITELIB}/poetry/version/version_selector.py
|
||||
${PYSITELIB}/poetry/version/version_selector.pyc
|
||||
${PYSITELIB}/poetry/version/version_selector.pyo
|
6
devel/py-poetry/distinfo
Normal file
6
devel/py-poetry/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2022/01/11 19:21:49 adam Exp $
|
||||
|
||||
BLAKE2s (poetry-1.1.12.tar.gz) = 68c213c68ea4e2b8bd7a30f39ce4b7f432511883bb36b7533d66800533e022d0
|
||||
SHA512 (poetry-1.1.12.tar.gz) = e65c69e0259ad6d631ec0b578a71c5224a8c2787e07f472341189d9a02224a25da44bfb3ecba2bb100b94aec4513056f4ef5c76f16773f26ed49674155ceca43
|
||||
Size (poetry-1.1.12.tar.gz) = 135789 bytes
|
||||
SHA1 (patch-setup.py) = 87294e65a2c8082246af945ac651c7e7e405e64c
|
15
devel/py-poetry/patches/patch-setup.py
Normal file
15
devel/py-poetry/patches/patch-setup.py
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-setup.py,v 1.1 2022/01/11 19:21:49 adam Exp $
|
||||
|
||||
Allow newer py-packaging.
|
||||
|
||||
--- setup.py.orig 2022-01-11 10:51:17.000000000 +0000
|
||||
+++ setup.py
|
||||
@@ -41,7 +41,7 @@ install_requires = \
|
||||
'cleo>=0.8.1,<0.9.0',
|
||||
'clikit>=0.6.2,<0.7.0',
|
||||
'html5lib>=1.0,<2.0',
|
||||
- 'packaging>=20.4,<21.0',
|
||||
+ 'packaging>=20.4',
|
||||
'pexpect>=4.7.0,<5.0.0',
|
||||
'pkginfo>=1.4,<2.0',
|
||||
'poetry-core>=1.0.7,<1.1.0',
|
Loading…
Reference in a new issue