Fixed invalid lvalue.

This commit is contained in:
rillig 2007-11-30 20:43:08 +00:00
parent 84ab38246e
commit 1ab529e81c
2 changed files with 15 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.9 2005/02/24 14:08:27 wiz Exp $
$NetBSD: distinfo,v 1.10 2007/11/30 20:43:08 rillig Exp $
SHA1 (mod_dtcl-0.11.6.tar.gz) = 8a48b2292bb1048b17fd268011d1a4307ef5770e
RMD160 (mod_dtcl-0.11.6.tar.gz) = 9fe42c888d476029852dad2742accb7b7d654e67
Size (mod_dtcl-0.11.6.tar.gz) = 90374 bytes
SHA1 (patch-aa) = 512e310549e475fbd6106eef52d2f789f4a0390b
SHA1 (patch-ab) = 6eed9b2e971501ddcd1500cab5e16fa6a7037658

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2007/11/30 20:43:09 rillig Exp $
--- tcl_commands.c.orig 2002-03-13 15:56:06.000000000 +0000
+++ tcl_commands.c 2007-11-30 20:41:17.000000000 +0000
@@ -388,7 +388,7 @@ int HGetVars(ClientData clientData, Tcl_
env = (table_entry *) env_arr->elts;
/* Get the user/pass info for Basic authentication */
- (const char*)authorization = ap_table_get(globals->r->headers_in, "Authorization");
+ authorization = (const char *)ap_table_get(globals->r->headers_in, "Authorization");
if (authorization && !strcasecmp(ap_getword_nc(POOL, &authorization, ' '), "Basic"))
{
char *tmp;