Delete lynx-current because the lynx package has now caught up to it.
Make a note in CHANGES.
This commit is contained in:
parent
04f60d7fa2
commit
1aefcbdb5a
9 changed files with 3 additions and 290 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: CHANGES,v 1.5077 2004/03/03 21:09:52 manu Exp $
|
||||
$NetBSD: CHANGES,v 1.5078 2004/03/03 21:19:34 ben Exp $
|
||||
|
||||
Changes to the packages collection and infrastructure in 2004:
|
||||
|
||||
|
@ -1142,3 +1142,4 @@ Changes to the packages collection and infrastructure in 2004:
|
|||
Updated py-ZODB 3.2.1 [recht 2004-03-03]
|
||||
Updated silc-server to 0.9.18 [salo 2004-03-03]
|
||||
Updated milter-regex to 1.2 [manu 2004-03-03]
|
||||
Deleted lynx-current [ben 2004-03-03]
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.306 2004/02/29 17:49:30 xtraeme Exp $
|
||||
# $NetBSD: Makefile,v 1.307 2004/03/03 21:19:34 ben Exp $
|
||||
#
|
||||
|
||||
COMMENT= Packages related to the World Wide Web
|
||||
|
@ -115,7 +115,6 @@ SUBDIR+= libwww
|
|||
SUBDIR+= links
|
||||
SUBDIR+= links-gui
|
||||
SUBDIR+= lynx
|
||||
SUBDIR+= lynx-current
|
||||
SUBDIR+= mMosaic
|
||||
SUBDIR+= make_album
|
||||
SUBDIR+= micro_httpd
|
||||
|
|
|
@ -1,3 +0,0 @@
|
|||
lynx is a program which allows a user to access World-Wide Web servers
|
||||
and other information servers. It uses only ascii representation so
|
||||
that it can be used from ascii-terminals and dialin-lines.
|
|
@ -1,119 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.53 2004/02/26 14:02:40 fredb Exp $
|
||||
#
|
||||
|
||||
DISTNAME= lynx2.8.5dev.7
|
||||
PKGNAME= lynx-2.8.5.0.7
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://lynx.isc.org/current/ \
|
||||
ftp://ftp.nl.uu.net/pub/unix/www/lynx/current/ \
|
||||
ftp://ftp.cyf-kr.edu.pl/pub/unix/lynx/current/ \
|
||||
ftp://ftp.netlab.is.tsukuba.ac.jp/pub/network/WWW/lynx/current/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= fredb@NetBSD.org
|
||||
HOMEPAGE= http://lynx.isc.org/
|
||||
COMMENT= Alphanumeric display oriented World-Wide Web Client
|
||||
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
|
||||
BUILD_USES_MSGFMT= yes
|
||||
|
||||
WRKSRC= ${WRKDIR}/lynx2-8-5
|
||||
USE_BUILDLINK3= yes
|
||||
USE_PKGLOCALEDIR= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNU_TOOLS+= make
|
||||
INSTALL_TARGET= install-full install-lss
|
||||
MAKEFILE= makefile
|
||||
|
||||
BUILD_DEFS+= LYNX_SCREEN_LIB USE_SOCKS USE_INET6
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
# For nls/gettext
|
||||
CONFIGURE_ARGS+= --enable-nls
|
||||
CONFIGURE_ARGS+= --with-nls-datadir=${PREFIX}/share
|
||||
CONFIGURE_ARGS+= --without-included-gettext
|
||||
|
||||
# With SSL, lynx can get https:// and snews:// URL's.
|
||||
CONFIGURE_ARGS+= --with-ssl
|
||||
|
||||
# Note: --enable-{default-colors,scrollbar} are simply ignored
|
||||
# for certain settings of --with-screen.
|
||||
CONFIGURE_ARGS+= --with-screen=${LYNX_SCREEN_LIB}
|
||||
CONFIGURE_ARGS+= --enable-default-colors
|
||||
CONFIGURE_ARGS+= --enable-scrollbar
|
||||
|
||||
# Install gzip'ed help files to ${PREFIX}/share/lynx
|
||||
CONFIGURE_ARGS+= --libdir="${PREFIX}/share/lynx"
|
||||
CONFIGURE_ARGS+= --enable-gzip-help --with-zlib
|
||||
|
||||
# Miscellaneous
|
||||
CONFIGURE_ARGS+= --enable-externs
|
||||
CONFIGURE_ARGS+= --enable-source-cache
|
||||
|
||||
# Experimental features
|
||||
CONFIGURE_ARGS+= --enable-file-upload
|
||||
CONFIGURE_ARGS+= --enable-justify-elts
|
||||
CONFIGURE_ARGS+= --enable-kbd-layout
|
||||
CONFIGURE_ARGS+= --enable-nested-tables
|
||||
CONFIGURE_ARGS+= --enable-prettysrc
|
||||
CONFIGURE_ARGS+= --enable-read-eta
|
||||
|
||||
.if ${LYNX_SCREEN_LIB} == "slang"
|
||||
. include "../../devel/libslang/buildlink3.mk"
|
||||
.elif ${LYNX_SCREEN_LIB} == "ncurses"
|
||||
USE_NCURSES= color
|
||||
. include "../../devel/ncurses/buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --enable-color-style
|
||||
.elif ${LYNX_SCREEN_LIB} == curses
|
||||
. include "../../mk/curses.buildlink3.mk"
|
||||
. if !empty(MACHINE_PLATFORM:MNetBSD-1.5*-i386)
|
||||
CONFIGURE_ARGS+= --enable-color-style
|
||||
. endif
|
||||
.else
|
||||
pre-configure:
|
||||
@${ECHO} '****************************************************'
|
||||
@${ECHO} '* Invalid value for LYNX_SCREEN_LIB. Please choose *'
|
||||
@${ECHO} '* one of "slang", "ncurses", or "curses"! *'
|
||||
@${ECHO} '****************************************************'
|
||||
@${FALSE}
|
||||
|
||||
.endif
|
||||
|
||||
# Include SOCKS firewall support, if desired.
|
||||
.if defined(USE_SOCKS) && (${USE_SOCKS} == 4 || ${USE_SOCKS} == 5)
|
||||
.if (${LYNX_SCREEN_LIB} == slang)
|
||||
pre-configure:
|
||||
@${ECHO} '******************************************************'
|
||||
@${ECHO} '* Socks may not be enabled together with the "slang" *'
|
||||
@${ECHO} '* screen library. If socks support is desired, *'
|
||||
@${ECHO} '* please also set LYNX_SCREEN_LIB to one of "curses" *'
|
||||
@${ECHO} '* or "ncurses"! *'
|
||||
@${ECHO} '******************************************************'
|
||||
@${FALSE}
|
||||
|
||||
.endif
|
||||
.if ${USE_SOCKS} == 4
|
||||
CONFIGURE_ARGS+= --with-socks
|
||||
. include "../../net/socks4/buildlink3.mk"
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-socks5
|
||||
. include "../../net/socks5/buildlink3.mk"
|
||||
.endif
|
||||
.endif
|
||||
|
||||
# Do IPV6 on systems which can support it.
|
||||
.if defined(USE_INET6) && ${USE_INET6} == YES
|
||||
CONFIGURE_ARGS+= --enable-ipv6
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/lynx
|
||||
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,81 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2003/04/27 14:57:57 cjep Exp $
|
||||
bin/lynx
|
||||
man/man1/lynx.1
|
||||
${PKGLOCALEDIR}/locale/cs/LC_MESSAGES/lynx.mo
|
||||
${PKGLOCALEDIR}/locale/da/LC_MESSAGES/lynx.mo
|
||||
${PKGLOCALEDIR}/locale/de/LC_MESSAGES/lynx.mo
|
||||
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/lynx.mo
|
||||
${PKGLOCALEDIR}/locale/ja/LC_MESSAGES/lynx.mo
|
||||
${PKGLOCALEDIR}/locale/nl/LC_MESSAGES/lynx.mo
|
||||
${PKGLOCALEDIR}/locale/pt_BR/LC_MESSAGES/lynx.mo
|
||||
${PKGLOCALEDIR}/locale/ru/LC_MESSAGES/lynx.mo
|
||||
${PKGLOCALEDIR}/locale/sl/LC_MESSAGES/lynx.mo
|
||||
${PKGLOCALEDIR}/locale/sv/LC_MESSAGES/lynx.mo
|
||||
share/lynx/lynx.cfg
|
||||
share/lynx/lynx.lss
|
||||
share/lynx/lynx_doc/CHANGES
|
||||
share/lynx/lynx_doc/COPYHEADER
|
||||
share/lynx/lynx_doc/COPYING
|
||||
share/lynx/lynx_doc/PROBLEMS
|
||||
share/lynx/lynx_doc/README
|
||||
share/lynx/lynx_doc/samples/blue-background.lss
|
||||
share/lynx/lynx_doc/samples/bright-blue.lss
|
||||
share/lynx/lynx_doc/samples/cernrules.txt
|
||||
share/lynx/lynx_doc/samples/installdirs.html
|
||||
share/lynx/lynx_doc/samples/jumpsUnix.html
|
||||
share/lynx/lynx_doc/samples/jumpsVMS.html
|
||||
share/lynx/lynx_doc/samples/keepviewer
|
||||
share/lynx/lynx_doc/samples/lynx-keymaps
|
||||
share/lynx/lynx_doc/samples/lynx.com
|
||||
share/lynx/lynx_doc/samples/lynx.lss
|
||||
share/lynx/lynx_doc/samples/lynxdump
|
||||
share/lynx/lynx_doc/samples/mailcap
|
||||
share/lynx/lynx_doc/samples/mime.types
|
||||
share/lynx/lynx_doc/samples/mild-colors.lss
|
||||
share/lynx/lynx_doc/samples/mailto-form.pl
|
||||
share/lynx/lynx_doc/test/ALT88592.html
|
||||
share/lynx/lynx_doc/test/ISO_LATIN1_test.html
|
||||
share/lynx/lynx_doc/test/README.txt
|
||||
share/lynx/lynx_doc/test/TestComment.html
|
||||
share/lynx/lynx_doc/test/c1.html
|
||||
share/lynx/lynx_doc/test/iso8859-1.html
|
||||
share/lynx/lynx_doc/test/iso88592.html
|
||||
share/lynx/lynx_doc/test/quickbrown.html
|
||||
share/lynx/lynx_doc/test/raw8bit.html
|
||||
share/lynx/lynx_doc/test/sgml.html
|
||||
share/lynx/lynx_doc/test/spaces.html
|
||||
share/lynx/lynx_doc/test/tabtest.html
|
||||
share/lynx/lynx_doc/test/unicode.html
|
||||
share/lynx/lynx_doc/test/utf-8-demo.html
|
||||
share/lynx/lynx_help/COPYING
|
||||
share/lynx/lynx_help/COPYHEADER
|
||||
share/lynx/lynx_help/Lynx_users_guide.html.gz
|
||||
share/lynx/lynx_help/about_lynx.html.gz
|
||||
share/lynx/lynx_help/lynx-dev.html.gz
|
||||
share/lynx/lynx_help/lynx_help_main.html.gz
|
||||
share/lynx/lynx_help/lynx_url_support.html.gz
|
||||
share/lynx/lynx_help/keystrokes/alt_edit_help.html.gz
|
||||
share/lynx/lynx_help/keystrokes/bashlike_edit_help.html.gz
|
||||
share/lynx/lynx_help/keystrokes/bookmark_help.html.gz
|
||||
share/lynx/lynx_help/keystrokes/cookie_help.html.gz
|
||||
share/lynx/lynx_help/keystrokes/dired_help.html.gz
|
||||
share/lynx/lynx_help/keystrokes/edit_help.html.gz
|
||||
share/lynx/lynx_help/keystrokes/environments.html.gz
|
||||
share/lynx/lynx_help/keystrokes/follow_help.html.gz
|
||||
share/lynx/lynx_help/keystrokes/gopher_types_help.html.gz
|
||||
share/lynx/lynx_help/keystrokes/history_help.html.gz
|
||||
share/lynx/lynx_help/keystrokes/keystroke_help.html.gz
|
||||
share/lynx/lynx_help/keystrokes/movement_help.html.gz
|
||||
share/lynx/lynx_help/keystrokes/option_help.html.gz
|
||||
share/lynx/lynx_help/keystrokes/other_help.html.gz
|
||||
share/lynx/lynx_help/keystrokes/print_help.html.gz
|
||||
share/lynx/lynx_help/keystrokes/scrolling_help.html.gz
|
||||
share/lynx/lynx_help/keystrokes/test_display.html.gz
|
||||
share/lynx/lynx_help/keystrokes/visited_help.html.gz
|
||||
share/lynx/lynx_help/keystrokes/xterm_help.html.gz
|
||||
@dirrm share/lynx/lynx_help/keystrokes
|
||||
@dirrm share/lynx/lynx_help
|
||||
@dirrm share/lynx/lynx_doc/samples
|
||||
@dirrm share/lynx/lynx_doc/test
|
||||
@dirrm share/lynx/lynx_doc
|
||||
@dirrm share/lynx/
|
|
@ -1,7 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.6 2002/08/25 21:52:16 jlam Exp $
|
||||
|
||||
SHA1 (lynx2.8.5dev.7.tar.bz2) = 8e9eb4bf11944c24517e99ec0ef76b203022c5fe
|
||||
Size (lynx2.8.5dev.7.tar.bz2) = 1966524 bytes
|
||||
SHA1 (patch-aa) = 8935e11ef53dc6a686b2fc19359aa2db7fffc226
|
||||
SHA1 (patch-ab) = 5f683f4cf53582db6b2cbc8e37f840a6e51e3345
|
||||
SHA1 (patch-ae) = 116b1a797f52b214c125dd362ed1161bab78313f
|
|
@ -1,41 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.6 2002/05/04 17:06:49 fredb Exp $
|
||||
|
||||
--- configure.orig Tue Jan 1 19:30:08 2002
|
||||
+++ configure
|
||||
@@ -4474,7 +4474,7 @@
|
||||
fi
|
||||
;;
|
||||
esac
|
||||
-LIBS="$LIBS -lsocks"
|
||||
+LIBS="$LIBS -lsocks4"
|
||||
cat >> confdefs.h <<\EOF
|
||||
#define SOCKS 1
|
||||
EOF
|
||||
@@ -5590,12 +5590,25 @@
|
||||
echo "$ac_t""$cf_cv_screen" 1>&6
|
||||
|
||||
case $cf_cv_screen in
|
||||
-ncurses|ncursesw|slang)
|
||||
+ncurses|ncursesw)
|
||||
+ case $host_os in
|
||||
+ netbsd)
|
||||
+ cf_cv_ncurses_h=ncurses.h
|
||||
+ ;;
|
||||
+ esac
|
||||
+ ;;
|
||||
+slang)
|
||||
;;
|
||||
pdcurses)
|
||||
cf_cv_ncurses_header=xcurses.h
|
||||
;;
|
||||
-#curses)
|
||||
+curses)
|
||||
+ case $host_os in
|
||||
+ netbsd)
|
||||
+ ac_cv_header_term_h=no
|
||||
+ cf_cv_ncurses_version=no
|
||||
+ ;;
|
||||
+ esac
|
||||
# if eval "test \"`echo '$''{'cf_cv_ncurses_header'+set}'`\" != set"; then
|
||||
# cf_cv_ncurses_header=curses.h
|
||||
# fi
|
|
@ -1,23 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.4 2002/08/25 21:52:17 jlam Exp $
|
||||
|
||||
--- src/LYCurses.c.orig Wed Aug 21 21:16:48 2002
|
||||
+++ src/LYCurses.c
|
||||
@@ -564,9 +564,7 @@ PUBLIC void curses_style ARGS2(
|
||||
}
|
||||
#endif /* USE_COLOR_STYLE */
|
||||
|
||||
-#ifndef USE_SLANG
|
||||
PRIVATE BOOL lynx_called_initscr = FALSE;
|
||||
-#endif
|
||||
|
||||
#if defined(HAVE_USE_DEFAULT_COLORS) && defined(USE_DEFAULT_COLORS)
|
||||
/*
|
||||
@@ -1274,7 +1272,7 @@ PUBLIC void stop_curses NOARGS
|
||||
lynx_nl2crlf(TRUE);
|
||||
lynx_enable_mouse (0);
|
||||
#if (!defined(WIN_EX) || defined(__CYGWIN__)) /* @@@ */
|
||||
- if(LYscreen) {
|
||||
+ if(LYscreen || lynx_called_initscr) {
|
||||
endwin(); /* stop curses */
|
||||
LYDELSCR();
|
||||
}
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.4 2002/05/04 17:06:49 fredb Exp $
|
||||
|
||||
--- WWW/Library/Implementation/HTParse.c.orig Sun Apr 1 19:51:46 2001
|
||||
+++ WWW/Library/Implementation/HTParse.c
|
||||
@@ -291,7 +291,7 @@
|
||||
char *p2, *h;
|
||||
if ((p2 = strchr(result, '@')) != NULL)
|
||||
tail = (p2 + 1);
|
||||
- p2 = strchr(tail, ':');
|
||||
+ p2 = strrchr(tail, ':');
|
||||
if (p2 != NULL && !isdigit(UCH(p2[1])))
|
||||
/*
|
||||
** Colon not followed by a port number.
|
Loading…
Reference in a new issue