Rearrange inline patches to hopefully work on both gcc and clang.

This commit is contained in:
dholland 2012-05-05 22:14:42 +00:00
parent ba89f184a2
commit 1b20cf05ba
3 changed files with 32 additions and 15 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.3 2012/05/04 16:03:13 joerg Exp $
$NetBSD: distinfo,v 1.4 2012/05/05 22:14:42 dholland Exp $
SHA1 (adms-2.2.5.tar.gz) = 03093643feee7ef759cf2f65b497155e2e0df791
RMD160 (adms-2.2.5.tar.gz) = 274f2330696e9e0825b77a3a3ca0a307e9f00bed
@ -6,4 +6,4 @@ Size (adms-2.2.5.tar.gz) = 706220 bytes
SHA1 (patch-aa) = d1aae5799925a164841b7905ef991d261a33867a
SHA1 (patch-ab) = fc6914555c5ccaa33c1b787f705ce6a205d83235
SHA1 (patch-admsVeriloga_verilogaLex.l) = d064e39c6e265d8e9af1b623cc88a1c005cdd67b
SHA1 (patch-admsXml_admsXml.c) = 2bebb05f316177326f064088381623850694c8f0
SHA1 (patch-admsXml_xmlXpath.c) = fb7ac04ba6790a1b6a1af1a2193d944d8de5fea6

View file

@ -1,13 +0,0 @@
$NetBSD: patch-admsXml_admsXml.c,v 1.1 2012/05/04 16:03:13 joerg Exp $
--- admsXml/admsXml.c.orig 2012-04-28 21:39:15.000000000 +0000
+++ admsXml/admsXml.c
@@ -254,6 +254,8 @@
#include <admsObject/admsC.h>
#include <time.h>
+#define inline static inline
+
static int adms_donouse_xml_implicit_file=0;
static p_admsttransform adms_admstpath_admsttransform(p_admsttransform myadmsttransform,const char*myname)

View file

@ -0,0 +1,30 @@
$NetBSD: patch-admsXml_xmlXpath.c,v 1.1 2012/05/05 22:14:42 dholland Exp $
Patch up gcc inline semantics.
--- admsXml/xmlXpath.c~ 2007-04-19 12:44:04.000000000 +0000
+++ admsXml/xmlXpath.c
@@ -1860,10 +1860,10 @@ _t_goto_parse(parse_unary)
/*admstpathevaluate*/
-#define _t_goto_evaluate_local(function) inline p_admstpathevaluate (function)(p_admstpathevaluate myadmstpathevaluate,p_admst mycuradmst)
-#define _t_goto_evaluate(function) inline void (function)(p_admstpathevaluate myadmstpathevaluate,p_admst mycuradmst)
-#define _t_goto_evaluate_location(function) inline void (function)(p_admstpathevaluate myadmstpathevaluate,p_admst mycuradmst,p_slist *mynewlocationptr)
-#define _t_goto_evaluate_binary(function) inline void (function) (p_admstpathevaluate myadmstpathevaluate,p_slist mylocation,p_admst mycuradmst)
+#define _t_goto_evaluate_local(function) static inline p_admstpathevaluate (function)(p_admstpathevaluate myadmstpathevaluate,p_admst mycuradmst)
+#define _t_goto_evaluate(function) static inline void (function)(p_admstpathevaluate myadmstpathevaluate,p_admst mycuradmst)
+#define _t_goto_evaluate_location(function) static inline void (function)(p_admstpathevaluate myadmstpathevaluate,p_admst mycuradmst,p_slist *mynewlocationptr)
+#define _t_goto_evaluate_binary(function) static inline void (function) (p_admstpathevaluate myadmstpathevaluate,p_slist mylocation,p_admst mycuradmst)
_t_goto_evaluate(admstpathevaluate_admstroot);
_t_goto_evaluate_local(admstpathevaluate_local_admstroot);
_t_goto_evaluate(admstpathevaluate_admstpath);
@@ -2190,7 +2190,7 @@ _t_goto_evaluate_local(admstpathevaluate
return mynewadmstpathevaluate;
}
-inline void code1 (char**mytext,p_admstpathevaluate myadmstpathevaluate,p_admst mypreviousadmst)
+static inline void code1 (char**mytext,p_admstpathevaluate myadmstpathevaluate,p_admst mypreviousadmst)
{
p_slist mynewlocation=NULL;
admstpathevaluate_location(myadmstpathevaluate,mypreviousadmst,&mynewlocation);