A Django app for managing hierarchical pages of content in multiple languages,

on different sites. Django CMS handles the navigation rendering for you in
multiple languages with internationalization (i18n) slugs, and the navigation
can be extended by your own models. Pages are rendered with a template that
has placeholders which get filled via plugins.
This commit is contained in:
adam 2011-01-12 08:15:06 +00:00
parent 2007a8d867
commit 1b21b2c2b3
5 changed files with 1050 additions and 0 deletions

5
www/py-django-cms/DESCR Normal file
View file

@ -0,0 +1,5 @@
A Django app for managing hierarchical pages of content in multiple languages,
on different sites. Django CMS handles the navigation rendering for you in
multiple languages with internationalization (i18n) slugs, and the navigation
can be extended by your own models. Pages are rendered with a template that
has placeholders which get filled via plugins.

View file

@ -0,0 +1,24 @@
# $NetBSD: Makefile,v 1.1.1.1 2011/01/12 08:15:06 adam Exp $
DISTNAME= django-cms-2.0.2
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= www python
MASTER_SITES= http://pypi.python.org/packages/source/d/django-cms/
MAINTAINER= adam@NetBSD.org
HOMEPAGE= http://www.django-cms.org/
COMMENT= Django content management system
LICENSE= modified-bsd
PKG_DESTDIR_SUPPORT= user-destdir
EGG_NAME= ${DISTNAME:S/-/_/}
USE_LANGUAGES= # empty
DEPENDS+= ${PYPKGPREFIX}-django-[0-9]*:../../www/py-django
DEPENDS+= ${PYPKGPREFIX}-imaging-[0-9]*:../../graphics/py-imaging
DEPENDS+= ${PYPKGPREFIX}-django-south-[0-9]*:../../www/py-django-south
DEPENDS+= ${PYPKGPREFIX}-django-classy-tags-[0-9]*:../../www/py-django-classy-tags
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

1002
www/py-django-cms/PLIST Normal file

File diff suppressed because it is too large Load diff

View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2011/01/12 08:15:06 adam Exp $
SHA1 (django-cms-2.0.2.tar.gz) = 3ce4c7c502c4e106542aa5e5a9927a10fed8993c
RMD160 (django-cms-2.0.2.tar.gz) = 07cc5952c94d586b41febc66261e17cad6e563d1
Size (django-cms-2.0.2.tar.gz) = 1405106 bytes
SHA1 (patch-aa) = 2c3bef8655b65fa0a72c76942fc04afe7adb964d

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2011/01/12 08:15:06 adam Exp $
--- setup.py.orig 2010-12-28 19:26:14.000000000 +0000
+++ setup.py
@@ -4,7 +4,7 @@ import cms
media_files = []
for dirpath, dirnames, filenames in os.walk('cms/media'):
- media_files.append([dirpath, [os.path.join(dirpath, f) for f in filenames]])
+ media_files.append(['share/django-'+dirpath, [os.path.join(dirpath, f) for f in filenames]])
setup(
author="Patrick Lauber",