enhanced xpaint

This commit is contained in:
hubertf 1998-04-21 00:46:57 +00:00
parent 3d3346cdc4
commit 1b34bb3c11
8 changed files with 157 additions and 0 deletions

24
graphics/xart/Makefile Normal file
View file

@ -0,0 +1,24 @@
# $NetBSD: Makefile,v 1.1 1998/04/21 00:46:57 hubertf Exp $
#
DISTNAME= xart19980415
PKGNAME= xart-19980415
CATEGORIES= graphics x11
MASTER_SITES= http://www.cqi.com/~humbubba/linux/
EXTRACT_SUFX= .tgz
MAINTAINER= packages@netbsd.org
LIB_DEPENDS= jpeg.7.:${PORTSDIR}/graphics/jpeg \
tiff.3.:${PORTSDIR}/graphics/tiff \
Xpm.4.:${PORTSDIR}/graphics/xpm \
png.0.:${PORTSDIR}/graphics/png
WRKSRC= ${WRKDIR}/19980415
USE_IMAKE= yes
post-extract:
find ${WRKSRC} -type d -print | xargs chmod 755
find ${WRKSRC} -type f -print | xargs chmod 644
.include "../../mk/bsd.pkg.mk"

1
graphics/xart/files/md5 Normal file
View file

@ -0,0 +1 @@
MD5 (xart19980415.tgz) = df972c30448c173ff232037a472bb2d7

View file

@ -0,0 +1,28 @@
--- Imakefile.orig Sat Apr 4 07:43:01 1998
+++ Imakefile Tue Apr 21 02:13:19 1998
@@ -91,7 +91,7 @@
InstallAppDefaults(XArt)
NamedMakeSubdirs(always, $(SUBDIRS))
-MakefileSubdirs($(SUBDIRS) bitmaps Doc)
+MakefileSubdirs($(SUBDIRS) bitmaps)
CleanSubdirs($(SUBDIRS))
# Other targets...
@@ -103,12 +103,13 @@
xart.ad: xart.ad.in version
sed -e 's/XPAINT_VERSION/$(VERSION)/' < xart.ad.in > $@
+ ln $@ XArt.ad
xart.ad.h: xart.ad
- ./ad2c.script $? > $@
+ sh ./ad2c.script $? > $@
DefaultRC.txt.h: DefaultRC
- ./ad2c.script $? > $@
+ sh ./ad2c.script $? > $@
Help.txt.h: Help.txt
- sed -e 's/ *$$//' -e 's/^$$/ /' < $? | ./ad2c.script > $@
+ sed -e 's/ *$$//' -e 's/^$$/ /' < $? | sh ./ad2c.script > $@
xart.man: xart.man.in version
sed -e 's/XPAINT_VERSION/$(VERSION)/' < xart.man.in > $@

View file

@ -0,0 +1,16 @@
--- dynPenOp.c.orig Tue Apr 21 00:57:13 1998
+++ dynPenOp.c Tue Apr 21 01:08:15 1998
@@ -24,11 +24,12 @@
#include <X11/Intrinsic.h>
#include <X11/StringDefs.h>
#include <X11/cursorfont.h>
+#include <time.h>
#include "xpaint.h"
#include "misc.h"
#include "Paint.h"
-#define XTIMEOUT ((unsigned long)(1.5*1000/HZ)) /* ms, should be larger than 1000/HZ */
+#define XTIMEOUT ((unsigned long)(1.5*1000/CLK_TCK)) /* ms, should be larger than 1000/HZ */
typedef struct {
float startx, starty;

View file

@ -0,0 +1,79 @@
--- Local.config.orig Tue Apr 21 01:10:02 1998
+++ Local.config Tue Apr 21 01:28:13 1998
@@ -62,8 +62,8 @@
#define HaveTIFF
#ifdef HaveTIFF
-TIFF_LIB = -L/usr/local/lib -ltiff
-TIFF_INCLUDE = -I/usr/local/include/tiff
+TIFF_LIB = -L${LOCALBASE}/lib -ltiff
+TIFF_INCLUDE = -I${LOCALBASE}/include
#endif
XCOMM If you have the JPEG library, make HaveJPEG defined
@@ -73,8 +73,8 @@
#define HaveJPEG
#ifdef HaveJPEG
-JPEG_LIB = -L/usr/local/lib -ljpeg
-JPEG_INCLUDE = -I/usr/local/include/jpeg
+JPEG_LIB = -L${LOCALBASE}/lib -ljpeg
+JPEG_INCLUDE = -I${LOCALBASE}/include
#endif
XCOMM If you have the PNG library, make HavePNG defined
@@ -84,8 +84,8 @@
#define HavePNG
#ifdef HavePNG
-PNG_LIB = -L/usr/local/lib -lpng -lz
-PNG_INCLUDE = -I/usr/local/include/png
+PNG_LIB = -L${LOCALBASE}/lib -lpng -lz
+PNG_INCLUDE = -I${LOCALBASE}/include
#endif
XCOMM If you are running SunOS and get an error with the following undefined
@@ -102,11 +102,11 @@
XCOMM You must have the XPM library.
XCOMM Make sure the path name to the library is correct.
-XPM_LIB = -L/usr/X11R6/lib -lXpm
+XPM_LIB = -L${X11BASE}/lib -lXpm
XCOMM Make sure this points to the location of the 'xpm.h' file.
-XPM_INCLUDE = -I/usr/X11R6/include/X11
+XPM_INCLUDE = -I${X11BASE}/include/X11
DEPENDFLAGS = -I./bitmaps
@@ -114,10 +114,10 @@
XCOMM Uncomment these lines and tailor to taste, if you don't like
XCOMM the default paths and man page extension.
XCOMM
-XCOMM BINDIR = /usr/local/bin
-XCOMM MANDIR = /usr/local/man
-XCOMM #undef ManSuffix
-XCOMM #define ManSuffix 1
+BINDIR = ${PREFIX}/bin
+MANDIR = ${PREFIX}/man/cat1
+#undef ManSuffix
+#define ManSuffix 1
XCOMM Add '-g' here if you want to include debugging information.
XCOMM Also add any optimizer flags etc. that you want.
@@ -138,9 +138,9 @@
#if defined(FreeBSDArchitecture) || defined(NetBSDArchitecture) || \
defined(BSD386Architecture)
ARCH_DEFINES = -DHAVE_PARAM_H
-TIFF_INCLUDE = -I/usr/local/include
-TIFF_LIB = -L/usr/local/lib -ltiff
-JPEG_INCLUDE = -I/usr/local/include
-JPEG_LIB = -L/usr/local/lib -ljpeg
-XPM_INCLUDE = -I/usr/X11R6/include/X11
+TIFF_INCLUDE = -I${LOCALBASE}/include
+TIFF_LIB = -L${LOCALBASE}/lib -ltiff
+JPEG_INCLUDE = -I${LOCALBASE}/include
+JPEG_LIB = -L${LOCALBASE}/lib -ljpeg
+XPM_INCLUDE = -I${X11BASE}/include/X11
#endif

View file

@ -0,0 +1 @@
Paint program (enhanced xpaint).

4
graphics/xart/pkg/DESCR Normal file
View file

@ -0,0 +1,4 @@
XArt is a enhanced version of XPaint.
XPaint is a color image editing tool which features most standard paint
program options. It allows for the editing of mul- tiple images simultaneously
and supports various formats, including PPM, XBM, TIFF, etc.

4
graphics/xart/pkg/PLIST Normal file
View file

@ -0,0 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 1998/04/21 00:46:59 hubertf Exp $
bin/xart
man/cat1/xart.0
lib/X11/app-defaults/XArt