Update to 20070508 snapshot. From the changelog:
2007/05/01 (thomasb) ---------- - Updated German, Euskara, Hungarian, Romanian and Spanish translation - Added Hindi and Kurdish localization 2007/04/28 (thomasb) ---------- - LDAP access is back in address book (closes #1484087) - Added search function for contacts - New Template parsing and output encoding - Fixed bugs #1484119 and #1483978 2007/04/08 (thomasb) ---------- - Fixed message moving procedure (closes #1484308) - Fixed display of multiple attachments (closes #1466563) - Fixed check for new messages (closes #1484310) - List attachments without filename 2007/03/27 (thomasb) ---------- - New session authentication: Change sessid cookie when login, authentication with sessauth cookie is now configurable. Should close bugs #1483951 and #1484299 2007/03/23 (thomasb) ---------- - Correctly translate mailbox names (closes #1484276) - Quote e-mail address links (closes #1484300) 2007/03/21 (thomasb) ---------- - Updated PEAR::Mail_mime package - Added Persian localization - Updated Catalan and Brazilian Portuguese translations - Updated INSTALL manual with a note about database passwords - Accept single quotes for HTML attributes when modifying message body (thanks Jason) - Sanitize input for new users/identities (thanks Colin Alston) 2007/03/19 (thomasb) ---------- - Don't download HTML message parts - Convert HTML parts to plaintext if 'prefer_html' is off - Correctly parse message/rfc822 parts (closes #1484045) - Code cleanup 2007/03/18 (thomasb) ---------- - Also use user_id for unique key in messages table (closes #1484074) - Hide contacts drop down on blur (closes #1484203) - Make entries in contacts drop down clickable - Turn off browser autocompletion on login page - Quote <? in text/html message parts - Hide border around radio buttons - Replaced old JS function calls. 2007/03/13 (thomasb) ---------- - Applied patch for attachment download by crichardson (closes #1484198) - Fixed bug in Postgres DB handling (closes #1484068) - Fixed bug of invalid calls to fetchRow() in rcube_db.inc (closes #1484280) - Fixed array_merge bug (closes #1484281) - Fixed flag for deletion in list view (closes #1484264) - Finally support semicolons as recipient separator (closes ##1484251) - Fixed message headers (subject) encoding pkgsrc changes: * Make iconv and mbstring dependencies PKG_OPTIONS ("iconv" and "multibyte") * Write logs and tempfiles under ${VARBASE}, not ${PREFIX} * Cosmetic and pkglint-appeasing tweaks
This commit is contained in:
parent
d47a0d4dcb
commit
1b746356e5
6 changed files with 122 additions and 54 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.2 2007/04/08 21:25:44 adrianp Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2007/05/11 11:51:05 schmonz Exp $
|
||||
#
|
||||
|
||||
# SVN build 508
|
||||
DISTNAME= roundcube-0.1-20070314
|
||||
DISTNAME= roundcube-0.1-20070508
|
||||
PKGNAME= ${DISTNAME:S/-0.1//}
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://www.farrokhi.net/roundcube/
|
||||
|
@ -12,55 +11,56 @@ MAINTAINER= adrianp@NetBSD.org
|
|||
HOMEPAGE= http://roundcube.net/
|
||||
COMMENT= Browser-based multilingual IMAP client
|
||||
|
||||
.include "../../lang/php/phpversion.mk"
|
||||
|
||||
DEPENDS+= ${PHP_PKG_PREFIX}-iconv>=4.3.1:../../converters/php-iconv
|
||||
DEPENDS+= ${PHP_PKG_PREFIX}-mbstring>=4.3.1:../../misc/php-mbstring
|
||||
|
||||
USE_LANGUAGES= # none
|
||||
NO_BUILD= yes
|
||||
WRKSRC= ${WRKDIR}/roundcubemail
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
PKG_SYSCONFSUBDIR?= httpd
|
||||
|
||||
BUILD_DEFS+= APACHE_USER APACHE_GROUP
|
||||
BUILD_DEFS+= APACHE_USER APACHE_GROUP VARBASE
|
||||
RCDIR= ${PREFIX}/share/roundcube
|
||||
EGDIR= ${PREFIX}/share/examples/roundcube
|
||||
DOCDIR= ${PREFIX}/share/doc/roundcube
|
||||
PAX_DIRS= program skins
|
||||
|
||||
MESSAGE_SUBST+= DOCDIR=${DOCDIR:Q} PKG_SYSCONFDIR=${PKG_SYSCONFDIR:Q}
|
||||
FILES_SUBST+= RCDIR=${RCDIR:Q}
|
||||
|
||||
CONF_FILES= ${EGDIR}/roundcube.conf ${PKG_SYSCONFDIR}/roundcube.conf
|
||||
CONF_FILES_PERMS+= ${EGDIR}/db.inc.php ${RCDIR}/config/db.inc.php \
|
||||
${APACHE_USER} ${APACHE_GROUP} 0440
|
||||
CONF_FILES_PERMS+= ${EGDIR}/main.inc.php ${RCDIR}/config/main.inc.php \
|
||||
${APACHE_USER} ${APACHE_GROUP} 0440
|
||||
OWN_DIRS+= ${PKG_SYSCONFDIR}/roundcube
|
||||
OWN_DIRS_PERMS+=${VARBASE}/log/roundcube ${APACHE_USER} ${APACHE_GROUP} 0755
|
||||
OWN_DIRS_PERMS+=${VARBASE}/tmp/roundcube ${APACHE_USER} ${APACHE_GROUP} 0755
|
||||
|
||||
CONF_FILES= ${EGDIR}/roundcube.conf ${PKG_SYSCONFDIR}/roundcube.conf
|
||||
CONF_FILES_PERMS+= \
|
||||
${EGDIR}/db.inc.php ${PKG_SYSCONFDIR}/roundcube/db.inc.php \
|
||||
${APACHE_USER} ${APACHE_GROUP} 0440 \
|
||||
${EGDIR}/main.inc.php ${PKG_SYSCONFDIR}/roundcube/main.inc.php \
|
||||
${APACHE_USER} ${APACHE_GROUP} 0440
|
||||
|
||||
SUBST_CLASSES+= files
|
||||
SUBST_STAGE.files= post-build
|
||||
SUBST_STAGE.files= do-configure
|
||||
SUBST_FILES.files= roundcube.conf
|
||||
SUBST_FILES.files+= config/main.inc.php.dist
|
||||
SUBST_FILES.files+= program/include/main.inc
|
||||
SUBST_SED.files= -e "s|@RCDIR@|${RCDIR}|g"
|
||||
SUBST_SED.files+= -e "s|@VARBASE@|${VARBASE}|g"
|
||||
SUBST_SED.files+= -e "s|@PKG_SYSCONFDIR@|${PKG_SYSCONFDIR}|g"
|
||||
SUBST_MESSAGE.files= Fixing configuration files.
|
||||
|
||||
INSTALLATION_DIRS= ${RCDIR}/program ${RCDIR}/skins ${EGDIR}/SQL ${DOCDIR}
|
||||
|
||||
.include "options.mk"
|
||||
.include "../../mk/apache.mk"
|
||||
|
||||
do-build:
|
||||
${CP} ${FILESDIR}/roundcube.conf ${WRKSRC}/roundcube.conf
|
||||
post-extract:
|
||||
cp ${FILESDIR}/roundcube.conf ${WRKSRC}/roundcube.conf
|
||||
|
||||
pre-install:
|
||||
find ${WRKSRC} -name "*.orig" -print | xargs rm -f
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA_DIR} ${RCDIR}
|
||||
${INSTALL_DATA_DIR} ${RCDIR}/config
|
||||
${INSTALL_DATA_DIR} ${RCDIR}/program
|
||||
${INSTALL_DATA_DIR} ${RCDIR}/skins
|
||||
${INSTALL_DATA_DIR} ${RCDIR}/temp
|
||||
${INSTALL_DATA_DIR} ${RCDIR}/logs
|
||||
${INSTALL_DATA_DIR} ${EGDIR}
|
||||
${INSTALL_DATA_DIR} ${EGDIR}/SQL
|
||||
${INSTALL_DATA_DIR} ${DOCDIR}
|
||||
|
||||
${INSTALL_DATA} ${WRKSRC}/roundcube.conf ${EGDIR}/roundcube.conf
|
||||
${INSTALL_DATA} ${WRKSRC}/INSTALL ${DOCDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCDIR}
|
||||
|
@ -70,23 +70,17 @@ do-install:
|
|||
${INSTALL_DATA} ${WRKSRC}/SQL/*.sql ${EGDIR}/SQL/
|
||||
|
||||
${INSTALL_DATA} ${WRKSRC}/.htaccess ${RCDIR}/
|
||||
${INSTALL_DATA} ${WRKSRC}/config/.htaccess ${RCDIR}/config/
|
||||
${INSTALL_DATA} ${WRKSRC}/temp/.htaccess ${RCDIR}/temp/
|
||||
${INSTALL_DATA} ${WRKSRC}/logs/.htaccess ${RCDIR}/logs/
|
||||
|
||||
${INSTALL_DATA} ${WRKSRC}/index.php ${RCDIR}/
|
||||
|
||||
${INSTALL_DATA} ${WRKSRC}/config/db.inc.php.dist ${EGDIR}/db.inc.php
|
||||
${INSTALL_DATA} ${WRKSRC}/config/main.inc.php.dist ${EGDIR}/main.inc.php
|
||||
|
||||
${CHOWN} ${APACHE_USER}:${APACHE_GROUP} ${RCDIR}/temp/
|
||||
${CHOWN} ${APACHE_USER}:${APACHE_GROUP} ${RCDIR}/logs/
|
||||
|
||||
.for i in ${PAX_DIRS}
|
||||
cd ${WRKSRC}/${i} && ${PAX} -rw . ${RCDIR}/${i}
|
||||
${FIND} ${RCDIR}/${i} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
|
||||
${FIND} ${RCDIR}/${i} -type d | ${XARGS} ${CHMOD} ${PKGDIRMODE}
|
||||
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${RCDIR}/${i}
|
||||
cd ${WRKSRC}/${i} && pax -rw . ${RCDIR}/${i}
|
||||
find ${RCDIR}/${i} -type f | xargs chmod ${SHAREMODE}
|
||||
find ${RCDIR}/${i} -type d | xargs chmod ${PKGDIRMODE}
|
||||
chown -R ${SHAREOWN}:${SHAREGRP} ${RCDIR}/${i}
|
||||
.endfor
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2007/04/08 17:04:08 adrianp Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2007/05/11 11:51:05 schmonz Exp $
|
||||
share/doc/roundcube/INSTALL
|
||||
share/doc/roundcube/LICENSE
|
||||
share/doc/roundcube/README
|
||||
|
@ -16,14 +16,14 @@ share/examples/roundcube/db.inc.php
|
|||
share/examples/roundcube/main.inc.php
|
||||
share/examples/roundcube/roundcube.conf
|
||||
share/roundcube/.htaccess
|
||||
share/roundcube/config/.htaccess
|
||||
share/roundcube/index.php
|
||||
share/roundcube/logs/.htaccess
|
||||
share/roundcube/program/blank.gif
|
||||
share/roundcube/program/blocked.gif
|
||||
share/roundcube/program/include/bugs.inc
|
||||
share/roundcube/program/include/cache.inc
|
||||
share/roundcube/program/include/main.inc
|
||||
share/roundcube/program/include/rcmail_template.inc
|
||||
share/roundcube/program/include/rcube_contacts.inc
|
||||
share/roundcube/program/include/rcube_db.inc
|
||||
share/roundcube/program/include/rcube_imap.inc
|
||||
share/roundcube/program/include/rcube_ldap.inc
|
||||
|
@ -306,6 +306,7 @@ share/roundcube/program/lib/html2text.inc
|
|||
share/roundcube/program/lib/icl_commons.inc
|
||||
share/roundcube/program/lib/imap.inc
|
||||
share/roundcube/program/lib/mime.inc
|
||||
share/roundcube/program/lib/rc_mail_mime.inc
|
||||
share/roundcube/program/lib/utf7.inc
|
||||
share/roundcube/program/lib/utf8.class.php
|
||||
share/roundcube/program/localization/am/labels.inc
|
||||
|
@ -338,10 +339,14 @@ share/roundcube/program/localization/et_EE/labels.inc
|
|||
share/roundcube/program/localization/et_EE/messages.inc
|
||||
share/roundcube/program/localization/eu/labels.inc
|
||||
share/roundcube/program/localization/eu/messages.inc
|
||||
share/roundcube/program/localization/fa/labels.inc
|
||||
share/roundcube/program/localization/fa/messages.inc
|
||||
share/roundcube/program/localization/fi/labels.inc
|
||||
share/roundcube/program/localization/fi/messages.inc
|
||||
share/roundcube/program/localization/fr/labels.inc
|
||||
share/roundcube/program/localization/fr/messages.inc
|
||||
share/roundcube/program/localization/hi/labels.inc
|
||||
share/roundcube/program/localization/hi/messages.inc
|
||||
share/roundcube/program/localization/hr/labels.inc
|
||||
share/roundcube/program/localization/hr/messages.inc
|
||||
share/roundcube/program/localization/hu/labels.inc
|
||||
|
@ -353,6 +358,8 @@ share/roundcube/program/localization/it/labels.inc
|
|||
share/roundcube/program/localization/it/messages.inc
|
||||
share/roundcube/program/localization/ja/labels.inc
|
||||
share/roundcube/program/localization/ja/messages.inc
|
||||
share/roundcube/program/localization/kur_KU/labels.inc
|
||||
share/roundcube/program/localization/kur_KU/messages.inc
|
||||
share/roundcube/program/localization/lt/labels.inc
|
||||
share/roundcube/program/localization/lt/messages.inc
|
||||
share/roundcube/program/localization/lv/labels.inc
|
||||
|
@ -395,12 +402,14 @@ share/roundcube/program/localization/vn/labels.inc
|
|||
share/roundcube/program/localization/vn/messages.inc
|
||||
share/roundcube/program/localization/zh_CN/labels.inc
|
||||
share/roundcube/program/localization/zh_CN/messages.inc
|
||||
share/roundcube/program/steps/addressbook/copy.inc
|
||||
share/roundcube/program/steps/addressbook/delete.inc
|
||||
share/roundcube/program/steps/addressbook/edit.inc
|
||||
share/roundcube/program/steps/addressbook/func.inc
|
||||
share/roundcube/program/steps/addressbook/ldapsearchform.inc
|
||||
share/roundcube/program/steps/addressbook/list.inc
|
||||
share/roundcube/program/steps/addressbook/mailto.inc
|
||||
share/roundcube/program/steps/addressbook/save.inc
|
||||
share/roundcube/program/steps/addressbook/search.inc
|
||||
share/roundcube/program/steps/addressbook/show.inc
|
||||
share/roundcube/program/steps/error.inc
|
||||
share/roundcube/program/steps/mail/addcontact.inc
|
||||
|
@ -414,7 +423,6 @@ share/roundcube/program/steps/mail/list.inc
|
|||
share/roundcube/program/steps/mail/mark.inc
|
||||
share/roundcube/program/steps/mail/move_del.inc
|
||||
share/roundcube/program/steps/mail/quotadisplay.inc
|
||||
share/roundcube/program/steps/mail/quotaimg.inc
|
||||
share/roundcube/program/steps/mail/rss.inc
|
||||
share/roundcube/program/steps/mail/search.inc
|
||||
share/roundcube/program/steps/mail/sendmail.inc
|
||||
|
@ -569,7 +577,6 @@ share/roundcube/skins/default/includes/links.html
|
|||
share/roundcube/skins/default/includes/settingscripts.html
|
||||
share/roundcube/skins/default/includes/settingstabs.html
|
||||
share/roundcube/skins/default/includes/taskbar.html
|
||||
share/roundcube/skins/default/ldapsearchform.css
|
||||
share/roundcube/skins/default/mail.css
|
||||
share/roundcube/skins/default/pngbehavior.htc
|
||||
share/roundcube/skins/default/print.css
|
||||
|
@ -583,7 +590,6 @@ share/roundcube/skins/default/templates/editcontact.html
|
|||
share/roundcube/skins/default/templates/editidentity.html
|
||||
share/roundcube/skins/default/templates/error.html
|
||||
share/roundcube/skins/default/templates/identities.html
|
||||
share/roundcube/skins/default/templates/ldappublicsearch.html
|
||||
share/roundcube/skins/default/templates/login.html
|
||||
share/roundcube/skins/default/templates/mail.html
|
||||
share/roundcube/skins/default/templates/managefolders.html
|
||||
|
@ -594,8 +600,6 @@ share/roundcube/skins/default/templates/printmessage.html
|
|||
share/roundcube/skins/default/templates/settings.html
|
||||
share/roundcube/skins/default/templates/showcontact.html
|
||||
share/roundcube/skins/default/watermark.html
|
||||
share/roundcube/temp/.htaccess
|
||||
@dirrm share/roundcube/temp
|
||||
@dirrm share/roundcube/skins/default/templates
|
||||
@dirrm share/roundcube/skins/default/includes
|
||||
@dirrm share/roundcube/skins/default/images/icons
|
||||
|
@ -630,13 +634,16 @@ share/roundcube/temp/.htaccess
|
|||
@dirrm share/roundcube/program/localization/nb_NO
|
||||
@dirrm share/roundcube/program/localization/lv
|
||||
@dirrm share/roundcube/program/localization/lt
|
||||
@dirrm share/roundcube/program/localization/kur_KU
|
||||
@dirrm share/roundcube/program/localization/ja
|
||||
@dirrm share/roundcube/program/localization/it
|
||||
@dirrm share/roundcube/program/localization/id_ID
|
||||
@dirrm share/roundcube/program/localization/hu
|
||||
@dirrm share/roundcube/program/localization/hr
|
||||
@dirrm share/roundcube/program/localization/hi
|
||||
@dirrm share/roundcube/program/localization/fr
|
||||
@dirrm share/roundcube/program/localization/fi
|
||||
@dirrm share/roundcube/program/localization/fa
|
||||
@dirrm share/roundcube/program/localization/eu
|
||||
@dirrm share/roundcube/program/localization/et_EE
|
||||
@dirrm share/roundcube/program/localization/es
|
||||
|
@ -707,8 +714,6 @@ share/roundcube/temp/.htaccess
|
|||
@dirrm share/roundcube/program/js
|
||||
@dirrm share/roundcube/program/include
|
||||
@dirrm share/roundcube/program
|
||||
@dirrm share/roundcube/logs
|
||||
@dirrm share/roundcube/config
|
||||
@dirrm share/roundcube
|
||||
@dirrm share/examples/roundcube/SQL
|
||||
@dirrm share/examples/roundcube
|
||||
|
|
|
@ -1,5 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2007/04/08 17:04:08 adrianp Exp $
|
||||
$NetBSD: distinfo,v 1.2 2007/05/11 11:51:05 schmonz Exp $
|
||||
|
||||
SHA1 (roundcube-0.1-20070314.tar.bz2) = 1c54fe2a44214e850ddcbc4837e29536548d8173
|
||||
RMD160 (roundcube-0.1-20070314.tar.bz2) = e022f42d78243b1f65dcdc0b557b80ebe8a84c53
|
||||
Size (roundcube-0.1-20070314.tar.bz2) = 755003 bytes
|
||||
SHA1 (roundcube-0.1-20070508.tar.bz2) = caf52339e7b4d6a97d0aee14d9f9fd85b0bbfacd
|
||||
RMD160 (roundcube-0.1-20070508.tar.bz2) = 9a0070c192482ab9c2e127c4c2f26d23887217db
|
||||
Size (roundcube-0.1-20070508.tar.bz2) = 765709 bytes
|
||||
SHA1 (patch-aa) = 6672520123bab023c2ee50a363a3c634db2202e3
|
||||
SHA1 (patch-ab) = 15ed0f903072be25eaf1d0edac8ddbe8cca8ac25
|
||||
|
|
|
@ -1,15 +1,17 @@
|
|||
# $NetBSD: options.mk,v 1.1.1.1 2007/04/08 17:04:08 adrianp Exp $
|
||||
# $NetBSD: options.mk,v 1.2 2007/05/11 11:51:05 schmonz Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.roundcube
|
||||
|
||||
PKG_OPTIONS_REQUIRED_GROUPS= db
|
||||
PKG_OPTIONS_GROUP.db= mysql pgsql sqlite
|
||||
|
||||
PKG_SUPPORTED_OPTIONS= ldap
|
||||
PKG_SUPPORTED_OPTIONS= iconv ldap multibyte
|
||||
PKG_SUGGESTED_OPTIONS= mysql
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
.include "../../lang/php/phpversion.mk"
|
||||
|
||||
###
|
||||
### Use mysql backend
|
||||
###
|
||||
|
@ -35,9 +37,23 @@ PHP_VERSIONS_ACCEPTED= 4
|
|||
DEPENDS+= ${PHP_PKG_PREFIX}-sqlite-[0-9]*:../../databases/php-sqlite
|
||||
.endif
|
||||
|
||||
###
|
||||
### Use iconv
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Miconv)
|
||||
DEPENDS+= ${PHP_PKG_PREFIX}-iconv>=4.3.1:../../converters/php-iconv
|
||||
.endif
|
||||
|
||||
###
|
||||
### Use OpenLDAP for storing data
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mldap)
|
||||
DEPENDS+= ${PHP_PKG_PREFIX}-ldap>=4.3.1:../../databases/php-ldap
|
||||
.endif
|
||||
|
||||
###
|
||||
### Use mbstring
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mmultibyte)
|
||||
DEPENDS+= ${PHP_PKG_PREFIX}-mbstring>=4.3.1:../../misc/php-mbstring
|
||||
.endif
|
||||
|
|
17
mail/roundcube/patches/patch-aa
Normal file
17
mail/roundcube/patches/patch-aa
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-aa,v 1.1 2007/05/11 11:51:05 schmonz Exp $
|
||||
|
||||
--- config/main.inc.php.dist.orig 2007-05-08 05:22:27.000000000 -0400
|
||||
+++ config/main.inc.php.dist
|
||||
@@ -88,10 +88,10 @@ $rcmail_config['list_cols'] = array('sub
|
||||
$rcmail_config['skin_path'] = 'skins/default/';
|
||||
|
||||
// use this folder to store temp files (must be writebale for apache user)
|
||||
-$rcmail_config['temp_dir'] = 'temp/';
|
||||
+$rcmail_config['temp_dir'] = '@VARBASE@/tmp/roundcube/';
|
||||
|
||||
// use this folder to store log files (must be writebale for apache user)
|
||||
-$rcmail_config['log_dir'] = 'logs/';
|
||||
+$rcmail_config['log_dir'] = '@VARBASE@/log/roundcube/';
|
||||
|
||||
// session lifetime in minutes
|
||||
$rcmail_config['session_lifetime'] = 10;
|
34
mail/roundcube/patches/patch-ab
Normal file
34
mail/roundcube/patches/patch-ab
Normal file
|
@ -0,0 +1,34 @@
|
|||
$NetBSD: patch-ab,v 1.1 2007/05/11 11:51:05 schmonz Exp $
|
||||
|
||||
--- program/include/main.inc.orig 2007-05-08 05:22:23.000000000 -0400
|
||||
+++ program/include/main.inc
|
||||
@@ -107,7 +107,7 @@ function rcmail_load_config()
|
||||
global $INSTALL_PATH;
|
||||
|
||||
// load config file
|
||||
- include_once('config/main.inc.php');
|
||||
+ include_once('@PKG_SYSCONFDIR@/roundcube/main.inc.php');
|
||||
$conf = is_array($rcmail_config) ? $rcmail_config : array();
|
||||
|
||||
// load host-specific configuration
|
||||
@@ -116,7 +116,7 @@ function rcmail_load_config()
|
||||
$conf['skin_path'] = $conf['skin_path'] ? unslashify($conf['skin_path']) : 'skins/default';
|
||||
|
||||
// load db conf
|
||||
- include_once('config/db.inc.php');
|
||||
+ include_once('@PKG_SYSCONFDIR@/roundcube/db.inc.php');
|
||||
$conf = array_merge($conf, $rcmail_config);
|
||||
|
||||
if (empty($conf['log_dir']))
|
||||
@@ -149,9 +149,9 @@ function rcmail_load_host_config(&$confi
|
||||
else if (!empty($config['include_host_config']))
|
||||
$fname = preg_replace('/[^a-z0-9\.\-_]/i', '', $_SERVER['HTTP_HOST']) . '.inc.php';
|
||||
|
||||
- if ($fname && is_file('config/'.$fname))
|
||||
+ if ($fname && is_file('@PKG_SYSCONFDIR@/roundcube/'.$fname))
|
||||
{
|
||||
- include('config/'.$fname);
|
||||
+ include('@PKG_SYSCONFDIR@/roundcube/'.$fname);
|
||||
$config = array_merge($config, $rcmail_config);
|
||||
}
|
||||
}
|
Loading…
Reference in a new issue