Initial import of ns-plugger-common-3.2, the common part of the splitup of
the plugger package.
This commit is contained in:
parent
7ba0d5e56e
commit
1b7c564f97
8 changed files with 143 additions and 0 deletions
54
www/ns-plugger-common/Makefile
Normal file
54
www/ns-plugger-common/Makefile
Normal file
|
@ -0,0 +1,54 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2000/08/22 11:02:12 rh Exp $
|
||||
#
|
||||
|
||||
DISTNAME= plugger-3.2-linux-x86-glibc
|
||||
PKGNAME= ns-${PLUGGERNAME}-${BINNAME}-${PLUGGERVERS}
|
||||
WRKSRC= ${WRKDIR}/${PLUGGERFULL}
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://fredrik.hubbe.net/plugger/
|
||||
|
||||
MAINTAINER= rh@netbsd.org
|
||||
HOMEPAGE= http://fredrik.hubbe.net/plugger.html
|
||||
|
||||
BINNAME?= common
|
||||
|
||||
.if ${BINNAME} != common
|
||||
DEPENDS+= ${BINNAME}-*:../../www/${BINNAME}
|
||||
|
||||
MOZILLA_HOME= ${PREFIX}/lib/netscape/${NSNAME}
|
||||
NS_VERS= ${NSNAME:C/.*-//}
|
||||
|
||||
PLIST_SUBST+= NS_VERS=${NS_VERS} BINNAME=${BINNAME}
|
||||
.endif
|
||||
|
||||
CONFLICTS+= plugger-* # obsolete all-in-one plugger package
|
||||
|
||||
ONLY_FOR_PLATFORM= NetBSD-*-i386
|
||||
|
||||
NO_CONFIGURE= YES
|
||||
NO_BUILD= YES
|
||||
|
||||
PLUGGERFULL= ${DISTNAME:C/-linux-x86-glibc//}
|
||||
PLUGGERVERS= ${PLUGGERFULL:C/.*-//}
|
||||
PLUGGERNAME= ${PLUGGERFULL:C/-.*//}
|
||||
NS_PLUGINS_DIR= ${PREFIX}/lib/netscape/plugins
|
||||
|
||||
do-install:
|
||||
.if ${BINNAME} != common
|
||||
cd ${WRKSRC} && \
|
||||
${INSTALL_DATA} pluggerrc ${MOZILLA_HOME}
|
||||
.else
|
||||
cd ${WRKSRC} && \
|
||||
${INSTALL_DATA_DIR} ${NS_PLUGINS_DIR} && \
|
||||
${INSTALL_PROGRAM} plugger.so ${NS_PLUGINS_DIR} && \
|
||||
${INSTALL_DATA} plugger.7 ${PREFIX}/man/man7 && \
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/plugger && \
|
||||
${INSTALL_DATA} README ${PREFIX}/share/doc/plugger && \
|
||||
${INSTALL_DATA} COPYING ${PREFIX}/share/doc/plugger
|
||||
.endif
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
||||
.if ${BINNAME} != common
|
||||
NSNAME!= ( ${PKG_INFO} 2>/dev/null -e ${BINNAME} || ${ECHO} "" )
|
||||
.endif
|
3
www/ns-plugger-common/files/md5
Normal file
3
www/ns-plugger-common/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 2000/08/22 11:02:12 rh Exp $
|
||||
|
||||
MD5 (plugger-3.2-linux-x86-glibc.tar.gz) = 6a1457df52172af0b4a614ca9b6a9edf
|
3
www/ns-plugger-common/files/patch-sum
Normal file
3
www/ns-plugger-common/files/patch-sum
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 2000/08/22 11:02:12 rh Exp $
|
||||
|
||||
MD5 (patch-aa) = b0402c8de263a3bec13370881989c9aa
|
38
www/ns-plugger-common/patches/patch-aa
Normal file
38
www/ns-plugger-common/patches/patch-aa
Normal file
|
@ -0,0 +1,38 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2000/08/22 11:02:12 rh Exp $
|
||||
|
||||
--- pluggerrc.orig Wed Nov 10 02:42:29 1999
|
||||
+++ pluggerrc
|
||||
@@ -27,6 +27,7 @@
|
||||
|
||||
audio/midi: midi,mid: MIDI audio file
|
||||
audio/x-midi: midi,mid: MIDI audio file
|
||||
+ many: midiplay $file
|
||||
many: timidity -s 44100 -a -idqqqqqqq $file
|
||||
: playmidi $file
|
||||
|
||||
@@ -48,6 +49,7 @@
|
||||
audio/x-mpeg: mpa,abs,mpega: MPEG audio
|
||||
stream, preload: splay -t 200 -M
|
||||
stream, preload: mpg123 -q -b 128 -
|
||||
+ many: gqmpeg --playlist_add_play $file
|
||||
many: splay -t 200 $file
|
||||
many: amp -b 200 -q $file
|
||||
many: mpg123 -q -b 128 $file
|
||||
@@ -68,7 +70,9 @@
|
||||
|
||||
audio/wav:wav:Microsoft wave file
|
||||
audio/x-wav:wav:Microsoft wave file
|
||||
+ stream, preload: audioplay
|
||||
stream, preload: splay -W
|
||||
+ many: audioplay $file
|
||||
many: wavplay -q $file
|
||||
stream, preload: bplay 1>/dev/null 2>/dev/null
|
||||
: bplay 1>/dev/null 2>/dev/null
|
||||
@@ -84,6 +88,7 @@
|
||||
image/x-sun-raster: rs: SUN raster image
|
||||
exits: xloadimage -quiet -windowid $window $file
|
||||
exits: display -window $window -backdrop $file
|
||||
+ many: xv $file
|
||||
|
||||
audio/mpeg-url: m3u: MPEG music resource locator
|
||||
audio/x-mpeg-url: m3u: MPEG music resource locator
|
1
www/ns-plugger-common/pkg/COMMENT
Normal file
1
www/ns-plugger-common/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
streaming multimedia plugin for Netscape
|
9
www/ns-plugger-common/pkg/DESCR
Normal file
9
www/ns-plugger-common/pkg/DESCR
Normal file
|
@ -0,0 +1,9 @@
|
|||
Tired of getting teased by Windows users because your Netscape isn't as
|
||||
|<()()|_ as theirs? Well, your problems are almost solved. Plugger is a
|
||||
multimedia plugin for Unix Netscape 3.0 or later that handles Quicktime, MPEG,
|
||||
MP2, AVI, SGI-movie, Tiff, DL, IFF-anim, MIDI, Soundtracker, AU, WAV and
|
||||
Commodore 64 audio files. And now, with Plugger 3.2, MPEG audio and video can
|
||||
be played streaming.
|
||||
|
||||
No more waiting! Plugger is a very small plugin, because plugger uses
|
||||
external programs to show/play the different formats.
|
28
www/ns-plugger-common/pkg/MESSAGE
Normal file
28
www/ns-plugger-common/pkg/MESSAGE
Normal file
|
@ -0,0 +1,28 @@
|
|||
$NetBSD: MESSAGE,v 1.1.1.1 2000/08/22 11:02:12 rh Exp $
|
||||
|
||||
==========================================================================
|
||||
Plugger has now been installed on your system.
|
||||
|
||||
This package is only a plugin wrapper around common multimedia
|
||||
utilities. If you want to use plugger to display a certain file type
|
||||
at least one of the utilities listed for that particular file type has
|
||||
to be present:
|
||||
|
||||
file type utilities
|
||||
--------- ---------
|
||||
MPEG video mtv, xanim
|
||||
Quicktime xanim
|
||||
midi midiplay, timidity
|
||||
mod mikmod, nspmod
|
||||
MPEG Layer 3 splay, amp, mpg123, maplay, gqmpeg
|
||||
PNG, TIFF ImageMagick, xv
|
||||
|
||||
The plugger package does not automatically depend on these utilities,
|
||||
but all of them are available as packages. You will find them in the
|
||||
package categories audio and graphics.
|
||||
|
||||
For information on adding more file types and applications, type
|
||||
`man plugger'. To use a different (or no) plugin for a specific file
|
||||
type, use the Navigator/Applications preferences of your Netscape
|
||||
browser.
|
||||
==========================================================================
|
7
www/ns-plugger-common/pkg/PLIST
Normal file
7
www/ns-plugger-common/pkg/PLIST
Normal file
|
@ -0,0 +1,7 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2000/08/22 11:02:12 rh Exp $
|
||||
lib/netscape/plugins/plugger.so
|
||||
man/man7/plugger.7
|
||||
share/doc/plugger/README
|
||||
share/doc/plugger/COPYING
|
||||
@unexec rmdir -p %D/lib/netscape/plugins 2>/dev/null || true
|
||||
@dirrm share/doc/plugger
|
Loading…
Reference in a new issue