Fix build under Mac OS X Snow Leopard if the Mac OS X Leopard is not
installed. Based on changes sugested by Martin Brandenburg in PR pkg/45086.
This commit is contained in:
parent
c2af97fcfa
commit
1b80dac1bf
3 changed files with 22 additions and 4 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.6 2011/06/20 20:31:29 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.7 2011/06/21 18:14:30 tron Exp $
|
||||
|
||||
DISTNAME= libvpx-v0.9.6
|
||||
PKGNAME= ${DISTNAME:S/-v/-/}
|
||||
|
@ -36,8 +36,10 @@ REPLACE_BASH= configure \
|
|||
|
||||
.if ${OPSYS} == "Darwin"
|
||||
. if ${MACHINE_ARCH} == "i386"
|
||||
. if empty(OS_VERSION:M8.*)
|
||||
CONFIGURE_ARGS+= --target=x86-darwin9-gcc
|
||||
. if !empty(OS_VERSION:M10.*)
|
||||
CONFIGURE_ARGS+= --target=x86-darwin10-gcc
|
||||
. elif !empty(OS_VERSION:M9.*)
|
||||
CONFIGURE_ARGS+= --target=x86-darwin10-gcc
|
||||
. else
|
||||
CONFIGURE_ARGS+= --target=x86-darwin8-gcc
|
||||
. endif
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.4 2011/06/16 13:22:48 seanb Exp $
|
||||
$NetBSD: distinfo,v 1.5 2011/06/21 18:14:30 tron Exp $
|
||||
|
||||
SHA1 (libvpx-v0.9.6.tar.bz2) = a3522bd2b73d52381ba767ded1cbf4760e9cc6f8
|
||||
RMD160 (libvpx-v0.9.6.tar.bz2) = b85038b92d911b29b3b912c3d71c60e13f89a551
|
||||
|
@ -7,3 +7,4 @@ SHA1 (patch-aa) = 7f0816d094a7855cfb059905a7a21e438eb03000
|
|||
SHA1 (patch-ab) = bd8cc8cf876eb3a8c6dbc317fb9eba3867f2cf2b
|
||||
SHA1 (patch-ac) = e41b971e300a108beb5ae717ab6a57abc25318d9
|
||||
SHA1 (patch-ad) = e535891d4819a40ce47b1cfdc6e9d5cc1fefcc97
|
||||
SHA1 (patch-ae) = e9a5895bbd34b58844bf14bd7851b116c900d1ff
|
||||
|
|
15
multimedia/libvpx/patches/patch-ae
Normal file
15
multimedia/libvpx/patches/patch-ae
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ae,v 1.1 2011/06/21 18:14:30 tron Exp $
|
||||
|
||||
Fix build under Mac OS X Snow Leopard if the Mac OS X Leopard SDK
|
||||
is not installed.
|
||||
|
||||
--- configure.orig 2011-06-21 19:02:21.000000000 +0100
|
||||
+++ configure 2011-06-21 19:04:37.000000000 +0100
|
||||
@@ -105,6 +105,7 @@
|
||||
all_platforms="${all_platforms} x86-darwin8-icc"
|
||||
all_platforms="${all_platforms} x86-darwin9-gcc"
|
||||
all_platforms="${all_platforms} x86-darwin9-icc"
|
||||
+all_platforms="${all_platforms} x86-darwin10-gcc"
|
||||
all_platforms="${all_platforms} x86-linux-gcc"
|
||||
all_platforms="${all_platforms} x86-linux-icc"
|
||||
all_platforms="${all_platforms} x86-solaris-gcc"
|
Loading…
Reference in a new issue