Update ap2-ruby pacakge to 1.2.4.
Changes are huge, please see ChangeLog.
This commit is contained in:
parent
a319a17434
commit
1b8ca4e068
6 changed files with 24 additions and 75 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.8 2004/11/28 04:57:17 taca Exp $
|
||||
# $NetBSD: Makefile,v 1.9 2004/11/28 15:34:06 taca Exp $
|
||||
|
||||
DISTNAME= mod_ruby-${VERSION}
|
||||
PKGNAME= ap2-${RUBY_PKGPREFIX}-${VERSION}
|
||||
|
@ -14,17 +14,15 @@ CONFLICTS+= ap-ruby*
|
|||
USE_BUILDLINK3= yes
|
||||
USE_PKGINSTALL= yes
|
||||
APACHE_MODULE= yes
|
||||
VERSION= 1.1.1
|
||||
VERSION= 1.2.4
|
||||
HAS_CONFIGURE= yes
|
||||
INSTALL_TARGET= site-install
|
||||
CONFIGURE_SCRIPT= ${RUBY} configure.rb
|
||||
CONFIGURE_ARGS+= --with-apxs="${APXS}" \
|
||||
--with-eruby-includes="${BUILDLINK_PREFIX.ruby-eruby}/include" \
|
||||
--with-eruby-libraries="${BUILDLINK_PREFIX.ruby-eruby}/lib"
|
||||
CONFIGURE_ARGS+= --with-apxs="${APXS}"
|
||||
MAKE_FLAGS+= APACHE_INCLUDES='-I${PREFIX}/include/httpd \
|
||||
-I${PREFIX}/include/apr-0'
|
||||
MESSAGE_SUBST+= RUBY_DOCDIR=${RUBY_DOCDIR}
|
||||
DOCS= ChangeLog README.en README.ja
|
||||
DOCS= ChangeLog NOTICE README.en README.ja
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2004/11/28 04:57:17 taca Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2004/11/28 15:34:06 taca Exp $
|
||||
lib/httpd/mod_ruby.so
|
||||
${RUBY_SITELIBDIR}/apache/erb-run.rb
|
||||
${RUBY_SITELIBDIR}/apache/eruby-debug.rb
|
||||
${RUBY_SITELIBDIR}/apache/eruby-run.rb
|
||||
${RUBY_SITELIBDIR}/apache/query.rb
|
||||
${RUBY_SITELIBDIR}/apache/rd2html.rb
|
||||
${RUBY_SITELIBDIR}/apache/query.rb
|
||||
${RUBY_SITELIBDIR}/apache/registry.rb
|
||||
${RUBY_SITELIBDIR}/apache/ruby-debug.rb
|
||||
${RUBY_SITELIBDIR}/apache/ruby-run.rb
|
||||
|
@ -13,6 +13,7 @@ ${RUBY_SITELIBDIR}/auto-reload.rb
|
|||
${RUBY_EXAMPLESDIR}/mod_ruby/mod_ruby.conf
|
||||
@dirrm ${RUBY_EXAMPLESDIR}/mod_ruby
|
||||
${RUBY_DOCDIR}/mod_ruby/ChangeLog
|
||||
${RUBY_DOCDIR}/mod_ruby/NOTICE
|
||||
${RUBY_DOCDIR}/mod_ruby/README.en
|
||||
${RUBY_DOCDIR}/mod_ruby/README.ja
|
||||
${RUBY_DOCDIR}/mod_ruby/classes.en.rd
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.2 2003/07/27 08:07:05 taca Exp $
|
||||
$NetBSD: distinfo,v 1.3 2004/11/28 15:34:06 taca Exp $
|
||||
|
||||
SHA1 (ruby/mod_ruby-1.1.1.tar.gz) = 87540c3be006ea04d40927af8a3d99dedecc153e
|
||||
Size (ruby/mod_ruby-1.1.1.tar.gz) = 62191 bytes
|
||||
SHA1 (patch-aa) = 3413b96e9a881afdb17ebe931b167d7e6ae281cd
|
||||
SHA1 (patch-ab) = 46e9903be8f851668177d298cb2603812585d559
|
||||
SHA1 (ruby/mod_ruby-1.2.4.tar.gz) = 758e1706944ab77a1547c88ceb0aadd69131d732
|
||||
Size (ruby/mod_ruby-1.2.4.tar.gz) = 107797 bytes
|
||||
SHA1 (patch-ac) = 675f906fc5a08347a83eef440ee41d64381d23fe
|
||||
|
|
|
@ -1,49 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1 2003/07/27 08:07:06 taca Exp $
|
||||
|
||||
--- mod_ruby.c.orig Mon Mar 17 11:34:23 2003
|
||||
+++ mod_ruby.c
|
||||
@@ -86,7 +86,7 @@ static const char *default_kcode;
|
||||
static int ruby_is_running = 0;
|
||||
array_header *ruby_required_libraries = NULL;
|
||||
|
||||
-#ifdef APR_HAS_THREADS
|
||||
+#if APR_HAS_THREADS
|
||||
#include "apr_thread_cond.h"
|
||||
|
||||
static apr_thread_t *ruby_thread;
|
||||
@@ -662,7 +662,7 @@ static void ruby_finalize_interpreter()
|
||||
}
|
||||
}
|
||||
|
||||
-#ifdef APR_HAS_THREADS
|
||||
+#if APR_HAS_THREADS
|
||||
static void *ruby_thread_start(apr_thread_t *t, void *data)
|
||||
{
|
||||
server_rec *s = (server_rec *) data;
|
||||
@@ -731,7 +731,7 @@ apr_status_t ruby_call_interpreter(pool
|
||||
|
||||
static APR_CLEANUP_RETURN_TYPE ruby_child_cleanup(void *data)
|
||||
{
|
||||
-#ifdef APR_HAS_THREADS
|
||||
+#if APR_HAS_THREADS
|
||||
pool *p;
|
||||
apr_status_t status;
|
||||
|
||||
@@ -754,7 +754,7 @@ static void ruby_child_init(server_rec *
|
||||
#endif
|
||||
{
|
||||
if (!ruby_running()) {
|
||||
-#ifdef APR_HAS_THREADS
|
||||
+#if APR_HAS_THREADS
|
||||
apr_status_t status;
|
||||
status = apr_thread_mutex_create(&ruby_request_queue_mutex,
|
||||
APR_THREAD_MUTEX_DEFAULT, p);
|
||||
@@ -1097,7 +1097,7 @@ static int ruby_handler(request_rec *r,
|
||||
arg->run_all = run_all;
|
||||
arg->flush = flush;
|
||||
arg->retval = 0;
|
||||
-#ifdef APR_HAS_THREADS
|
||||
+#if APR_HAS_THREADS
|
||||
{
|
||||
apr_status_t status;
|
||||
char buf[256];
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1 2003/07/27 08:07:06 taca Exp $
|
||||
|
||||
--- ruby_config.c.orig Mon Mar 17 11:34:23 2003
|
||||
+++ ruby_config.c
|
||||
@@ -229,7 +229,7 @@ static void ruby_require(pool *p, char *
|
||||
arg->server = server;
|
||||
arg->sconf = sconf;
|
||||
arg->dconf = dconf;
|
||||
-#ifdef APR_HAS_THREADS
|
||||
+#if APR_HAS_THREADS
|
||||
{
|
||||
apr_status_t status;
|
||||
char buf[256];
|
13
www/ap2-ruby/patches/patch-ac
Normal file
13
www/ap2-ruby/patches/patch-ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.1 2004/11/28 15:34:06 taca Exp $
|
||||
|
||||
--- apache_request.c.orig 2004-09-24 03:43:18.000000000 +0900
|
||||
+++ apache_request.c
|
||||
@@ -230,7 +230,7 @@ static unsigned int utf8_convert(char *s
|
||||
x = x * 16 + str[i] - '0';
|
||||
}
|
||||
else {
|
||||
- str[i] = tolower( str[i] );
|
||||
+ str[i] = tolower((unsigned int)str[i] );
|
||||
x = x * 16 + str[i] - 'a' + 10;
|
||||
}
|
||||
}
|
Loading…
Reference in a new issue