Changes 1.8.10:

* The following new C function has been added:
	H5Pget_mpio_no_collective_cause
* The following new Fortran subroutine has been added:
	h5pget_mpio_actual_io_mode_f
* The syntax of the following high-level C function has changed:
	H5TBAget_fill
This function’s return type has been changed to h5tri_t. A return value of 1 indicates that a fill value is present, 0 indicates that no fill value is present, and a negative value indicates an error. (The former return type was herr_t.)
Note that H5TBAget_fill and a companion function H5TBAget_title, both in the HDF5 Table (H5TB) high-level API, are undocumented. These functions will be added to the HDF5 Reference Manual shortly after HDF5 Release 1.8.10.

Changed Command-line Tool
* h5import has been updated to accept an input file created by h5dump.
This commit is contained in:
adam 2012-12-09 00:07:38 +00:00
parent 8c28d8fdfc
commit 1bcf58e4aa
16 changed files with 46 additions and 167 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.45 2011/10/07 10:38:50 alnsn Exp $
# $NetBSD: Makefile,v 1.46 2012/12/09 00:07:38 adam Exp $
PKGNAME= hdf5-${HDF5_VER}
COMMENT= Hierarchical Data Format (new generation)
@ -9,14 +9,14 @@ INSTALLATION_DIRS+= share/examples/hdf5/c
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/tools/misc/h5cc \
${DESTDIR}${PREFIX}/bin/
${DESTDIR}${PREFIX}/bin/
${INSTALL_SCRIPT} ${WRKSRC}/tools/misc/h5redeploy.in \
${DESTDIR}${PREFIX}/bin/h5redeploy
${DESTDIR}${PREFIX}/bin/h5redeploy
cd ${WRKSRC} && ${INSTALL_DATA} COPYING \
release_docs/RELEASE.txt \
release_docs/HISTORY-1_8.txt \
release_docs/HISTORY-1_0-1_8_0_rc3.txt \
${DESTDIR}${PREFIX}/share/doc/hdf5/
release_docs/RELEASE.txt \
release_docs/HISTORY-1_8.txt \
release_docs/HISTORY-1_0-1_8_0_rc3.txt \
${DESTDIR}${PREFIX}/share/doc/hdf5/
.include "Makefile.common"
.include "options.mk"

View file

@ -1,14 +1,15 @@
# $NetBSD: Makefile.common,v 1.4 2012/10/31 11:17:05 asau Exp $
# $NetBSD: Makefile.common,v 1.5 2012/12/09 00:07:38 adam Exp $
# used by devel/hdf5/Makefile
# used by devel/hdf5-c++/Makefile
HDF5_VER= 1.8.9
HDF5_VER= 1.8.10
DISTNAME= hdf5-${HDF5_VER}
CATEGORIES= devel
MASTER_SITES= ftp://ftp.hdfgroup.org/HDF5/current/src/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= alnsn@NetBSD.org
HOMEPAGE= http://www.hdfgroup.org/HDF5/
LICENSE= original-bsd
USE_LIBTOOL= yes

View file

@ -1,22 +1,15 @@
$NetBSD: distinfo,v 1.28 2012/10/27 08:54:48 asau Exp $
$NetBSD: distinfo,v 1.29 2012/12/09 00:07:38 adam Exp $
SHA1 (hdf5-1.8.9.tar.gz) = 4ba3ede947b1571e9586fdeb8351d6585a56133c
RMD160 (hdf5-1.8.9.tar.gz) = a971f0f666786d93f33f8cc59d67e29fab77a351
Size (hdf5-1.8.9.tar.gz) = 8258774 bytes
SHA1 (patch-c++_examples_Makefile.in) = 4c063e3138507a5dbf99f4c7785611a45ffcf753
SHA1 (hdf5-1.8.10.tar.bz2) = 867a91b75ee0bbd1f1b13aecd52e883be1507a2c
RMD160 (hdf5-1.8.10.tar.bz2) = 78fe33ae4205068f7bddeb98f0e7a2c77310b651
Size (hdf5-1.8.10.tar.bz2) = 6024645 bytes
SHA1 (patch-c++_examples_Makefile.in) = 9ae14ae81abc9c858abb0d03b92e498b2113591c
SHA1 (patch-c++_examples_run-c++-ex.sh.in) = 58c38b2ba5557cdae2c4fe1e72c6fa55e5606f1e
SHA1 (patch-configure.in) = c08f39c3aba0ff34022d4afc26cdfd8785f504b7
SHA1 (patch-examples_Makefile.in) = 3049b17a6656e7b9818ec69607b278b6e7dc937d
SHA1 (patch-configure) = b8d6e6e53ecb5e5861fba88be1a203cedf6747b3
SHA1 (patch-examples_Makefile.in) = 93d0764eaa8ccebdd3705195ba0ffc5fa83c2610
SHA1 (patch-examples_run-c-ex.sh.in) = 744d3e6bbae1a9b496e3657db6a62fac78fcd7ed
SHA1 (patch-hl_c++_examples_Makefile.in) = 6e651fae42365e67c281d8bc80e2c60faeddec01
SHA1 (patch-hl_c++_examples_Makefile.in) = a3310436f9f73946fba0d404158c990d68638f16
SHA1 (patch-hl_c++_examples_run-hlc++-ex.sh.in) = fba3d976adb02d80682ddc42a8ef64f6dddffa41
SHA1 (patch-hl_examples_Makefile.in) = 2fe09e8a88eeca49db58908a6b4a3a70f01cb0b4
SHA1 (patch-hl_examples_run-hlc-ex.sh.in) = 38c2c112439d6febb023d638d965f04bbaa45d5f
SHA1 (patch-tools_h5copy_testh5copy.sh) = 745f951117bbc1a05fbfb6df8cdff3d58771c635
SHA1 (patch-tools_h5diff_testh5diff.sh) = 62e02ee65a4b9284f548f872aad9bcf7884fb477
SHA1 (patch-tools_h5dump_testh5dump.sh.in) = d373f9a0618499bbb71827df6ffe6bed2b5dab17
SHA1 (patch-tools_h5import_h5importtestutil.sh) = 7bd31ce6ca50c0a8d4040b7d2518dc4658b51c5c
SHA1 (patch-tools_h5jam_testh5jam.sh.in) = 1d8d618ee90adfe6735a22eecd1a6c60c1437da6
SHA1 (patch-tools_h5ls_testh5ls.sh.in) = 71bfe26ce98d3579bf8decaf7ef10a5f5f27e255
SHA1 (patch-tools_h5repack_h5repack.sh.in) = c235aef4f6c781ef0028685b505fd77aa7b5722d
SHA1 (patch-tools_h5stat_testh5stat.sh.in) = 962ff9cdf8c7c459e47147cf85826e190aee4179
SHA1 (patch-tools_h5jam_testh5jam.sh.in) = 89068ae1694c586f85b25240fda30549eddf2d0f

View file

@ -1,10 +1,10 @@
$NetBSD: patch-c++_examples_Makefile.in,v 1.1 2011/10/07 10:38:51 alnsn Exp $
$NetBSD: patch-c++_examples_Makefile.in,v 1.2 2012/12/09 00:07:38 adam Exp $
Fix paths to examples.
--- c++/examples/Makefile.in.orig 2011-05-10 14:20:43.000000000 +0000
+++ c++/examples/Makefile.in
@@ -376,7 +376,7 @@ CXX_API = yes
@@ -405,7 +405,7 @@ CXX_API = yes
# Where to install examples
# Note: no '/' after DESTDIR. Explanation in commence.am

View file

@ -0,0 +1,18 @@
$NetBSD: patch-configure,v 1.1 2012/12/09 00:07:38 adam Exp $
Unreverse order of CPPFLAGS.
--- configure.orig 2012-10-27 00:14:59.000000000 +0000
+++ configure
@@ -30787,9 +30787,9 @@ if test -n "$AM_CPPFLAGS"; then
d="-I${ROOT}/${d}"
;;
esac
- TEMP_CPPFLAGS="$d $TEMP_CPPFLAGS"
+ TEMP_CPPFLAGS="$TEMP_CPPFLAGS $d"
done
- AM_CPPFLAGS=$TEMP_CPPFLAGS
+ AM_CPPFLAGS="$TEMP_CPPFLAGS"
fi
## ----------------------------------------------------------------------

View file

@ -1,18 +0,0 @@
$NetBSD: patch-configure.in,v 1.1 2011/10/07 10:38:51 alnsn Exp $
Unreverses order of CPPFLAGS.
--- configure.in.orig 2011-05-10 14:20:36.000000000 +0000
+++ configure.in
@@ -4121,9 +4121,9 @@ if test -n "$AM_CPPFLAGS"; then
d="-I${ROOT}/${d}"
;;
esac
- TEMP_CPPFLAGS="$d $TEMP_CPPFLAGS"
+ TEMP_CPPFLAGS="$TEMP_CPPFLAGS $d"
done
- AM_CPPFLAGS=$TEMP_CPPFLAGS
+ AM_CPPFLAGS="$TEMP_CPPFLAGS"
fi
dnl ----------------------------------------------------------------------

View file

@ -1,10 +1,10 @@
$NetBSD: patch-examples_Makefile.in,v 1.1 2011/10/07 10:38:51 alnsn Exp $
$NetBSD: patch-examples_Makefile.in,v 1.2 2012/12/09 00:07:38 adam Exp $
Fix paths to examples.
--- examples/Makefile.in.orig 2011-05-10 14:20:44.000000000 +0000
+++ examples/Makefile.in
@@ -387,8 +387,8 @@ EXTLINK_DIRS = red blue u2w
@@ -417,8 +417,8 @@ EXTLINK_DIRS = red blue u2w
# Example directory
# Note: no '/' after DESTDIR. Explanation in commence.am

View file

@ -1,10 +1,10 @@
$NetBSD: patch-hl_c++_examples_Makefile.in,v 1.1 2011/10/07 10:38:52 alnsn Exp $
$NetBSD: patch-hl_c++_examples_Makefile.in,v 1.2 2012/12/09 00:07:38 adam Exp $
Fix paths to examples.
--- hl/c++/examples/Makefile.in.orig 2011-05-10 14:20:48.000000000 +0000
+++ hl/c++/examples/Makefile.in
@@ -372,7 +372,7 @@ CXX_API = yes
@@ -401,7 +401,7 @@ CXX_API = yes
# Where to install examples
# Note: no '/' after DESTDIR. Explanation in commence.am

View file

@ -1,15 +0,0 @@
$NetBSD: patch-tools_h5copy_testh5copy.sh,v 1.1 2012/10/27 08:54:48 asau Exp $
Use portable construct to check file existence.
--- tools/h5copy/testh5copy.sh.orig 2012-05-09 15:06:14.000000000 +0000
+++ tools/h5copy/testh5copy.sh
@@ -105,7 +105,7 @@ COPY_TESTFILES_TO_TESTDIR()
echo $tstfile | tr -d ' ' | grep '^#' > /dev/null
RET=$?
if [ $RET -eq 1 ]; then
- if [ -a $tstfile ]; then
+ if [ -e $tstfile ]; then
$CP -f $tstfile $TESTDIR
else
echo "Error: FAILED to copy $tstfile."

View file

@ -1,15 +0,0 @@
$NetBSD: patch-tools_h5diff_testh5diff.sh,v 1.1 2012/10/27 08:54:48 asau Exp $
Use portable construct to check file existence.
--- tools/h5diff/testh5diff.sh.orig 2012-05-09 15:06:12.000000000 +0000
+++ tools/h5diff/testh5diff.sh
@@ -313,7 +313,7 @@ COPY_TESTFILES_TO_TESTDIR()
echo $tstfile | tr -d ' ' | grep '^#' > /dev/null
RET=$?
if [ $RET -eq 1 ]; then
- if [ -a $tstfile ]; then
+ if [ -e $tstfile ]; then
$CP -f $tstfile $TESTDIR
else
echo "Error: FAILED to copy $tstfile ."

View file

@ -1,15 +0,0 @@
$NetBSD: patch-tools_h5dump_testh5dump.sh.in,v 1.1 2012/10/27 08:54:48 asau Exp $
Use portable construct to check file existence.
--- tools/h5dump/testh5dump.sh.in.orig 2012-05-09 15:06:02.000000000 +0000
+++ tools/h5dump/testh5dump.sh.in
@@ -448,7 +448,7 @@ COPY_TESTFILES_TO_TESTDIR()
echo $tstfile | tr -d ' ' | grep '^#' > /dev/null
RET=$?
if [ $RET -eq 1 ]; then
- if [ -a $tstfile ]; then
+ if [ -e $tstfile ]; then
$CP -f $tstfile $TESTDIR
else
echo "Error: FAILED to copy $tstfile"

View file

@ -1,15 +0,0 @@
$NetBSD: patch-tools_h5import_h5importtestutil.sh,v 1.1 2012/10/27 08:54:48 asau Exp $
Use portable construct to check file existence.
--- tools/h5import/h5importtestutil.sh.orig 2012-05-09 15:06:14.000000000 +0000
+++ tools/h5import/h5importtestutil.sh
@@ -115,7 +115,7 @@ COPY_TESTFILES_TO_TESTDIR()
echo $tstfile | tr -d ' ' | grep '^#' > /dev/null
RET=$?
if [ $RET -eq 1 ]; then
- if [ -a $tstfile ]; then
+ if [ -e $tstfile ]; then
$CP -f $tstfile $TESTDIR
else
echo "Error: FAILED to copy $tstfile"

View file

@ -1,20 +1,10 @@
$NetBSD: patch-tools_h5jam_testh5jam.sh.in,v 1.1 2012/10/27 08:54:48 asau Exp $
$NetBSD: patch-tools_h5jam_testh5jam.sh.in,v 1.2 2012/12/09 00:07:39 adam Exp $
Use portable construct to check file existence.
Use portable "=" to test string equality.
--- tools/h5jam/testh5jam.sh.in.orig 2012-05-09 15:06:08.000000000 +0000
+++ tools/h5jam/testh5jam.sh.in
@@ -103,7 +103,7 @@ COPY_TESTFILES_TO_TESTDIR()
echo $tstfile | tr -d ' ' | grep '^#' > /dev/null
RET=$?
if [ $RET -eq 1 ]; then
- if [ -a $tstfile ]; then
+ if [ -e $tstfile ]; then
$CP -f $tstfile $TESTDIR
else
echo "Error: FAILED to copy $tstfile"
@@ -456,9 +456,9 @@ UNJAMTEST () {
@@ -464,9 +464,9 @@ UNJAMTEST () {
#
TOOLTEST_OUTPUT() {

View file

@ -1,15 +0,0 @@
$NetBSD: patch-tools_h5ls_testh5ls.sh.in,v 1.1 2012/10/27 08:54:48 asau Exp $
Use portable construct to check file existence.
--- tools/h5ls/testh5ls.sh.in.orig 2012-05-09 15:06:15.000000000 +0000
+++ tools/h5ls/testh5ls.sh.in
@@ -167,7 +167,7 @@ COPY_TESTFILES_TO_TESTDIR()
echo $tstfile | tr -d ' ' | grep '^#' > /dev/null
RET=$?
if [ $RET -eq 1 ]; then
- if [ -a $tstfile ]; then
+ if [ -e $tstfile ]; then
$CP -f $tstfile $TESTDIR
else
echo "Error: FAILED to copy $tstfile"

View file

@ -1,15 +0,0 @@
$NetBSD: patch-tools_h5repack_h5repack.sh.in,v 1.1 2012/10/27 08:54:48 asau Exp $
Use portable construct to check file existence.
--- tools/h5repack/h5repack.sh.in.orig 2012-05-09 15:06:03.000000000 +0000
+++ tools/h5repack/h5repack.sh.in
@@ -137,7 +137,7 @@ COPY_TESTFILES_TO_TESTDIR()
echo $tstfile | tr -d ' ' | grep '^#' > /dev/null
RET=$?
if [ $RET -eq 1 ]; then
- if [ -a $tstfile ]; then
+ if [ -e $tstfile ]; then
$CP -f $tstfile $TESTDIR
else
echo "Error: FAILED to copy $tstfile"

View file

@ -1,15 +0,0 @@
$NetBSD: patch-tools_h5stat_testh5stat.sh.in,v 1.1 2012/10/27 08:54:48 asau Exp $
Use portable construct to check file existence.
--- tools/h5stat/testh5stat.sh.in.orig 2012-05-09 15:06:15.000000000 +0000
+++ tools/h5stat/testh5stat.sh.in
@@ -105,7 +105,7 @@ COPY_TESTFILES_TO_TESTDIR()
echo $tstfile | tr -d ' ' | grep '^#' > /dev/null
RET=$?
if [ $RET -eq 1 ]; then
- if [ -a $tstfile ]; then
+ if [ -e $tstfile ]; then
$CP -f $tstfile $TESTDIR
else
echo "Error: FAILED to copy $tstfile"