Update sysutils/syslog-ng* to 3.11.1.
3.11.1 Features - Add geoip2 parser and template function. - Add SSL support to AMQP. - Add template option to apache-accesslog-parser. - Add configurable event time to Riemann destination. - Add drop-unmatched() option to dbparser. - Add Ubuntu Xenial to the bundled docker images. - Support multi-instance support for Solaris 10 and 11. - Support multi-instance for systemd. - Add configurable timeout to HTTP destination. - Add prefix() option to cisco-parser. Bugfixes - Fix a memory usage counter underflow for threaded destination drivers and writers. - Fix a potential crash in AMQP. - Fix a potential crash during reload. - Fix a reload/shutdown issue. - Fix a potential crash in afsocket destination during reload. - Fix a counter registration bug. - Fix a build issue on FreeBSD. - Fix a memory leak in diskq plugin. - Fix systemd-journal error codes validation. - Fix a potential crash in diskq when it is used with file destination and the file is reaped. - Fix a memory leak in HTTP destination - Fix ENABLE_DEBUG in dbparser. - Fix a unit tests that caused build issue on 32 bit platforms. Other changes - The eventlog library is part of syslog-ng from now. - Improve error messages when the config cannot be initialized. - Improve source suspended/resumed debug messages. - Rename syslog-debun to syslog-ng-debun. - Update manpages to v3.11 - Remove tgz2build directory. 3.10.1 Features - Support https in http (curl) module - Docker support : from now Dockerfile for CentOS7, Ubuntu Zesty and for Debian Jessie is part of our upstream - Add --database parameter for geoip template function - Metric improvements - Add snmp-parser (v1, v2) - Add snmp-soure - Add osquery source - Add cisco-parser - Add wildcard filesource - Add startdate template function - Add $(basename) and $(dirname) template functions - Add Kerberos support for HDFS destination - Add AUTH support for redis destination - Add map-value-pairs() parser - Extend Python language binding by Python parser - Add support for extract-stray-words() option in kv-parser() - Add $(context-values) template function - Add $(context-lookup) function - Add list related template functions - Add add query commands to syslog-ng-ctl - Support multiple servers in elasticsearch2-http destination - Implements elastic-v2 https in http mode - Add getent module (ported from incubator) - Add support for IP_FREEBIND Bugfixes - Fix a libnet detection check error that caused problem configuring enable-spoof-source. - Avoid warnings about _DEFAULT_SOURCE on recent glibc versions - Fix invalid database warning for geoip parser - Fix prefix() default in systemd-journal for new config versions - Fix a potential message loss in Riemann destination - Fix a potential crash in the Riemann destination when the client is not connected to the Riemann server. - Fix a possible add-contextual-data() related data loss in case of multiple reference to the same add-contextual-data parser in several logpaths. - Fix dbparser deadlock - Fix Python destination - Fix processed stats counter for afsocket - Fix stats source for pipes - Fix csv-parser multithreaded support - Fix a message loss in case of filesource when syslog-ng was restarted and the log_msg_size > file size. - Fix a potential crash in cryptofuncs - Fix a potential crash in syslog-ng-ctl when no command line parameters was set. - Fix token duplication in the output of '--preprocess-into' - Fix UTF-8 support in syslog-ng-ctl - Fix a potential crash during X.509 certificate validation. - Fix a segfault in Python module startup - Fix a possible endless reading loop issue in case of multi-line filesource. - Fix soname for the http module from "curl" to "http" - Avoid openssl 1.1.0 deprecated APIs Other changes - Increase processed counter by queued counter after reload or restart when diskqueue is used otherwise the newly added written counter would underflow. - Set the default time-zone to UTC for elasticsearch2 - Add retries support for python destination - Prefer server side cipher suite order - Always include librabbitmq in the dist tarball - Always include ivykis in the dist tarball - Marking parse error locations with >@<. - Default log_msg_size is increased to 64Kbyte from 8Kb - Tons of syslog-debun improvements - Exit with 0 return code when --help is specified for syslog-ng-ctl - syslog-ng: make '--preprocess-into' foreground only - Add debug messages on log_msg_set_value() - Add more detail to filter evaluation related debug messages
This commit is contained in:
parent
c9d4ef7df6
commit
1bd43f3d7d
9 changed files with 95 additions and 21 deletions
|
@ -1,9 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.6 2017/08/24 20:03:40 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.7 2017/08/31 12:53:50 fhajny Exp $
|
||||
|
||||
SYSLOG_MOD= http
|
||||
SYSLOG_MOD_TARGET= curl
|
||||
COMMENT= Syslog-ng curl module
|
||||
PKGREVISION= 2
|
||||
|
||||
.include "../../sysutils/syslog-ng/Makefile.module"
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2016/08/21 20:20:59 fhajny Exp $
|
||||
lib/syslog-ng/libcurl.la
|
||||
@comment $NetBSD: PLIST,v 1.2 2017/08/31 12:53:50 fhajny Exp $
|
||||
lib/syslog-ng/libhttp.la
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.29 2017/01/10 18:54:15 fhajny Exp $
|
||||
# $NetBSD: Makefile,v 1.30 2017/08/31 12:53:50 fhajny Exp $
|
||||
|
||||
.include "../../sysutils/syslog-ng/Makefile.common"
|
||||
|
||||
|
@ -12,6 +12,9 @@ CPPFLAGS.SunOS+= -D_XOPEN_SOURCE=600 -D__EXTENSIONS__
|
|||
|
||||
.include "options.mk"
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 27
|
||||
REPLACE_PYTHON+= lib/merge-grammar.py
|
||||
|
||||
BUILD_DEFS+= VARBASE
|
||||
|
||||
PKG_SYSCONFSUBDIR= syslog-ng
|
||||
|
@ -40,12 +43,12 @@ PKGCONFIG_OVERRIDE= libtest/syslog-ng-test.pc.in \
|
|||
syslog-ng.pc.in
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/INSTALL ${DESTDIR}${DOCDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/contrib/syslog-ng.conf.doc ${DESTDIR}${DOCDIR}
|
||||
.for f in syslog-ng.conf.RedHat syslog-ng.conf.SunOS
|
||||
.for f in syslog-ng.conf.HP-UX syslog-ng.conf.RedHat syslog-ng.conf.SunOS
|
||||
${INSTALL_DATA} ${WRKSRC}/contrib/${f} ${DESTDIR}${EGDIR}
|
||||
.endfor
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/contrib/syslog2ng ${DESTDIR}${PREFIX}/bin
|
||||
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../security/tcp_wrappers/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile.common,v 1.5 2017/01/10 18:54:15 fhajny Exp $
|
||||
# $NetBSD: Makefile.common,v 1.6 2017/08/31 12:53:50 fhajny Exp $
|
||||
# used by sysutils/syslog-ng/Makefile
|
||||
# used by sysutils/syslog-ng/Makefile.module
|
||||
|
||||
DISTNAME= syslog-ng-3.9.1
|
||||
DISTNAME= syslog-ng-3.11.1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=balabit/}
|
||||
|
||||
|
@ -47,6 +47,7 @@ CONFIGURE_ARGS+= --with-librabbitmq-client=no
|
|||
CONFIGURE_ARGS+= --with-pidfile-dir=${VARBASE}/run
|
||||
|
||||
CONFIGURE_ARGS.SunOS+= --enable-dynamic-linking
|
||||
CONFIGURE_ARGS.SunOS+= ac_cv_func_inotify_init=no
|
||||
|
||||
SUBST_CLASSES+= unamepath
|
||||
SUBST_STAGE.unamepath= post-configure
|
||||
|
@ -54,7 +55,6 @@ SUBST_FILES.unamepath= contrib/syslog2ng
|
|||
SUBST_VARS.unamepath= UNAME
|
||||
|
||||
REPLACE_AWK+= contrib/syslog2ng
|
||||
REPLACE_PERL+= lib/merge-grammar.pl
|
||||
|
||||
.include "../../converters/libiconv/buildlink3.mk"
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
|
@ -62,5 +62,4 @@ REPLACE_PERL+= lib/merge-grammar.pl
|
|||
.include "../../devel/ivykis/buildlink3.mk"
|
||||
.include "../../devel/pcre/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../sysutils/eventlog/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.module,v 1.2 2016/08/21 20:18:30 fhajny Exp $
|
||||
# $NetBSD: Makefile.module,v 1.3 2017/08/31 12:53:50 fhajny Exp $
|
||||
# used by sysutils/py-syslog-ng/Makefile
|
||||
# used by sysutils/syslog-ng-amqp/Makefile
|
||||
# used by sysutils/syslog-ng-curl/Makefile
|
||||
|
@ -22,6 +22,7 @@ SYSLOG_MOD_TARGET?= ${SYSLOG_MOD_DIR}
|
|||
BUILD_TARGET?= modules/${SYSLOG_MOD_DIR}/lib${SYSLOG_MOD_TARGET}.la
|
||||
|
||||
INSTALL_TARGET= install-moduleLTLIBRARIES
|
||||
INSTALL_MAKE_FLAGS+= lib_LTLIBRARIES=""
|
||||
INSTALL_MAKE_FLAGS+= module_LTLIBRARIES=${BUILD_TARGET}
|
||||
|
||||
INSTALLATION_DIRS= lib/syslog-ng
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.10 2017/01/10 18:54:15 fhajny Exp $
|
||||
@comment $NetBSD: PLIST,v 1.11 2017/08/31 12:53:50 fhajny Exp $
|
||||
bin/dqtool
|
||||
bin/loggen
|
||||
bin/pdbtool
|
||||
|
@ -25,10 +25,13 @@ include/syslog-ng/compat/getutent.h
|
|||
include/syslog-ng/compat/glib.h
|
||||
include/syslog-ng/compat/lfs.h
|
||||
include/syslog-ng/compat/openssl_support.h
|
||||
include/syslog-ng/compat/pcre.h
|
||||
include/syslog-ng/compat/pio.h
|
||||
include/syslog-ng/compat/socket.h
|
||||
include/syslog-ng/compat/string.h
|
||||
include/syslog-ng/compat/time.h
|
||||
include/syslog-ng/control/control-commands.h
|
||||
include/syslog-ng/control/control-main.h
|
||||
include/syslog-ng/control/control-server.h
|
||||
include/syslog-ng/control/control.h
|
||||
include/syslog-ng/crypto.h
|
||||
|
@ -37,6 +40,8 @@ include/syslog-ng/debugger/debugger.h
|
|||
include/syslog-ng/debugger/tracer.h
|
||||
include/syslog-ng/dnscache.h
|
||||
include/syslog-ng/driver.h
|
||||
include/syslog-ng/evtlog.h
|
||||
include/syslog-ng/evtmaps.h
|
||||
include/syslog-ng/fdhelpers.h
|
||||
include/syslog-ng/file-perms.h
|
||||
include/syslog-ng/filter/filter-call.h
|
||||
|
@ -58,6 +63,7 @@ include/syslog-ng/gsocket.h
|
|||
include/syslog-ng/host-id.h
|
||||
include/syslog-ng/host-resolve.h
|
||||
include/syslog-ng/hostname.h
|
||||
include/syslog-ng/libtest/license_module_mock.h
|
||||
include/syslog-ng/libtest/mock-transport.h
|
||||
include/syslog-ng/libtest/msg_parse_lib.h
|
||||
include/syslog-ng/libtest/persist_lib.h
|
||||
|
@ -118,6 +124,7 @@ include/syslog-ng/parse-number.h
|
|||
include/syslog-ng/parser/parser-expr-parser.h
|
||||
include/syslog-ng/parser/parser-expr.h
|
||||
include/syslog-ng/pathutils.h
|
||||
include/syslog-ng/pe-versioning.h
|
||||
include/syslog-ng/persist-state.h
|
||||
include/syslog-ng/persistable-state-header.h
|
||||
include/syslog-ng/persistable-state-presenter.h
|
||||
|
@ -140,14 +147,21 @@ include/syslog-ng/rewrite/rewrite-unset.h
|
|||
include/syslog-ng/ringbuffer.h
|
||||
include/syslog-ng/run-id.h
|
||||
include/syslog-ng/scanner/csv-scanner/csv-scanner.h
|
||||
include/syslog-ng/scanner/kv-scanner/kv-scanner.h
|
||||
include/syslog-ng/scanner/list-scanner/list-scanner.h
|
||||
include/syslog-ng/scratch-buffers.h
|
||||
include/syslog-ng/seqnum.h
|
||||
include/syslog-ng/serialize.h
|
||||
include/syslog-ng/service-management.h
|
||||
include/syslog-ng/stats/stats-cluster-logpipe.h
|
||||
include/syslog-ng/stats/stats-cluster-single.h
|
||||
include/syslog-ng/stats/stats-cluster.h
|
||||
include/syslog-ng/stats/stats-control.h
|
||||
include/syslog-ng/stats/stats-counter.h
|
||||
include/syslog-ng/stats/stats-csv.h
|
||||
include/syslog-ng/stats/stats-log.h
|
||||
include/syslog-ng/stats/stats-query-commands.h
|
||||
include/syslog-ng/stats/stats-query.h
|
||||
include/syslog-ng/stats/stats-registry.h
|
||||
include/syslog-ng/stats/stats-syslog.h
|
||||
include/syslog-ng/stats/stats.h
|
||||
|
@ -188,6 +202,7 @@ include/syslog-ng/value-pairs/evttag.h
|
|||
include/syslog-ng/value-pairs/transforms.h
|
||||
include/syslog-ng/value-pairs/value-pairs.h
|
||||
include/syslog-ng/versioning.h
|
||||
lib/libevtlog.la
|
||||
lib/libsyslog-ng-native-connector.a
|
||||
lib/libsyslog-ng.la
|
||||
lib/pkgconfig/syslog-ng-add-contextual-data.pc
|
||||
|
@ -211,21 +226,27 @@ lib/syslog-ng/libdisk-buffer.la
|
|||
lib/syslog-ng/libgraphite.la
|
||||
lib/syslog-ng/libkvformat.la
|
||||
lib/syslog-ng/liblinux-kmsg-format.la
|
||||
lib/syslog-ng/libmap-value-pairs.la
|
||||
lib/syslog-ng/libpseudofile.la
|
||||
${PLIST.systemd}lib/syslog-ng/libsdjournal.la
|
||||
lib/syslog-ng/libsnmptrapd-parser.la
|
||||
lib/syslog-ng/libstardate.la
|
||||
lib/syslog-ng/libsyslogformat.la
|
||||
lib/syslog-ng/libsystem-source.la
|
||||
lib/syslog-ng/libtest/libsyslog-ng-test.a
|
||||
lib/syslog-ng/libtfgetent.la
|
||||
sbin/syslog-ng
|
||||
sbin/syslog-ng-ctl
|
||||
share/doc/syslog-ng/INSTALL
|
||||
sbin/syslog-ng-debun
|
||||
share/doc/syslog-ng/syslog-ng.conf.doc
|
||||
share/examples/syslog-ng/scl.conf
|
||||
share/examples/syslog-ng/syslog-ng.conf
|
||||
share/examples/syslog-ng/syslog-ng.conf.HP-UX
|
||||
share/examples/syslog-ng/syslog-ng.conf.RedHat
|
||||
share/examples/syslog-ng/syslog-ng.conf.SunOS
|
||||
share/syslog-ng/include/scl/apache/apache.conf
|
||||
share/syslog-ng/include/scl/cim/template.conf
|
||||
share/syslog-ng/include/scl/cisco/plugin.conf
|
||||
share/syslog-ng/include/scl/elasticsearch/plugin.conf
|
||||
share/syslog-ng/include/scl/graphite/README
|
||||
share/syslog-ng/include/scl/graphite/plugin.conf
|
||||
|
@ -235,8 +256,10 @@ share/syslog-ng/include/scl/loggly/loggly.conf
|
|||
share/syslog-ng/include/scl/logmatic/logmatic.conf
|
||||
share/syslog-ng/include/scl/mbox/mbox.conf
|
||||
share/syslog-ng/include/scl/nodejs/plugin.conf
|
||||
share/syslog-ng/include/scl/osquery/plugin.conf
|
||||
share/syslog-ng/include/scl/pacct/plugin.conf
|
||||
share/syslog-ng/include/scl/rewrite/cc-mask.conf
|
||||
share/syslog-ng/include/scl/snmptrap/snmptrapd-source.conf
|
||||
share/syslog-ng/include/scl/solaris/plugin.conf
|
||||
share/syslog-ng/include/scl/syslogconf/README
|
||||
share/syslog-ng/include/scl/syslogconf/convert-syslogconf.awk
|
||||
|
@ -244,7 +267,7 @@ share/syslog-ng/include/scl/syslogconf/plugin.conf
|
|||
share/syslog-ng/include/scl/system/plugin.conf
|
||||
share/syslog-ng/tools/cfg-grammar.y
|
||||
share/syslog-ng/tools/lex-rules.am
|
||||
share/syslog-ng/tools/merge-grammar.pl
|
||||
share/syslog-ng/tools/merge-grammar.py
|
||||
share/syslog-ng/tools/system-expand.sh
|
||||
share/syslog-ng/xsd/patterndb-1.xsd
|
||||
share/syslog-ng/xsd/patterndb-2.xsd
|
||||
|
|
|
@ -1,10 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.8 2017/01/10 18:54:15 fhajny Exp $
|
||||
$NetBSD: distinfo,v 1.9 2017/08/31 12:53:50 fhajny Exp $
|
||||
|
||||
SHA1 (syslog-ng-3.9.1.tar.gz) = 1ca437393d8895654452bef8ac0b996fe73284f8
|
||||
RMD160 (syslog-ng-3.9.1.tar.gz) = 20bbcab38d02c369aa964c364fa2acdcfa86a673
|
||||
SHA512 (syslog-ng-3.9.1.tar.gz) = aade44fa6dffa7e84fc951aa20f0e40db2ee6438f46108c95244e465b1fafc08e6f9afab12c057576d601cc51dd7cefb16370183ca036af0d68046fdb29fdd02
|
||||
Size (syslog-ng-3.9.1.tar.gz) = 8312677 bytes
|
||||
SHA1 (syslog-ng-3.11.1.tar.gz) = 81bb726c9823a3af9701a4297311e71f68050ccb
|
||||
RMD160 (syslog-ng-3.11.1.tar.gz) = 0a83af1872e993991ae19d14c6b73f0abbf2bc9a
|
||||
SHA512 (syslog-ng-3.11.1.tar.gz) = 780fa81daaf4cf327e2b8203e89dca6a8dcf51bf01a16eab672c536eae9e28bac6d5e19c46630806b6c7ea6f3fdcfb625e733be092a360897b234f46f9ae8c51
|
||||
Size (syslog-ng-3.11.1.tar.gz) = 8523684 bytes
|
||||
SHA1 (patch-ac) = 7d48f689b6ff69c68697baf729fba8be9aec5ce8
|
||||
SHA1 (patch-configure) = 2d8ef2285de44de016f44e51be47cd4c1178dfdb
|
||||
SHA1 (patch-lib_ivykis_src_iv__fd__port.c) = a6b1feafd7c8031a1ed7d2cb0abc57ca3633fb5a
|
||||
SHA1 (patch-modules_getent_getent-protocols.c) = 43f16088a5303b6d61a1a9342a3b4f076a87b96d
|
||||
SHA1 (patch-modules_getent_getent-services.c) = d8121893407f10e0fb0a38b766eb0360717604d1
|
||||
SHA1 (patch-modules_system-source_system-source.c) = f51ed8d2e6d603744b3e6636eeb9c68382e5cda6
|
||||
|
|
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-modules_getent_getent-protocols.c,v 1.1 2017/08/31 12:53:50 fhajny Exp $
|
||||
|
||||
Different arg count on SunOS (at least).
|
||||
|
||||
--- modules/getent/getent-protocols.c.orig 2017-07-31 10:40:19.000000000 +0000
|
||||
+++ modules/getent/getent-protocols.c
|
||||
@@ -29,9 +29,17 @@ tf_getent_protocols(gchar *key, gchar *m
|
||||
char buf[4096];
|
||||
|
||||
if ((is_num = parse_number(key, &d)) == TRUE)
|
||||
+#if defined(__sun)
|
||||
+ res = getprotobynumber_r((int) d, &proto, buf, sizeof(buf));
|
||||
+#else
|
||||
getprotobynumber_r((int) d, &proto, buf, sizeof(buf), &res);
|
||||
+#endif
|
||||
else
|
||||
+#if defined(__sun)
|
||||
+ res = getprotobyname_r(key, &proto, buf, sizeof(buf));
|
||||
+#else
|
||||
getprotobyname_r(key, &proto, buf, sizeof(buf), &res);
|
||||
+#endif
|
||||
|
||||
if (res == NULL)
|
||||
return TRUE;
|
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-modules_getent_getent-services.c,v 1.1 2017/08/31 12:53:50 fhajny Exp $
|
||||
|
||||
Different arg count on SunOS (at least).
|
||||
|
||||
--- modules/getent/getent-services.c.orig 2017-07-31 10:40:19.000000000 +0000
|
||||
+++ modules/getent/getent-services.c
|
||||
@@ -29,9 +29,17 @@ tf_getent_services(gchar *key, gchar *me
|
||||
char buf[4096];
|
||||
|
||||
if ((is_num = parse_number(key, &d)) == TRUE)
|
||||
+#if defined(__sun)
|
||||
+ res = getservbyport_r((int)ntohs(d), NULL, &serv, buf, sizeof(buf));
|
||||
+#else
|
||||
getservbyport_r((int)ntohs(d), NULL, &serv, buf, sizeof(buf), &res);
|
||||
+#endif
|
||||
else
|
||||
+#if defined(__sun)
|
||||
+ res = getservbyname_r(key, NULL, &serv, buf, sizeof(buf));
|
||||
+#else
|
||||
getservbyname_r(key, NULL, &serv, buf, sizeof(buf), &res);
|
||||
+#endif
|
||||
|
||||
if (res == NULL)
|
||||
return TRUE;
|
Loading…
Reference in a new issue