Update tcpdump to 4.0.0

Summary for 4.0.0 tcpdump release

Add support for Bluetooth Sniffing
Add support for Realtek Remote Control Protocol (openrrcp.org.ru)
Add support for 802.11 AVS
Add support for SMB over TCP
Add support for 4 byte BGP AS printing
Add support for compiling on case-insensitive file systems
Add support for ikev2 printing
Update support for decoding AFS
Update DHCPv6 printer
Use newer libpcap API's (allows -B option on all platforms)
Add -I to turn on monitor mode
Bugfixes in lldp, lspping, dccp, ESP, NFS printers
Cleanup unused files and various cruft

Per request in PR 40588. Addresses PR 37500 and PR 40203.
This commit is contained in:
asau 2009-05-20 20:09:33 +00:00
parent e840138df6
commit 1be342a8b7
5 changed files with 40 additions and 26 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.27 2008/06/20 01:09:31 joerg Exp $
# $NetBSD: Makefile,v 1.28 2009/05/20 20:09:33 asau Exp $
DISTNAME= tcpdump-3.9.7
PKGREVISION= 2
DISTNAME= tcpdump-4.0.0
CATEGORIES= net
MASTER_SITES= http://www.tcpdump.org/release/

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.16 2007/10/19 03:48:47 taca Exp $
$NetBSD: distinfo,v 1.17 2009/05/20 20:09:33 asau Exp $
SHA1 (tcpdump-3.9.7.tar.gz) = 5d2a95f0de1cbae70ba01c64f9a2c0fac0183dba
RMD160 (tcpdump-3.9.7.tar.gz) = 1c662f61c99121bfc8336eb059b60630cab03998
Size (tcpdump-3.9.7.tar.gz) = 873866 bytes
SHA1 (patch-af) = 5bf681fd99c2436875d7aafb8939fae231e906cf
SHA1 (tcpdump-4.0.0.tar.gz) = 618ac122d1a9d80f64865f0a4e4c4391baa54132
RMD160 (tcpdump-4.0.0.tar.gz) = 294e8cc7b7026357fa061c296434eab363281de1
Size (tcpdump-4.0.0.tar.gz) = 708774 bytes
SHA1 (patch-ag) = ff1d8c79e2137639e0a8aac2a18d18f09340c99a
SHA1 (patch-ah) = b6ca131244c11a63fb4f3044abba99d217bc80d5

View file

@ -1,18 +0,0 @@
$NetBSD: patch-af,v 1.3 2007/10/19 03:48:47 taca Exp $
--- print-rsvp.c.orig Thu Jun 14 10:03:21 2007
+++ print-rsvp.c
@@ -1574,11 +1574,12 @@ rsvp_obj_print (const u_char *tptr, cons
case RSVP_OBJ_LABEL_SET:
switch(rsvp_obj_ctype) {
+ u_int action, subchannel;
+
case RSVP_CTYPE_1:
if (obj_tlen < 4)
return-1;
- u_int action, subchannel;
action = (EXTRACT_16BITS(obj_tptr)>>8);
printf("%s Action: %s (%u), Label type: %u", ident,

View file

@ -0,0 +1,18 @@
$NetBSD: patch-ag,v 1.1 2009/05/20 20:09:33 asau Exp $
Fix breakage with IPv6 disabled.
--- print-enc.c.orig 2008-09-01 06:44:22.000000000 +0400
+++ print-enc.c 2009-05-20 11:05:45.000000000 +0400
@@ -77,9 +77,11 @@
case AF_INET:
ip_print(gndo, p, length);
break;
+#ifdef INET6
case AF_INET6:
ip6_print(p, length);
break;
+#endif
}
out:

View file

@ -0,0 +1,14 @@
$NetBSD: patch-ah,v 1.1 2009/05/20 20:09:33 asau Exp $
Don't install another copy.
--- Makefile.in.orig 2008-09-01 06:44:11.000000000 +0400
+++ Makefile.in 2009-05-20 11:08:24.000000000 +0400
@@ -325,7 +325,6 @@
[ -d $(DESTDIR)$(sbindir) ] || \
(mkdir -p $(DESTDIR)$(sbindir); chmod 755 $(DESTDIR)$(sbindir))
$(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(sbindir)/$(PROG)
- $(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(sbindir)/$(PROG).`cat ${srcdir}/VERSION`
[ -d $(DESTDIR)$(mandir)/man1 ] || \
(mkdir -p $(DESTDIR)$(mandir)/man1; chmod 755 $(DESTDIR)$(mandir)/man1)
$(INSTALL_DATA) $(srcdir)/$(PROG).1 $(DESTDIR)$(mandir)/man1/$(PROG).1