Update ktorrent to 2.2.1nb1. Fix compile on NetBSD/-current - from Bernd Ernesti - PR/36804

This commit is contained in:
abs 2007-08-23 16:40:29 +00:00
parent e44e2c60b8
commit 1beeafcfef
3 changed files with 19 additions and 8 deletions

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.10 2007/08/17 16:05:48 abs Exp $
# $NetBSD: Makefile,v 1.11 2007/08/23 16:40:29 abs Exp $
DISTNAME= ktorrent-${KTORRENT_VER}
PKGREVISION= 1
CATEGORIES= net kde
MASTER_SITES= http://ktorrent.org/downloads/${KTORRENT_VER}/

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.5 2007/08/17 16:05:48 abs Exp $
$NetBSD: distinfo,v 1.6 2007/08/23 16:40:29 abs Exp $
SHA1 (ktorrent-2.2.1.tar.gz) = 53dd36430fd47b396b16d30d466c45bd87ae40b2
RMD160 (ktorrent-2.2.1.tar.gz) = 329b6e0556a11875d7ce36d669c5c25370552936
Size (ktorrent-2.2.1.tar.gz) = 3763678 bytes
SHA1 (patch-aa) = ef4fb3204159a548ba13b8259efb1aa9cb50a19f
SHA1 (patch-ab) = ca44c60b7de0d9cc82d02b2266a9b95e34fa0bb0
SHA1 (patch-aa) = 77e5d150ba09f460e147664f6e0a97ebc40414c4
SHA1 (patch-ab) = 7deeb27c42d10f104852d227cacd5ddd54e46f49

View file

@ -1,12 +1,22 @@
$NetBSD: patch-ab,v 1.3 2007/07/22 08:38:58 abs Exp $
$NetBSD: patch-ab,v 1.4 2007/08/23 16:40:29 abs Exp $
--- plugins/stats/ChartDrawer.cc.orig 2007-07-18 15:37:03.000000000 +0100
--- plugins/stats/ChartDrawer.cc.orig 2007-07-23 17:43:08.000000000 +0100
+++ plugins/stats/ChartDrawer.cc
@@ -272,6 +272,8 @@ void ChartDrawer::AddValue(const size_t
@@ -25,6 +25,9 @@
int isinf(double x) { return !finite(x) && x==x; }
#endif
+#ifdef Q_OS_NETBSD
+#include <sys/param.h>
+#endif
namespace kt {
@@ -272,6 +275,8 @@ void ChartDrawer::AddValue(const size_t
#ifdef USE_SOLARIS
if(isnand(val) || (isinf(val)))
+#elif defined(Q_OS_NETBSD)
+#elif defined(Q_OS_NETBSD) && __NetBSD_Version__ < 499002000
+ if(isnan(val) || isinf(val))
#else
if(std::isnan(val) || (std::isinf(val)))