Substitute the patform's audio device in config file.
This commit is contained in:
parent
4a130d1424
commit
1bf9cc87d4
3 changed files with 27 additions and 3 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.14 2021/06/30 15:41:54 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.15 2021/11/21 16:06:30 hauke Exp $
|
||||
|
||||
DISTNAME= alsa-plugins-1.2.5
|
||||
PKGNAME= ${DISTNAME:S/plugins/plugins-oss/}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ftp://ftp.alsa-project.org/pub/plugins/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -17,10 +18,17 @@ USE_LIBTOOL= yes
|
|||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
SUBST_CLASSES+= audiodev
|
||||
SUBST_STAGE.audiodev= pre-configure
|
||||
SUBST_FILES.audiodev= oss/50-oss.conf
|
||||
SUBST_VARS.audiodev= DEVOSSAUDIO
|
||||
|
||||
CFLAGS.SunOS+= -DSOUND_MIXER_PHONEIN=SOUND_MIXER_PHONE
|
||||
CFLAGS.SunOS+= -DSOUND_MIXER_PHONEOUT=SOUND_MIXER_MONO
|
||||
CFLAGS.SunOS+= -DSOUND_MIXER_MONITOR=SOUND_MIXER_DEPTH
|
||||
CFLAGS.SunOS+= -Du_int8_t=uint8_t -Du_int16_t=uint16_t -Du_int32_t=uint32_t -Du_int64_t=uint64_t
|
||||
CFLAGS.SunOS+= -Du_int8_t=uint8_t -Du_int16_t=uint16_t
|
||||
CFLAGS.SunOS+= -Du_int32_t=uint32_t -Du_int64_t=uint64_t
|
||||
|
||||
CFLAGS+= -DDEVOSSAUDIO=\"${DEVOSSAUDIO:U/dev/dsp}\"
|
||||
LIBS+= ${LIBOSSAUDIO}
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.12 2021/10/26 09:58:46 nia Exp $
|
||||
$NetBSD: distinfo,v 1.13 2021/11/21 16:06:30 hauke Exp $
|
||||
|
||||
BLAKE2s (alsa-plugins-1.2.5.tar.bz2) = 2d677bca9733c8c9d704094d7e7d3088a230eea488e04a4e55bb9c1bee575ca0
|
||||
SHA512 (alsa-plugins-1.2.5.tar.bz2) = 32aa475ec4af040861c2bfb01eac71042242d2109d3c5102d0111f3327e3f6c9031c32cbb50eb4b6568a6bd9408691a047a39972f09d6087e31ec11f19ddc9cf
|
||||
|
@ -6,4 +6,5 @@ Size (alsa-plugins-1.2.5.tar.bz2) = 406134 bytes
|
|||
SHA1 (patch-aa) = ac2169b0a069bcf6ed60ca7ccd199ccd1988357f
|
||||
SHA1 (patch-ab) = 9cf0bda9f1928f46d0d5eac9464b790710ea2fda
|
||||
SHA1 (patch-ac) = 13da103ce3daad29d3c715f8f7d58dcd7bb9a72c
|
||||
SHA1 (patch-oss_50-oss.conf) = 74bf27539f8bc6bd3ee559f29437b5cc057d1a34
|
||||
SHA1 (patch-oss_Makefile.in) = 9ca6c96d426f7f150c86ad7a3a15fa0999a3cfdd
|
||||
|
|
15
audio/alsa-plugins-oss/patches/patch-oss_50-oss.conf
Normal file
15
audio/alsa-plugins-oss/patches/patch-oss_50-oss.conf
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-oss_50-oss.conf,v 1.1 2021/11/21 16:06:30 hauke Exp $
|
||||
|
||||
Substitute actual audio device
|
||||
|
||||
--- oss/50-oss.conf.orig 2021-05-27 17:18:39.000000000 +0000
|
||||
+++ oss/50-oss.conf
|
||||
@@ -2,7 +2,7 @@ pcm.oss {
|
||||
@args [ DEVICE ]
|
||||
@args.DEVICE {
|
||||
type string
|
||||
- default "/dev/dsp"
|
||||
+ default "@DEVOSSAUDIO@"
|
||||
}
|
||||
type oss
|
||||
device $DEVICE
|
Loading…
Reference in a new issue