Release 0.3.1
Lensfun 0.3.1 maintenance release is out with more than 60 new lens profiles and another 30 updated calibrations. Other changes: Improved performance when used with 32-bit float image buffers Introduced automated testing lensfun-update-data now also works without root privileges Fixed autoscaling for panoramic and equirectangular projections
This commit is contained in:
parent
112195e2dc
commit
1c1c6edd24
8 changed files with 23 additions and 140 deletions
|
@ -1,52 +1,24 @@
|
|||
# $NetBSD: Makefile,v 1.29 2015/06/06 12:03:24 gdt Exp $
|
||||
# $NetBSD: Makefile,v 1.30 2015/06/29 13:11:12 adam Exp $
|
||||
|
||||
DISTNAME= lensfun-0.2.8
|
||||
PKGREVISION= 1
|
||||
DISTNAME= lensfun-0.3.1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=lensfun/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= gdt@NetBSD.org
|
||||
HOMEPAGE= http://lensfun.sourceforge.net/
|
||||
COMMENT= Library for rectifying defects introduced by photographic equipment
|
||||
LICENSE= gnu-lgpl-v3
|
||||
|
||||
# But, the build system looks for makedep, not makedepend.
|
||||
# Defer, because cmake is coming.
|
||||
BUILD_DEPENDS+= makedepend-[0-9]*:../../devel/makedepend
|
||||
|
||||
USE_CMAKE= yes
|
||||
USE_LANGUAGES= c c++
|
||||
USE_TOOLS+= gmake pkg-config gsed
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --libdir=${PREFIX}/lib
|
||||
CONFIGURE_ARGS+= --prefix=${PREFIX}
|
||||
CONFIGURE_ARGS+= --vectorization=
|
||||
MAKE_FILE= GNUmakefile
|
||||
|
||||
CONFIG_SHELL= ${PYTHONBIN}
|
||||
PYTHON_FOR_BUILD_ONLY= yes
|
||||
REPLACE_PYTHON= configure
|
||||
PKGCONFIG_OVERRIDE= libs/lensfun/lensfun.pc.in
|
||||
REPLACE_SH= apps/g-lensfun-update-data
|
||||
REPLACE_PYTHON+= apps/lensfun-add-adapter
|
||||
REPLACE_PYTHON+= apps/lensfun-update-data
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
# Starting in 0.2.6, the library is misinstalled as liblensfun.so,
|
||||
# with no .0 variant. Manually fix it, because that's easier than
|
||||
# understanding the build, and upstream is moving to cmake anyway.
|
||||
post-install:
|
||||
.if ${OPSYS} == "Darwin"
|
||||
${MV} ${DESTDIR}${PREFIX}/lib/liblensfun.dylib.${PKGVERSION_NOREV} \
|
||||
${DESTDIR}${PREFIX}/lib/liblensfun.${PKGVERSION_NOREV}.dylib
|
||||
install_name_tool -id \
|
||||
${PREFIX}/lib/liblensfun.${PKGVERSION_NOREV}.dylib \
|
||||
${DESTDIR}${PREFIX}/lib/liblensfun.${PKGVERSION_NOREV}.dylib
|
||||
${RM} ${DESTDIR}${PREFIX}/lib/liblensfun.dylib*
|
||||
${LN} -s liblensfun.${PKGVERSION_NOREV}.dylib \
|
||||
${DESTDIR}${PREFIX}/lib/liblensfun.0.dylib
|
||||
${LN} -s liblensfun.${PKGVERSION_NOREV}.dylib \
|
||||
${DESTDIR}${PREFIX}/lib/liblensfun.dylib
|
||||
.endif
|
||||
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
# png: for test programs only
|
||||
|
|
|
@ -1,15 +1,14 @@
|
|||
@comment $NetBSD: PLIST,v 1.10 2013/10/25 12:59:07 adam Exp $
|
||||
include/lensfun.h
|
||||
@comment $NetBSD: PLIST,v 1.11 2015/06/29 13:11:12 adam Exp $
|
||||
bin/g-lensfun-update-data
|
||||
bin/lensfun-add-adapter
|
||||
bin/lensfun-update-data
|
||||
include/lensfun/lensfun.h
|
||||
lib/liblensfun.so
|
||||
lib/liblensfun.so.0
|
||||
lib/liblensfun.so.${PKGVERSION}
|
||||
lib/pkgconfig/lensfun.pc
|
||||
@comment lensfun inexplicably uses an extra .0 in the doc dir
|
||||
share/doc/${PKGNAME}.0/README
|
||||
share/doc/${PKGNAME}.0/cc-by-sa-3.0.txt
|
||||
share/doc/${PKGNAME}.0/gpl-3.0.txt
|
||||
share/doc/${PKGNAME}.0/lgpl-3.0.txt
|
||||
share/lensfun/6x6.xml
|
||||
share/lensfun/actioncams.xml
|
||||
share/lensfun/compact-canon.xml
|
||||
share/lensfun/compact-casio.xml
|
||||
share/lensfun/compact-fujifilm.xml
|
||||
|
@ -30,10 +29,13 @@ share/lensfun/mil-fujifilm.xml
|
|||
share/lensfun/mil-nikon.xml
|
||||
share/lensfun/mil-olympus.xml
|
||||
share/lensfun/mil-panasonic.xml
|
||||
share/lensfun/mil-pentax.xml
|
||||
share/lensfun/mil-samsung.xml
|
||||
share/lensfun/mil-samyang.xml
|
||||
share/lensfun/mil-sigma.xml
|
||||
share/lensfun/mil-sony.xml
|
||||
share/lensfun/mil-zeiss.xml
|
||||
share/lensfun/misc.xml
|
||||
share/lensfun/rf-leica.xml
|
||||
share/lensfun/slr-canon.xml
|
||||
share/lensfun/slr-contax.xml
|
||||
|
@ -44,6 +46,7 @@ share/lensfun/slr-nikon.xml
|
|||
share/lensfun/slr-olympus.xml
|
||||
share/lensfun/slr-panasonic.xml
|
||||
share/lensfun/slr-pentax.xml
|
||||
share/lensfun/slr-ricoh.xml
|
||||
share/lensfun/slr-samsung.xml
|
||||
share/lensfun/slr-samyang.xml
|
||||
share/lensfun/slr-schneider.xml
|
||||
|
@ -53,3 +56,6 @@ share/lensfun/slr-sony.xml
|
|||
share/lensfun/slr-tamron.xml
|
||||
share/lensfun/slr-tokina.xml
|
||||
share/lensfun/slr-ussr.xml
|
||||
share/lensfun/slr-vivitar.xml
|
||||
share/lensfun/slr-zeiss.xml
|
||||
share/lensfun/timestamp.txt
|
||||
|
|
|
@ -1,10 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.13 2013/10/25 12:59:07 adam Exp $
|
||||
$NetBSD: distinfo,v 1.14 2015/06/29 13:11:12 adam Exp $
|
||||
|
||||
SHA1 (lensfun-0.2.8.tar.bz2) = 0e85eb7692620668d27e2303687492ad68c90eb4
|
||||
RMD160 (lensfun-0.2.8.tar.bz2) = 527b4ca0e9ce40f514e7340548d0d0635bdc875e
|
||||
Size (lensfun-0.2.8.tar.bz2) = 628913 bytes
|
||||
SHA1 (patch-aa) = d31dd742f232aa8a75f50f14f782918ba11a8119
|
||||
SHA1 (patch-ab) = 5455bda9546dce6cc5b4a73429092afdee04bd23
|
||||
SHA1 (patch-ad) = f9d54534d3be809e8517ec262e776c9d1785acd8
|
||||
SHA1 (patch-ae) = 9fe7181571f24d90058b340e9f95e7a5557cdd48
|
||||
SHA1 (patch-build_tibs_compiler_pkgconfig.mak) = 692dd4c04c3b1f348a8c7ef5a1c708cf254a0b14
|
||||
SHA1 (lensfun-0.3.1.tar.gz) = 905168c39c7ccb980ee3d985778723a8c65cddb8
|
||||
RMD160 (lensfun-0.3.1.tar.gz) = b98aeed79c4514ed73ecd48e46d78c673b7d7e96
|
||||
Size (lensfun-0.3.1.tar.gz) = 761892 bytes
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2009/07/09 19:44:50 drochner Exp $
|
||||
|
||||
--- tools/makedep/main.cpp.orig 2008-05-20 11:36:18.000000000 +0000
|
||||
+++ tools/makedep/main.cpp
|
||||
@@ -40,6 +40,9 @@
|
||||
|
||||
#include "def.h"
|
||||
|
||||
+/* assume that in pkgsrc, we're only POSIX systems */
|
||||
+#define _POSIX_SOURCE
|
||||
+
|
||||
#ifdef hpux
|
||||
#define sigvec sigvector
|
||||
#endif /* hpux */
|
|
@ -1,19 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.2 2010/05/02 11:39:31 wiz Exp $
|
||||
|
||||
--- build/tibs/host/posix.mak.orig 2010-03-22 20:32:47.000000000 +0000
|
||||
+++ build/tibs/host/posix.mak
|
||||
@@ -5,12 +5,12 @@ SHELL := /bin/sh
|
||||
# $1 - file, $2 - target dir, $3 - mode
|
||||
define SINGLE.INSTALL
|
||||
if [ ! -d $2 ]; then install -m 0755 -d $2; fi
|
||||
- if [ -L $1 ]; then cp -d $1 $(patsubst %/,%,$2)/$(notdir $1); else install -m $3 $1 $(patsubst %/,%,$2)/$(notdir $1); fi
|
||||
+ if [ -L $1 ]; then cp $1 $(patsubst %/,%,$2)/$(notdir $1); else install -m $3 $1 $(patsubst %/,%,$2)/$(notdir $1); fi
|
||||
endef
|
||||
|
||||
# $1 - directory, $2 - target dir, $3 - mode for files
|
||||
define SINGLE.INSTALLDIR
|
||||
if [ ! -d $2 ]; then install -m 0755 -d $2; fi
|
||||
- cp -drP $1* $2
|
||||
+ cp -r $1* $2
|
||||
find $2 -type f -print0 | xargs -0 chmod $3
|
||||
endef
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.2 2010/05/02 11:39:31 wiz Exp $
|
||||
|
||||
--- libs/lensfun/auxfun.cpp.orig 2010-03-14 18:47:00.000000000 +0000
|
||||
+++ libs/lensfun/auxfun.cpp
|
||||
@@ -90,7 +90,7 @@ LF_EXPORT lfMLstr lf_mlstr_add (lfMLstr
|
||||
{
|
||||
str_len = strlen (str) + 1;
|
||||
while (str [str_len])
|
||||
- str_len += 1 + strlen (str + str_len + 1);
|
||||
+ str_len += 2 + strlen (str + str_len + 1);
|
||||
}
|
||||
|
||||
if (!lang)
|
|
@ -1,29 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.2 2013/10/25 06:41:47 wiz Exp $
|
||||
|
||||
GNU Make check is broken -- does not recognize 4.0 as newer than 3.81.
|
||||
http://developer.berlios.de/bugs/?func=detailbug&bug_id=19153&group_id=9034
|
||||
Remove doxygen detection to avoid pulling it in unintendedly.
|
||||
|
||||
--- configure.orig 2013-01-27 16:51:06.000000000 +0000
|
||||
+++ configure
|
||||
@@ -45,18 +45,14 @@ if tibs.TARGET [0] == "windows":
|
||||
}
|
||||
|
||||
# Check for tools
|
||||
-tibs.check_program ("GNU Make", "make --version", ".*?([0-9\.]+).*", "3.81", True)
|
||||
+#tibs.check_program ("GNU Make", "make --version", ".*?([0-9\.]+).*", "3.81", True)
|
||||
if tibs.check_program ("makedep", "makedep -V", ".*Version.*?([0-9\.]+).*", "0.1.0"):
|
||||
tibs.add_config_mak ("MAKEDEP", "makedep")
|
||||
makedep = "yes"
|
||||
else:
|
||||
makedep = "no"
|
||||
|
||||
-if tibs.check_program ("Doxygen", "doxygen --version", "([0-9\.]+)", "1.5.0"):
|
||||
- tibs.add_config_mak ("DOXYGEN", "doxygen")
|
||||
- doxygen = "yes"
|
||||
-else:
|
||||
- doxygen = "no"
|
||||
+doxygen = "no"
|
||||
|
||||
tibs.pkgconfig_check_library ("glib-2.0", "2.0",
|
||||
"this is the low-level library that libLensFun relies on")
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-build_tibs_compiler_pkgconfig.mak,v 1.1 2013/08/04 19:12:00 adam Exp $
|
||||
|
||||
Install pkgconfig file also on Darwin.
|
||||
|
||||
--- build/tibs//compiler/pkgconfig.mak.orig 2013-08-04 19:08:20.000000000 +0000
|
||||
+++ build/tibs//compiler/pkgconfig.mak
|
||||
@@ -4,7 +4,7 @@ ifdef CONF_LIBDIR
|
||||
# Try to guess here if target supports pkgconfig
|
||||
# - Any POSIX platform
|
||||
# - Cross-compiling on a POSIX target for WINDOWS (mingw32)
|
||||
-ifneq ($(findstring /posix/,/$(TARGET)/)$(findstring /posix-windows/,/$(HOST)-$(TARGET)/),)
|
||||
+ifneq ($(findstring /posix/,/$(TARGET)/)$(findstring /mac/,/$(TARGET)/),)
|
||||
|
||||
XFNAME.PKGCONFIG = $(addprefix $$(OUT),$1)
|
||||
MKDEPS.PKGCONFIG = $1
|
Loading…
Reference in a new issue