Remove trailing comma from generator expressions for Python 3.7 compat.

This commit is contained in:
joerg 2018-12-27 15:03:53 +00:00
parent d5effc9f46
commit 1c6e96caaa
3 changed files with 27 additions and 1 deletions

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.5 2018/05/16 06:54:52 adam Exp $
$NetBSD: distinfo,v 1.6 2018/12/27 15:03:53 joerg Exp $
SHA1 (diffoscope-94.tar.gz) = 2dca48b577383377d4bb43d9472ecd9ae5112739
RMD160 (diffoscope-94.tar.gz) = 78261a206f3c232c2b5e386eb3b5b6d825a79d56
SHA512 (diffoscope-94.tar.gz) = a68fda09a8340b1b36683b0bda4c854cb04afb189b0464185b6de655c7fe2e122215612a0154738a1174ca1594bab3598359b10425a2375f692eb0bd089d89f1
Size (diffoscope-94.tar.gz) = 9405785 bytes
SHA1 (patch-diffoscope_comparators_json.py) = 6f148f9847f8d0b24007feaeed76265dfb47b8e9
SHA1 (patch-diffoscope_presenters_formats.py) = f42ba00bcdf7347ed82c7b6aaff3af17b662b246

View file

@ -0,0 +1,13 @@
$NetBSD: patch-diffoscope_comparators_json.py,v 1.1 2018/12/27 15:03:53 joerg Exp $
--- diffoscope/comparators/json.py.orig 2018-12-25 21:53:50.738372750 +0000
+++ diffoscope/comparators/json.py
@@ -39,7 +39,7 @@ class JSONFile(File):
# Try fuzzy matching for JSON files
is_text = any(
file.magic_file_type.startswith(x)
- for x in ('ASCII text', 'UTF-8 Unicode text'),
+ for x in ('ASCII text', 'UTF-8 Unicode text')
)
if is_text and not file.name.endswith('.json'):
buf = f.read(10)

View file

@ -0,0 +1,11 @@
$NetBSD: patch-diffoscope_presenters_formats.py,v 1.1 2018/12/27 15:03:53 joerg Exp $
--- diffoscope/presenters/formats.py.orig 2018-12-25 21:54:25.209444143 +0000
+++ diffoscope/presenters/formats.py
@@ -109,5 +109,5 @@ class PresenterManager(object):
"""
return any(
- x['klass'].supports_visual_diffs for x in self.config.values(),
+ x['klass'].supports_visual_diffs for x in self.config.values()
)