font related utilities are located in fonts category these days.

so xmbdfed will go there.
This commit is contained in:
kei 2002-10-15 12:26:30 +00:00
parent 9637caddd6
commit 1c7db1e0d3
6 changed files with 0 additions and 113 deletions

View file

@ -1,29 +0,0 @@
From README:
XmBDFEditor is a Motif-based BDF font editor with the following features:
o Multiple fonts can be loaded from the command line.
o Multiple fonts can be open at the same time.
o Cutting and pasting glyphs between fonts.
o Multiple glyph bitmap editors can be open at the same time.
o Cutting and pasting between glyph bitmap editors.
o Export of XBM files from glyph bitmap editors.
o Automatic correction of certain metrics when a font is loaded.
o Generation of XLFD font names for fonts without XLFD names.
o Update an XLFD font name from the font properties.
o Update the font properties from an XLFD font name.
o Font property editor.
o Font comment editor.
o Supports unencoded glyphs (ENCODING of -1).
o Display of glyph encodings in octal, decimal, or hex.
o Builtin on-line help.
o Imports PK/GF fonts.
o Imports HBF (Han Bitmap Font) fonts.
o Imports Linux console fonts (PSF, CP, and FNT).
o Imports Sun console fonts (vfont format).
o Imports fonts from the X server.
o Imports Windows FON/FNT fonts.
o Imports TrueType fonts and collections.
o Exports PSF fonts.
o Exports HEX fonts.
o Edits two and four bits per pixel gray scale fonts.

View file

@ -1,21 +0,0 @@
# $NetBSD: Makefile,v 1.4 2002/09/23 01:22:37 jlam Exp $
DISTNAME= xmbdfed-4.4
CATEGORIES= graphics x11
MASTER_SITES= ftp://crl.nmsu.edu/CLR/multiling/General/
MAINTAINER= kei@netbsd.org
HOMEPAGE= http://crl.nmsu.edu/~mleisher/xmbdfed.html
COMMENT= Motif-based BDF font editor with lots of features
USE_BUILDLINK2= YES
USE_X11BASE= YES
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xmbdfed ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/xmbdfed.man ${PREFIX}/man/man1/xmbdfed.1
.include "../../graphics/freetype-lib/buildlink2.mk"
.include "../../mk/motif.buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2002/03/19 16:17:11 kei Exp $
bin/xmbdfed
man/man1/xmbdfed.1

View file

@ -1,6 +0,0 @@
$NetBSD: distinfo,v 1.1.1.1 2002/03/19 16:17:11 kei Exp $
SHA1 (xmbdfed-4.4.tar.gz) = 34cf268d1d69ef6ee486f1ca2d898f2fe4ec309c
Size (xmbdfed-4.4.tar.gz) = 281619 bytes
SHA1 (patch-aa) = c56292901cfe776c26fc21da2b851aa2fccf2e02
SHA1 (patch-ab) = eb5c46e723988cf9febf65f64e0b142ce8dccde3

View file

@ -1,41 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2002/03/19 16:17:11 kei Exp $
--- Makefile.orig Fri Mar 17 05:08:49 2000
+++ Makefile Wed Mar 20 00:37:53 2002
@@ -24,4 +24,4 @@
#
-CC = gcc
-CFLAGS = -g -Wall
+#CC = gcc
+#CFLAGS = -g -Wall
@@ -48,5 +48,5 @@
#
-#FTYPE_INCS = -I/usr/local/include
-#FTYPE_LIBS = -L/user/local/lib -lttf
-#FTYPE_DEFS = -DHAVE_FREETYPE
+FTYPE_INCS = -I${LOCALBASE}/include/freetype
+FTYPE_LIBS = -L${LOCALBASE}/lib -lttf
+FTYPE_DEFS = -DHAVE_FREETYPE
@@ -66,3 +66,3 @@
#
-HBFDEFS = -Dunix -DIN_MEMORY -DGUNZIP_CMD="\"/usr/local/bin/gunzip -c\""
+#HBFDEFS = -Dunix -DIN_MEMORY -DGUNZIP_CMD="\"${PREFIX}/bin/gunzip -c\""
@@ -73,2 +73,6 @@
+INCS = -I${X11BASE}/include -I${LOCALBASE}/include ${FTYPE_INCS}
+LIBS = -L${X11BASE}/lib -R${X11BASE}/lib -L${LOCALBASE}/lib -R${LOCALBASE}/lib \
+ -lXm -lXmu -lXt -lXext -lX11 ${FTYPE_LIBS}
+
#
@@ -84,5 +88,5 @@
#
-INCS = -I/usr/openwin/include -I/usr/dt/include $(FTYPE_INCS)
-LIBS = -R/usr/openwin/lib -R/usr/dt/lib -L/usr/dt/lib -lXm \
- -L/usr/openwin/lib -lXmu -lXt -lXext -lX11 $(FTYPE_LIBS)
+#INCS = -I/usr/openwin/include -I/usr/dt/include $(FTYPE_INCS)
+#LIBS = -R/usr/openwin/lib -R/usr/dt/lib -L/usr/dt/lib -lXm \
+# -L/usr/openwin/lib -lXmu -lXt -lXext -lX11 $(FTYPE_LIBS)

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2002/03/19 16:17:11 kei Exp $
--- bdf.h.orig Wed Jul 4 10:21:42 2001
+++ bdf.h Wed Jul 4 10:22:01 2001
@@ -41,7 +41,7 @@
#ifdef HAVE_FREETYPE
#include <freetype.h>
-#include <extend/ftxsbit.h>
+#include <ftxsbit.h>
#endif /* HAVE_FREETYPE */
#ifdef __cplusplus