Pick wcschr from std.

This commit is contained in:
joerg 2013-04-30 22:29:39 +00:00
parent 1b1f20ef03
commit 1ca0791fcb
2 changed files with 15 additions and 1 deletions

View file

@ -1,8 +1,9 @@
$NetBSD: distinfo,v 1.3 2012/11/16 01:07:26 joerg Exp $
$NetBSD: distinfo,v 1.4 2013/04/30 22:29:39 joerg Exp $
SHA1 (clucene-core-0.9.21b.tar.gz) = aba21d626ba3e66a0cce162b205d97cbb2d666dd
RMD160 (clucene-core-0.9.21b.tar.gz) = b7307b980da6219638f21a33f201b2b20b0d34bb
Size (clucene-core-0.9.21b.tar.gz) = 1891099 bytes
SHA1 (patch-src_CLucene_config_repl__tchar.h) = eba4c2fe2a7dadf59490c916bc12557e4f073aa1
SHA1 (patch-src_CLucene_index_SegmentMerger.cpp) = 8ee2c0e5636690ccff094ee5f869141758bbfcb9
SHA1 (patch-src_CLucene_search_FieldCacheImpl.cpp) = 8ec21159b9efbee77f7236e5c7d2db0413328154
SHA1 (patch-src_CLucene_util_Arrays.h) = ef1200cedb394fcefbaccd2b3e71e58e149fddc7

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_CLucene_config_repl__tchar.h,v 1.1 2013/04/30 22:29:39 joerg Exp $
--- src/CLucene/config/repl_tchar.h.orig 2013-04-28 04:24:47.000000000 +0000
+++ src/CLucene/config/repl_tchar.h
@@ -33,7 +33,7 @@
#define _tcscpy wcscpy //copy a string to another string
#define _tcsncpy wcsncpy //copy a specified amount of one string to another string.
#define _tcscat wcscat //copy a string onto the end of the other string
- #define _tcschr wcschr //find location of one character
+ #define _tcschr ::std::wcschr //find location of one character
#define _tcsstr wcsstr //find location of a string
#define _tcslen wcslen //get length of a string
#define _tcscmp wcscmp //case sensitive compare two strings