Update to 0.11.0, requested by Patrick Welche.

Bump dependency in buildlink3.mk since its only user is dconf-editor.
Set LICENSE.
Add comments to patches.

Changes in dconf 0.10.0
=======================

The version number was increased and a new entry was added to the NEWS.

Changes in dconf 0.9.1
======================

  - give a g_warning() on failure to communicate with service

  - remove unworking 'set lock' call from dconf API and commandline tool

  - add code to exit gracefully on receipt of SIGINT, SIGHUP, SIGTERM

  - remove "service function" logic; always use the XDG runtime directory

Changes in dconf 0.9.0
======================

There has been an extremely minor incompatible change in the D-Bus API
of dconf this release.  From a practical standpoint, this change will
have no effect.  However, it serves as a reminder that the dconf D-Bus
API is private and can change from version to version (and will likely
change in the future).

As such, it is appropriate for those packaging dconf to kill all running
instances of dconf ('killall dconf-service') as part of their postinst
for the package.  It will be dbus-activated again on the next use.

  - support loading/storing of maybe types in dconf

  - remove NFS detection hackery and rely on XDG runtime dir

  - add proper support for change notification to DConfClient

  - commandline tool improvements

    - reset: reset keys or entire subpaths

    - dump: dump entire subpaths to keyfile format

    - load: load them back again (maybe at a different path)

    - watch: actually works now

  - editor improvements

    - keys now change in editor when changed from outside

    - support for flags

    - show dconf-editor in applications list

  - work around incompatible Vala bindings changes with an #if

  - don't install the bash completion script as executable

  - fix a warning caused by reusing a GError variable

  - other small fixes


Changes in dconf 0.7.5
======================

This release corrects a serious flaw in the previous release: crashing
if the database did not already exist.

It also contains many fixes and improvements to the dconf-editor,
including use of GSettings to store the window geometry.

This is the final release before 0.8.0 which will become the first
release in a new stable series.  Feature development will continue on
'master' toward 0.9 past that point.

Changes in dconf 0.7.4
======================

Changes in this version:

  - #648949: multithreading issue fixed (which actually affects all
    GSettings-using programs since dconf is used from a helper thread in
    that case)

  - dconf commandline tool is vastly more friendly now

    - no more aborting on unrecognised arguments

    - proper help

    - bash completion support

  - support for sysadmin lockdown

  - the editor now properly reads installed enum xml files

Changes in dconf 0.7.3
======================

This release consists almost entirely of fixes made by Robert to
dconf-editor.  A few other trivial build fixes are included as well
(bumping library version dependencies to match reality, etc).

Changes in dconf 0.7.2
======================

This is entirely a cleanup/fixes release.  Some fixes here to make the
increasingly-strict toolchain happy, and also some fixes for some
crashers in the GSettings backend and service.

 - remove some unused variables (new GCC gives a warning: #640566, another)
 - add a mutex to fix multi-threading issue (#640611)
 - don't crash if we have no D-Bus
 - clean up symbol exports
 - fix a crash in the service when using 'reset'
 - drop old linker options that were for libtool

Changes in dconf 0.7.1
======================

The last release contained a few problems that caused build failures on
some strict linkers.  Those should be fixed now.

Changes in dconf 0.7
====================

 - new library to use dconf with libdbus-1
 - quite a lot of improvements and bug-fixes in dconf-editor, thanks to
   Robert Ancell
 - some bug fixes in the GSettings backend (crashers caused by use if
   custom dconf profiles)
 - some FreeBSD build fixes
 - increased Vala dependency to 0.11.4 (required for dconf-editor fixes)

Changes in dconf 0.6
====================

 - Rewrite a lot of the GSettings backend to reduce GDBus abuse.  We use
   our own worker thread now instead of trying to hijack GDBus's.
 - disable gobject-introspection support for now
 - drop support for GTK2 in dconf-editor
 - Add a new torture-test case
 - Increase dbus timeout to 2 minutes (in case the service is heavily loaded)
 - Fix several memory leaks and other bugs
This commit is contained in:
wiz 2012-07-31 15:46:20 +00:00
parent 652dd15bd1
commit 1ca3fe7d74
12 changed files with 75 additions and 116 deletions

View file

@ -1,17 +1,16 @@
# $NetBSD: Makefile,v 1.7 2012/06/14 07:45:19 sbd Exp $
# $NetBSD: Makefile,v 1.8 2012/07/31 15:46:20 wiz Exp $
#
DISTNAME= dconf-0.5.1
PKGNAME= dconf-editor-0.5.1
PKGREVISION= 5
DISTNAME= dconf-0.11.0
PKGNAME= dconf-editor-0.11.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/dconf/0.5/}
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/dconf/0.11/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://live.gnome.org/dconf
COMMENT= Backend for gsettings
#LICENSE= # TODO: (see mk/license.mk)
LICENSE= gnu-lgpl-v2.1
DISTINFO_FILE= ${.CURDIR}/../../devel/dconf/distinfo
PATCHDIR= ${.CURDIR}/../../devel/dconf/patches
@ -38,6 +37,8 @@ pre-build:
BUILDLINK_DEPMETHOD.vala= build
.include "../../lang/vala/buildlink3.mk"
.include "../../devel/dconf/buildlink3.mk"
.include "../../sysutils/dbus/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../x11/gtk3/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,2 +1,5 @@
@comment $NetBSD: PLIST,v 1.1 2011/01/12 13:52:10 drochner Exp $
@comment $NetBSD: PLIST,v 1.2 2012/07/31 15:46:20 wiz Exp $
bin/dconf-editor
share/applications/dconf-editor.desktop
share/dconf-editor/dconf-editor.ui
share/glib-2.0/schemas/ca.desrt.dconf-editor.gschema.xml

View file

@ -1,16 +1,17 @@
# $NetBSD: Makefile,v 1.8 2012/03/03 00:12:00 wiz Exp $
# $NetBSD: Makefile,v 1.9 2012/07/31 15:46:20 wiz Exp $
#
# Attention: Update this only together with devel/dconf-editor
#
DISTNAME= dconf-0.5.1
PKGREVISION= 3
DISTNAME= dconf-0.11.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/dconf/0.5/}
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/dconf/0.11/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://live.gnome.org/dconf
COMMENT= Backend for gsettings
#LICENSE= # TODO: (see mk/license.mk)
LICENSE= gnu-lgpl-v2.1
PKG_DESTDIR_SUPPORT= user-destdir
@ -19,9 +20,10 @@ CONFIGURE_ARGS+= --disable-editor
USE_LIBTOOL= yes
USE_TOOLS+= pkg-config gmake
PKGCONFIG_OVERRIDE+= client/dconf.pc.in
PKGCONFIG_OVERRIDE+= client/dconf.pc.in dbus-1/dconf-dbus-1.pc.in
BUILDLINK_DEPMETHOD.vala= build
.include "../../lang/vala/buildlink3.mk"
.include "../../devel/glib2/modules.mk"
.include "../../sysutils/dbus/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,6 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2010/11/16 19:47:07 drochner Exp $
@comment $NetBSD: PLIST,v 1.2 2012/07/31 15:46:20 wiz Exp $
bin/dconf
include/dconf-dbus-1/dconf-dbus-1.h
include/dconf/dconf-client.h
include/dconf/dconf-engine.h
include/dconf/dconf-paths.h
@ -7,19 +8,22 @@ include/dconf/dconf-readtype.h
include/dconf/dconf-resetlist.h
include/dconf/dconf.h
lib/gio/modules/libdconfsettings.so
lib/libdconf-dbus-1.so
lib/libdconf-dbus-1.so.0
lib/libdconf-dbus-1.so.0.0.0
lib/libdconf.so
lib/libdconf.so.0
lib/libdconf.so.0.0.0
lib/pkgconfig/dconf-dbus-1.pc
lib/pkgconfig/dconf.pc
libexec/dconf-service
share/bash-completion.d/dconf-bash-completion.sh
share/dbus-1/services/ca.desrt.dconf.service
share/dbus-1/system-services/ca.desrt.dconf.service
share/gtk-doc/html/dconf/DConfClient.html
share/gtk-doc/html/dconf/annotation-glossary.html
share/gtk-doc/html/dconf/api-index-full.html
share/gtk-doc/html/dconf/ch01.html
share/gtk-doc/html/dconf/dconf-DConf-Paths.html
share/gtk-doc/html/dconf/dconf.devhelp
share/gtk-doc/html/dconf/dconf.devhelp2
share/gtk-doc/html/dconf/home.png
share/gtk-doc/html/dconf/index.html

View file

@ -1,15 +1,15 @@
# $NetBSD: buildlink3.mk,v 1.5 2012/05/07 01:53:21 dholland Exp $
# $NetBSD: buildlink3.mk,v 1.6 2012/07/31 15:46:20 wiz Exp $
BUILDLINK_TREE+= dconf
.if !defined(DCONF_BUILDLINK3_MK)
DCONF_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.dconf+= dconf>=0.5.1
BUILDLINK_ABI_DEPENDS.dconf+= dconf>=0.5.1nb3
BUILDLINK_API_DEPENDS.dconf+= dconf>=0.11.0
BUILDLINK_PKGSRCDIR.dconf?= ../../devel/dconf
.include "../../devel/glib2/buildlink3.mk"
.include "../../sysutils/dbus/buildlink3.mk"
.endif # DCONF_BUILDLINK3_MK
BUILDLINK_TREE+= -dconf

View file

@ -1,9 +1,7 @@
$NetBSD: distinfo,v 1.2 2011/01/12 13:52:10 drochner Exp $
$NetBSD: distinfo,v 1.3 2012/07/31 15:46:20 wiz Exp $
SHA1 (dconf-0.5.1.tar.bz2) = 4e1dab1f744aad0bff1896ac6f288ad6a9dfece8
RMD160 (dconf-0.5.1.tar.bz2) = ebc02b010a44d78ac48dc1c4426cc723430b3016
Size (dconf-0.5.1.tar.bz2) = 251287 bytes
SHA1 (patch-aa) = 4e0ca83a57cae340cb0f661e36a4af4e772ae91b
SHA1 (patch-ab) = c9878b23be5bf4b2305aae6318026cd081c674ce
SHA1 (patch-ac) = 44a5e59474a26d42398dcbb099110f917492829a
SHA1 (patch-ad) = 9e7b4dd33c755225562a6747ade1ce628e2f9125
SHA1 (dconf-0.11.0.tar.bz2) = d1d81af4901fe20d9e4c7840e4b562ef4a09dabb
RMD160 (dconf-0.11.0.tar.bz2) = e7d1a63019398bdd2f0b809dec32b43cdf048969
Size (dconf-0.11.0.tar.bz2) = 211800 bytes
SHA1 (patch-bin_Makefile.in) = acf5ef1e506461e0968250e8a45e4113b087eee4
SHA1 (patch-editor_Makefile.in) = 47932981464911411b7a13f97231d7e741ce7f12

View file

@ -1,39 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2010/11/16 19:47:07 drochner Exp $
--- common/dconf-shmdir.c.orig 2010-07-26 14:10:20.000000000 +0000
+++ common/dconf-shmdir.c
@@ -21,9 +21,6 @@
#include "dconf-shmdir.h"
-#include <sys/statfs.h>
-#include <sys/vfs.h>
-#include <errno.h>
#ifndef NFS_SUPER_MAGIC
#define NFS_SUPER_MAGIC 0x6969
@@ -32,23 +29,7 @@
static gboolean
is_local (const gchar *filename)
{
- struct statfs buf;
- gint s;
-
- do
- s = statfs (filename, &buf);
- while (s < 0 && errno == EINTR);
-
- if (s < 0 && errno == ENOENT)
- {
- g_mkdir_with_parents (filename, 0700);
-
- do
- s = statfs (filename, &buf);
- while (s < 0 && errno == EINTR);
- }
-
- return s == 0 && buf.f_type != NFS_SUPER_MAGIC;
+ return 1;
}
gchar *

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2010/11/16 19:47:07 drochner Exp $
--- engine/dconf-engine.c.orig 2010-08-04 15:40:53.000000000 +0000
+++ engine/dconf-engine.c
@@ -144,7 +144,8 @@ dconf_engine_setup_user (DConfEngine *en
if (fd >= 0)
{
- if (posix_fallocate (fd, 0, 1) == 0)
+ ftruncate(fd, 1);
+ if (1)
{
engine->shm = mmap (NULL, 1, PROT_READ, MAP_SHARED, fd, 0);

View file

@ -1,22 +0,0 @@
$NetBSD: patch-ac,v 1.1 2011/01/12 13:52:10 drochner Exp $
--- editor/Makefile.in.orig 2010-09-15 20:11:43.000000000 +0000
+++ editor/Makefile.in
@@ -50,7 +50,7 @@ am_dconf_editor_OBJECTS = dconf-editor.$
dconf-schema.$(OBJEXT) dconf-view.$(OBJEXT)
dconf_editor_OBJECTS = $(am_dconf_editor_OBJECTS)
am__DEPENDENCIES_1 =
-dconf_editor_DEPENDENCIES = ../client/libdconf.so.0 \
+dconf_editor_DEPENDENCIES = \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
DEFAULT_INCLUDES = -I.@am__isrc@
depcomp = $(SHELL) $(top_srcdir)/aux/depcomp
@@ -194,7 +194,7 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
AM_CFLAGS = $(gtk_CFLAGS) $(libxml_CFLAGS) -I$(top_srcdir)/common -I$(top_srcdir)/client
AM_VALAFLAGS = --vapidir ../client --pkg gtk+-2.0 --pkg libxml-2.0 --pkg dconf
-dconf_editor_LDADD = ../client/libdconf.so.0 $(gtk_LIBS) $(gee_LIBS) $(libxml_LIBS)
+dconf_editor_LDADD = $(prefix)/lib/libdconf.so.0 $(gtk_LIBS) $(gee_LIBS) $(libxml_LIBS)
dconf_editor_SOURCES = dconf-editor.vala dconf-model.vala dconf-schema.vala dconf-view.vala
all: all-am

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ad,v 1.1 2011/01/12 13:52:10 drochner Exp $
--- editor/dconf-model.vala.orig 2010-09-15 13:34:58.000000000 +0000
+++ editor/dconf-model.vala
@@ -469,7 +469,7 @@ public class SettingsModel: GLib.Object,
schemas = new SchemaList();
try
{
- schemas.load_directory("/usr/share/glib-2.0/schemas");
+ schemas.load_directory("@PREFIX@/share/glib-2.0/schemas");
} catch (Error e) {
warning("Failed to parse schemas: %s", e.message);
}

View file

@ -0,0 +1,15 @@
$NetBSD: patch-bin_Makefile.in,v 1.1 2012/07/31 15:46:20 wiz Exp $
Adapt bash completion file path for pkgsrc.
--- bin/Makefile.in.orig 2012-07-31 15:35:54.000000000 +0000
+++ bin/Makefile.in
@@ -226,7 +226,7 @@ INCLUDES = -I$(top_srcdir)/common -I$(to
dconf_VALAFLAGS = --vapidir ../client --pkg=gio-2.0 --pkg=posix --pkg=dconf
dconf_LDADD = $(gio_LIBS) ../client/libdconf.so.0
dconf_SOURCES = dconf.vala dconf-update.vala dconf-dump.vala ../gvdb/gvdb-builder.c gvdb.vapi
-completiondir = $(sysconfdir)/bash_completion.d
+completiondir = $(prefix)/share/bash-completion.d
completion_DATA = dconf-bash-completion.sh
EXTRA_DIST = $(completion_DATA)
all: all-am

View file

@ -0,0 +1,24 @@
$NetBSD: patch-editor_Makefile.in,v 1.1 2012/07/31 15:46:20 wiz Exp $
Adapt for pkgsrc split of dconf-editor into separate package.
--- editor/Makefile.in.orig 2011-10-26 19:02:16.000000000 +0000
+++ editor/Makefile.in
@@ -55,7 +55,7 @@ am_dconf_editor_OBJECTS = dconf-editor.$
dconf-schema.$(OBJEXT) dconf-view.$(OBJEXT)
dconf_editor_OBJECTS = $(am_dconf_editor_OBJECTS)
am__DEPENDENCIES_1 =
-dconf_editor_DEPENDENCIES = ../client/libdconf.so.0 \
+dconf_editor_DEPENDENCIES = \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1)
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
@@ -225,7 +225,7 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
AM_CFLAGS = $(gtk_CFLAGS) $(gmodule_CFLAGS) $(libxml_CFLAGS) -I$(top_srcdir)/common -I$(top_srcdir)/client -DPKGDATADIR=\"@datadir@/dconf-editor\"
AM_VALAFLAGS = --vapidir ../client --pkg gtk+-3.0 --pkg gmodule-2.0 --pkg libxml-2.0 --pkg dconf
-dconf_editor_LDADD = ../client/libdconf.so.0 $(gtk_LIBS) $(gmodule_LIBS) $(gee_LIBS) $(libxml_LIBS)
+dconf_editor_LDADD = $(prefix)/client/libdconf.so.0 $(gtk_LIBS) $(gmodule_LIBS) $(gee_LIBS) $(libxml_LIBS)
dconf_editor_SOURCES = config.vapi dconf-editor.vala dconf-model.vala dconf-schema.vala dconf-view.vala
desktopdir = $(datadir)/applications
desktop_in_files = dconf-editor.desktop.in.in