Update libslang2 to 2.2.2. Add license.
Changelog: Changes since 2.2.1 1. src/slsmg.c: Call SLutf8_enable if UTF8 mode has not been setup. 2. src/slutty.c: Allow the hook that gets called when the read function gets interrupted to change the read file descriptor. Before, if this happened, the SLang_getkey function would return SLANG_GETKEY_ERROR. 3. lib/slsh/print.sl: Turn off buffering of the pager pipe. 4. modules/tm/*.tm: A couple of typos corrected (John Houck) 5. src/slmath.c: The round function was not correctly rounding values between 0.5 and 1.0. 6. src/slstdio.c,slclass.c: If a call to fwrite produces errno=EPIPE, then do not bother trying the write again. 7. modules/fork-module.c: Use WIFCONTINUED only if it is defined. 8. slsh/Makefile.in: Change the order of the libraries such that the newly built ones will be found first. (Markus Hennecke) 9. src/slagetput.inc: Avoid possible access violation when using a range array as an index. 10. doc/tm/rtl/lists.tm: Documented the optional argument to the list_to_array function (Manfred Hanke). Changes since 2.2.0 1. modules/socket-module.c: glibc-2.8 removed the h_addr macro. 2. src/slclass.c: Call clearerr before performing the stdio_fread/fwrite functions. 3. src/slstdio.c: typeof in the fputs intrinsic fixed (n instead of dn was compared to 0). 4. src/slscanf.c: sscanf will treat NaN and Inf in a case-insensitive manner. Also, the NaN([a-zA-Z0-9]*) form is also supported. 5. src/slang.h: SLclass_set_aelem_init_function was missing from the API. 6. src/slmath.c: The expm1 and log1p functions were returning NaN when given Inf arguments. 7. src/slmath,c: log1p(-1) produced nan instead of -inf. 8. configure: Added pkg-config support (based upon a debian patch sent to me by Luca Bigliardi). 9. doc/tm/rtl/math.tm: Updated the help for set_float_format and added documentation for the get_float_format function. 10. autoconf/slangpc.in: Added URL and Libs.private entries to the slang.pc pkg-config file. 11. src/slang.h: prototype for SLang_create_array1 missing from slang.h. 12. src/slcurses.c: Added debian patch that adds support for additional graphics characters (DIAMOND, DEGREE, etc...). 13. doc/tm/slang.tm: Added a small section about arrays of arrays. 14. src/slang.c: __builtin_expect is used for the stack functions if compiled with gcc. 15. src/*.c: A few public variables were not explicitly initialized to 0. Apparantly not doing so causes them not be be exported from the windows DLL. Complete changes at: ftp://space.mit.edu/pub/davis/slang/v2.2/changes.txt
This commit is contained in:
parent
345a3a7c7d
commit
1cee1ffd3e
8 changed files with 72 additions and 49 deletions
|
@ -1,18 +1,18 @@
|
|||
# $NetBSD: Makefile,v 1.5 2009/10/24 14:45:43 zafer Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2009/12/16 19:16:58 zafer Exp $
|
||||
#
|
||||
|
||||
DISTNAME= slang-2.1.3
|
||||
PKGREVISION= 1
|
||||
DISTNAME= slang-2.2.2
|
||||
PKGNAME= lib${DISTNAME:slang%=slang2%}
|
||||
SVR4_PKGNAME= lslan
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ftp://space.mit.edu/pub/davis/slang/v2.1/ \
|
||||
ftp://ftp.ntua.gr/pub/lang/slang/slang/v2.1/
|
||||
MASTER_SITES= ftp://space.mit.edu/pub/davis/slang/v2.2/ \
|
||||
ftp://ftp.ntua.gr/pub/lang/slang/slang/v2.2/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.s-lang.org/
|
||||
COMMENT= Routines for rapid alpha-numeric terminal applications development
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
@ -30,7 +30,7 @@ CONFIGURE_ARGS+= --without-x
|
|||
DLOPEN_REQUIRE_PTHREADS=no
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/libslang2
|
||||
CONF_FILES+= ${EGDIR}/slsh.rc ${PKG_SYSCONFDIR}/slsh.rc
|
||||
CONF_FILES+= ${EGDIR}/slsh.rc ${PKG_SYSCONFDIR}/slsh.rc
|
||||
|
||||
INSTALL_MAKE_FLAGS+= DEST_SLSH_CONF_DIR=${DESTDIR}/${EGDIR}
|
||||
|
||||
|
|
|
@ -1,18 +1,20 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2009/06/14 17:48:56 joerg Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2009/12/16 19:16:58 zafer Exp $
|
||||
bin/slsh
|
||||
include/slang2/slang.h
|
||||
include/slang2/slcurses.h
|
||||
lib/libslang2.la
|
||||
lib/pkgconfig/slang.pc
|
||||
lib/slang/v2/modules/fcntl-module.la
|
||||
lib/slang/v2/modules/fork-module.la
|
||||
lib/slang/v2/modules/iconv-module.la
|
||||
${PLIST.oniguruma}lib/slang/v2/modules/onig-module.la
|
||||
${PLIST.pcre}lib/slang/v2/modules/pcre-module.la
|
||||
${PLIST.png}lib/slang/v2/modules/png-module.la
|
||||
lib/slang/v2/modules/rand-module.la
|
||||
lib/slang/v2/modules/select-module.la
|
||||
lib/slang/v2/modules/slsmg-module.la
|
||||
lib/slang/v2/modules/socket-module.la
|
||||
lib/slang/v2/modules/sysconf-module.la
|
||||
lib/slang/v2/modules/termios-module.la
|
||||
lib/slang/v2/modules/varray-module.la
|
||||
lib/slang/v2/modules/zlib-module.la
|
||||
man/man1/slsh.1
|
||||
share/doc/slang/v2/COPYING
|
||||
share/doc/slang/v2/changes.txt
|
||||
|
@ -28,6 +30,8 @@ share/doc/slsh/html/slshfun-4.html
|
|||
share/doc/slsh/html/slshfun-5.html
|
||||
share/doc/slsh/html/slshfun-6.html
|
||||
share/doc/slsh/html/slshfun-7.html
|
||||
share/doc/slsh/html/slshfun-8.html
|
||||
share/doc/slsh/html/slshfun-9.html
|
||||
share/doc/slsh/html/slshfun.html
|
||||
share/examples/libslang2/slsh.rc
|
||||
share/slsh/arrayfuns.sl
|
||||
|
@ -35,6 +39,8 @@ share/slsh/autoload.sl
|
|||
share/slsh/cmaps/cool.map
|
||||
share/slsh/cmaps/copper.map
|
||||
share/slsh/cmaps/drywet.map
|
||||
share/slsh/cmaps/ds9b.map
|
||||
share/slsh/cmaps/ds9sls.map
|
||||
share/slsh/cmaps/gebco.map
|
||||
share/slsh/cmaps/globe.map
|
||||
share/slsh/cmaps/gray.map
|
||||
|
@ -54,6 +60,7 @@ share/slsh/cmaps/topo.map
|
|||
share/slsh/cmaps/wysiwyg.map
|
||||
share/slsh/cmdopt.sl
|
||||
share/slsh/fcntl.sl
|
||||
share/slsh/fork.sl
|
||||
share/slsh/glob.sl
|
||||
share/slsh/help
|
||||
share/slsh/iconv.sl
|
||||
|
@ -61,7 +68,9 @@ share/slsh/onig.sl
|
|||
share/slsh/pcre.sl
|
||||
share/slsh/png.sl
|
||||
share/slsh/print.sl
|
||||
share/slsh/process.sl
|
||||
share/slsh/profile.sl
|
||||
share/slsh/rand.sl
|
||||
share/slsh/readascii.sl
|
||||
share/slsh/require.sl
|
||||
share/slsh/rline/complete.sl
|
||||
|
@ -85,5 +94,7 @@ share/slsh/slsmg.sl
|
|||
share/slsh/socket.sl
|
||||
share/slsh/stkcheck.sl
|
||||
share/slsh/structfuns.sl
|
||||
share/slsh/sysconf.sl
|
||||
share/slsh/termios.sl
|
||||
share/slsh/varray.sl
|
||||
share/slsh/zlib.sl
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.2 2008/12/03 11:10:34 is Exp $
|
||||
$NetBSD: distinfo,v 1.3 2009/12/16 19:16:58 zafer Exp $
|
||||
|
||||
SHA1 (slang-2.1.3.tar.bz2) = 31fc6162684f69d9dd0377372dfdc336f0c4343a
|
||||
RMD160 (slang-2.1.3.tar.bz2) = b59424972e52c361a15b23874d1a0539683608e5
|
||||
Size (slang-2.1.3.tar.bz2) = 1191425 bytes
|
||||
SHA1 (patch-aa) = 6bccdf8d5caaadbc66c3f2b7eeab6da85efc5fef
|
||||
SHA1 (patch-ab) = eae92ea5fac608b1dd9e6106b452d67c79c19bcb
|
||||
SHA1 (slang-2.2.2.tar.bz2) = 13bb6344f71779cad8c05e1b6b1ef2d073888d58
|
||||
RMD160 (slang-2.2.2.tar.bz2) = d642c7d513aee198ad5d6d1b710c5c0f65dc381a
|
||||
Size (slang-2.2.2.tar.bz2) = 1366850 bytes
|
||||
SHA1 (patch-aa) = ce77fba22cd04aff3ddc3f30774d1de53dcb6465
|
||||
SHA1 (patch-ab) = 45d8e13a3672d30620e2cac458838d1c366f8013
|
||||
SHA1 (patch-ac) = 1181b6ce5de5c7c149aa8692dbcded981bda688e
|
||||
SHA1 (patch-ad) = 03f839d82cd3f18f526293ff8015bfa1e029ede0
|
||||
SHA1 (patch-ae) = 85ed2a5053bb908ab9f55161ef626ee9705acd5f
|
||||
SHA1 (patch-af) = 335d14eef480ff49bd7fb2ffc7a434a77ac9a2ec
|
||||
SHA1 (patch-ad) = 9ab953b8d850832f49f8af9bdb397f474af209eb
|
||||
SHA1 (patch-ae) = 8182ca4c317ec60650186bf4b4ee75b468baefa9
|
||||
SHA1 (patch-af) = 225817d482d438e46f39831fe3a193f2c469fc82
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2008/08/09 21:22:11 bjs Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2009/12/16 19:16:58 zafer Exp $
|
||||
|
||||
--- src/Makefile.in.orig 2007-09-07 22:47:29.000000000 -0400
|
||||
--- src/Makefile.in.orig 2009-12-05 20:03:51.000000000 +0100
|
||||
+++ src/Makefile.in
|
||||
@@ -4,7 +4,7 @@
|
||||
#---------------------------------------------------------------------------
|
||||
|
@ -34,7 +34,7 @@ $NetBSD: patch-aa,v 1.1.1.1 2008/08/09 21:22:11 bjs Exp $
|
|||
OBJDIR_NORMAL_LIB = $(OBJDIR)/$(NORMAL_LIB)
|
||||
|
||||
# On most systems, these variables have values of the form:
|
||||
@@ -136,14 +136,14 @@ UPDATE_VERSION_SCRIPT = $(HOME)/bin/upda
|
||||
@@ -138,14 +138,14 @@ UPDATE_VERSION_SCRIPT = $(HOME)/bin/upda
|
||||
#---------------------------------------------------------------------------
|
||||
# Rules
|
||||
#---------------------------------------------------------------------------
|
||||
|
@ -55,7 +55,7 @@ $NetBSD: patch-aa,v 1.1.1.1 2008/08/09 21:22:11 bjs Exp $
|
|||
@echo ""
|
||||
@echo $(NORMAL_LIB) created in $(OBJDIR)
|
||||
|
||||
@@ -184,10 +184,9 @@ install-docs: $(DEST_DOCDIR)
|
||||
@@ -186,10 +186,9 @@ install-docs: $(DEST_DOCDIR)
|
||||
echo $(INSTALL_DATA) $$i $(DEST_DOCDIR)/; \
|
||||
$(INSTALL_DATA) $$i $(DEST_DOCDIR)/; \
|
||||
done
|
||||
|
@ -68,7 +68,7 @@ $NetBSD: patch-aa,v 1.1.1.1 2008/08/09 21:22:11 bjs Exp $
|
|||
install-elf-and-links:
|
||||
-$(RM) $(DEST_LIBDIR)/$(ELFLIB)
|
||||
-$(RM) $(DEST_LIBDIR)/$(ELFLIB_MAJOR)
|
||||
@@ -205,9 +204,9 @@ install-elf-cygwin:
|
||||
@@ -207,9 +206,9 @@ install-elf-cygwin:
|
||||
$(INSTALL_DATA) $(ELFDIR_DLL_LIB) $(DEST_LIBDIR)/
|
||||
$(MKINSDIR) $(DEST_BINDIR)
|
||||
$(INSTALL) $(ELFDIR_ELF_LIB) $(DEST_BINDIR)/
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2008/08/09 21:22:11 bjs Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2009/12/16 19:16:58 zafer Exp $
|
||||
|
||||
--- configure.orig 2007-10-22 13:49:55.000000000 -0400
|
||||
--- configure.orig 2009-12-05 20:03:51.000000000 +0100
|
||||
+++ configure
|
||||
@@ -10692,6 +10692,7 @@ fi
|
||||
@@ -11918,6 +11918,7 @@ fi
|
||||
|
||||
|
||||
fi
|
||||
|
@ -10,7 +10,7 @@ $NetBSD: patch-ab,v 1.1.1.1 2008/08/09 21:22:11 bjs Exp $
|
|||
{ echo "$as_me:$LINENO: checking for terminfo" >&5
|
||||
echo $ECHO_N "checking for terminfo... $ECHO_C" >&6; }
|
||||
if test "$nc5config" != "no"
|
||||
@@ -10717,6 +10718,7 @@ echo "${ECHO_T}yes" >&6; }
|
||||
@@ -11943,6 +11944,7 @@ echo "${ECHO_T}yes" >&6; }
|
||||
break
|
||||
fi
|
||||
done
|
||||
|
@ -18,7 +18,7 @@ $NetBSD: patch-ab,v 1.1.1.1 2008/08/09 21:22:11 bjs Exp $
|
|||
if test "$TERMCAP"; then
|
||||
{ echo "$as_me:$LINENO: result: no" >&5
|
||||
echo "${ECHO_T}no" >&6; }
|
||||
@@ -10762,8 +10764,8 @@ then
|
||||
@@ -11988,8 +11990,8 @@ then
|
||||
fi
|
||||
fi
|
||||
|
||||
|
@ -28,4 +28,4 @@ $NetBSD: patch-ab,v 1.1.1.1 2008/08/09 21:22:11 bjs Exp $
|
|||
+ELFDIR=$OBJDIR
|
||||
|
||||
|
||||
|
||||
missingmodules=""
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2008/08/09 21:22:11 bjs Exp $
|
||||
$NetBSD: patch-ad,v 1.2 2009/12/16 19:16:58 zafer Exp $
|
||||
|
||||
--- demo/Makefile.in.orig 2006-05-12 15:09:10.000000000 -0400
|
||||
--- demo/Makefile.in.orig 2009-12-05 20:03:51.000000000 +0100
|
||||
+++ demo/Makefile.in
|
||||
@@ -28,17 +28,17 @@ CONFIG_H = config.h
|
||||
|
||||
|
@ -8,7 +8,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2008/08/09 21:22:11 bjs Exp $
|
|||
|
||||
-COMPILE_CMD = $(CC) -c $(ALL_CFLAGS)
|
||||
+COMPILE_CMD = $(LIBTOOL) --mode=compile $(CC) -c $(ALL_CFLAGS)
|
||||
EXECLIBS = -L$(SLANG_LIB) -lslang -lm $(TCAPLIB)
|
||||
EXECLIBS = -L$(SLANG_LIB) -lslang @M_LIB@ $(TCAPLIB)
|
||||
-EXECDEPS = $(SLANG_LIB)/libslang.a
|
||||
+EXECDEPS = $(SLANG_LIB)/libslang.la
|
||||
DOT_O_DEPS = demolib.c
|
||||
|
|
|
@ -1,31 +1,34 @@
|
|||
$NetBSD: patch-ae,v 1.2 2008/12/03 11:10:34 is Exp $
|
||||
$NetBSD: patch-ae,v 1.3 2009/12/16 19:16:58 zafer Exp $
|
||||
|
||||
--- modules/Makefile.in.orig 2007-09-08 04:47:29.000000000 +0200
|
||||
--- modules/Makefile.in.orig 2009-12-05 20:03:51.000000000 +0100
|
||||
+++ modules/Makefile.in
|
||||
@@ -1,4 +1,5 @@
|
||||
# -*- sh -*-
|
||||
+MODULE_LIBTOOL_FLAGS=--tag=disable-static
|
||||
MODULES = slsmg-module.so termios-module.so select-module.so fcntl-module.so \
|
||||
varray-module.so socket-module.so @PCRE_MODULE@ @PNG_MODULE@ \
|
||||
@ICONV_MODULE@ @ONIG_MODULE@
|
||||
@@ -69,9 +70,10 @@ DEST_HELPDIR = $(DESTDIR)$(HELP_DIR)
|
||||
varray-module.so socket-module.so rand-module.so fork-module.so @PCRE_MODULE@ @PNG_MODULE@ \
|
||||
@ICONV_MODULE@ @ONIG_MODULE@ @ZLIB_MODULE@ @SYSCONF_MODULE@
|
||||
@@ -75,9 +76,10 @@ DEST_HELPDIR = $(DESTDIR)$(HELP_DIR)
|
||||
#---------------------------------------------------------------------------
|
||||
RPATH = @RPATH@
|
||||
|
||||
-LIBS = $(LDFLAGS) $(RPATH) $(SLANG_LIB) $(DL_LIB) -lm
|
||||
+LIBS = $(LDFLAGS) -module -avoid-version -rpath $(PREFIX)/lib $(SLANG_LIB) $(DL_LIB) -lm
|
||||
#LIBS = $(RPATH) $(DL_LIB) -lm
|
||||
-LIBS = $(LDFLAGS) $(RPATH) $(SLANG_LIB) $(DL_LIB) @M_LIB@
|
||||
+LIBS = $(LDFLAGS) -module -avoid-version -rpath $(PREFIX)/lib $(SLANG_LIB) $(DL_LIB) @M_LIB@
|
||||
#LIBS = $(RPATH) $(DL_LIB) @M_LIB@
|
||||
INCS = $(SLANG_INC)
|
||||
+CC_SHARED:=${LIBTOOL} --mode=link ${MODULE_LIBTOOL_FLAGS} ${CC}
|
||||
|
||||
all: $(MODULES)
|
||||
|
||||
@@ -79,35 +81,35 @@ config.h: ../src/config.h
|
||||
@@ -85,43 +87,43 @@ config.h: ../src/config.h
|
||||
cp ../src/config.h .
|
||||
|
||||
slsmg-module.so: slsmg-module.c config.h
|
||||
- $(CC_SHARED) $(INCS) slsmg-module.c -o slsmg-module.so $(LIBS)
|
||||
+ $(CC_SHARED) $(INCS) slsmg-module.c -o slsmg-module.la $(LIBS)
|
||||
rand-module.so: rand-module.c config.h
|
||||
- $(CC_SHARED) $(INCS) rand-module.c -o rand-module.so $(LIBS)
|
||||
+ $(CC_SHARED) $(INCS) rand-module.c -o rand-module.la $(LIBS)
|
||||
newt-module.so: newt-module.c config.h
|
||||
- $(CC_SHARED) $(INCS) newt-module.c -o newt-module.so -lnewt $(LIBS)
|
||||
+ $(CC_SHARED) $(INCS) newt-module.c -o newt-module.la -lnewt $(LIBS)
|
||||
|
@ -56,6 +59,15 @@ $NetBSD: patch-ae,v 1.2 2008/12/03 11:10:34 is Exp $
|
|||
iconv-module.so: iconv-module.c config.h
|
||||
- $(CC_SHARED) $(INCS) $(ICONV_INC) iconv-module.c -o iconv-module.so $(ICONV_LIB) $(LIBS)
|
||||
+ $(CC_SHARED) $(INCS) $(ICONV_INC) iconv-module.c -o iconv-module.la $(ICONV_LIB) $(LIBS)
|
||||
zlib-module.so: zlib-module.c config.h
|
||||
- $(CC_SHARED) $(INCS) $(ZLIB_INC) zlib-module.c -o zlib-module.so $(ZLIB_LIB) $(LIBS)
|
||||
+ $(CC_SHARED) $(INCS) $(ZLIB_INC) zlib-module.c -o zlib-module.la $(ZLIB_LIB) $(LIBS)
|
||||
fork-module.so: fork-module.c config.h
|
||||
- $(CC_SHARED) $(INCS) fork-module.c -o fork-module.so $(LIBS)
|
||||
+ $(CC_SHARED) $(INCS) fork-module.c -o fork-module.la $(LIBS)
|
||||
sysconf-module.so: sysconf-module.c config.h
|
||||
- $(CC_SHARED) $(INCS) sysconf-module.c -o sysconf-module.so $(LIBS)
|
||||
+ $(CC_SHARED) $(INCS) sysconf-module.c -o sysconf-module.la $(LIBS)
|
||||
|
||||
# Note that Windows/Cygwin modules need execute permissions
|
||||
install: all
|
||||
|
|
|
@ -1,17 +1,17 @@
|
|||
$NetBSD: patch-af,v 1.1.1.1 2008/08/09 21:22:11 bjs Exp $
|
||||
$NetBSD: patch-af,v 1.2 2009/12/16 19:16:58 zafer Exp $
|
||||
|
||||
--- slsh/Makefile.in.orig 2007-09-08 21:39:18.000000000 -0400
|
||||
--- slsh/Makefile.in.orig 2009-12-05 20:03:51.000000000 +0100
|
||||
+++ slsh/Makefile.in
|
||||
@@ -64,7 +64,7 @@ DEST_SLSH_DOC_DIR= $(DESTDIR)$(SLSH_DOC_
|
||||
#----------------------------------------------------------------------------
|
||||
@@ -65,7 +65,7 @@ DEST_SLSH_DOC_DIR= $(DESTDIR)$(SLSH_DOC_
|
||||
@SET_MAKE@
|
||||
SHELL = /bin/sh
|
||||
-INST_LIBS = $(RPATH) $(SLANG_INST_LIB) $(DEST_LIB_DIR) -lslang $(READLINE_LIB) $(OTHER_LIBS)
|
||||
#INST_LIBS = $(RPATH) $(SLANG_INST_LIB) $(DEST_LIB_DIR) -lslang $(READLINE_LIB) $(OTHER_LIBS)
|
||||
-INST_LIBS = $(DEST_LIB_DIR) $(RPATH) $(SLANG_INST_LIB) -lslang $(READLINE_LIB) $(OTHER_LIBS)
|
||||
+INST_LIBS = -L$(PREFIX)/lib -lslang $(READLINE_LIB) $(OTHER_LIBS)
|
||||
DEFS = -DSLSH_CONF_DIR='"$(SLSH_CONF_DIR)"' -DSLSH_PATH='"$(SLSH_LIB_DIR)"' \
|
||||
-DSLSH_CONF_DIR_ENV='$(SLSH_CONF_DIR_ENV)' -DSLSH_LIB_DIR_ENV='$(SLSH_LIB_DIR_ENV)' \
|
||||
-DSLSH_PATH_ENV='$(SLSH_PATH_ENV)'
|
||||
@@ -72,25 +72,25 @@ SRC_LIBS = $(SLANG_SRCLIB) -lslang $(REA
|
||||
@@ -73,25 +73,25 @@ SRC_LIBS = $(SLANG_SRCLIB) -lslang $(REA
|
||||
#
|
||||
all: slsh_exe
|
||||
slsh_exe: slsh.o readline.o
|
||||
|
@ -51,7 +51,7 @@ $NetBSD: patch-af,v 1.1.1.1 2008/08/09 21:22:11 bjs Exp $
|
|||
install_lib_files:
|
||||
@for X in lib/*.sl; \
|
||||
do \
|
||||
@@ -139,7 +139,7 @@ install_docs:
|
||||
@@ -140,7 +140,7 @@ install_docs:
|
||||
|
||||
install: slsh install_directories install_lib_files install_rline_files \
|
||||
install_scripts install_help install_docs
|
||||
|
|
Loading…
Reference in a new issue