py-matplotlib: Update to 3.5.2
* Use mplsetup.cfg to use freetype2 and qhull from pkgsrc to avoid build-time downloading. CHangelog: 3.5.2: * Preliminary support for Windows on arm64 target has been added; this requires FreeType 2.11 or above. 3.5.1: Bugfixes 3.5.0: What's new in Matplotlib 3.5.0 (Nov 15, 2021) Figure and Axes creation / management * subplot_mosaic supports simple Axes sharing * Figure now has draw_without_rendering method * Figure __init__ passes keyword arguments through to set Plotting methods * Add Annulus patch * set_data method for FancyArrow patch * New arrow styles in ArrowStyle and ConnectionPatch * Setting collection offset transform after initialization Colors and colormaps * Colormap registry (experimental) * Image interpolation now possible at RGBA stage * imshow supports half-float arrays * A callback registry has been added to Normalize objects Titles, ticks, and labels * Settings tick positions and labels simultaneously in set_ticks Fonts and Text * Triple and quadruple dot mathtext accents * Font properties of legend title are configurable * Text and TextBox added parse_math option * Text can be positioned inside TextBox widget * Simplifying the font setting for usetex mode * Type 42 subsetting is now enabled for PDF/PS backends rcParams improvements * Allow setting default legend labelcolor globally 3D Axes improvements * Axes3D now allows manual control of draw order * Allow changing the vertical axis in 3d plots * plot_surface supports masked arrays and NaNs * 3D plotting methods support data keyword argument Interactive tool improvements * Colorbars now have pan and zoom functionality * Updated the appearance of Slider widgets * Removing points on a PolygonSelector * Dragging selectors * Clearing selectors * Setting artist properties of selectors * Ignore events outside selection * CallbackRegistry objects gain a method to temporarily block signals * Directional sizing cursors Sphinx extensions * More configuration of mathmpl sphinx extension Backend-specific improvements * GTK backend * Qt backends * HiDPI support in Cairo-based, GTK, and Tk backends * Qt figure options editor improvements * WX backends support mouse navigation buttons * WebAgg uses asyncio instead of Tornado
This commit is contained in:
parent
6c9cad307f
commit
1d060105fc
4 changed files with 51 additions and 39 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.73 2022/05/15 10:27:07 nia Exp $
|
||||
# $NetBSD: Makefile,v 1.74 2022/06/16 15:24:40 ryoon Exp $
|
||||
|
||||
DISTNAME= matplotlib-3.4.3
|
||||
DISTNAME= matplotlib-3.5.2
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= graphics python
|
||||
MASTER_SITES= ${MASTER_SITE_PYPI:=m/matplotlib/}
|
||||
|
||||
|
@ -18,6 +17,7 @@ DEPENDS+= ${PYPKGPREFIX}-dateutil>=2.7:../../time/py-dateutil
|
|||
DEPENDS+= ${PYPKGPREFIX}-kiwisolver>=1.0.1:../../math/py-kiwisolver
|
||||
DEPENDS+= ${PYPKGPREFIX}-pyparsing>=2.2.1:../../devel/py-pyparsing
|
||||
BUILD_DEPENDS+= ${PYPKGPREFIX}-certifi>=2020.06.20:../../security/py-certifi
|
||||
BUILD_DEPENDS+= ${PYPKGPREFIX}-setuptools_scm_git_archive-[0-9]*:../../devel/py-setuptools_scm_git_archive
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test-[0-9]*:../../devel/py-test
|
||||
|
||||
USE_LANGUAGES= c c++
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
@comment $NetBSD: PLIST,v 1.27 2021/05/05 10:11:29 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.28 2022/06/16 15:24:40 ryoon Exp $
|
||||
${PYSITELIB}/${EGG_NAME}-nspkg.pth
|
||||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/namespace_packages.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/requires.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
|
||||
${PYSITELIB}/${EGG_NAME}-nspkg.pth
|
||||
${PYSITELIB}/matplotlib/__init__.py
|
||||
${PYSITELIB}/matplotlib/__init__.pyc
|
||||
${PYSITELIB}/matplotlib/__init__.pyo
|
||||
|
@ -18,6 +18,9 @@ ${PYSITELIB}/matplotlib/_api/__init__.pyo
|
|||
${PYSITELIB}/matplotlib/_api/deprecation.py
|
||||
${PYSITELIB}/matplotlib/_api/deprecation.pyc
|
||||
${PYSITELIB}/matplotlib/_api/deprecation.pyo
|
||||
${PYSITELIB}/matplotlib/_blocking_input.py
|
||||
${PYSITELIB}/matplotlib/_blocking_input.pyc
|
||||
${PYSITELIB}/matplotlib/_blocking_input.pyo
|
||||
${PYSITELIB}/matplotlib/_c_internal_utils.so
|
||||
${PYSITELIB}/matplotlib/_cm.py
|
||||
${PYSITELIB}/matplotlib/_cm.pyc
|
||||
|
@ -53,9 +56,9 @@ ${PYSITELIB}/matplotlib/_pylab_helpers.py
|
|||
${PYSITELIB}/matplotlib/_pylab_helpers.pyc
|
||||
${PYSITELIB}/matplotlib/_pylab_helpers.pyo
|
||||
${PYSITELIB}/matplotlib/_qhull.so
|
||||
${PYSITELIB}/matplotlib/_text_layout.py
|
||||
${PYSITELIB}/matplotlib/_text_layout.pyc
|
||||
${PYSITELIB}/matplotlib/_text_layout.pyo
|
||||
${PYSITELIB}/matplotlib/_text_helpers.py
|
||||
${PYSITELIB}/matplotlib/_text_helpers.pyc
|
||||
${PYSITELIB}/matplotlib/_text_helpers.pyo
|
||||
${PYSITELIB}/matplotlib/_tri.so
|
||||
${PYSITELIB}/matplotlib/_ttconv.so
|
||||
${PYSITELIB}/matplotlib/_version.py
|
||||
|
@ -101,6 +104,9 @@ ${PYSITELIB}/matplotlib/backends/__init__.py
|
|||
${PYSITELIB}/matplotlib/backends/__init__.pyc
|
||||
${PYSITELIB}/matplotlib/backends/__init__.pyo
|
||||
${PYSITELIB}/matplotlib/backends/_backend_agg.so
|
||||
${PYSITELIB}/matplotlib/backends/_backend_gtk.py
|
||||
${PYSITELIB}/matplotlib/backends/_backend_gtk.pyc
|
||||
${PYSITELIB}/matplotlib/backends/_backend_gtk.pyo
|
||||
${PYSITELIB}/matplotlib/backends/_backend_pdf_ps.py
|
||||
${PYSITELIB}/matplotlib/backends/_backend_pdf_ps.pyc
|
||||
${PYSITELIB}/matplotlib/backends/_backend_pdf_ps.pyo
|
||||
|
@ -123,6 +129,15 @@ ${PYSITELIB}/matplotlib/backends/backend_gtk3agg.pyo
|
|||
${PYSITELIB}/matplotlib/backends/backend_gtk3cairo.py
|
||||
${PYSITELIB}/matplotlib/backends/backend_gtk3cairo.pyc
|
||||
${PYSITELIB}/matplotlib/backends/backend_gtk3cairo.pyo
|
||||
${PYSITELIB}/matplotlib/backends/backend_gtk4.py
|
||||
${PYSITELIB}/matplotlib/backends/backend_gtk4.pyc
|
||||
${PYSITELIB}/matplotlib/backends/backend_gtk4.pyo
|
||||
${PYSITELIB}/matplotlib/backends/backend_gtk4agg.py
|
||||
${PYSITELIB}/matplotlib/backends/backend_gtk4agg.pyc
|
||||
${PYSITELIB}/matplotlib/backends/backend_gtk4agg.pyo
|
||||
${PYSITELIB}/matplotlib/backends/backend_gtk4cairo.py
|
||||
${PYSITELIB}/matplotlib/backends/backend_gtk4cairo.pyc
|
||||
${PYSITELIB}/matplotlib/backends/backend_gtk4cairo.pyo
|
||||
${PYSITELIB}/matplotlib/backends/backend_macosx.py
|
||||
${PYSITELIB}/matplotlib/backends/backend_macosx.pyc
|
||||
${PYSITELIB}/matplotlib/backends/backend_macosx.pyo
|
||||
|
@ -141,15 +156,9 @@ ${PYSITELIB}/matplotlib/backends/backend_pgf.pyo
|
|||
${PYSITELIB}/matplotlib/backends/backend_ps.py
|
||||
${PYSITELIB}/matplotlib/backends/backend_ps.pyc
|
||||
${PYSITELIB}/matplotlib/backends/backend_ps.pyo
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt4.py
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt4.pyc
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt4.pyo
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt4agg.py
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt4agg.pyc
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt4agg.pyo
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt4cairo.py
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt4cairo.pyc
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt4cairo.pyo
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt.py
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt.pyc
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt.pyo
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt5.py
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt5.pyc
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt5.pyo
|
||||
|
@ -159,6 +168,12 @@ ${PYSITELIB}/matplotlib/backends/backend_qt5agg.pyo
|
|||
${PYSITELIB}/matplotlib/backends/backend_qt5cairo.py
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt5cairo.pyc
|
||||
${PYSITELIB}/matplotlib/backends/backend_qt5cairo.pyo
|
||||
${PYSITELIB}/matplotlib/backends/backend_qtagg.py
|
||||
${PYSITELIB}/matplotlib/backends/backend_qtagg.pyc
|
||||
${PYSITELIB}/matplotlib/backends/backend_qtagg.pyo
|
||||
${PYSITELIB}/matplotlib/backends/backend_qtcairo.py
|
||||
${PYSITELIB}/matplotlib/backends/backend_qtcairo.pyc
|
||||
${PYSITELIB}/matplotlib/backends/backend_qtcairo.pyo
|
||||
${PYSITELIB}/matplotlib/backends/backend_svg.py
|
||||
${PYSITELIB}/matplotlib/backends/backend_svg.pyc
|
||||
${PYSITELIB}/matplotlib/backends/backend_svg.pyo
|
||||
|
@ -195,15 +210,9 @@ ${PYSITELIB}/matplotlib/backends/qt_editor/__init__.pyo
|
|||
${PYSITELIB}/matplotlib/backends/qt_editor/_formlayout.py
|
||||
${PYSITELIB}/matplotlib/backends/qt_editor/_formlayout.pyc
|
||||
${PYSITELIB}/matplotlib/backends/qt_editor/_formlayout.pyo
|
||||
${PYSITELIB}/matplotlib/backends/qt_editor/_formsubplottool.py
|
||||
${PYSITELIB}/matplotlib/backends/qt_editor/_formsubplottool.pyc
|
||||
${PYSITELIB}/matplotlib/backends/qt_editor/_formsubplottool.pyo
|
||||
${PYSITELIB}/matplotlib/backends/qt_editor/figureoptions.py
|
||||
${PYSITELIB}/matplotlib/backends/qt_editor/figureoptions.pyc
|
||||
${PYSITELIB}/matplotlib/backends/qt_editor/figureoptions.pyo
|
||||
${PYSITELIB}/matplotlib/backends/qt_editor/formsubplottool.py
|
||||
${PYSITELIB}/matplotlib/backends/qt_editor/formsubplottool.pyc
|
||||
${PYSITELIB}/matplotlib/backends/qt_editor/formsubplottool.pyo
|
||||
${PYSITELIB}/matplotlib/backends/web_backend/.eslintrc.js
|
||||
${PYSITELIB}/matplotlib/backends/web_backend/.prettierignore
|
||||
${PYSITELIB}/matplotlib/backends/web_backend/.prettierrc
|
||||
|
@ -246,9 +255,6 @@ ${PYSITELIB}/matplotlib/colorbar.pyo
|
|||
${PYSITELIB}/matplotlib/colors.py
|
||||
${PYSITELIB}/matplotlib/colors.pyc
|
||||
${PYSITELIB}/matplotlib/colors.pyo
|
||||
${PYSITELIB}/matplotlib/compat/__init__.py
|
||||
${PYSITELIB}/matplotlib/compat/__init__.pyc
|
||||
${PYSITELIB}/matplotlib/compat/__init__.pyo
|
||||
${PYSITELIB}/matplotlib/container.py
|
||||
${PYSITELIB}/matplotlib/container.pyc
|
||||
${PYSITELIB}/matplotlib/container.pyo
|
||||
|
@ -454,6 +460,7 @@ ${PYSITELIB}/matplotlib/mpl-data/images/zoom_to_rect.pdf
|
|||
${PYSITELIB}/matplotlib/mpl-data/images/zoom_to_rect.png
|
||||
${PYSITELIB}/matplotlib/mpl-data/images/zoom_to_rect.svg
|
||||
${PYSITELIB}/matplotlib/mpl-data/images/zoom_to_rect_large.png
|
||||
${PYSITELIB}/matplotlib/mpl-data/kpsewhich.lua
|
||||
${PYSITELIB}/matplotlib/mpl-data/matplotlibrc
|
||||
${PYSITELIB}/matplotlib/mpl-data/plot_directive/plot_directive.css
|
||||
${PYSITELIB}/matplotlib/mpl-data/sample_data/Minduka_Present_Blue_Pack.png
|
||||
|
@ -473,6 +480,8 @@ ${PYSITELIB}/matplotlib/mpl-data/sample_data/s1045.ima.gz
|
|||
${PYSITELIB}/matplotlib/mpl-data/sample_data/topobathy.npz
|
||||
${PYSITELIB}/matplotlib/mpl-data/stylelib/Solarize_Light2.mplstyle
|
||||
${PYSITELIB}/matplotlib/mpl-data/stylelib/_classic_test_patch.mplstyle
|
||||
${PYSITELIB}/matplotlib/mpl-data/stylelib/_mpl-gallery-nogrid.mplstyle
|
||||
${PYSITELIB}/matplotlib/mpl-data/stylelib/_mpl-gallery.mplstyle
|
||||
${PYSITELIB}/matplotlib/mpl-data/stylelib/bmh.mplstyle
|
||||
${PYSITELIB}/matplotlib/mpl-data/stylelib/classic.mplstyle
|
||||
${PYSITELIB}/matplotlib/mpl-data/stylelib/dark_background.mplstyle
|
||||
|
@ -644,6 +653,9 @@ ${PYSITELIB}/matplotlib/tests/test_backend_cairo.pyo
|
|||
${PYSITELIB}/matplotlib/tests/test_backend_gtk3.py
|
||||
${PYSITELIB}/matplotlib/tests/test_backend_gtk3.pyc
|
||||
${PYSITELIB}/matplotlib/tests/test_backend_gtk3.pyo
|
||||
${PYSITELIB}/matplotlib/tests/test_backend_macosx.py
|
||||
${PYSITELIB}/matplotlib/tests/test_backend_macosx.pyc
|
||||
${PYSITELIB}/matplotlib/tests/test_backend_macosx.pyo
|
||||
${PYSITELIB}/matplotlib/tests/test_backend_nbagg.py
|
||||
${PYSITELIB}/matplotlib/tests/test_backend_nbagg.pyc
|
||||
${PYSITELIB}/matplotlib/tests/test_backend_nbagg.pyo
|
||||
|
@ -728,6 +740,9 @@ ${PYSITELIB}/matplotlib/tests/test_font_manager.pyo
|
|||
${PYSITELIB}/matplotlib/tests/test_fontconfig_pattern.py
|
||||
${PYSITELIB}/matplotlib/tests/test_fontconfig_pattern.pyc
|
||||
${PYSITELIB}/matplotlib/tests/test_fontconfig_pattern.pyo
|
||||
${PYSITELIB}/matplotlib/tests/test_getattr.py
|
||||
${PYSITELIB}/matplotlib/tests/test_getattr.pyc
|
||||
${PYSITELIB}/matplotlib/tests/test_getattr.pyo
|
||||
${PYSITELIB}/matplotlib/tests/test_gridspec.py
|
||||
${PYSITELIB}/matplotlib/tests/test_gridspec.pyc
|
||||
${PYSITELIB}/matplotlib/tests/test_gridspec.pyo
|
||||
|
@ -899,9 +914,6 @@ ${PYSITELIB}/matplotlib/tri/trirefine.pyo
|
|||
${PYSITELIB}/matplotlib/tri/tritools.py
|
||||
${PYSITELIB}/matplotlib/tri/tritools.pyc
|
||||
${PYSITELIB}/matplotlib/tri/tritools.pyo
|
||||
${PYSITELIB}/matplotlib/ttconv.py
|
||||
${PYSITELIB}/matplotlib/ttconv.pyc
|
||||
${PYSITELIB}/matplotlib/ttconv.pyo
|
||||
${PYSITELIB}/matplotlib/type1font.py
|
||||
${PYSITELIB}/matplotlib/type1font.pyc
|
||||
${PYSITELIB}/matplotlib/type1font.pyo
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.47 2021/11/06 11:59:28 adam Exp $
|
||||
$NetBSD: distinfo,v 1.48 2022/06/16 15:24:40 ryoon Exp $
|
||||
|
||||
BLAKE2s (matplotlib-3.4.3.tar.gz) = 8ddbdfe07af7899d22386b8dfeede8e669cdcb48999022ae29192dff4941e55c
|
||||
SHA512 (matplotlib-3.4.3.tar.gz) = c2fe54e7517a1417aa8e55596e83edd090534c07f22882634d6ba0a07196441b5bbdd15958473805d8e8871b1b73380487aff3224294d472cd6122490c783145
|
||||
Size (matplotlib-3.4.3.tar.gz) = 37850796 bytes
|
||||
SHA1 (patch-setup.cfg) = 11dd8b9dd84005c8b195d86f0ccd5ff58502edf4
|
||||
BLAKE2s (matplotlib-3.5.2.tar.gz) = ca969958dd09307b7760477480cf1f4d11a04f711918dbaa151ef43bc6007e05
|
||||
SHA512 (matplotlib-3.5.2.tar.gz) = 32844dfa85dbc43360c1773d748a58d2ab089111c51c825da62956c778a0eeaf10ca33a5c6c094295388a80d5873a2e1b17484e02b653e9e8e5ba98659329974
|
||||
Size (matplotlib-3.5.2.tar.gz) = 35210006 bytes
|
||||
SHA1 (patch-mplsetup.cfg) = 06bf93f112ab4ed4604179c1cc7fd2bdee62b56d
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-setup.cfg,v 1.2 2021/01/17 05:19:33 mef Exp $
|
||||
$NetBSD: patch-mplsetup.cfg,v 1.1 2022/06/16 15:24:40 ryoon Exp $
|
||||
|
||||
Instruct to use system Freetype
|
||||
|
||||
|
@ -19,8 +19,8 @@ contents:
|
|||
-----------
|
||||
|
||||
--- /dev/null 2021-01-17 13:10:59.949185604 +0900
|
||||
+++ setup.cfg 2021-01-17 13:55:23.673846857 +0900
|
||||
+++ mplsetup.cfg 2021-01-17 13:55:23.673846857 +0900
|
||||
@@ -0,0 +1,3 @@
|
||||
+ [libs]
|
||||
+ system_freetype = true
|
||||
+ system_qhull = true
|
||||
+[libs]
|
||||
+system_freetype = true
|
||||
+system_qhull = true
|
Loading…
Reference in a new issue