Update cabextract to version 1.2. Notable changes include:
* The "-t" archive integrity checking option has been added. This was requested by several users. cabextract can unpack cabinet files and give you MD5 checksums of the files inside, without writing the unpacked files to disk. * Large files (more than 2 gigabytes) are now correctly searched for cabinet files. * A security vulnerability has been fixed. Files compressed with the Quantum method, using a window size less than 32768 bytes, could cause cabextract to write beyond the end of the window and cause a segmentation fault. This fix also permits cabextract to unpack this type of cabinet file (of which only one has been found in the wild) correctly. * The unnecessary GNU source mempcpy.c, which caused compilation failures on several systems, was removed. * An off-by-one error introduced in 1.1's UTF-8 decoder was fixed. Files with UTF-8 filenames can now be extracted. The UTF-8 decoder was also upgraded to support the latest Unicode characer maps.
This commit is contained in:
parent
3f2bb2b72c
commit
1d272804ae
4 changed files with 6 additions and 50 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.16 2006/02/05 23:08:03 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.17 2006/09/23 13:02:17 ben Exp $
|
||||
#
|
||||
|
||||
DISTNAME= cabextract-1.1
|
||||
PKGREVISION= 1
|
||||
DISTNAME= cabextract-1.2
|
||||
CATEGORIES= archivers
|
||||
MASTER_SITES= http://www.kyz.uklinux.net/downloads/
|
||||
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.8 2005/02/23 14:45:22 agc Exp $
|
||||
$NetBSD: distinfo,v 1.9 2006/09/23 13:02:17 ben Exp $
|
||||
|
||||
SHA1 (cabextract-1.1.tar.gz) = 359c8f4ec9c62d9dac5d572269b607b2cae4fbf7
|
||||
RMD160 (cabextract-1.1.tar.gz) = f895a466d03c59cd4e99c217f8e9f409bf1b0bfc
|
||||
Size (cabextract-1.1.tar.gz) = 187495 bytes
|
||||
SHA1 (patch-aa) = 4d36b50b1ca2dfd6f317dd0bcbc23523e1da70f2
|
||||
SHA1 (patch-ab) = 87d0089ebc1589c805b67d44675c78f1cc4ffc3b
|
||||
SHA1 (cabextract-1.2.tar.gz) = 871b3db4bc2629eb5726659c147aecea1af6a6d0
|
||||
RMD160 (cabextract-1.2.tar.gz) = 55292e287047b14945e69b0be8ab9ff1d4902f71
|
||||
Size (cabextract-1.2.tar.gz) = 194006 bytes
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.5 2004/10/28 10:35:56 wiz Exp $
|
||||
|
||||
--- mempcpy.c.orig 2004-07-16 16:07:01.000000000 +0200
|
||||
+++ mempcpy.c
|
||||
@@ -29,7 +29,13 @@ Copies @var{length} bytes from memory re
|
||||
|
||||
*/
|
||||
|
||||
-#include <ansidecl.h>
|
||||
+#include <string.h>
|
||||
+#ifndef PTR
|
||||
+#define PTR void*
|
||||
+#endif
|
||||
+#ifndef PARAMS
|
||||
+#define PARAMS(x) x
|
||||
+#endif
|
||||
#ifdef ANSI_PROTOTYPES
|
||||
#include <stddef.h>
|
||||
#else
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1 2004/10/29 14:31:27 tv Exp $
|
||||
|
||||
--- configure.orig Fri Oct 29 09:40:19 2004
|
||||
+++ configure
|
||||
@@ -6608,7 +6608,7 @@ fi
|
||||
|
||||
|
||||
|
||||
-
|
||||
+if false; then
|
||||
for ac_func in mempcpy
|
||||
do
|
||||
as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
|
||||
@@ -6717,7 +6717,7 @@ esac
|
||||
|
||||
fi
|
||||
done
|
||||
-
|
||||
+fi
|
||||
|
||||
|
||||
ac_config_files="$ac_config_files Makefile cabextract.spec"
|
Loading…
Reference in a new issue