* Switched to gcc-4.1.2
* Clean-up
This commit is contained in:
parent
1f630bf27a
commit
1da7202b9c
19 changed files with 128 additions and 151 deletions
|
@ -1,26 +1,27 @@
|
|||
# $NetBSD: Makefile,v 1.14 2013/02/08 12:46:14 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.15 2013/05/20 05:47:34 adam Exp $
|
||||
|
||||
DISTNAME= g95_source
|
||||
VERSION= 0.93
|
||||
PKGNAME= g95-${VERSION}
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://ftp.g95.org/v${VERSION}/
|
||||
EXTRACT_SUFX= .tgz
|
||||
DIST_SUBDIR= ${PKGNAME_NOREV}
|
||||
DISTFILES= ${DEFAULT_DISTFILES}
|
||||
DISTFILES+= gcc-core-4.0.3.tar.bz2
|
||||
SITES.gcc-core-4.0.3.tar.bz2= ${MASTER_SITE_GNU:=gcc/gcc-4.0.3/}
|
||||
DISTNAME= g95_source
|
||||
PKGNAME= g95-0.93
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://ftp.g95.org/v${PKGVERSION_NOREV}/
|
||||
EXTRACT_SUFX= .tgz
|
||||
DISTFILES= ${DEFAULT_DISTFILES} gcc-core-${GCC_VER}.tar.bz2
|
||||
SITES.gcc-core-${GCC_VER}.tar.bz2= ${MASTER_SITE_GNU:=gcc/gcc-${GCC_VER}/}
|
||||
|
||||
MAINTAINER= wennmach@NetBSD.org
|
||||
HOMEPAGE= http://www.g95.org/
|
||||
COMMENT= Fortran 95 compiler from g95.org
|
||||
MAINTAINER= wennmach@NetBSD.org
|
||||
HOMEPAGE= http://www.g95.org/
|
||||
COMMENT= Fortran 95 compiler from g95.org
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_TOOLS+= gmake gtar
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --with-gcc-dir=${GCC_DIR}
|
||||
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
|
||||
PLIST_SUBST+= MACHINE_GNU_PLATFORM=${MACHINE_GNU_PLATFORM:Q}
|
||||
|
||||
GCC_DIR= ${WRKDIR}/gcc-4.0.3
|
||||
GCC_VER= 4.1.2
|
||||
GCC_DIR= ${WRKDIR}/gcc-${GCC_VER}
|
||||
GCC_G95_DIR= ${GCC_DIR}/g95
|
||||
GCC_CONFIGURE_SCRIPT= ../configure
|
||||
GCC_CONFIGURE_ARGS= ${CONFIGURE_ARGS}
|
||||
|
@ -31,18 +32,16 @@ GCC_CONFIGURE_ARGS+= --disable-multilib
|
|||
.if ${OPSYS} == "SunOS"
|
||||
GCC_CONFIGURE_ENV+= OBJDUMP=/usr/sfw/bin/gobjdump
|
||||
GCC_CONFIGURE_ARGS+= --without-gnu-ld --with-ld=/usr/ccs/bin/ld
|
||||
. if !exists(/usr/sfw/bin/gas)
|
||||
. if !exists(/usr/sfw/bin/gas)
|
||||
GCC_CONFIGURE_ARGS+= --without-gnu-as --with-as=/usr/ccs/bin/as
|
||||
. else
|
||||
. else
|
||||
GCC_CONFIGURE_ARGS+= --with-gnu-as --with-as=/usr/sfw/bin/gas
|
||||
. endif
|
||||
. endif
|
||||
.endif
|
||||
|
||||
CONFIGURE_ARGS+= --with-gcc-dir=${GCC_DIR}
|
||||
|
||||
post-extract:
|
||||
${MKDIR} ${GCC_G95_DIR}
|
||||
cd ${WRKSRC} && ${GTAR} -xzf libf95.a-${VERSION}.tar.gz
|
||||
cd ${WRKSRC} && ${GTAR} -xzf libf95.a-${PKGVERSION_NOREV}.tar.gz
|
||||
|
||||
pre-configure:
|
||||
rm -f ${GCC_DIR}/config.sub ${GCC_DIR}/config.guess
|
||||
|
@ -51,10 +50,10 @@ pre-configure:
|
|||
cd ${GCC_G95_DIR} && ${GCC_CONFIGURE_SCRIPT} ${GCC_CONFIGURE_ARGS} && ${GMAKE}
|
||||
|
||||
post-build:
|
||||
cd ${WRKSRC}/libf95.a-${VERSION} && ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS} && ${GMAKE}
|
||||
cd ${WRKSRC}/libf95.a-${PKGVERSION_NOREV} && ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS} && ${GMAKE}
|
||||
|
||||
post-install:
|
||||
cd ${WRKSRC}/libf95.a-${VERSION} && ${GMAKE} install DESTDIR=${DESTDIR:Q}
|
||||
cd ${WRKSRC}/libf95.a-${PKGVERSION_NOREV} && ${GMAKE} install DESTDIR=${DESTDIR:Q}
|
||||
cd ${DESTDIR}${PREFIX}/bin && ${LN} -sf ${MACHINE_GNU_PLATFORM:Q}-g95 g95
|
||||
cd ${DESTDIR}${PREFIX}/bin && ${LN} -sf ${MACHINE_GNU_PLATFORM:Q}-g95 f95
|
||||
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2009/06/14 18:03:31 joerg Exp $
|
||||
bin/g95
|
||||
@comment $NetBSD: PLIST,v 1.4 2013/05/20 05:47:34 adam Exp $
|
||||
bin/f95
|
||||
bin/g95
|
||||
bin/${MACHINE_GNU_PLATFORM}-g95
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/cc1
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/f951
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/libgcc_eh.a
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/libgcc_s.so
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/libgcc_s.so.1
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/libgcc.a
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/libf95.a
|
||||
share/doc/g95/INSTALL
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/cc1
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/f951
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/libgcc_eh.a
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/libgcc_s.so
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/libgcc_s.so.1
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/libgcc.a
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/libf95.a
|
||||
share/doc/g95/G95Manual.pdf
|
||||
share/doc/g95/INSTALL
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
@comment $NetBSD: PLIST.DragonFly,v 1.1 2011/12/16 17:17:49 marino Exp $
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/crtbegin.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/crtbeginS.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/crtend.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/crtendS.o
|
||||
@comment $NetBSD: PLIST.DragonFly,v 1.2 2013/05/20 05:47:34 adam Exp $
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/crtbegin.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/crtbeginS.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/crtend.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/crtendS.o
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
@comment $NetBSD: PLIST.Linux,v 1.1 2011/01/23 09:42:10 markd Exp $
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/crtbegin.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/crtbeginS.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/crtbeginT.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/crtend.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/crtendS.o
|
||||
@comment $NetBSD: PLIST.Linux,v 1.2 2013/05/20 05:47:34 adam Exp $
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/crtbegin.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/crtbeginS.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/crtbeginT.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/crtend.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/crtendS.o
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST.SunOS,v 1.1 2012/03/20 17:26:19 hans Exp $
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/crtbegin.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/crtend.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.0.3/gmon.o
|
||||
@comment $NetBSD: PLIST.SunOS,v 1.2 2013/05/20 05:47:34 adam Exp $
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/crtbegin.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/crtend.o
|
||||
lib/gcc-lib/${MACHINE_GNU_PLATFORM}/4.1.2/gmon.o
|
||||
|
|
|
@ -1,23 +1,22 @@
|
|||
$NetBSD: distinfo,v 1.14 2013/04/04 14:31:32 jperkin Exp $
|
||||
$NetBSD: distinfo,v 1.15 2013/05/20 05:47:34 adam Exp $
|
||||
|
||||
SHA1 (g95-0.93/g95_source.tgz) = b5e503fd6459b65cbda73190685f9490230d9cff
|
||||
RMD160 (g95-0.93/g95_source.tgz) = 98d03e9a1835f4b3553a72a798bdf1d90a757176
|
||||
Size (g95-0.93/g95_source.tgz) = 1355198 bytes
|
||||
SHA1 (g95-0.93/gcc-core-4.0.3.tar.bz2) = 5aa3e370dddaa485909028120002c3bb21e86be2
|
||||
RMD160 (g95-0.93/gcc-core-4.0.3.tar.bz2) = a930f26630a61194b134dba3c828b52e4bdbf81f
|
||||
Size (g95-0.93/gcc-core-4.0.3.tar.bz2) = 15573608 bytes
|
||||
SHA1 (patch-.._gcc-4.0.3_gcc_config.gcc) = f93cca19dbb3544a1259960a3ab092fd72038125
|
||||
SHA1 (patch-.._gcc-4.0.3_gcc_config_dragonfly-spec.h) = 2fac90d3b4b2113e4713497fbcf3a3999dde2045
|
||||
SHA1 (patch-.._gcc-4.0.3_gcc_config_dragonfly.h) = 12707232e61b664f3b1a9943cbb3a49e61e94fa9
|
||||
SHA1 (patch-.._gcc-4.0.3_gcc_config_i386_darwin.h) = f5b17c0c33e824f8463f9b8c82fb012796ba4927
|
||||
SHA1 (patch-.._gcc-4.0.3_gcc_config_i386_dragonfly.h) = 96fa1faed692f8d4aeade98dd42d25b85ba051d7
|
||||
SHA1 (patch-.._gcc-4.0.3_gcc_config_i386_dragonfly64.h) = b228dbcdf7b5cf22d41d6ff04a37c569ca514c50
|
||||
SHA1 (patch-.._gcc-4.0.3_gcc_config_t-dragonfly) = 9636163ffd359b2a0dbb0a7fec2ca1cf98032c3d
|
||||
SHA1 (patch-.._gcc-4.0.3_gcc_config_t-dragonfly-thread) = a7181b3061e32d3edd38c09eed34232a75de83cf
|
||||
SHA1 (patch-.._gcc-4.0.3_gcc_ginclude_stddef.h) = 5e18b132d36ca02dcfed0569297e7ad6b1eada26
|
||||
SHA1 (patch-.._gcc-4.0.3_gcc_toplev.h) = 164115c81d1a286c139afc652e6e85b2daba9d38
|
||||
SHA1 (patch-ab) = 7275d8df3ba1621f3d496c386df999295f36f974
|
||||
SHA1 (g95_source.tgz) = b5e503fd6459b65cbda73190685f9490230d9cff
|
||||
RMD160 (g95_source.tgz) = 98d03e9a1835f4b3553a72a798bdf1d90a757176
|
||||
Size (g95_source.tgz) = 1355198 bytes
|
||||
SHA1 (gcc-core-4.1.2.tar.bz2) = d6875295f6df1bec4a6f4ab8f0da54bfb8d97306
|
||||
RMD160 (gcc-core-4.1.2.tar.bz2) = 612cbd5b795f7095fb3f565e6a8eaaee82c472c5
|
||||
Size (gcc-core-4.1.2.tar.bz2) = 17485561 bytes
|
||||
SHA1 (patch-ab) = 74187ee99e3e383333219cbc53676c07ca03ff19
|
||||
SHA1 (patch-ac) = b20a90cc2f9078cf0048980b75fa6836da0f28a8
|
||||
SHA1 (patch-gcc_config.gcc) = 9da8f32372c64b1590d97e3f26aec0d5652cc959
|
||||
SHA1 (patch-gcc_config_dragonfly-spec.h) = bf0c97caa314714542cf8cc63fdf0c73bda80511
|
||||
SHA1 (patch-gcc_config_dragonfly.h) = 6d46b7b4637a20b36e19a15e1eaffdfff6638de9
|
||||
SHA1 (patch-gcc_config_i386_dragonfly.h) = 7d60d29b5ae636d69650e8c412a94f7a6045f6d9
|
||||
SHA1 (patch-gcc_config_i386_dragonfly64.h) = 9d2d8512a913e58055fa5c1b7d85a109117dcfba
|
||||
SHA1 (patch-gcc_config_t-dragonfly) = dd8d5919af737dfb9e3c18be9a41b4e2c6f31155
|
||||
SHA1 (patch-gcc_config_t-dragonfly-thread) = ebdb58dacf0dc5d0bf2f1f1707a7c6ab29ee308c
|
||||
SHA1 (patch-gcc_ginclude_stddef.h) = 60f51a470e03173803b5e20b1fa4d6882e8d1fe9
|
||||
SHA1 (patch-gcc_toplev.h) = 4894b45bf0fd30de0610a36827ef1089e0ec6bd5
|
||||
SHA1 (patch-libf95.a-0.92_configure) = e23998692b410acaabaf24f591b659d2b229bcca
|
||||
SHA1 (patch-libf95.a-0.92_io_atof.c) = 0c3a209815be3a97d984cb9a15ee888f93110d1d
|
||||
SHA1 (patch-libf95.a-0.93_intrinsics_dot__product10.c) = a2fe19bab2a6f719f541692fd4ef7e67766a18e5
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
$NetBSD: patch-.._gcc-4.0.3_gcc_config_i386_darwin.h,v 1.1 2013/04/04 14:31:32 jperkin Exp $
|
||||
|
||||
Fix -arch type on OSX.
|
||||
|
||||
--- ../gcc-4.0.3/gcc/config/i386/darwin.h.orig 2013-04-04 14:07:01.000000000 +0000
|
||||
+++ ../gcc-4.0.3/gcc/config/i386/darwin.h 2013-04-04 14:07:38.000000000 +0000
|
||||
@@ -23,7 +23,7 @@
|
||||
#undef TARGET_MACHO
|
||||
#define TARGET_MACHO 1
|
||||
|
||||
-#define TARGET_VERSION fprintf (stderr, " (i686 Darwin)");
|
||||
+#define TARGET_VERSION fprintf (stderr, " (i386 Darwin)");
|
||||
|
||||
#define TARGET_OS_CPP_BUILTINS() \
|
||||
do \
|
||||
@@ -43,12 +43,12 @@
|
||||
%{g: %{!fno-eliminate-unused-debug-symbols: -feliminate-unused-debug-symbols }}"
|
||||
|
||||
#undef ASM_SPEC
|
||||
-#define ASM_SPEC "-arch i686 -force_cpusubtype_ALL"
|
||||
+#define ASM_SPEC "-arch i386 -force_cpusubtype_ALL"
|
||||
|
||||
#undef SUBTARGET_EXTRA_SPECS
|
||||
#define SUBTARGET_EXTRA_SPECS \
|
||||
- { "darwin_arch", "i686" }, \
|
||||
- { "darwin_subarch", "%{march=pentium3:pentIIm3;:i686}" },
|
||||
+ { "darwin_arch", "i386" }, \
|
||||
+ { "darwin_subarch", "%{march=pentium3:pentIIm3;:i386}" },
|
||||
|
||||
|
||||
/* Use the following macro for any Darwin/x86-specific command-line option
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-.._gcc-4.0.3_gcc_config_t-dragonfly,v 1.1 2011/02/19 16:06:31 rumko Exp $
|
||||
|
||||
DragonFly BSD support.
|
||||
|
||||
--- /dev/null 2011-02-07 10:19:08 +0100
|
||||
+++ ../gcc-4.0.3/gcc/config/t-dragonfly 2011-02-07 10:22:59 +0100
|
||||
@@ -0,0 +1,5 @@
|
||||
+# Compile crtbeginS.o and crtendS.o with pic.
|
||||
+CRTSTUFF_T_CFLAGS_S = -fPIC
|
||||
+
|
||||
+# Compile libgcc.a with pic.
|
||||
+TARGET_LIBGCC2_CFLAGS += -fPIC
|
|
@ -1,9 +0,0 @@
|
|||
$NetBSD: patch-.._gcc-4.0.3_gcc_config_t-dragonfly-thread,v 1.1 2011/02/19 16:06:31 rumko Exp $
|
||||
|
||||
DragonFly BSD support.
|
||||
|
||||
--- /dev/null 2011-02-07 10:19:08 +0100
|
||||
+++ ../gcc-4.0.3/gcc/config/t-dragonfly-thread 2011-02-07 10:23:04 +0100
|
||||
@@ -0,0 +1,2 @@
|
||||
+# This is currently needed to compile libgcc2 for threads support
|
||||
+TARGET_LIBGCC2_CFLAGS += -pthread
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-ab,v 1.6 2012/05/08 02:59:16 sbd Exp $
|
||||
$NetBSD: patch-ab,v 1.7 2013/05/20 05:47:34 adam Exp $
|
||||
|
||||
Use $(host_alias) as the program prefix so it matches ${MACHINE_GNU_PLATFORM}
|
||||
|
||||
--- Makefile.in.orig 2009-02-17 16:46:06.000000000 +0000
|
||||
--- Makefile.in.orig 2010-04-22 04:23:24.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -1330,7 +1330,7 @@ clean-local:
|
||||
@@ -1418,7 +1418,7 @@ clean-local:
|
||||
rm -f options.tmp options.c options.h version.c
|
||||
|
||||
install-exec-hook:
|
||||
|
@ -13,7 +13,7 @@ Use $(host_alias) as the program prefix so it matches ${MACHINE_GNU_PLATFORM}
|
|||
|
||||
install-data-hook:
|
||||
-ln -sf f951$(EXEEXT) $(DESTDIR)@DEST_LIBDIR@/cc1
|
||||
@@ -1341,8 +1341,9 @@ install-data-hook:
|
||||
@@ -1429,8 +1429,9 @@ install-data-hook:
|
||||
ranlib $(DESTDIR)@DEST_LIBDIR@/libgcc_eh.a ; \
|
||||
ranlib $(DESTDIR)@DEST_LIBDIR@/libgcc.a ; \
|
||||
fi
|
||||
|
|
|
@ -1,10 +1,11 @@
|
|||
$NetBSD: patch-.._gcc-4.0.3_gcc_config.gcc,v 1.1 2011/02/19 16:06:31 rumko Exp $
|
||||
$NetBSD: patch-gcc_config.gcc,v 1.1 2013/05/20 05:47:34 adam Exp $
|
||||
|
||||
Darwin 64-bit support.
|
||||
DragonFly BSD support.
|
||||
|
||||
--- ../gcc-4.0.3/gcc/config.gcc.orig 2011-02-01 19:11:53 +0100
|
||||
+++ ../gcc-4.0.3/gcc/config.gcc 2011-02-01 21:15:59 +0100
|
||||
@@ -440,6 +440,23 @@
|
||||
--- ../gcc-4.1.2/gcc/config.gcc.orig 2006-10-15 23:12:23.000000000 +0000
|
||||
+++ ../gcc-4.1.2/gcc/config.gcc
|
||||
@@ -440,6 +440,23 @@ case ${target} in
|
||||
esac
|
||||
fbsd_tm_file="${fbsd_tm_file} freebsd-spec.h freebsd.h"
|
||||
;;
|
||||
|
@ -28,7 +29,16 @@ DragonFly BSD support.
|
|||
*-*-linux*libc1* | *-*-linux*aout*)
|
||||
# Avoid the generic linux case.
|
||||
;;
|
||||
@@ -969,6 +986,12 @@
|
||||
@@ -981,6 +998,8 @@ hppa[12]*-*-hpux11*)
|
||||
i[34567]86-*-darwin*)
|
||||
# All the configuration is presently done generically.
|
||||
;;
|
||||
+x86_64-*-darwin*)
|
||||
+ ;;
|
||||
i[34567]86-*-elf*)
|
||||
tm_file="${tm_file} i386/unix.h i386/att.h dbxelf.h elfos.h i386/i386elf.h"
|
||||
tmake_file="i386/t-i386elf t-svr4"
|
||||
@@ -1012,6 +1031,12 @@ i[34567]86-*-freebsd*)
|
||||
x86_64-*-freebsd*)
|
||||
tm_file="${tm_file} i386/unix.h i386/att.h dbxelf.h elfos.h ${fbsd_tm_file} i386/x86-64.h i386/freebsd.h i386/freebsd64.h"
|
||||
;;
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-.._gcc-4.0.3_gcc_config_dragonfly-spec.h,v 1.1 2011/02/19 16:06:31 rumko Exp $
|
||||
$NetBSD: patch-gcc_config_dragonfly-spec.h,v 1.1 2013/05/20 05:47:34 adam Exp $
|
||||
|
||||
DragonFly BSD support.
|
||||
|
||||
--- /dev/null 2011-02-01 20:59:25 +0100
|
||||
+++ ../gcc-4.0.3/gcc/config/dragonfly-spec.h 2011-02-01 19:58:33 +0100
|
||||
--- ../gcc-4.1.2/gcc/config/dragonfly-spec.h.orig 2013-05-19 08:50:27.000000000 +0000
|
||||
+++ ../gcc-4.1.2/gcc/config/dragonfly-spec.h
|
||||
@@ -0,0 +1,117 @@
|
||||
+/* Base configuration file for all DragonFly targets.
|
||||
+ Copyright (C) 1999, 2000, 2001, 2004, 2005 Free Software Foundation, Inc.
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-.._gcc-4.0.3_gcc_config_dragonfly.h,v 1.1 2011/02/19 16:06:31 rumko Exp $
|
||||
$NetBSD: patch-gcc_config_dragonfly.h,v 1.1 2013/05/20 05:47:34 adam Exp $
|
||||
|
||||
DragonFly BSD support.
|
||||
|
||||
--- /dev/null 2011-02-01 20:59:25 +0100
|
||||
+++ ../gcc-4.0.3/gcc/config/dragonfly.h 2011-02-01 19:19:27 +0100
|
||||
--- ../gcc-4.1.2/gcc/config/dragonfly.h.orig 2013-05-19 08:51:14.000000000 +0000
|
||||
+++ ../gcc-4.1.2/gcc/config/dragonfly.h
|
||||
@@ -0,0 +1,87 @@
|
||||
+/* Base configuration file for all DragonFly targets.
|
||||
+ Copyright (C) 1999, 2000, 2001 Free Software Foundation, Inc.
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-.._gcc-4.0.3_gcc_config_i386_dragonfly.h,v 1.1 2011/02/19 16:06:31 rumko Exp $
|
||||
$NetBSD: patch-gcc_config_i386_dragonfly.h,v 1.1 2013/05/20 05:47:34 adam Exp $
|
||||
|
||||
DragonFly BSD support.
|
||||
|
||||
--- /dev/null 2011-02-01 20:59:25 +0100
|
||||
+++ ../gcc-4.0.3/gcc/config/i386/dragonfly.h 2011-02-01 19:38:39 +0100
|
||||
+++ ../gcc-4.1.2/gcc/config/i386/dragonfly.h 2011-02-01 19:38:39 +0100
|
||||
@@ -0,0 +1,145 @@
|
||||
+/* Definitions for Intel 386 running DragonFly with ELF format
|
||||
+ Copyright (C) 1996, 2000, 2002, 2004 Free Software Foundation, Inc.
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-.._gcc-4.0.3_gcc_config_i386_dragonfly64.h,v 1.1 2011/02/19 16:06:31 rumko Exp $
|
||||
$NetBSD: patch-gcc_config_i386_dragonfly64.h,v 1.1 2013/05/20 05:47:34 adam Exp $
|
||||
|
||||
DragonFly BSD support.
|
||||
|
||||
--- /dev/null 2011-02-01 20:59:25 +0100
|
||||
+++ ../gcc-4.0.3/gcc/config/i386/dragonfly64.h 2011-02-01 19:38:50 +0100
|
||||
--- ../gcc-4.1.2/gcc/config/i386/dragonfly64.h.orig 2013-05-19 08:54:10.000000000 +0000
|
||||
+++ ../gcc-4.1.2/gcc/config/i386/dragonfly64.h
|
||||
@@ -0,0 +1,45 @@
|
||||
+/* Definitions for AMD x86-64 running DragonFly with ELF format
|
||||
+ Copyright (C) 2002, 2004 Free Software Foundation, Inc.
|
12
lang/g95/patches/patch-gcc_config_t-dragonfly
Normal file
12
lang/g95/patches/patch-gcc_config_t-dragonfly
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-gcc_config_t-dragonfly,v 1.1 2013/05/20 05:47:34 adam Exp $
|
||||
|
||||
DragonFly BSD support.
|
||||
|
||||
--- ../gcc-4.1.2/gcc/config/t-dragonfly.orig 2013-05-19 08:54:45.000000000 +0000
|
||||
+++ ../gcc-4.1.2/gcc/config/t-dragonfly
|
||||
@@ -0,0 +1,5 @@
|
||||
+# Compile crtbeginS.o and crtendS.o with pic.
|
||||
+CRTSTUFF_T_CFLAGS_S = -fPIC
|
||||
+
|
||||
+# Compile libgcc.a with pic.
|
||||
+TARGET_LIBGCC2_CFLAGS += -fPIC
|
9
lang/g95/patches/patch-gcc_config_t-dragonfly-thread
Normal file
9
lang/g95/patches/patch-gcc_config_t-dragonfly-thread
Normal file
|
@ -0,0 +1,9 @@
|
|||
$NetBSD: patch-gcc_config_t-dragonfly-thread,v 1.1 2013/05/20 05:47:34 adam Exp $
|
||||
|
||||
DragonFly BSD support.
|
||||
|
||||
--- ../gcc-4.1.2/gcc/config/t-dragonfly-thread.orig 2013-05-19 08:55:29.000000000 +0000
|
||||
+++ ../gcc-4.1.2/gcc/config/t-dragonfly-thread
|
||||
@@ -0,0 +1,2 @@
|
||||
+# This is currently needed to compile libgcc2 for threads support
|
||||
+TARGET_LIBGCC2_CFLAGS += -pthread
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-.._gcc-4.0.3_gcc_ginclude_stddef.h,v 1.1 2011/02/19 16:06:31 rumko Exp $
|
||||
$NetBSD: patch-gcc_ginclude_stddef.h,v 1.1 2013/05/20 05:47:34 adam Exp $
|
||||
|
||||
DragonFly BSD support (_PTRDIFF_T_DECLARED is also needed on dfly).
|
||||
|
||||
--- ../gcc-4.0.3/gcc/ginclude/stddef.h.orig 2011-02-06 21:30:12 +0100
|
||||
+++ ../gcc-4.0.3/gcc/ginclude/stddef.h 2011-02-06 21:31:14 +0100
|
||||
@@ -62,6 +62,10 @@
|
||||
--- ../gcc-4.1.2/gcc/ginclude/stddef.h.orig 2005-06-25 01:11:52.000000000 +0000
|
||||
+++ ../gcc-4.1.2/gcc/ginclude/stddef.h
|
||||
@@ -62,6 +62,10 @@ Boston, MA 02110-1301, USA. */
|
||||
#include <sys/_types.h>
|
||||
#endif
|
||||
|
||||
|
@ -15,7 +15,7 @@ DragonFly BSD support (_PTRDIFF_T_DECLARED is also needed on dfly).
|
|||
/* In 4.3bsd-net2, machine/ansi.h defines these symbols, which are
|
||||
defined if the corresponding type is *not* defined.
|
||||
FreeBSD-2.1 defines _MACHINE_ANSI_H_ instead of _ANSI_H_ */
|
||||
@@ -131,6 +135,7 @@
|
||||
@@ -131,6 +135,7 @@ _TYPE_wchar_t;
|
||||
or if we want this type in particular. */
|
||||
#if defined (_STDDEF_H) || defined (__need_ptrdiff_t)
|
||||
#ifndef _PTRDIFF_T /* in case <sys/types.h> has defined it. */
|
||||
|
@ -23,7 +23,7 @@ DragonFly BSD support (_PTRDIFF_T_DECLARED is also needed on dfly).
|
|||
#ifndef _T_PTRDIFF_
|
||||
#ifndef _T_PTRDIFF
|
||||
#ifndef __PTRDIFF_T
|
||||
@@ -139,6 +144,7 @@
|
||||
@@ -139,6 +144,7 @@ _TYPE_wchar_t;
|
||||
#ifndef ___int_ptrdiff_t_h
|
||||
#ifndef _GCC_PTRDIFF_T
|
||||
#define _PTRDIFF_T
|
||||
|
@ -31,7 +31,7 @@ DragonFly BSD support (_PTRDIFF_T_DECLARED is also needed on dfly).
|
|||
#define _T_PTRDIFF_
|
||||
#define _T_PTRDIFF
|
||||
#define __PTRDIFF_T
|
||||
@@ -157,6 +163,7 @@
|
||||
@@ -157,6 +163,7 @@ typedef __PTRDIFF_TYPE__ ptrdiff_t;
|
||||
#endif /* __PTRDIFF_T */
|
||||
#endif /* _T_PTRDIFF */
|
||||
#endif /* _T_PTRDIFF_ */
|
||||
|
@ -39,7 +39,7 @@ DragonFly BSD support (_PTRDIFF_T_DECLARED is also needed on dfly).
|
|||
#endif /* _PTRDIFF_T */
|
||||
|
||||
/* If this symbol has done its job, get rid of it. */
|
||||
@@ -202,8 +209,8 @@
|
||||
@@ -202,8 +209,8 @@ typedef __PTRDIFF_TYPE__ ptrdiff_t;
|
||||
#define ___int_size_t_h
|
||||
#define _GCC_SIZE_T
|
||||
#define _SIZET_
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-.._gcc-4.0.3_gcc_toplev.h,v 1.1 2013/03/02 18:05:46 joerg Exp $
|
||||
$NetBSD: patch-gcc_toplev.h,v 1.1 2013/05/20 05:47:34 adam Exp $
|
||||
|
||||
--- ../gcc-4.0.3/gcc/toplev.h.orig 2013-03-01 10:43:23.000000000 +0000
|
||||
+++ ../gcc-4.0.3/gcc/toplev.h
|
||||
@@ -180,13 +180,13 @@ extern int floor_log2 (
|
||||
--- ../gcc-4.1.2/gcc/toplev.h.orig 2005-09-09 00:47:05.000000000 +0000
|
||||
+++ ../gcc-4.1.2/gcc/toplev.h
|
||||
@@ -171,13 +171,13 @@ extern int floor_log2 (
|
||||
# define CTZ_HWI __builtin_ctz
|
||||
# endif
|
||||
|
Loading…
Reference in a new issue