Fix build with gcc4.5
This commit is contained in:
parent
9980daec90
commit
1dabb531e3
9 changed files with 126 additions and 2 deletions
|
@ -1,7 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.2 2010/06/13 22:44:28 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.3 2011/01/29 22:39:27 markd Exp $
|
||||
|
||||
SHA1 (digikam-0.9.6.tar.bz2) = e63148a13c40e87957eeb8b17dc8047dffa2a1a5
|
||||
RMD160 (digikam-0.9.6.tar.bz2) = 3abc8d6d7dc4a95473b00eacc8800c044b110215
|
||||
Size (digikam-0.9.6.tar.bz2) = 11517637 bytes
|
||||
SHA1 (patch-aa) = 818a8ae95459dd8fb25ace8210af0a0576084aba
|
||||
SHA1 (patch-ab) = 50636e14be0b183ac8ee2147a3b3a8227cef10d5
|
||||
SHA1 (patch-ac) = ec8cfcb1c400f13ebc9e92cc807eb179e5fc6a56
|
||||
SHA1 (patch-ad) = 59fb7af989b7e32978444d1d2e13493e821cc10e
|
||||
SHA1 (patch-ae) = 8f19dd6698647434bb20f222ef25024473a7ff2d
|
||||
SHA1 (patch-af) = d34710baea502e96cd8254164157ef68a4ef276f
|
||||
SHA1 (patch-ag) = 3dc532aa36451f7df8d10aa35149db767b295d8c
|
||||
|
|
15
graphics/digikam-kde3/patches/patch-ac
Normal file
15
graphics/digikam-kde3/patches/patch-ac
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ac,v 1.1 2011/01/29 22:39:27 markd Exp $
|
||||
|
||||
Dont insist on 1990 standard or fails to handle // comments in lcms.h
|
||||
|
||||
--- configure.orig 2011-01-29 03:23:57.867128819 +0000
|
||||
+++ configure
|
||||
@@ -5286,7 +5286,7 @@ fi
|
||||
CXXFLAGS="-Wall -W -Wpointer-arith $CXXFLAGS"
|
||||
case $host in
|
||||
*-*-linux-gnu)
|
||||
- CFLAGS="-std=iso9899:1990 -W -Wall -Wchar-subscripts -Wshadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -D_XOPEN_SOURCE=500 -D_BSD_SOURCE $CFLAGS"
|
||||
+ CFLAGS="-W -Wall -Wchar-subscripts -Wshadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -D_XOPEN_SOURCE=500 -D_BSD_SOURCE $CFLAGS"
|
||||
CXXFLAGS="-ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts $CXXFLAGS"
|
||||
|
||||
{ echo "$as_me:$LINENO: checking whether $CXX supports -Wmissing-format-attribute" >&5
|
15
graphics/digikam-kde3/patches/patch-ad
Normal file
15
graphics/digikam-kde3/patches/patch-ad
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ad,v 1.1 2011/01/29 22:39:27 markd Exp $
|
||||
|
||||
Fix build with gcc4.5
|
||||
|
||||
--- digikam/libs/dimg/dcolor.cpp.orig 2009-07-03 05:19:41.000000000 +0000
|
||||
+++ digikam/libs/dimg/dcolor.cpp
|
||||
@@ -83,7 +83,7 @@ QColor DColor::getQColor() const
|
||||
return eightBit.getQColor();
|
||||
}
|
||||
|
||||
- return (QColor::QColor(m_red, m_green, m_blue));
|
||||
+ return (QColor(m_red, m_green, m_blue));
|
||||
}
|
||||
|
||||
void DColor::convertToSixteenBit()
|
15
graphics/digikam-kde3/patches/patch-ae
Normal file
15
graphics/digikam-kde3/patches/patch-ae
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ae,v 1.1 2011/01/29 22:39:27 markd Exp $
|
||||
|
||||
Fix build with gcc4.5
|
||||
|
||||
--- digikam/utilities/imageeditor/editor/imageiface.cpp.orig 2009-07-03 05:19:41.000000000 +0000
|
||||
+++ digikam/utilities/imageeditor/editor/imageiface.cpp
|
||||
@@ -140,7 +140,7 @@ DColor ImageIface::getColorInfoFromTarge
|
||||
if ( d->targetPreviewImage.isNull() || point.x() > previewWidth() || point.y() > previewHeight() )
|
||||
{
|
||||
DWarning() << k_funcinfo << "Coordinate out of range or no image data available!" << endl;
|
||||
- return DColor::DColor();
|
||||
+ return DColor();
|
||||
}
|
||||
|
||||
return d->targetPreviewImage.getPixelColor(point.x(), point.y());
|
18
graphics/digikam-kde3/patches/patch-af
Normal file
18
graphics/digikam-kde3/patches/patch-af
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-af,v 1.1 2011/01/29 22:39:27 markd Exp $
|
||||
|
||||
Fix build with gcc4.5
|
||||
|
||||
--- digikam/imageplugins/border/bordertool.cpp.orig 2009-07-03 05:19:41.000000000 +0000
|
||||
+++ digikam/imageplugins/border/bordertool.cpp
|
||||
@@ -144,9 +144,9 @@ BorderTool::BorderTool(QObject* parent)
|
||||
// -------------------------------------------------------------------
|
||||
|
||||
m_labelForeground = new QLabel(m_gboxSettings->plainPage());
|
||||
- m_firstColorButton = new KColorButton( QColor::QColor( 192, 192, 192 ), m_gboxSettings->plainPage() );
|
||||
+ m_firstColorButton = new KColorButton( QColor( 192, 192, 192 ), m_gboxSettings->plainPage() );
|
||||
m_labelBackground = new QLabel(m_gboxSettings->plainPage());
|
||||
- m_secondColorButton = new KColorButton( QColor::QColor( 128, 128, 128 ), m_gboxSettings->plainPage() );
|
||||
+ m_secondColorButton = new KColorButton( QColor( 128, 128, 128 ), m_gboxSettings->plainPage() );
|
||||
|
||||
// -------------------------------------------------------------------
|
||||
|
24
graphics/digikam-kde3/patches/patch-ag
Normal file
24
graphics/digikam-kde3/patches/patch-ag
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-ag,v 1.1 2011/01/29 22:39:27 markd Exp $
|
||||
|
||||
Fix build with gcc4.5
|
||||
|
||||
--- digikam/imageplugins/superimpose/dirselectwidget.cpp.orig 2009-07-03 05:19:41.000000000 +0000
|
||||
+++ digikam/imageplugins/superimpose/dirselectwidget.cpp
|
||||
@@ -61,7 +61,7 @@ DirSelectWidget::DirSelectWidget(QWidget
|
||||
if ( headerLabel.isNull() )
|
||||
header()->hide();
|
||||
|
||||
- setAlternateBackground(QColor::QColor());
|
||||
+ setAlternateBackground(QColor());
|
||||
}
|
||||
|
||||
DirSelectWidget::DirSelectWidget(KURL rootUrl, KURL currentUrl,
|
||||
@@ -75,7 +75,7 @@ DirSelectWidget::DirSelectWidget(KURL ro
|
||||
if ( headerLabel.isNull() )
|
||||
header()->hide();
|
||||
|
||||
- setAlternateBackground(QColor::QColor());
|
||||
+ setAlternateBackground(QColor());
|
||||
setRootPath(rootUrl, currentUrl);
|
||||
}
|
||||
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.2 2011/01/03 20:47:01 markd Exp $
|
||||
$NetBSD: distinfo,v 1.3 2011/01/29 22:49:20 markd Exp $
|
||||
|
||||
SHA1 (kipi-plugins-0.1.7.tar.bz2) = 520b6b9d36a8c5b8893c3a6b5a1a14f6b9cbd216
|
||||
RMD160 (kipi-plugins-0.1.7.tar.bz2) = f66473c11e66f9e06aa6772c7952b640b565def9
|
||||
|
@ -6,3 +6,5 @@ Size (kipi-plugins-0.1.7.tar.bz2) = 8836654 bytes
|
|||
SHA1 (patch-aa) = 02e5cb365c7fb4e24c7236b592af3d00eeab1fdf
|
||||
SHA1 (patch-ab) = 777834238d49c0b02c7e1d5c63dbdf0d27f13e24
|
||||
SHA1 (patch-ac) = 0022166061696e3db820c97be64e2780a63e8b4c
|
||||
SHA1 (patch-ad) = b33efd502e1bd305242debe0e9837903ab34021f
|
||||
SHA1 (patch-ae) = 6e12d87f6169d3ba1687eaa202c2edb1ac5ec7a4
|
||||
|
|
15
graphics/kipi-plugins-kde3/patches/patch-ad
Normal file
15
graphics/kipi-plugins-kde3/patches/patch-ad
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ad,v 1.1 2011/01/29 22:49:20 markd Exp $
|
||||
|
||||
Fix build with gcc4.5
|
||||
|
||||
--- kipi-plugins/simpleviewerexport/simpleviewerexport.cpp.orig 2008-12-13 11:20:05.000000000 +0000
|
||||
+++ kipi-plugins/simpleviewerexport/simpleviewerexport.cpp
|
||||
@@ -113,7 +113,7 @@ SimpleViewerExport::SimpleViewerExport(K
|
||||
m_simpleViewerFiles.append("swfobject.js");
|
||||
|
||||
const KAboutData *data = KApplication::kApplication()->aboutData();
|
||||
- m_hostName = QString::QString( data->appName() );
|
||||
+ m_hostName = QString( data->appName() );
|
||||
m_hostURL = data->homepage();
|
||||
|
||||
if (m_hostURL.isEmpty())
|
15
graphics/kipi-plugins-kde3/patches/patch-ae
Normal file
15
graphics/kipi-plugins-kde3/patches/patch-ae
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ae,v 1.1 2011/01/29 22:49:20 markd Exp $
|
||||
|
||||
Fix build with gcc4.5
|
||||
|
||||
--- kipi-plugins/cdarchiving/cdarchiving.cpp.orig 2008-12-13 11:20:05.000000000 +0000
|
||||
+++ kipi-plugins/cdarchiving/cdarchiving.cpp
|
||||
@@ -74,7 +74,7 @@ CDArchiving::CDArchiving( KIPI::Interfac
|
||||
{
|
||||
KImageIO::registerFormats();
|
||||
const KAboutData *data = KApplication::kApplication()->aboutData();
|
||||
- m_hostName = QString::QString( data->appName() );
|
||||
+ m_hostName = QString( data->appName() );
|
||||
|
||||
m_hostURL = data->homepage();
|
||||
|
Loading…
Reference in a new issue