Do as the comment say and use -fPIC everywhere but for Win32.

Bump revision.
This commit is contained in:
joerg 2015-03-22 20:07:46 +00:00
parent 3061cc2ebe
commit 1dc5c4a0b7
3 changed files with 17 additions and 2 deletions

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.2 2015/03/19 13:24:13 jperkin Exp $
# $NetBSD: Makefile,v 1.3 2015/03/22 20:07:46 joerg Exp $
DISTNAME= tigervnc-1.3.1
PKGREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=tigervnc/}
XORG_SERVER_FILE= xorg-server-1.12.4

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.1 2015/02/08 19:42:09 wiz Exp $
$NetBSD: distinfo,v 1.2 2015/03/22 20:07:46 joerg Exp $
SHA1 (tigervnc-1.3.1.tar.gz) = 308ec9a9a627d20406eebfaeac4f3d4398278cc1
RMD160 (tigervnc-1.3.1.tar.gz) = 522cbd74cfd0293dbc82f4a570dc5beb206c9ed8
@ -7,6 +7,7 @@ SHA1 (xorg-server-1.12.4.tar.bz2) = 6d616874f9c7677bda08dc073c03f83e78fbc585
RMD160 (xorg-server-1.12.4.tar.bz2) = 4907b5dc42efd6b3fb6bf9d64f1441080a6a6983
Size (xorg-server-1.12.4.tar.bz2) = 5444761 bytes
SHA1 (patch-CMakeLists.txt) = c5d2bd4b0f56977c8cd3c4b0a46359c765ada200
SHA1 (patch-common_CMakeLists.txt) = e3dabe3d8ae146cf68a9660a20af2f36c2827731
SHA1 (patch-media_CMakeLists.txt) = cd50f9b7a9405aa523412ef823a32437a3c19ffa
SHA1 (patch-unix_vncserver) = 8baacca2d1083f330781caff7da2ac996af91aa4
SHA1 (patch-unix_xserver_hw_vnc_InputXKB.cc) = 440067e4995b7e1a0580bd106eb63740f400cb2c

View file

@ -0,0 +1,13 @@
$NetBSD: patch-common_CMakeLists.txt,v 1.1 2015/03/22 20:07:46 joerg Exp $
--- common/CMakeLists.txt.orig 2015-03-22 17:29:15.000000000 +0000
+++ common/CMakeLists.txt
@@ -16,7 +16,7 @@ add_subdirectory(rfb)
# because PIC code does not exist on that platform and MinGW complains if -fPIC
# is passed (additionally, libvnc is not used on Windows.)
-if(CMAKE_COMPILER_IS_GNUCXX AND (CMAKE_SIZEOF_VOID_P MATCHES 8) AND NOT WIN32)
+if(NOT WIN32)
set_target_properties(os rdr network Xregion rfb
PROPERTIES COMPILE_FLAGS -fPIC)
if(USE_INCLUDED_ZLIB)