Use more void.

This commit is contained in:
joerg 2012-10-20 22:03:46 +00:00
parent 9d5d782e0a
commit 1de173ba1a
4 changed files with 72 additions and 12 deletions

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.9 2010/09/29 21:57:04 minskim Exp $
$NetBSD: distinfo,v 1.10 2012/10/20 22:03:46 joerg Exp $
SHA1 (fastcap-2.0-18Sep92.tgz) = 7ad255cfe33c60428e934b87298951829331e4d5
RMD160 (fastcap-2.0-18Sep92.tgz) = 3073f17442abaf67b9d3a7c8bd05054dbb706a9a
Size (fastcap-2.0-18Sep92.tgz) = 1392318 bytes
SHA1 (patch-aa) = 489b5f8716627f9c9297e8d11f1cfb0e1777b3fe
SHA1 (patch-ab) = 4336ebcb0ba385e6937129735653db20d48d186f
SHA1 (patch-ab) = c0e078a2d3607f65a797fb6c61dc34ce33a0d4e2
SHA1 (patch-ac) = 3b3b6d461d5875dfdbaf8af16546887f57279b88
SHA1 (patch-ad) = a9d971f0990d5cf04651afd73689170ce1eb0f13
SHA1 (patch-ae) = fd04e26454f89661a02e37fc51770746af108fd1
@ -20,3 +20,5 @@ SHA1 (patch-an) = 51f9cf9fdf32755ab3b79b093873782e8ce20a41
SHA1 (patch-ao) = 55fb0926e433b96336a0574e09231e825c717607
SHA1 (patch-ap) = 63378fe5ceac7b2c76bdb4d6f3a50010cef621f8
SHA1 (patch-aq) = e0620792ae3bcadfc4d7ec3cdf7f4cd21ce465cd
SHA1 (patch-src_mulDo.c) = b080cc22b07ee30527e98f92c71080049df796e2
SHA1 (patch-src_mulMats.c) = b6258dc14cfc5d3445a0a9b8e30d7de30ff15e99

View file

@ -1,21 +1,41 @@
$NetBSD: patch-ab,v 1.2 1998/08/07 10:36:26 agc Exp $
$NetBSD: patch-ab,v 1.3 2012/10/20 22:03:46 joerg Exp $
--- src/mulSetup.c.orig Wed May 6 19:48:32 1998
+++ src/mulSetup.c Wed May 6 19:55:09 1998
@@ -36,6 +36,16 @@
--- src/mulSetup.c.orig 2004-08-11 17:44:56.000000000 +0000
+++ src/mulSetup.c
@@ -37,6 +37,16 @@ operation of Software or Licensed Progra
cube *cstack[1024]; /* Stack used in several routines. */
+
+/* Function prototypes for static functions in this file */
+static int placeq(int flag, ssystem *sys,charge *charges);
+static indexkid(ssystem *sys, cube *dad, int *pqindex, int *pcindex);
+static getnbrs(ssystem *sys);
+static linkcubes(ssystem *sys);
+static setMaxq(ssystem *sys);
+static getAllInter(ssystem *sys);
+static set_vector_masks(ssystem *sys);
+static int indexkid(ssystem *sys, cube *dad, int *pqindex, int *pcindex);
+static void getnbrs(ssystem *sys);
+static void linkcubes(ssystem *sys);
+static int setMaxq(ssystem *sys);
+static int getAllInter(ssystem *sys);
+static int set_vector_masks(ssystem *sys);
+
/*
sets up the partitioning of space and room for charges and expansions
*/
@@ -717,8 +727,7 @@ int all_mul_exact, all_loc_exact, p, num
Find all the nearest neighbors.
At the bottom level, get neighbors due to a parents being exact.
*/
-static getnbrs(sys)
-ssystem *sys;
+static void getnbrs(ssystem *sys)
{
cube *nc, *np, *****cubes = sys->cubes;
int depth = sys->depth;
@@ -793,8 +802,7 @@ for the cubes requiring local expansion
direct methods and one for cubes with potential evaluation points.
Note, upnumvects and exact must be set!!!
*/
-static linkcubes(sys)
-ssystem *sys;
+static void linkcubes(ssystem *sys)
{
cube *nc, **plnc, **pdnc, **pmnc, *****cubes = sys->cubes;
int i, j, k, l, cnt = 0;

View file

@ -0,0 +1,24 @@
$NetBSD: patch-src_mulDo.c,v 1.1 2012/10/20 22:03:46 joerg Exp $
--- src/mulDo.c.orig 2012-10-20 10:20:10.000000000 +0000
+++ src/mulDo.c
@@ -150,8 +150,7 @@ int type;
/*
Loop through upward pass.
*/
-mulUp(sys)
-ssystem *sys;
+void mulUp(ssystem *sys)
{
int i, j, k, l;
int msize;
@@ -224,8 +223,7 @@ ssystem *sys;
/*
Loop through downward pass.
*/
-mulDown(sys)
-ssystem *sys;
+void mulDown(ssystem *sys)
{
cube *nc;
int depth, i, j, k, lsize;

View file

@ -0,0 +1,14 @@
$NetBSD: patch-src_mulMats.c,v 1.1 2012/10/20 22:03:46 joerg Exp $
--- src/mulMats.c.orig 2012-10-20 10:19:34.000000000 +0000
+++ src/mulMats.c
@@ -706,8 +706,7 @@ children's multipoles or charges. Note t
multipole to multipole matrices is computed per level by exploiting the
uniform break-up of three-space (ie many shifts have similar geometries).
*/
-mulMatUp(sys)
-ssystem *sys;
+void mulMatUp(ssystem *sys)
{
cube *nextc, *kid;
int i, j, numterms, depth, order = sys->order;