add a patch from upstream to fix an assertion error with pixman-0.15.16
(see fdo bug #22642) bump PKGREVISION
This commit is contained in:
parent
30dff3eb70
commit
1df1fda841
3 changed files with 34 additions and 3 deletions
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.48 2009/07/09 13:14:24 tnn Exp $
|
||||
# $NetBSD: Makefile,v 1.49 2009/07/21 11:15:53 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= xorg-server-1.6.2
|
||||
PKGNAME= modular-${DISTNAME}
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ${MASTER_SITE_XORG:=xserver/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.35 2009/07/08 17:55:59 hasso Exp $
|
||||
$NetBSD: distinfo,v 1.36 2009/07/21 11:15:53 drochner Exp $
|
||||
|
||||
SHA1 (xorg-server-1.6.2.tar.bz2) = 7eb0ae82762eecf5be031d63a77f0c1281569414
|
||||
RMD160 (xorg-server-1.6.2.tar.bz2) = 37af2d733cdc7155de13cfdb21cc6367135bb440
|
||||
|
@ -10,6 +10,7 @@ SHA1 (patch-aj) = 84ff5c6215d0b62734cf26e78394a70afe2b7007
|
|||
SHA1 (patch-ak) = df6d3b2172254e1f9d44eb40144cad5ed29a7d1d
|
||||
SHA1 (patch-al) = cb1fb44037f23fb2838ed36aaf2591946264fe53
|
||||
SHA1 (patch-am) = be278e6044dfa37b108d2544c82b84f36b6ca9d7
|
||||
SHA1 (patch-an) = e429179bad703addd7a23b60ff3ecd2420457a17
|
||||
SHA1 (patch-ba) = 803f8df4e2ad2ebdfde9f7e17c3dd26fa11262ab
|
||||
SHA1 (patch-sa) = a22001b4146dcbcbd5405c9a1ff7b1632ec946b8
|
||||
SHA1 (patch-sb) = 0a064016b16e088d08cd9e290a57cb4efb4f5d26
|
||||
|
|
30
x11/modular-xorg-server/patches/patch-an
Normal file
30
x11/modular-xorg-server/patches/patch-an
Normal file
|
@ -0,0 +1,30 @@
|
|||
$NetBSD: patch-an,v 1.4 2009/07/21 11:15:54 drochner Exp $
|
||||
|
||||
--- exa/exa_accel.c.orig 2009-07-07 19:48:58.000000000 +0200
|
||||
+++ exa/exa_accel.c
|
||||
@@ -415,6 +415,7 @@ exaCopyNtoN (DrawablePtr pSrcDrawable
|
||||
|
||||
if (rects) {
|
||||
int i;
|
||||
+ int ordering;
|
||||
|
||||
for (i = 0; i < nbox; i++) {
|
||||
rects[i].x = pbox[i].x1 + dx + src_off_x;
|
||||
@@ -423,7 +424,16 @@ exaCopyNtoN (DrawablePtr pSrcDrawable
|
||||
rects[i].height = pbox[i].y2 - pbox[i].y1;
|
||||
}
|
||||
|
||||
- srcregion = RECTS_TO_REGION(pScreen, nbox, rects, CT_YXBANDED);
|
||||
+ /* This must match the miRegionCopy() logic for reversing rect order */
|
||||
+ if (nbox == 1 || (dx > 0 && dy > 0) ||
|
||||
+ (pDstDrawable != pSrcDrawable &&
|
||||
+ (pDstDrawable->type != DRAWABLE_WINDOW ||
|
||||
+ pSrcDrawable->type != DRAWABLE_WINDOW)))
|
||||
+ ordering = CT_YXBANDED;
|
||||
+ else
|
||||
+ ordering = CT_UNSORTED;
|
||||
+
|
||||
+ srcregion = RECTS_TO_REGION(pScreen, nbox, rects, ordering);
|
||||
xfree(rects);
|
||||
|
||||
if (!pGC || !exaGCReadsDestination(pDstDrawable, pGC->planemask,
|
Loading…
Reference in a new issue