Initial import of camlimages.

CamlImages is an image processing library, which provides

* Basic functions for image processing and loading/saving various image
  file formats (hence providing a translation facility from format to
  format),
* An interface with the Caml graphics library allows to display
  images in the Graphics module screen and to mix them with Caml
  drawings,
* A freetype interface, integrated into the library:
  you can draw texts into images using any truetype fonts.

In addition, the library can handle huge images that cannot be (or can
hardly be) stored into the main memory (the library then automatically
creates swap files and escapes them to reduce the memory usage).
This commit is contained in:
jtb 2003-08-31 01:24:36 +00:00
parent bb3ce4f639
commit 1e1d8355a3
7 changed files with 224 additions and 0 deletions

14
graphics/camlimages/DESCR Normal file
View file

@ -0,0 +1,14 @@
CamlImages is an image processing library, which provides
* Basic functions for image processing and loading/saving various image
file formats (hence providing a translation facility from format to
format),
* An interface with the Caml graphics library allows to display
images in the Graphics module screen and to mix them with Caml
drawings,
* A freetype interface, integrated into the library:
you can draw texts into images using any truetype fonts.
In addition, the library can handle huge images that cannot be (or can
hardly be) stored into the main memory (the library then automatically
creates swap files and escapes them to reduce the memory usage).

View file

@ -0,0 +1,32 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/08/31 01:24:36 jtb Exp $
DISTNAME= camlimages-2.11
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.inria.fr/INRIA/caml-light/bazar-ocaml/
EXTRACT_SUFX= .tgz
MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://pauillac.inria.fr/camlimages/
COMMENT= Image processing library for Objective Caml
USE_BUILDLINK2= yes
USE_PKGLOCALEDIR= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
PLIST_SRC= ${PKGDIR}/PLIST
.if (${MACHINE_ARCH} == "i386") || (${MACHINE_ARCH} == "powerpc") || (${MACHINE_ARCH} == "sparc")
ALL_TARGET+= all.opt
PLIST_SRC+= ${PKGDIR}/PLIST.opt
.endif
.include "../../lang/ocaml/buildlink2.mk"
.include "../../x11/lablgtk/buildlink2.mk"
.include "../../graphics/jpeg/buildlink2.mk"
.include "../../graphics/png/buildlink2.mk"
.include "../../graphics/xpm/buildlink2.mk"
.include "../../graphics/libungif/buildlink2.mk"
.include "../../graphics/gdk-pixbuf/buildlink2.mk"
.include "../../graphics/freetype2/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

105
graphics/camlimages/PLIST Normal file
View file

@ -0,0 +1,105 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/08/31 01:24:37 jtb Exp $
lib/ocaml/camlimages/Makefile.config
lib/ocaml/camlimages/bitmap.cmi
lib/ocaml/camlimages/bitmap.mli
lib/ocaml/camlimages/blend.cmi
lib/ocaml/camlimages/blend.mli
lib/ocaml/camlimages/bmp.cmi
lib/ocaml/camlimages/bmp.mli
lib/ocaml/camlimages/camlimages.cmi
lib/ocaml/camlimages/ci_bmp.cma
lib/ocaml/camlimages/ci_core.cma
lib/ocaml/camlimages/ci_freetype.cma
lib/ocaml/camlimages/ci_gif.cma
lib/ocaml/camlimages/ci_graphics.cma
lib/ocaml/camlimages/ci_jpeg.cma
lib/ocaml/camlimages/ci_lablgtk.cma
lib/ocaml/camlimages/ci_png.cma
lib/ocaml/camlimages/ci_ppm.cma
lib/ocaml/camlimages/ci_ps.cma
lib/ocaml/camlimages/ci_tiff.cma
lib/ocaml/camlimages/ci_xpm.cma
lib/ocaml/camlimages/ci_xvthumb.cma
lib/ocaml/camlimages/cmyk32.cmi
lib/ocaml/camlimages/cmyk32.mli
lib/ocaml/camlimages/color.cmi
lib/ocaml/camlimages/color.mli
lib/ocaml/camlimages/colorhist.cmi
lib/ocaml/camlimages/config.h
lib/ocaml/camlimages/freetype.cmi
lib/ocaml/camlimages/freetype.mli
lib/ocaml/camlimages/ftlow.cmi
lib/ocaml/camlimages/ftlow.mli
lib/ocaml/camlimages/fttext.cmi
lib/ocaml/camlimages/fttext.mli
lib/ocaml/camlimages/genimage.cmi
lib/ocaml/camlimages/genimage.mli
lib/ocaml/camlimages/geometry.cmi
lib/ocaml/camlimages/gif.cmi
lib/ocaml/camlimages/gif.mli
lib/ocaml/camlimages/graphic_image.cmi
lib/ocaml/camlimages/graphic_image.mli
lib/ocaml/camlimages/image.cmi
lib/ocaml/camlimages/image.mli
lib/ocaml/camlimages/index16.cmi
lib/ocaml/camlimages/index16.mli
lib/ocaml/camlimages/index8.cmi
lib/ocaml/camlimages/index8.mli
lib/ocaml/camlimages/info.cmi
lib/ocaml/camlimages/info.mli
lib/ocaml/camlimages/jis_table.cmi
lib/ocaml/camlimages/jis_unicode.cmi
lib/ocaml/camlimages/jis_unicode.mli
lib/ocaml/camlimages/jpeg.cmi
lib/ocaml/camlimages/jpeg.mli
lib/ocaml/camlimages/libci_freetype.a
lib/ocaml/camlimages/libci_gif.a
lib/ocaml/camlimages/libci_jpeg.a
lib/ocaml/camlimages/libci_png.a
lib/ocaml/camlimages/libci_tiff.a
lib/ocaml/camlimages/libci_xpm.a
lib/ocaml/camlimages/mstring.cmi
lib/ocaml/camlimages/mstring.mli
lib/ocaml/camlimages/oBmp.cmi
lib/ocaml/camlimages/oColor.cmi
lib/ocaml/camlimages/oColor.mli
lib/ocaml/camlimages/oFreetype.cmi
lib/ocaml/camlimages/oGif.cmi
lib/ocaml/camlimages/oGraphic.cmi
lib/ocaml/camlimages/oImage.cmi
lib/ocaml/camlimages/oImage.mli
lib/ocaml/camlimages/oJpeg.cmi
lib/ocaml/camlimages/oPng.cmi
lib/ocaml/camlimages/oPpm.cmi
lib/ocaml/camlimages/oPs.cmi
lib/ocaml/camlimages/oTiff.cmi
lib/ocaml/camlimages/oXimage.cmi
lib/ocaml/camlimages/oXimage.mli
lib/ocaml/camlimages/oXpm.cmi
lib/ocaml/camlimages/oXvthumb.cmi
lib/ocaml/camlimages/oXvthumb.mli
lib/ocaml/camlimages/png.cmi
lib/ocaml/camlimages/png.mli
lib/ocaml/camlimages/ppm.cmi
lib/ocaml/camlimages/ppm.mli
lib/ocaml/camlimages/ps.cmi
lib/ocaml/camlimages/ps.mli
lib/ocaml/camlimages/reduce.cmi
lib/ocaml/camlimages/reduce.mli
lib/ocaml/camlimages/region.cmi
lib/ocaml/camlimages/region.mli
lib/ocaml/camlimages/rgb24.cmi
lib/ocaml/camlimages/rgb24.mli
lib/ocaml/camlimages/rgba32.cmi
lib/ocaml/camlimages/rgba32.mli
lib/ocaml/camlimages/tiff.cmi
lib/ocaml/camlimages/tiff.mli
lib/ocaml/camlimages/tmpfile.cmi
lib/ocaml/camlimages/tmpfile.mli
lib/ocaml/camlimages/ximage.cmi
lib/ocaml/camlimages/ximage.mli
lib/ocaml/camlimages/xpm.cmi
lib/ocaml/camlimages/xpm.mli
lib/ocaml/camlimages/xvthumb.cmi
lib/ocaml/camlimages/xvthumb.mli
@unexec ${RMDIR} %D/lib/ocaml/camlimages 2>/dev/null || ${TRUE}

View file

@ -0,0 +1,28 @@
@comment $NetBSD: PLIST.opt,v 1.1.1.1 2003/08/31 01:24:41 jtb Exp $
lib/ocaml/camlimages/ci_core.a
lib/ocaml/camlimages/ci_core.cmxa
lib/ocaml/camlimages/ci_ppm.a
lib/ocaml/camlimages/ci_ppm.cmxa
lib/ocaml/camlimages/ci_bmp.a
lib/ocaml/camlimages/ci_bmp.cmxa
lib/ocaml/camlimages/ci_xvthumb.a
lib/ocaml/camlimages/ci_xvthumb.cmxa
lib/ocaml/camlimages/ci_jpeg.a
lib/ocaml/camlimages/ci_jpeg.cmxa
lib/ocaml/camlimages/ci_tiff.a
lib/ocaml/camlimages/ci_tiff.cmxa
lib/ocaml/camlimages/ci_gif.a
lib/ocaml/camlimages/ci_gif.cmxa
lib/ocaml/camlimages/ci_png.a
lib/ocaml/camlimages/ci_png.cmxa
lib/ocaml/camlimages/ci_xpm.a
lib/ocaml/camlimages/ci_xpm.cmxa
lib/ocaml/camlimages/ci_ps.a
lib/ocaml/camlimages/ci_ps.cmxa
lib/ocaml/camlimages/ci_graphics.a
lib/ocaml/camlimages/ci_graphics.cmxa
lib/ocaml/camlimages/ci_freetype.a
lib/ocaml/camlimages/ci_freetype.cmxa
lib/ocaml/camlimages/ci_lablgtk.a
lib/ocaml/camlimages/ci_lablgtk.cmxa
@dirrm lib/ocaml/camlimages

View file

@ -0,0 +1,20 @@
# $NetBSD: buildlink2.mk,v 1.1.1.1 2003/08/31 01:24:41 jtb Exp $
#
# This Makefile fragment is included by packages that use camlimages.
.if !defined(CAMLIMAGES_BUILDLINK2_MK)
CAMLIMAGES_BUILDLINK2_MK= # defined
BUILDLINK_PACKAGES+= camlimages
BUILDLINK_DEPENDS.camlimages?= camlimages>=2.11
BUILDLINK_PKGSRCDIR.camlimages?= ../../graphics/camlimages
EVAL_PREFIX+= BUILDLINK_PREFIX.camlimages=camlimages
BUILDLINK_PREFIX.camlimages_DEFAULT= ${LOCALBASE}
BUILDLINK_FILES.camlimages+= lib/ocaml/camlimages/*
BUILDLINK_TARGETS+= camlimages-buildlink
camlimages-buildlink: _BUILDLINK_USE
.endif # CAMLIMAGES_BUILDLINK2_MK

View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2003/08/31 01:24:37 jtb Exp $
SHA1 (camlimages-2.11.tgz) = 487fa871e3cf81864979bbbddb9abf86f4c9fbab
Size (camlimages-2.11.tgz) = 1354100 bytes
SHA1 (patch-aa) = 89889b3af5bd314bdef5328ea9880a315f879240

View file

@ -0,0 +1,20 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/08/31 01:24:41 jtb Exp $
--- Makefile.shared.orig 2002-07-03 04:18:26.000000000 +0100
+++ Makefile.shared 2003-08-18 20:20:36.000000000 +0100
@@ -1,5 +1,5 @@
$(CLIB) $(CDLL): $(COBJS)
- $(CAMLMKLIB) -oc $(LIBNAME) -L/usr/local/lib $(COBJS) $(EXTCLIB)
+ $(CAMLMKLIB) -oc $(LIBNAME) $(LDFLAGS) $(COBJS) $(EXTCLIB)
$(CMA): $(CLIB) $(MLOBJS)
if test "X$(CLIB)" = "X"; then \
@@ -62,7 +62,7 @@
$(CAMLYACC) $<
.c.o: ../config.h
- $(CAMLC) -ccopt "-I.. $(CFLAGS) -I/usr/local/include" -c $<
+ $(CAMLC) -ccopt "-I.. $(CFLAGS) $(CPPFLAGS)" -c $<
depend: .depend