Fix build problem under platforms were "size_t" is not an integer.

This commit is contained in:
tron 2005-08-07 22:21:05 +00:00
parent 0680c23678
commit 1e258b4190
2 changed files with 17 additions and 1 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.9 2005/08/05 12:04:33 tron Exp $
$NetBSD: distinfo,v 1.10 2005/08/07 22:21:05 tron Exp $
SHA1 (ipsec-tools-0.6.1rc1.tar.bz2) = 2ed2692165b1d59074e00d9f3465ed7e416d5b78
RMD160 (ipsec-tools-0.6.1rc1.tar.bz2) = 985a15f0a004985c22d6d4a55fbeb786291f4d74
Size (ipsec-tools-0.6.1rc1.tar.bz2) = 663281 bytes
SHA1 (patch-aa) = 0f6d9495cb4b644883274ae9985e6648630a7252

View file

@ -0,0 +1,15 @@
$NetBSD: patch-aa,v 1.3 2005/08/07 22:21:05 tron Exp $
--- src/racoon/privsep.c.orig 2005-06-04 23:08:15.000000000 +0100
+++ src/racoon/privsep.c 2005-08-07 22:35:41.000000000 +0100
@@ -912,8 +912,8 @@
{
if ((port < 0) || (port >= isakmp_cfg_config.pool_size)) {
plog(LLV_ERROR, LOCATION, NULL,
- "privsep: port %d outsied of allowed range [0,%d]\n",
- port, isakmp_cfg_config.pool_size - 1);
+ "privsep: port %d outside of allowed range [0,%d]\n",
+ port, (int)isakmp_cfg_config.pool_size - 1);
return -1;
}