Allow build with C++11 STL providing std::ratio.
This commit is contained in:
parent
16c0ffab4c
commit
1e2b81266c
3 changed files with 29 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.45 2014/11/15 21:15:18 markd Exp $
|
||||
$NetBSD: distinfo,v 1.46 2014/11/17 19:02:30 joerg Exp $
|
||||
|
||||
SHA1 (digikam-4.4.0.tar.bz2) = 1feb43120addda314e09761440ec2058e430171c
|
||||
RMD160 (digikam-4.4.0.tar.bz2) = 540f243361aba3c95b675c05f84d8d60efab1948
|
||||
|
@ -9,4 +9,6 @@ SHA1 (patch-core_libs_3rdparty_kmemoryinfo_kmemoryinfo_backend.cpp) = 050904de64
|
|||
SHA1 (patch-core_libs_dimg_filters_icc_iccmanager.h) = 999bd32312fbe840913a8d29613b351384061b65
|
||||
SHA1 (patch-core_libs_imageproperties_captionedit.cpp) = a0f181ff4af9f71eee5679aef540a78497a113a9
|
||||
SHA1 (patch-core_libs_imageproperties_imagedescedittab.cpp) = a09fa20eaac60bf7dc6bcb2b9a1304891029ccb0
|
||||
SHA1 (patch-core_tests_imgqsort_detectblur_detectblur.cpp) = a2d49329ff9c4d7d05c23d5f0a2a152e9d02d790
|
||||
SHA1 (patch-core_tests_imgqsort_detectnoise_detectnoise.cpp) = 62b4f08733475c7eaf95c64747bc8c18a3dbfae3
|
||||
SHA1 (patch-doc_CMakeLists.txt) = 5b4ba1daa49607b8773c3903d953e11bebc4d661
|
||||
|
|
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-core_tests_imgqsort_detectblur_detectblur.cpp,v 1.1 2014/11/17 19:02:30 joerg Exp $
|
||||
|
||||
--- core/tests/imgqsort/detectblur/detectblur.cpp.orig 2014-11-17 15:36:48.000000000 +0000
|
||||
+++ core/tests/imgqsort/detectblur/detectblur.cpp
|
||||
@@ -53,7 +53,7 @@ void CannyThreshold(int, void*)
|
||||
blur( src_gray, detected_edges, Size(3,3) );
|
||||
|
||||
// Canny detector
|
||||
- Canny( detected_edges, detected_edges, lowThreshold, lowThreshold*ratio, kernel_size );
|
||||
+ Canny( detected_edges, detected_edges, lowThreshold, lowThreshold*::ratio, kernel_size );
|
||||
|
||||
// Using Canny's output as a mask, we display our result
|
||||
dst = Scalar::all(0);
|
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-core_tests_imgqsort_detectnoise_detectnoise.cpp,v 1.1 2014/11/17 19:02:30 joerg Exp $
|
||||
|
||||
--- core/tests/imgqsort/detectnoise/detectnoise.cpp.orig 2014-11-17 15:37:46.000000000 +0000
|
||||
+++ core/tests/imgqsort/detectnoise/detectnoise.cpp
|
||||
@@ -48,7 +48,7 @@ void CannyThreshold(int, void*)
|
||||
blur( src_gray, detected_edges, Size(3,3) );
|
||||
|
||||
// Canny detector
|
||||
- Canny( detected_edges, detected_edges, lowThreshold, lowThreshold*ratio, kernel_size );
|
||||
+ Canny( detected_edges, detected_edges, lowThreshold, lowThreshold*::ratio, kernel_size );
|
||||
|
||||
// Using Canny's output as a mask, we display our result
|
||||
dst = Scalar::all(0);
|
Loading…
Reference in a new issue