update to 1.4.2

changes: bugfixes
This commit is contained in:
drochner 2011-07-08 17:27:29 +00:00
parent 730556e965
commit 1e4a8c3fe8
3 changed files with 6 additions and 56 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.44 2011/06/10 09:39:41 obache Exp $
# $NetBSD: Makefile,v 1.45 2011/07/08 17:27:29 drochner Exp $
DISTNAME= webkit-1.4.1
DISTNAME= webkit-1.4.2
PKGNAME= ${DISTNAME:S/webkit/webkit-gtk/}
PKGREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.webkitgtk.org/

View file

@ -1,9 +1,8 @@
$NetBSD: distinfo,v 1.36 2011/06/22 14:05:37 wiz Exp $
$NetBSD: distinfo,v 1.37 2011/07/08 17:27:29 drochner Exp $
SHA1 (webkit-1.4.1.tar.gz) = 5813112e94315db747c68d6b45ca763a45774357
RMD160 (webkit-1.4.1.tar.gz) = da77eea6b7abb0e1ffeb322d747386a2c4b7cc9c
Size (webkit-1.4.1.tar.gz) = 8494373 bytes
SHA1 (webkit-1.4.2.tar.gz) = 675ae0bfef56b8519f3f00b04fc7baf72215bd3b
RMD160 (webkit-1.4.2.tar.gz) = e1de3cd5576d7ccc771475cda8c0e3b59aba1af7
Size (webkit-1.4.2.tar.gz) = 8504310 bytes
SHA1 (patch-Source_JavaScriptCore_jit_JITStubs.cpp) = 1b24daaf4bd8af75e45ceae790b43bd022540c05
SHA1 (patch-ab) = 1d31748ce0d300425f12cc800219954d7128adb8
SHA1 (patch-ag) = a09f7fc1336750bc707b1bcc57aa6dc3e02a0460
SHA1 (patch-ah) = 03e7863ad0b0a1de9a95a6b370e4259a6f7c34ac

View file

@ -1,48 +0,0 @@
$NetBSD: patch-ab,v 1.9 2011/06/09 11:00:01 drochner Exp $
--- Source/WebCore/platform/image-decoders/png/PNGImageDecoder.cpp.orig 2011-03-21 18:43:07.000000000 +0000
+++ Source/WebCore/platform/image-decoders/png/PNGImageDecoder.cpp
@@ -226,7 +226,7 @@ static ColorProfile readColorProfile(png
#ifdef PNG_iCCP_SUPPORTED
char* profileName;
int compressionType;
- char* profile;
+ png_byte* profile;
png_uint_32 profileLength;
if (png_get_iCCP(png, info, &profileName, &compressionType, &profile, &profileLength)) {
ColorProfile colorProfile;
@@ -241,11 +241,11 @@ void PNGImageDecoder::headerAvailable()
{
png_structp png = m_reader->pngPtr();
png_infop info = m_reader->infoPtr();
- png_uint_32 width = png->width;
- png_uint_32 height = png->height;
+ png_uint_32 width = png_get_image_width(png, info);
+ png_uint_32 height = png_get_image_height(png, info);
// Protect against large images.
- if (png->width > cMaxPNGSize || png->height > cMaxPNGSize) {
+ if (width > cMaxPNGSize || height > cMaxPNGSize) {
longjmp(JMPBUF(png), 1);
return;
}
@@ -319,8 +319,7 @@ void PNGImageDecoder::headerAvailable()
if (m_reader->decodingSizeOnly()) {
// If we only needed the size, halt the reader.
- m_reader->setReadOffset(m_reader->currentBufferSize() - png->buffer_size);
- png->buffer_size = 0;
+ m_reader->setReadOffset(m_reader->currentBufferSize() - png_process_data_pause(png, 0/*do not save the data*/));
}
}
@@ -343,7 +342,8 @@ void PNGImageDecoder::rowAvailable(unsig
// For PNGs, the frame always fills the entire image.
buffer.setOriginalFrameRect(IntRect(IntPoint(), size()));
- if (m_reader->pngPtr()->interlaced)
+ if (png_get_interlace_type(m_reader->pngPtr(), m_reader->infoPtr())
+ != PNG_INTERLACE_NONE)
m_reader->createInterlaceBuffer((m_reader->hasAlpha() ? 4 : 3) * size().width() * size().height());
}